]> git.pld-linux.org Git - packages/systemtap.git/commitdiff
- updated to 4.8
authorJan Rękorajski <baggins@pld-linux.org>
Sun, 18 Dec 2022 09:35:11 +0000 (10:35 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Sun, 18 Dec 2022 09:35:11 +0000 (10:35 +0100)
format-security.patch [deleted file]
systemtap-build.patch [deleted file]
systemtap-dyninst.patch [deleted file]
systemtap-no-werror.patch [deleted file]
systemtap.spec

diff --git a/format-security.patch b/format-security.patch
deleted file mode 100644 (file)
index 454b473..0000000
+++ /dev/null
@@ -1,71 +0,0 @@
---- systemtap-2.6/cache.cxx~   2014-09-05 21:33:21.000000000 +0000
-+++ systemtap-2.6/cache.cxx    2014-12-31 20:01:49.768965553 +0000
-@@ -294,7 +294,11 @@
-         {
-           //interval not passed, don't continue
-           if (s.verbose > 1)
-+#ifdef __ILP32__
-+            clog << _F("Cache cleaning skipped, interval not reached %llu s / %lu s.",
-+#else
-             clog << _F("Cache cleaning skipped, interval not reached %lu s / %lu s.",
-+#endif
-                        (current_time.tv_sec-sb.st_mtime), cache_clean_interval)  << endl;
-           return;
-         }
-@@ -302,7 +306,11 @@
-         {
-           //interval reached, continue
-           if (s.verbose > 1)
-+#ifdef __ILP32__
-+            clog << _F("Cleaning cache, interval reached %llu s > %lu s.",
-+#else
-             clog << _F("Cleaning cache, interval reached %lu s > %lu s.",
-+#endif
-                        (current_time.tv_sec-sb.st_mtime), cache_clean_interval)  << endl;
-         }
---- systemtap-3.3/staprun/monitor.c.orig       2018-06-09 00:28:59.000000000 +0200
-+++ systemtap-3.3/staprun/monitor.c    2021-12-20 13:10:38.290932651 +0100
-@@ -448,12 +448,12 @@
-       if (active_window == 0)
-         wattron(status, A_BOLD);
-       wprintw(status, "\n%*s\t%*s\t%*s\t%*s\t%*s\t%*s\t%s\n",
--              width[p_index], HIGHLIGHT("index", p_index, comp_fn_index),
--              width[p_state], HIGHLIGHT("state", p_state, comp_fn_index),
--              width[p_hits], HIGHLIGHT("hits", p_hits, comp_fn_index),
--              width[p_min], HIGHLIGHT("min", p_min, comp_fn_index),
--              width[p_avg], HIGHLIGHT("avg", p_avg, comp_fn_index),
--              width[p_max], HIGHLIGHT("max", p_max, comp_fn_index),
-+              (int) width[p_index], HIGHLIGHT("index", p_index, comp_fn_index),
-+              (int) width[p_state], HIGHLIGHT("state", p_state, comp_fn_index),
-+              (int) width[p_hits], HIGHLIGHT("hits", p_hits, comp_fn_index),
-+              (int) width[p_min], HIGHLIGHT("min", p_min, comp_fn_index),
-+              (int) width[p_avg], HIGHLIGHT("avg", p_avg, comp_fn_index),
-+              (int) width[p_max], HIGHLIGHT("max", p_max, comp_fn_index),
-               HIGHLIGHT("name", p_name, comp_fn_index));
-       if (active_window == 0)
-         wattroff(status, A_BOLD);
-@@ -466,17 +466,17 @@
-           json_object *probe, *field;
-           probe = json_object_array_get_idx(jso_probe_list, i);
-           json_object_object_get_ex(probe, "index", &field);
--          wprintw(status, "%*s\t", width[p_index], json_object_get_string(field));
-+          wprintw(status, "%*s\t", (int) width[p_index], json_object_get_string(field));
-           json_object_object_get_ex(probe, "state", &field);
--          wprintw(status, "%*s\t", width[p_state], json_object_get_string(field));
-+          wprintw(status, "%*s\t", (int) width[p_state], json_object_get_string(field));
-           json_object_object_get_ex(probe, "hits", &field);
--          wprintw(status, "%*s\t", width[p_hits], json_object_get_string(field));
-+          wprintw(status, "%*s\t", (int) width[p_hits], json_object_get_string(field));
-           json_object_object_get_ex(probe, "min", &field);
--          wprintw(status, "%*s\t", width[p_min], json_object_get_string(field));
-+          wprintw(status, "%*s\t", (int) width[p_min], json_object_get_string(field));
-           json_object_object_get_ex(probe, "avg", &field);
--          wprintw(status, "%*s\t", width[p_avg], json_object_get_string(field));
-+          wprintw(status, "%*s\t", (int) width[p_avg], json_object_get_string(field));
-           json_object_object_get_ex(probe, "max", &field);
--          wprintw(status, "%*s\t", width[p_max], json_object_get_string(field));
-+          wprintw(status, "%*s\t", (int) width[p_max], json_object_get_string(field));
-           getyx(status, discard, cur_x);
-           json_object_object_get_ex(probe, "name", &field);
-           wprintw(status, "%.*s", max_cols-cur_x-1, json_object_get_string(field));
diff --git a/systemtap-build.patch b/systemtap-build.patch
deleted file mode 100644 (file)
index d91b9dd..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- systemtap-2.2.1/Makefile.am.orig   2013-07-05 21:26:27.918188876 +0200
-+++ systemtap-2.2.1/Makefile.am        2013-07-05 21:34:45.071501358 +0200
-@@ -181,7 +181,7 @@
- stap_serverd_SOURCES = stap-serverd.cxx cscommon.cxx util.cxx privilege.cxx nsscommon.cxx cmdline.cxx
- stap_serverd_CXXFLAGS = $(AM_CXXFLAGS) @PIECXXFLAGS@ $(nss_CFLAGS)
- stap_serverd_CFLAGS = $(AM_CFLAGS) @PIECFLAGS@ $(nss_CFLAGS)
--stap_serverd_LDFLAGS = $(AM_LDFLAGS) @PIELDFLAGS@
-+stap_serverd_LDFLAGS = $(AM_LDFLAGS) @PIELDFLAGS@ -pthread
- stap_serverd_LDADD = $(nss_LIBS) -lpthread
- if HAVE_AVAHI
- stap_serverd_CFLAGS += $(avahi_CFLAGS)
diff --git a/systemtap-dyninst.patch b/systemtap-dyninst.patch
deleted file mode 100644 (file)
index 5ad0af5..0000000
+++ /dev/null
@@ -1,29 +0,0 @@
---- systemtap-3.1/stapdyn/dynsdt.cxx.orig      2017-02-17 18:37:01.000000000 +0100
-+++ systemtap-3.1/stapdyn/dynsdt.cxx   2017-04-11 20:34:37.723802317 +0200
-@@ -264,7 +264,7 @@
-   if (points.empty())
-     {
-       warnx("couldn't find %s:%s at %#" PRIx64 " -> %#lx",
--            p.provider.c_str(), p.name.c_str(), p.pc_offset, address);
-+            p.provider.c_str(), p.name.c_str(), p.pc_offset, (unsigned long)address);
-       return;
-     }
-@@ -290,7 +290,7 @@
-   BPatch_funcCallExpr printfCall(*(printfFuncs[0]), printfArgs);
-   warnx("inserting %s:%s at %#" PRIx64 " -> %#lx [%zu]",
--        p.provider.c_str(), p.name.c_str(), p.pc_offset, address, points.size());
-+        p.provider.c_str(), p.name.c_str(), p.pc_offset, (unsigned long)address, points.size());
-   process->insertSnippet(printfCall, points);
-   if (p.sem_offset)
-@@ -302,7 +302,7 @@
-       else
-         {
-           warnx("incrementing semaphore for %s:%s at %#" PRIx64 " -> %#lx",
--                p.provider.c_str(), p.name.c_str(), p.sem_offset, sem_address);
-+                p.provider.c_str(), p.name.c_str(), p.sem_offset, (unsigned long)sem_address);
-           BPatch_type *sem_type = image->findType("unsigned short");
-           BPatch_variableExpr *semaphore =
diff --git a/systemtap-no-werror.patch b/systemtap-no-werror.patch
deleted file mode 100644 (file)
index 24a852c..0000000
+++ /dev/null
@@ -1,26 +0,0 @@
---- systemtap-3.0/configure.ac.orig    2016-04-05 20:34:37.752195113 +0200
-+++ systemtap-3.0/configure.ac 2016-04-05 20:44:11.672171031 +0200
-@@ -93,8 +93,8 @@
- AS_IF([test "x$enable_ssp" != xno],[
-    save_CFLAGS="$CFLAGS"
-    save_CXXFLAGS="$CXXFLAGS"
--   CXXFLAGS="$CXXFLAGS -Werror -fstack-protector-all -D_FORTIFY_SOURCE=2"
--   CFLAGS="$CFLAGS -Werror -fstack-protector-all -D_FORTIFY_SOURCE=2"
-+   CXXFLAGS="$CXXFLAGS -fstack-protector-all -D_FORTIFY_SOURCE=2"
-+   CFLAGS="$CFLAGS -fstack-protector-all -D_FORTIFY_SOURCE=2"
-    AC_COMPILE_IFELSE([AC_LANG_SOURCE([int something ();])], [
-        AC_MSG_NOTICE([Compiling with gcc -fstack-protector-all et al.])
-       CFLAGS="$save_CFLAGS -fstack-protector-all -D_FORTIFY_SOURCE=2"
---- systemtap-3.0/Makefile.am.orig     2016-04-05 20:44:51.275502703 +0200
-+++ systemtap-3.0/Makefile.am  2016-04-05 20:51:00.125487222 +0200
-@@ -14,8 +14,8 @@
-               -DPY3EXECDIR='"$(py3execdir)"' \
-             -I$(srcdir)/includes -I$(builddir)/includes/sys
--AM_CFLAGS = -D_GNU_SOURCE -fexceptions -Wall -Wextra -Werror -Wunused -Wformat=2 -W
--AM_CXXFLAGS = -Wall -Wextra -Werror
-+AM_CFLAGS = -D_GNU_SOURCE -fexceptions -Wall -Wextra -Wunused -Wformat=2 -W
-+AM_CXXFLAGS = -Wall -Wextra
- bin_SCRIPTS = stap-report
- pkglibexec_SCRIPTS = stap-env
index d41f2eac63c0fbd217cf8f754b66867e029217c3..d9da8e8f63816eea175cd7e7f981d0d372cf6978 100644 (file)
@@ -1,5 +1,4 @@
-#
-# Conditional build:
+# # Conditional build:
 %bcond_without doc             # documentation build
 %bcond_with    publican        # publican guides build [as of 3.0 not rebuilt automatically, PDFs are included]
 %bcond_without crash           # crash extension
 Summary:       Instrumentation System
 Summary(pl.UTF-8):     System oprzyrządowania
 Name:          systemtap
-Version:       3.3
-Release:       10
+Version:       4.8
+Release:       0.1
 License:       GPL v2+
 Group:         Base
-Source0:       http://sourceware.org/systemtap/ftp/releases/%{name}-%{version}.tar.gz
-# Source0-md5: 7f80117649a9eb663781b5372e8a4f96
+Source0:       ftp://sourceware.org/pub/systemtap/releases/%{name}-%{version}.tar.gz
+# Source0-md5: c0d629b1188a649a482b95661b53c910
 Source1:       %{name}.tmpfiles
 Source2:       stap-server.tmpfiles
-Patch1:                %{name}-build.patch
-Patch2:                %{name}-rpm5-support.patch
-Patch3:                %{name}-no-werror.patch
-Patch4:                format-security.patch
-Patch5:                %{name}-dyninst.patch
+Patch0:                %{name}-rpm5-support.patch
 URL:           http://sourceware.org/systemtap/
 BuildRequires: autoconf >= 2.63
 BuildRequires: automake
@@ -283,11 +278,7 @@ Przewodniki i dokumentacja wprowadzająca do SystemTap.
 
 %prep
 %setup -q
-%patch1 -p1
-%{?with_rpm5:%patch2 -p1}
-%patch3 -p1
-%patch4 -p1
-%patch5 -p1
+%{?with_rpm5:%patch0 -p1}
 
 %{__sed} -E -i -e '1s,#!\s*/usr/bin/python(\s|$),#!%{__python}\1,' \
       testsuite/systemtap.examples/general/pyexample.py
This page took 0.064089 seconds and 4 git commands to generate.