]> git.pld-linux.org Git - packages/systemtap.git/commitdiff
- fix format string errors on x32
authorJan Rękorajski <baggins@pld-linux.org>
Wed, 31 Dec 2014 20:04:02 +0000 (20:04 +0000)
committerJan Rękorajski <baggins@pld-linux.org>
Wed, 31 Dec 2014 20:04:02 +0000 (20:04 +0000)
format-security.patch [new file with mode: 0644]
systemtap.spec

diff --git a/format-security.patch b/format-security.patch
new file mode 100644 (file)
index 0000000..1f37dfb
--- /dev/null
@@ -0,0 +1,26 @@
+--- systemtap-2.6/cache.cxx~   2014-09-05 21:33:21.000000000 +0000
++++ systemtap-2.6/cache.cxx    2014-12-31 20:01:49.768965553 +0000
+@@ -294,7 +294,11 @@
+         {
+           //interval not passed, don't continue
+           if (s.verbose > 1)
++#ifdef __ILP32__
++            clog << _F("Cache cleaning skipped, interval not reached %llu s / %lu s.",
++#else
+             clog << _F("Cache cleaning skipped, interval not reached %lu s / %lu s.",
++#endif
+                        (current_time.tv_sec-sb.st_mtime), cache_clean_interval)  << endl;
+           return;
+         }
+@@ -302,7 +306,11 @@
+         {
+           //interval reached, continue
+           if (s.verbose > 1)
++#ifdef __ILP32__
++            clog << _F("Cleaning cache, interval reached %llu s > %lu s.",
++#else
+             clog << _F("Cleaning cache, interval reached %lu s > %lu s.",
++#endif
+                        (current_time.tv_sec-sb.st_mtime), cache_clean_interval)  << endl;
+         }
index f9e179aa2aca40bb7d99572d61da73deea6a94b0..fffba1eaf3cd79ccf217d1c1b53560f241e15cab 100644 (file)
@@ -27,6 +27,7 @@ Patch0:               %{name}-configure.patch
 Patch1:                %{name}-build.patch
 Patch2:                %{name}-rpm5-support.patch
 Patch3:                %{name}-dtrace-flexibility.patch
+Patch4:                format-security.patch
 URL:           http://sourceware.org/systemtap/
 BuildRequires: autoconf >= 2.63
 BuildRequires: automake
@@ -222,6 +223,7 @@ dtrace, który przetwarza pliki .d na pliki nagłówkowe .h z makrami
 %patch0 -p1
 %patch1 -p1
 %patch3 -p1
+%patch4 -p1
 %if "%{_rpmversion}" >= "5.0"
 %patch2 -p1
 %endif
This page took 0.111776 seconds and 4 git commands to generate.