]> git.pld-linux.org Git - packages/systemd.git/commitdiff
up to 249.5 auto/th/systemd-249.5-1
authorJan Palus <atler@pld-linux.org>
Tue, 12 Oct 2021 18:18:49 +0000 (20:18 +0200)
committerJan Palus <atler@pld-linux.org>
Tue, 12 Oct 2021 18:18:49 +0000 (20:18 +0200)
cmsg_space_32bit.patch [deleted file]
systemd.spec

diff --git a/cmsg_space_32bit.patch b/cmsg_space_32bit.patch
deleted file mode 100644 (file)
index 88008ce..0000000
+++ /dev/null
@@ -1,86 +0,0 @@
-From 9365e296fe281da45797af89a97627e872fc019d Mon Sep 17 00:00:00 2001
-From: Yu Watanabe <watanabe.yu+github@gmail.com>
-Date: Sun, 29 Aug 2021 20:50:49 +0900
-Subject: [PATCH] socket-util: introduce CMSG_SPACE_TIMEVAL/TIMESPEC macro to
- support additional 64bit timeval or timespec
-
-Fixes #20482 and #20564.
----
- src/basic/socket-util.h             | 22 ++++++++++++++++++++++
- src/journal/journald-server.c       |  2 +-
- src/libsystemd-network/icmp6-util.c |  2 +-
- src/timesync/timesyncd-manager.c    |  2 +-
- 4 files changed, 25 insertions(+), 3 deletions(-)
-
-diff --git a/src/basic/socket-util.h b/src/basic/socket-util.h
-index e857ae434192..a844c1151afd 100644
---- a/src/basic/socket-util.h
-+++ b/src/basic/socket-util.h
-@@ -277,6 +277,28 @@ static inline int getsockopt_int(int fd, int level, int optname, int *ret) {
- int socket_bind_to_ifname(int fd, const char *ifname);
- int socket_bind_to_ifindex(int fd, int ifindex);
-+/* Define a 64bit version of timeval/timespec in any case, even on 32bit userspace. */
-+struct timeval_large {
-+        uint64_t tvl_sec, tvl_usec;
-+};
-+struct timespec_large {
-+        uint64_t tvl_sec, tvl_nsec;
-+};
-+
-+/* glibc duplicates timespec/timeval on certain 32bit archs, once in 32bit and once in 64bit.
-+ * See __convert_scm_timestamps() in glibc souce code. Hence, we need additional buffer space for them
-+ * to prevent from recvmsg_safe() returning -EXFULL. */
-+#define CMSG_SPACE_TIMEVAL                                              \
-+        ((sizeof(struct timeval) == sizeof(struct timeval_large)) ?     \
-+         CMSG_SPACE(sizeof(struct timeval)) :                           \
-+         CMSG_SPACE(sizeof(struct timeval)) +                           \
-+         CMSG_SPACE(sizeof(struct timeval_large)))
-+#define CMSG_SPACE_TIMESPEC                                             \
-+        ((sizeof(struct timespec) == sizeof(struct timespec_large)) ?   \
-+         CMSG_SPACE(sizeof(struct timespec)) :                          \
-+         CMSG_SPACE(sizeof(struct timespec)) +                          \
-+         CMSG_SPACE(sizeof(struct timespec_large)))
-+
- ssize_t recvmsg_safe(int sockfd, struct msghdr *msg, int flags);
- int socket_get_family(int fd, int *ret);
-diff --git a/src/journal/journald-server.c b/src/journal/journald-server.c
-index f2189964f0fa..9de31c2be070 100644
---- a/src/journal/journald-server.c
-+++ b/src/journal/journald-server.c
-@@ -1269,7 +1269,7 @@ int server_process_datagram(
-          * identical to NAME_MAX. For now we use that, but this should be updated one day when the final
-          * limit is known. */
-         CMSG_BUFFER_TYPE(CMSG_SPACE(sizeof(struct ucred)) +
--                         CMSG_SPACE(sizeof(struct timeval)) +
-+                         CMSG_SPACE_TIMEVAL +
-                          CMSG_SPACE(sizeof(int)) + /* fd */
-                          CMSG_SPACE(NAME_MAX) /* selinux label */) control;
-diff --git a/src/libsystemd-network/icmp6-util.c b/src/libsystemd-network/icmp6-util.c
-index 0b8c3e4cc3d7..823be0f2752b 100644
---- a/src/libsystemd-network/icmp6-util.c
-+++ b/src/libsystemd-network/icmp6-util.c
-@@ -149,7 +149,7 @@ int icmp6_receive(int fd, void *buffer, size_t size, struct in6_addr *ret_dst,
-                   triple_timestamp *ret_timestamp) {
-         CMSG_BUFFER_TYPE(CMSG_SPACE(sizeof(int)) + /* ttl */
--                         CMSG_SPACE(sizeof(struct timeval))) control;
-+                         CMSG_SPACE_TIMEVAL) control;
-         struct iovec iov = {};
-         union sockaddr_union sa = {};
-         struct msghdr msg = {
-diff --git a/src/timesync/timesyncd-manager.c b/src/timesync/timesyncd-manager.c
-index 3a89d9b1fac1..d7f511ee221c 100644
---- a/src/timesync/timesyncd-manager.c
-+++ b/src/timesync/timesyncd-manager.c
-@@ -416,7 +416,7 @@ static int manager_receive_response(sd_event_source *source, int fd, uint32_t re
-                 .iov_base = &ntpmsg,
-                 .iov_len = sizeof(ntpmsg),
-         };
--        CMSG_BUFFER_TYPE(CMSG_SPACE(sizeof(struct timespec))) control;
-+        CMSG_BUFFER_TYPE(CMSG_SPACE_TIMESPEC) control;
-         union sockaddr_union server_addr;
-         struct msghdr msghdr = {
-                 .msg_iov = &iov,
index d48fd984fde471595b8204a13b34d8007d3c7939..503fc3702895fd031974209de4c79270bd1928d3 100644 (file)
@@ -30,14 +30,14 @@ Summary:    A System and Service Manager
 Summary(pl.UTF-8):     systemd - zarządca systemu i usług dla Linuksa
 Name:          systemd
 # Verify ChangeLog and NEWS when updating (since there are incompatible/breaking changes very often)
-Version:       249.4
-Release:       2
+Version:       249.5
+Release:       1
 Epoch:         1
 License:       GPL v2+ (udev), LGPL v2.1+ (the rest)
 Group:         Base
 #Source0Download: https://github.com/systemd/systemd/releases
 Source0:       https://github.com/systemd/systemd-stable/archive/v%{version}/%{name}-%{version}.tar.gz
-# Source0-md5: dc9d117c35cb9cab411b6f6a6afdcf93
+# Source0-md5: bd8fccd7a5c5672fed1937f8fd228cba
 Source1:       %{name}-sysv-convert
 Source2:       %{name}_booted.c
 Source3:       network.service
@@ -79,7 +79,6 @@ Patch11:      optional-tmp-on-tmpfs.patch
 Patch13:       sysctl.patch
 Patch14:       pld-pam-%{name}-user.patch
 Patch15:       %{name}-x32.patch
-Patch16:       cmsg_space_32bit.patch
 URL:           https://www.freedesktop.org/wiki/Software/systemd/
 BuildRequires: acl-devel
 %{?with_audit:BuildRequires:   audit-libs-devel}
@@ -739,7 +738,6 @@ Uzupełnianie parametrów w zsh dla poleceń udev.
 %patch13 -p1
 %patch14 -p1
 %patch15 -p1
-%patch16 -p1
 
 cp -p %{SOURCE2} src/systemd_booted.c
 
This page took 0.260083 seconds and 4 git commands to generate.