]> git.pld-linux.org Git - packages/systemd.git/blob - systemd.spec
- instead of hacking into fedora specific services provide our own
[packages/systemd.git] / systemd.spec
1 #
2 # TODO:
3 #       - remove compat-pld-var-run.tmpfiles and maybe tmpfiles-not-fatal.patch
4 #         after enough packages provide their own tmpfiles.d configs for
5 #         /var/run directories
6 #
7 # Conditional build:
8 %bcond_without  audit           # without audit support
9 %bcond_without  cryptsetup      # without cryptsetup support
10 %bcond_without  gtk             # build gtk tools
11 %bcond_without  pam             # PAM authentication support
12 %bcond_with     plymouth        # plymouth support
13 %bcond_without  selinux         # without SELinux support
14 %bcond_without  tcpd            # libwrap (tcp_wrappers) support
15
16 Summary:        A System and Service Manager
17 Summary(pl.UTF-8):      systemd - zarządca systemu i usług dla Linuksa
18 Name:           systemd
19 Version:        43
20 Release:        4
21 License:        GPL v2+
22 Group:          Base
23 Source0:        http://www.freedesktop.org/software/systemd/%{name}-%{version}.tar.xz
24 # Source0-md5:  446cc6db7625617af67e2d8e5f503a49
25 Source1:        %{name}-sysv-convert
26 Source2:        %{name}_booted.c
27 Source3:        network.service
28 Source4:        compat-pld-media.tmpfiles
29 Source5:        compat-pld-var-run.tmpfiles
30 Source10:       pld-storage-init-late.service
31 Source11:       pld-storage-init.service
32 Source12:       pld-wait-storage.service
33 Source13:       pld-storage-init.sh
34 Patch0:         target-pld.patch
35 Patch1:         config-pld.patch
36 Patch2:         shut-sysv-up.patch
37 Patch3:         pld-sysv-network.patch
38 Patch4:         tmpfiles-not-fatal.patch
39 URL:            http://www.freedesktop.org/wiki/Software/systemd
40 BuildRequires:  acl-devel
41 %{?with_audit:BuildRequires:    audit-libs-devel}
42 BuildRequires:  autoconf >= 2.63
43 BuildRequires:  automake >= 1:1.11
44 BuildRequires:  binutils >= 3:2.22.52.0.1-2
45 %{?with_cryptsetup:BuildRequires:       cryptsetup-luks-devel}
46 BuildRequires:  dbus-devel >= 1.3.2
47 BuildRequires:  docbook-style-xsl
48 BuildRequires:  gperf
49 BuildRequires:  intltool >= 0.40.0
50 BuildRequires:  kmod-devel >= 5
51 BuildRequires:  libcap-devel
52 %{?with_selinux:BuildRequires:  libselinux-devel >= 2.1.0}
53 BuildRequires:  libtool >= 2:2.2
54 %{?with_tcpd:BuildRequires:     libwrap-devel}
55 BuildRequires:  libxslt-progs
56 BuildRequires:  m4
57 %{?with_pam:BuildRequires:      pam-devel}
58 BuildRequires:  pkgconfig >= 0.9.0
59 BuildRequires:  rpmbuild(macros) >= 1.627
60 BuildRequires:  udev-devel >= 1:172
61 # not required for building from release (which contains *.c for *.vala)
62 #BuildRequires: vala >= 0.10.0
63 BuildRequires:  xz-devel
64 %if %{with gtk}
65 BuildRequires:  glib2-devel >= 1:2.26.1
66 BuildRequires:  gtk+2-devel >= 2:2.24.0
67 BuildRequires:  libgee-devel
68 BuildRequires:  libnotify-devel >= 0.7.0
69 %endif
70 Requires:       %{name}-libs = %{version}-%{release}
71 Requires:       %{name}-units = %{version}-%{release}
72 Requires:       /etc/os-release
73 Requires:       SysVinit-tools
74 Requires:       agetty
75 Requires:       dbus >= 1.4.16-6
76 Requires:       filesystem >= 4.0-2
77 Requires:       rc-scripts >= 0.4.5.1-7
78 Requires:       setup >= 2.8.0-2
79 Requires:       udev-core >= 1:175-5
80 Requires:       udev-libs >= 1:172
81 Requires:       virtual(module-tools)
82 Suggests:       ConsoleKit
83 Suggests:       fsck >= 2.20
84 Suggests:       kmod >= 5
85 Suggests:       nss_myhostname
86 # python modules required by systemd-analyze
87 Suggests:       %{name}-no-compat-tmpfiles
88 Suggests:       python-dbus
89 Suggests:       python-modules
90 Suggests:       service(klogd)
91 Suggests:       service(syslog)
92 Provides:       udev-acl
93 # systemd takes care of that and causes problems
94 Conflicts:      binfmt-detector
95 # sytemd wants pam with pam_systemd.so in system-auth...
96 Conflicts:      pam < 1:1.1.5-5
97 # ...and sudo hates it
98 Conflicts:      sudo < 1:1.7.8p2-4
99 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
100
101 %define         _libexecdir     %{_prefix}/lib
102
103 %description
104 systemd is a system and service manager for Linux, compatible with
105 SysV and LSB init scripts. systemd provides aggressive parallelization
106 capabilities, uses socket and D-Bus activation for starting services,
107 offers on-demand starting of daemons, keeps track of processes using
108 Linux cgroups, supports snapshotting and restoring of the system
109 state, maintains mount and automount points and implements an
110 elaborate transactional dependency-based service control logic. It can
111 work as a drop-in replacement for sysvinit.
112
113 %description -l pl.UTF-8
114 systemd jest zarządcą systemu i usług dla Linuksa, kompatybilny ze
115 skryptami SysV i LSB. systemd udostępnia rozbudowane zdolności
116 paralelizacji, do uruchamiania usług używa socketów oraz D-Busa,
117 oferuje uruchamianie usług na życzenie, monitoruje procesy używając
118 linuksowych cgroups, wspomaga zapisywanie (snapshot) i odczytywanie
119 (restore) stanu systemu, zarządza (auto)mount pointami oraz
120 implementuje starannie opracowaną transakcjonalną, bazującą na
121 zależnościach logikę kontroli usług. Może pracować jako zastępca dla
122 sysvinit.
123
124 %package init
125 Summary:        systemd /sbin/init and LSB/SysV compatibility symlinks
126 Summary(pl.UTF-8):      /sbin/init z systemd i dowiązania dla kompatybilności z LSB/SysV
127 Group:          Base
128 Requires:       systemd
129 Provides:       readahead = 1:1.5.7-3
130 Provides:       virtual(init-daemon)
131 Obsoletes:      SysVinit
132 Obsoletes:      readahead < 1:1.5.7-3
133 Obsoletes:      virtual(init-daemon)
134 Conflicts:      upstart
135
136 %description init
137 Install this package when you are ready to final switch to systemd.
138
139 %description init -l pl.UTF-8
140 Ten pakiet należy zainstalować po przygotowaniu się do ostatecznego
141 przejścia na systemd.
142
143 %package units
144 Summary:        Configuration files, directories and installation tool for systemd
145 Summary(pl.UTF-8):      Pliki konfiguracyjne, katalogi i narzędzie instalacyjne dla systemd
146 Group:          Base
147 Requires(post): coreutils
148 Requires(post): /bin/awk
149
150 %description units
151 Basic configuration files, directories and installation tool for the
152 systemd system and service manager.
153
154 This is common config, use %{_sysconfdir}/systemd/system to override.
155
156 %description units -l pl.UTF-8
157 Podstawowe pliki konfiguracyjne, katalogi i narzędzie instalacyjne dla
158 zarządcy systemu i usług systemd.
159
160 Ten pakiet zawiera ogólną konfigurację, ustawienia można nadpisać
161 poprzez katalog %{_sysconfdir}/systemd/system.
162
163 %package plymouth
164 Summary:        Plymouth support units for systemd
165 Summary(pl.UTF-8):      Jednostki wspierające Plymouth dla systemd
166 Group:          Base
167 Requires:       %{name}-units = %{version}-%{release}
168
169 %description plymouth
170 Plymouth (graphical boot) support units for systemd.
171
172 %description plymouth -l pl.UTF-8
173 Jednostki wspierające Plymouth (graficzny start systemu) dla systemd.
174
175 %package gtk
176 Summary:        Graphical frontend for systemd
177 Summary(pl.UTF-8):      Graficzny interfejs do systemd
178 Group:          Base
179 Requires:       %{name} = %{version}-%{release}
180 Requires:       polkit
181
182 %description gtk
183 Graphical front-end for systemd.
184
185 %description gtk -l pl.UTF-8
186 Graficzny interfejs do systemd.
187
188 %package libs
189 Summary:        Shared systemd libraries
190 Summary(pl.UTF-8):      Biblioteki współdzielone systemd
191 Group:          Libraries
192
193 %description libs
194 Shared systemd libraries.
195
196 %description libs -l pl.UTF-8
197 Biblioteki współdzielone systemd.
198
199 %package devel
200 Summary:        Header files for systemd libraries
201 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek systemd
202 Group:          Development/Libraries
203 Requires:       %{name}-libs = %{version}-%{release}
204
205 %description devel
206 Header files for systemd libraries.
207
208 %description devel -l pl.UTF-8
209 Pliki nagłówkowe bibliotek systemd.
210
211 %package -n bash-completion-systemd
212 Summary:        bash-completion for systemd
213 Summary(pl.UTF-8):      Bashowe dopełnianie składni dla systemd
214 Group:          Applications/Shells
215 Requires:       %{name}
216 Requires:       bash-completion
217
218 %description -n bash-completion-systemd
219 bash-completion for systemd.
220
221 %description -n bash-completion-systemd -l pl.UTF-8
222 Bashowe dopełnianie składni dla systemd
223
224 %package no-compat-tmpfiles
225 Summary:        Force update of packages that provide tmpfiles.d configuration
226 Group:          Base
227 Requires(post): sed > 4.0
228 Conflicts:      ConsoleKit-dirs < 0.4.5-7
229 Conflicts:      NetworkManager < 2:0.9.2.0-3
230 Conflicts:      Zope < 2.11.8-2
231 Conflicts:      amavisd-new < 1:2.7.0-1
232 Conflicts:      apache-base < 2.2.21-4
233 Conflicts:      apache-mod_bw < 0.92-3
234 Conflicts:      apache-mod_fastcgi < 2.4.6-6
235 Conflicts:      apache1-base < 1.3.42-5
236 Conflicts:      apache1-mod_fastcgi < 2.4.6-2
237 Conflicts:      asterisk < 10.0.1-2
238 Conflicts:      autossh-init < 1.4b-3
239 Conflicts:      balance < 3.54-2
240 Conflicts:      bind < 7:9.8.1.P1-4
241 Conflicts:      bopm < 3.1.3-4
242 Conflicts:      callweaver < 1.2.1-9
243 Conflicts:      cassandra-bin < 0.8.9-2
244 Conflicts:      clamav < 0.97.3-3
245 Conflicts:      cups < 1:1.5.0-10
246 Conflicts:      dbus < 1.4.16-4
247 Conflicts:      dovecot < 1:2.0.16-3
248 Conflicts:      dspam < 3.9.0-6
249 Conflicts:      fail2ban < 0.8.4-4
250 Conflicts:      filesystem < 4.0-3
251 Conflicts:      gammu-smsd < 1:1.31.0-3
252 # Break gdm2.20 installs
253 #Conflicts:     gdm < 2:3.2.1.1-9
254 Conflicts:      greylistd < 0.8.8-2
255 Conflicts:      inn < 2.4.6-7
256 Conflicts:      ipsec-tools < 0.8.0-3
257 Conflicts:      jabber-common < 0-9
258 Conflicts:      laptop-mode-tools < 1.58-2
259 Conflicts:      libgpod < 0.8.0-6
260 Conflicts:      libvirt-utils < 0.9.9-4
261 Conflicts:      lighttpd < 1.4.30-5
262 Conflicts:      lirc < 0.9.0-20
263 Conflicts:      mailman < 5:2.1.14-4
264 Conflicts:      memcached < 1.4.11-2
265 Conflicts:      mpd < 0.16.5-4
266 Conflicts:      mrtg < 2.17.0-3
267 Conflicts:      munin-common < 1.4.5-5
268 Conflicts:      nagios-nrpe < 2.13-2
269 Conflicts:      ndisc6-rdnssd < 1.0.1-3
270 Conflicts:      nscd < 6:2.14.1-5
271 Conflicts:      nss_ldapd-nslcd < 0.8.4-2
272 Conflicts:      openct < 0.6.20-3
273 Conflicts:      openl2tp < 1.8-3
274 Conflicts:      openldap-overlay-nssov < 2.4.28-4
275 Conflicts:      openldap-servers < 2.4.28-4
276 Conflicts:      openvpn < 2.2.2-2
277 Conflicts:      pam-pam_mount < 2.12-3
278 Conflicts:      pam-pam_ssh < 1.97-2
279 Conflicts:      pcsc-lite < 1.8.1-2
280 Conflicts:      php-dirs < 1.2-3
281 Conflicts:      policyd < 2.0.10-3
282 Conflicts:      pound < 2.6-2
283 Conflicts:      pptp < 1.7.2-3
284 Conflicts:      proftpd-common < 2:1.3.4a-2
285 Conflicts:      pulseaudio-server < 1.1-2
286 Conflicts:      quagga < 0.99.20-3
287 Conflicts:      radvd < 1.8.5-2
288 Conflicts:      rc-scripts < 0.4.5.2-3
289 Conflicts:      red5 < 0.9.0-2
290 Conflicts:      redis-server < 2.4.2-4
291 Conflicts:      smokeping < 2.4.2-10
292 Conflicts:      smtp-gated < 1.4.17-2
293 Conflicts:      socat < 1.7.2.0-2
294 Conflicts:      speech-dispatcher < 0.7.1-2
295 Conflicts:      sphinx < 2.0.3-4
296 Conflicts:      splashutils < 1.5.4.3-3
297 Conflicts:      stunnel < 4.50-2
298 Conflicts:      tenshi < 0.12-2
299 Conflicts:      tor < 0.2.2.35-2
300 Conflicts:      ucarp < 1.5.2-3
301 Conflicts:      udisks < 1.0.4-3
302 Conflicts:      util-vserver < 0.30.216-1.pre3002.3
303 Conflicts:      vpnc < 0.5.3-2
304 Conflicts:      web2ldap < 1.1.0rc1-2
305 Conflicts:      wesnoth-server < 1:1.10-2
306 Conflicts:      wpa_supplicant < 0.7.3-10
307 Conflicts:      xl2tpd < 1.3.0-2
308
309 %description no-compat-tmpfiles
310 Force update of packages that provide tmpfiles.d configuration
311
312 %prep
313 %setup -q
314 %patch0 -p1
315 %patch1 -p1
316 %patch2 -p1
317 %patch3 -p1
318 %patch4 -p1
319 cp -p %{SOURCE2} src/systemd_booted.c
320
321 %build
322 %{__aclocal} -I m4
323 %{__autoconf}
324 %{__autoheader}
325 %{__automake}
326 %configure \
327         %{__enable_disable audit} \
328         %{__enable_disable cryptsetup libcryptsetup} \
329         %{__enable_disable gtk} \
330         %{__enable_disable pam} \
331         %{__enable_disable plymouth} \
332         %{__enable_disable selinux} \
333         %{__enable_disable tcpd tcpwrap} \
334         --disable-silent-rules \
335         --disable-static \
336         --with-distro=pld \
337         --with-rootprefix= \
338         --with-rootlibdir=/%{_lib} \
339         --enable-split-usr
340
341 %{__make}
342 ./libtool --mode=link --tag=CC %{__cc} %{rpmcppflags} %{rpmcflags} -o systemd_booted %{rpmldflags} src/systemd_booted.c -L. -lsystemd-daemon
343
344 %install
345 rm -rf $RPM_BUILD_ROOT
346
347 %{__make} install \
348         DESTDIR=$RPM_BUILD_ROOT
349
350 ./libtool --mode=install install -m755 systemd_booted $RPM_BUILD_ROOT/bin/systemd_booted
351
352 # Main binary has been moved, but we don't want to break existing installs
353 ln -s ../lib/systemd/systemd $RPM_BUILD_ROOT/bin/systemd
354
355 # Create SysV compatibility symlinks. systemctl/systemd are smart
356 # enough to detect the way they were called
357 install -d $RPM_BUILD_ROOT/sbin
358 ln -s ../lib/systemd/systemd $RPM_BUILD_ROOT/sbin/init
359 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/halt
360 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/poweroff
361 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/reboot
362 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/runlevel
363 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/shutdown
364 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/telinit
365
366 ln -s ../modules $RPM_BUILD_ROOT%{_sysconfdir}/modules-load.d/modules.conf
367
368 # disable redundant SYSV services
369 ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/allowlogin.service
370 ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/console.service
371 ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/cpusets.service
372 ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/killall.service
373 ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/netfs.service
374 ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/random.service
375
376 # add static (non-NetworkManager) networking
377 install %{SOURCE3} $RPM_BUILD_ROOT%{systemdunitdir}/network.service
378
379 # install compatibility tmpfiles configs
380 install %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/tmpfiles.d/compat-pld-media.conf
381 install %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/tmpfiles.d/compat-pld-var-run.conf
382
383 # Install and enable storage subsystems support services (RAID, LVM, etc.)
384 install %{SOURCE10} $RPM_BUILD_ROOT%{systemdunitdir}/pld-storage-init-late.service
385 install %{SOURCE11} $RPM_BUILD_ROOT%{systemdunitdir}/pld-storage-init.service
386 install %{SOURCE12} $RPM_BUILD_ROOT%{systemdunitdir}/pld-wait-storage.service
387 install %{SOURCE13} $RPM_BUILD_ROOT/lib/systemd/pld-storage-init
388
389 ln -s ../pld-storage-init-late.service $RPM_BUILD_ROOT%{systemdunitdir}/local-fs.target.wants/pld-storage-init-late.service
390 ln -s ../pld-storage-init.service $RPM_BUILD_ROOT%{systemdunitdir}/local-fs.target.wants/pld-storage-init.service
391
392 # it is in rc-scripts pkg
393 %{__rm} $RPM_BUILD_ROOT%{systemdunitdir}/rc-local.service
394
395 # Make sure these directories are properly owned:
396 #       - halt,kexec,poweroff,reboot: generic ones used by ConsoleKit-systemd,
397 #       - syslog _might_ be used by some syslog implementation (none for now),
398 #       - isn't dbus populated by dbus-systemd only (so to be moved there)?
399 install -d $RPM_BUILD_ROOT%{systemdunitdir}/{dbus,halt,kexec,poweroff,reboot,syslog}.target.wants
400
401 # Create new-style configuration files so that we can ghost-own them
402 touch $RPM_BUILD_ROOT%{_sysconfdir}/{hostname,locale.conf,machine-id,machine-info,timezone,vconsole.conf}
403
404 # Install SysV conversion tool for systemd
405 install -p %{SOURCE1} $RPM_BUILD_ROOT%{_bindir}
406
407 install -d $RPM_BUILD_ROOT/var/log
408 :> $RPM_BUILD_ROOT/var/log/btmp
409 :> $RPM_BUILD_ROOT/var/log/wtmp
410
411 %if %{without gtk}
412 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/systemadm.1*
413 %endif
414
415 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
416 %{__rm} $RPM_BUILD_ROOT/%{_lib}/security/pam_systemd.la
417 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
418
419 %clean
420 rm -rf $RPM_BUILD_ROOT
421
422 %post
423 /bin/systemd-machine-id-setup > /dev/null 2>&1 || :
424 /bin/systemctl daemon-reexec > /dev/null 2>&1 || :
425
426 %postun
427 if [ $1 -ge 1 ]; then
428         /bin/systemctl try-restart systemd-logind.service >/dev/null 2>&1 || :
429 fi
430
431 %post   libs -p /sbin/ldconfig
432 %postun libs -p /sbin/ldconfig
433
434 %post units
435 if [ $1 -eq 1 ]; then
436         # Try to read default runlevel from the old inittab if it exists
437         runlevel=$(/bin/awk -F ':' '$3 == "initdefault" && $1 !~ "^#" { print $2 }' /etc/inittab 2> /dev/null)
438         if [ -z "$runlevel" ] ; then
439                 target="%{systemdunitdir}/graphical.target"
440         else
441                 target="%{systemdunitdir}/runlevel$runlevel.target"
442         fi
443
444         # And symlink what we found to the new-style default.target
445         ln -s "$target" %{_sysconfdir}/systemd/system/default.target >/dev/null 2>&1 || :
446
447         # Setup hostname
448         [ -f /etc/sysconfig/network ] && . /etc/sysconfig/network
449         if [ -n "$HOSTNAME" -a "$HOSTNAME" != "pldmachine" ]; then
450                 [ -f /etc/hostname ] && mv -f /etc/hostname /etc/hostname.rpmsave
451                 echo $HOSTNAME > /etc/hostname
452                 chmod 644 /etc/hostname
453         fi
454
455         # Enable the services we install by default.
456         /bin/systemctl enable \
457                 getty@.service \
458                 network.service \
459                 remote-fs.target \
460                 systemd-readahead-replay.service \
461                 systemd-readahead-collect.service >/dev/null 2>&1 || :
462 fi
463
464 %preun units
465 if [ $1 -eq 0 ] ; then
466         /bin/systemctl disable \
467                 getty@.service \
468                 network.service \
469                 remote-fs.target \
470                 systemd-readahead-replay.service \
471                 systemd-readahead-collect.service >/dev/null 2>&1 || :
472
473         %{__rm} -f %{_sysconfdir}/systemd/system/default.target >/dev/null 2>&1 || :
474 fi
475
476 %postun units
477 if [ $1 -ge 1 ]; then
478         /bin/systemctl daemon-reload > /dev/null 2>&1 || :
479 fi
480
481 %triggerpostun units -- %{name}-units < 43-4
482 # Remove design fialures
483 /bin/systemctl disable network-post.service >/dev/null 2>&1 || :
484 rm -f %{_sysconfdir}/systemd/system/network.target.wants/ifcfg@*.service >/dev/null 2>&1 || :
485 rm -f %{_sysconfdir}/systemd/system/network.target.wants/network-post.service >/dev/null 2>&1 || :
486
487 %post no-compat-tmpfiles
488 %{__sed} -i -e '/^#/!s/^/# /g' %{_sysconfdir}/tmpfiles.d/compat-pld-var-run.conf
489
490 %files
491 %defattr(644,root,root,755)
492 %doc DISTRO_PORTING README TODO
493 /etc/dbus-1/system.d/org.freedesktop.hostname1.conf
494 /etc/dbus-1/system.d/org.freedesktop.locale1.conf
495 /etc/dbus-1/system.d/org.freedesktop.login1.conf
496 /etc/dbus-1/system.d/org.freedesktop.systemd1.conf
497 /etc/dbus-1/system.d/org.freedesktop.timedate1.conf
498 %ghost %config(noreplace) %{_sysconfdir}/machine-id
499 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/hostname
500 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/locale.conf
501 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/machine-info
502 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/timezone
503 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/vconsole.conf
504 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/systemd/*.conf
505 %dir %{_sysconfdir}/systemd/user
506 %dir %{_sysconfdir}/systemd/system/*.target.wants
507 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/systemd/system/*.target.wants/*.service
508 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/systemd/system/*.target.wants/*.target
509 /etc/xdg/systemd
510 %attr(755,root,root) /bin/systemd
511 %attr(755,root,root) /bin/systemd-ask-password
512 %attr(755,root,root) /bin/systemd-journalctl
513 %attr(755,root,root) /bin/systemd-loginctl
514 %attr(755,root,root) /bin/systemd-machine-id-setup
515 %attr(755,root,root) /bin/systemd-notify
516 %attr(755,root,root) /bin/systemd-tty-ask-password-agent
517 %attr(755,root,root) %{_bindir}/systemd-analyze
518 %attr(755,root,root) %{_bindir}/systemd-cat
519 %attr(755,root,root) %{_bindir}/systemd-cgtop
520 %attr(755,root,root) %{_bindir}/systemd-cgls
521 %attr(755,root,root) %{_bindir}/systemd-nspawn
522 %attr(755,root,root) %{_bindir}/systemd-stdio-bridge
523 %attr(755,root,root) %{_bindir}/systemd-sysv-convert
524 %attr(755,root,root) /lib/systemd/pld-storage-init
525 %attr(755,root,root) /lib/systemd/systemd-*
526 %dir /lib/systemd/system-generators
527 %attr(755,root,root) /lib/systemd/systemd
528 %attr(755,root,root) /lib/systemd/system-generators/systemd-*-generator
529 %dir /lib/systemd/system-shutdown
530 /lib/udev/rules.d/99-systemd.rules
531 /lib/udev/rules.d/70-uaccess.rules
532 /lib/udev/rules.d/71-seat.rules
533 /lib/udev/rules.d/73-seat-late.rules
534 %dir %{_libexecdir}/systemd
535 %{_libexecdir}/systemd/user
536 %dir %{_libexecdir}/systemd/user-generators
537 %config(noreplace,missingok) %{_libexecdir}/tmpfiles.d/*.conf
538 %{_datadir}/dbus-1/interfaces/org.freedesktop.hostname1.xml
539 %{_datadir}/dbus-1/interfaces/org.freedesktop.locale1.xml
540 %{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.*.xml
541 %{_datadir}/dbus-1/interfaces/org.freedesktop.timedate1.xml
542 %{_datadir}/dbus-1/services/org.freedesktop.systemd1.service
543 %{_datadir}/dbus-1/system-services/org.freedesktop.hostname1.service
544 %{_datadir}/dbus-1/system-services/org.freedesktop.locale1.service
545 %{_datadir}/dbus-1/system-services/org.freedesktop.login1.service
546 %{_datadir}/dbus-1/system-services/org.freedesktop.systemd1.service
547 %{_datadir}/dbus-1/system-services/org.freedesktop.timedate1.service
548 %{_datadir}/polkit-1/actions/org.freedesktop.hostname1.policy
549 %{_datadir}/polkit-1/actions/org.freedesktop.locale1.policy
550 %{_datadir}/polkit-1/actions/org.freedesktop.login1.policy
551 %{_datadir}/polkit-1/actions/org.freedesktop.systemd1.policy
552 %{_datadir}/polkit-1/actions/org.freedesktop.timedate1.policy
553 %dir %{_datadir}/systemd
554 %{_datadir}/systemd/kbd-model-map
555 %{_mandir}/man1/systemd.1*
556 %{_mandir}/man1/systemd-*.1*
557 %{_mandir}/man3/sd_booted.3*
558 %{_mandir}/man3/sd_is_fifo.3*
559 %{_mandir}/man3/sd_is_socket.3
560 %{_mandir}/man3/sd_is_socket_inet.3
561 %{_mandir}/man3/sd_is_socket_unix.3
562 %{_mandir}/man3/sd_listen_fds.3*
563 %{_mandir}/man3/sd_notify.3*
564 %{_mandir}/man3/sd_notifyf.3
565 %{_mandir}/man3/sd_readahead.3*
566 %{_mandir}/man5/binfmt.d.5*
567 %{_mandir}/man5/hostname.5*
568 %{_mandir}/man5/locale.conf.5*
569 %{_mandir}/man5/machine-id.5*
570 %{_mandir}/man5/machine-info.5*
571 %{_mandir}/man5/modules-load.d.5*
572 %{_mandir}/man5/os-release.5*
573 %{_mandir}/man5/sysctl.d.5*
574 %{_mandir}/man5/systemd.*.5*
575 %{_mandir}/man5/systemd-logind.conf.5*
576 %{_mandir}/man5/timezone.5*
577 %{_mandir}/man5/vconsole.conf.5*
578 %{_mandir}/man7/daemon.7*
579 %{_mandir}/man7/sd-daemon.7*
580 %{_mandir}/man7/sd-login.7*
581 %{_mandir}/man7/sd-readahead.7*
582 %{_mandir}/man7/systemd.special.7*
583 %attr(640,root,root) %ghost /var/log/btmp
584 %attr(664,root,utmp) %ghost /var/log/wtmp
585
586 %if %{with pam}
587 %attr(755,root,root) /%{_lib}/security/pam_systemd.so
588 %{_mandir}/man8/pam_systemd.8*
589 %endif
590
591 %files init
592 %defattr(644,root,root,755)
593 %attr(755,root,root) /sbin/halt
594 %attr(755,root,root) /sbin/init
595 %attr(755,root,root) /sbin/poweroff
596 %attr(755,root,root) /sbin/reboot
597 %attr(755,root,root) /sbin/runlevel
598 %attr(755,root,root) /sbin/shutdown
599 %attr(755,root,root) /sbin/telinit
600 %{_mandir}/man1/init.1
601 %{_mandir}/man8/halt.8*
602 %{_mandir}/man8/poweroff.8
603 %{_mandir}/man8/reboot.8
604 %{_mandir}/man8/runlevel.8*
605 %{_mandir}/man8/shutdown.8*
606 %{_mandir}/man8/telinit.8*
607
608 %files units
609 %defattr(644,root,root,755)
610 %dir %{_sysconfdir}/binfmt.d
611 %dir %{_sysconfdir}/modules-load.d
612 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/modules-load.d/modules.conf
613 %dir %{_sysconfdir}/sysctl.d
614 %dir %{_sysconfdir}/systemd
615 %dir %{_sysconfdir}/systemd/system
616 %dir %{_sysconfdir}/tmpfiles.d
617 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/tmpfiles.d/*.conf
618 %dir %{_libexecdir}/binfmt.d
619 %dir %{_libexecdir}/modules-load.d
620 %dir %{_libexecdir}/sysctl.d
621 %{_libexecdir}/sysctl.d/coredump.conf
622 %attr(755,root,root) /bin/systemctl
623 %attr(755,root,root) /bin/systemd-tmpfiles
624 %attr(755,root,root) /bin/systemd_booted
625 %{_mandir}/man1/systemctl.1*
626 %{_mandir}/man5/tmpfiles.d.5*
627 %{_mandir}/man8/systemd-tmpfiles.8*
628 %{_npkgconfigdir}/systemd.pc
629
630 %{systemdunitdir}/*.automount
631 %{systemdunitdir}/*.mount
632 %{systemdunitdir}/*.path
633 %{systemdunitdir}/*.service
634 %{systemdunitdir}/*.socket
635 %{systemdunitdir}/*.target
636 %{systemdunitdir}/*.timer
637 %if %{with plymouth}
638 %exclude %{systemdunitdir}/plymouth*.service
639 %exclude %{systemdunitdir}/systemd-ask-password-plymouth.*
640 %endif
641 %dir %{systemdunitdir}/basic.target.wants
642 %dir %{systemdunitdir}/dbus.target.wants
643 %dir %{systemdunitdir}/final.target.wants
644 %dir %{systemdunitdir}/graphical.target.wants
645 %dir %{systemdunitdir}/halt.target.wants
646 %dir %{systemdunitdir}/kexec.target.wants
647 %dir %{systemdunitdir}/local-fs.target.wants
648 %dir %{systemdunitdir}/multi-user.target.wants
649 %dir %{systemdunitdir}/poweroff.target.wants
650 %dir %{systemdunitdir}/reboot.target.wants
651 %dir %{systemdunitdir}/runlevel[12345].target.wants
652 %dir %{systemdunitdir}/shutdown.target.wants
653 %dir %{systemdunitdir}/sockets.target.wants
654 %dir %{systemdunitdir}/sysinit.target.wants
655 %dir %{systemdunitdir}/syslog.target.wants
656 %config(noreplace,missingok) %{systemdunitdir}/basic.target.wants/*
657 %config(noreplace,missingok) %{systemdunitdir}/final.target.wants/*
658 %config(noreplace,missingok) %{systemdunitdir}/graphical.target.wants/*
659 %config(noreplace,missingok) %{systemdunitdir}/local-fs.target.wants/*
660 %config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/getty.target
661 %config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/rc-local.service
662 %config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/systemd-ask-password-wall.path
663 %config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/systemd-logind.service
664 %config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/systemd-user-sessions.service
665 %config(noreplace,missingok) %{systemdunitdir}/runlevel[12345].target.wants/*
666 %config(noreplace,missingok) %{systemdunitdir}/shutdown.target.wants/*
667 %config(noreplace,missingok) %{systemdunitdir}/sockets.target.wants/*
668 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/cryptsetup.target
669 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/dev-hugepages.mount
670 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/dev-mqueue.mount
671 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/proc-sys-fs-binfmt_misc.automount
672 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/sys-*.mount
673 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/systemd-*
674
675 %if %{with plymouth}
676 %files plymouth
677 %defattr(644,root,root,755)
678 %{systemdunitdir}/plymouth-halt.service
679 %{systemdunitdir}/plymouth-kexec.service
680 %{systemdunitdir}/plymouth-poweroff.service
681 %{systemdunitdir}/plymouth-quit-wait.service
682 %{systemdunitdir}/plymouth-quit.service
683 %{systemdunitdir}/plymouth-read-write.service
684 %{systemdunitdir}/plymouth-reboot.service
685 %{systemdunitdir}/plymouth-start.service
686 %{systemdunitdir}/systemd-ask-password-plymouth.path
687 %{systemdunitdir}/systemd-ask-password-plymouth.service
688 %config(noreplace,missingok) %{systemdunitdir}/halt.target.wants/plymouth-halt.service
689 %config(noreplace,missingok) %{systemdunitdir}/kexec.target.wants/plymouth-kexec.service
690 %config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/plymouth-quit.service
691 %config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/plymouth-quit-wait.service
692 %config(noreplace,missingok) %{systemdunitdir}/poweroff.target.wants/plymouth-poweroff.service
693 %config(noreplace,missingok) %{systemdunitdir}/reboot.target.wants/plymouth-reboot.service
694 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/plymouth-read-write.service
695 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/plymouth-start.service
696 %endif
697
698 %if %{with gtk}
699 %files gtk
700 %defattr(644,root,root,755)
701 %attr(755,root,root) %{_bindir}/systemadm
702 %attr(755,root,root) %{_bindir}/systemd-gnome-ask-password-agent
703 %{_mandir}/man1/systemadm.1*
704 %endif
705
706 %files libs
707 %defattr(644,root,root,755)
708 %attr(755,root,root) /%{_lib}/libsystemd-daemon.so.*.*.*
709 %attr(755,root,root) %ghost /%{_lib}/libsystemd-daemon.so.0
710 %attr(755,root,root) /%{_lib}/libsystemd-id128.so.*.*.*
711 %attr(755,root,root) %ghost /%{_lib}/libsystemd-id128.so.0
712 %attr(755,root,root) /%{_lib}/libsystemd-journal.so.*.*.*
713 %attr(755,root,root) %ghost /%{_lib}/libsystemd-journal.so.0
714 %attr(755,root,root) /%{_lib}/libsystemd-login.so.*.*.*
715 %attr(755,root,root) %ghost /%{_lib}/libsystemd-login.so.0
716
717 %files devel
718 %defattr(644,root,root,755)
719 %attr(755,root,root) %{_libdir}/libsystemd-daemon.so
720 %attr(755,root,root) %{_libdir}/libsystemd-id128.so
721 %attr(755,root,root) %{_libdir}/libsystemd-journal.so
722 %attr(755,root,root) %{_libdir}/libsystemd-login.so
723 %{_includedir}/%{name}
724 %{_pkgconfigdir}/libsystemd-daemon.pc
725 %{_pkgconfigdir}/libsystemd-id128.pc
726 %{_pkgconfigdir}/libsystemd-journal.pc
727 %{_pkgconfigdir}/libsystemd-login.pc
728 %{_mandir}/man3/sd_get_seats.3*
729 %{_mandir}/man3/sd_get_sessions.3*
730 %{_mandir}/man3/sd_get_uids.3*
731 %{_mandir}/man3/sd_is_mq.3*
732 %{_mandir}/man3/sd_login_monitor_flush.3*
733 %{_mandir}/man3/sd_login_monitor_get_fd.3*
734 %{_mandir}/man3/sd_login_monitor_new.3*
735 %{_mandir}/man3/sd_login_monitor_unref.3*
736 %{_mandir}/man3/sd_pid_get_owner_uid.3*
737 %{_mandir}/man3/sd_pid_get_session.3*
738 %{_mandir}/man3/sd_pid_get_unit.3*
739 %{_mandir}/man3/sd_seat_can_multi_session.3*
740 %{_mandir}/man3/sd_seat_get_active.3*
741 %{_mandir}/man3/sd_seat_get_sessions.3*
742 %{_mandir}/man3/sd_session_get_seat.3*
743 %{_mandir}/man3/sd_session_get_uid.3*
744 %{_mandir}/man3/sd_session_is_active.3*
745 %{_mandir}/man3/sd_uid_get_seats.3*
746 %{_mandir}/man3/sd_uid_get_sessions.3*
747 %{_mandir}/man3/sd_uid_get_state.3*
748 %{_mandir}/man3/sd_uid_is_on_seat.3*
749
750 %files -n bash-completion-systemd
751 %defattr(644,root,root,755)
752 /etc/bash_completion.d/systemd-bash-completion.sh
753
754 %files no-compat-tmpfiles
755 %defattr(644,root,root,755)
756 # empty package
This page took 0.097085 seconds and 4 git commands to generate.