]> git.pld-linux.org Git - packages/systemd.git/blob - systemd.spec
- revert last change, ${TMPDIR:-/tmp} is on a read only / at the time of boot
[packages/systemd.git] / systemd.spec
1 #
2 # TODO:
3 #       - remove compat-pld-var-run.tmpfiles and maybe tmpfiles-not-fatal.patch
4 #         after enough packages provide their own tmpfiles.d configs for
5 #         /var/run directories
6 #
7 # Conditional build:
8 %bcond_without  audit           # without audit support
9 %bcond_without  cryptsetup      # without cryptsetup support
10 %bcond_without  pam             # PAM authentication support
11 %bcond_without  plymouth        # do not install plymouth units
12 %bcond_without  selinux         # without SELinux support
13 %bcond_without  tcpd            # libwrap (tcp_wrappers) support
14
15 Summary:        A System and Service Manager
16 Summary(pl.UTF-8):      systemd - zarządca systemu i usług dla Linuksa
17 Name:           systemd
18 Version:        44
19 Release:        8
20 License:        GPL v2+
21 Group:          Base
22 Source0:        http://www.freedesktop.org/software/systemd/%{name}-%{version}.tar.xz
23 # Source0-md5:  11f44ff74c87850064e4351518bcff17
24 Source1:        %{name}-sysv-convert
25 Source2:        %{name}_booted.c
26 Source3:        network.service
27 Source4:        compat-pld-media.tmpfiles
28 Source5:        compat-pld-var-run.tmpfiles
29 Source10:       pld-storage-init-late.service
30 Source11:       pld-storage-init.service
31 Source12:       pld-wait-storage.service
32 Source13:       pld-storage-init.sh
33 Source14:       pld-clean-tmp.service
34 Source15:       pld-clean-tmp.sh
35 Patch0:         target-pld.patch
36 Patch1:         config-pld.patch
37 Patch2:         shut-sysv-up.patch
38 Patch3:         pld-sysv-network.patch
39 Patch4:         tmpfiles-not-fatal.patch
40 Patch5:         CVE-2012-1174.patch
41 Patch6:         dont-trash-X-sessions.patch
42 URL:            http://www.freedesktop.org/wiki/Software/systemd
43 BuildRequires:  acl-devel
44 %{?with_audit:BuildRequires:    audit-libs-devel}
45 BuildRequires:  autoconf >= 2.63
46 BuildRequires:  automake >= 1:1.11
47 BuildRequires:  binutils >= 3:2.22.52.0.1-2
48 %{?with_cryptsetup:BuildRequires:       cryptsetup-luks-devel}
49 BuildRequires:  dbus-devel >= 1.3.2
50 BuildRequires:  docbook-style-xsl
51 BuildRequires:  gperf
52 BuildRequires:  intltool >= 0.40.0
53 BuildRequires:  kmod-devel >= 5
54 BuildRequires:  libcap-devel
55 %{?with_selinux:BuildRequires:  libselinux-devel >= 2.1.0}
56 BuildRequires:  libtool >= 2:2.2
57 %{?with_tcpd:BuildRequires:     libwrap-devel}
58 BuildRequires:  libxslt-progs
59 BuildRequires:  m4
60 %{?with_pam:BuildRequires:      pam-devel}
61 BuildRequires:  pkgconfig >= 0.9.0
62 BuildRequires:  rpmbuild(macros) >= 1.627
63 BuildRequires:  udev-devel >= 1:172
64 BuildRequires:  xz-devel
65 Requires:       %{name}-libs = %{version}-%{release}
66 Requires:       %{name}-units = %{version}-%{release}
67 Requires:       /etc/os-release
68 Requires:       SysVinit-tools
69 Requires:       agetty
70 Requires:       dbus >= 1.4.16-6
71 Requires:       filesystem >= 4.0-2
72 Requires:       libutempter
73 Requires:       rc-scripts >= 0.4.5.3-7
74 Requires:       setup >= 2.8.0-2
75 Requires:       udev-core >= 1:175-5
76 Requires:       udev-libs >= 1:172
77 Requires:       virtual(module-tools)
78 Suggests:       %{name}-no-compat-tmpfiles
79 Suggests:       ConsoleKit
80 Suggests:       fsck >= 2.20
81 Suggests:       kmod >= 5
82 Suggests:       nss_myhostname
83 Suggests:       service(klogd)
84 Suggests:       service(syslog)
85 Provides:       udev-acl
86 # systemd takes care of that and causes problems
87 Conflicts:      binfmt-detector
88 # sytemd wants pam with pam_systemd.so in system-auth...
89 Conflicts:      pam < 1:1.1.5-5
90 # ...and sudo hates it
91 Conflicts:      sudo < 1:1.7.8p2-4
92 # for prefdm script
93 Conflicts:      xinitrc-ng < 1.0
94 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
95
96 %define         _libexecdir     %{_prefix}/lib
97
98 %description
99 systemd is a system and service manager for Linux, compatible with
100 SysV and LSB init scripts. systemd provides aggressive parallelization
101 capabilities, uses socket and D-Bus activation for starting services,
102 offers on-demand starting of daemons, keeps track of processes using
103 Linux cgroups, supports snapshotting and restoring of the system
104 state, maintains mount and automount points and implements an
105 elaborate transactional dependency-based service control logic. It can
106 work as a drop-in replacement for sysvinit.
107
108 %description -l pl.UTF-8
109 systemd jest zarządcą systemu i usług dla Linuksa, kompatybilny ze
110 skryptami SysV i LSB. systemd udostępnia rozbudowane zdolności
111 paralelizacji, do uruchamiania usług używa socketów oraz D-Busa,
112 oferuje uruchamianie usług na życzenie, monitoruje procesy używając
113 linuksowych cgroups, wspomaga zapisywanie (snapshot) i odczytywanie
114 (restore) stanu systemu, zarządza (auto)mount pointami oraz
115 implementuje starannie opracowaną transakcjonalną, bazującą na
116 zależnościach logikę kontroli usług. Może pracować jako zastępca dla
117 sysvinit.
118
119 %package init
120 Summary:        systemd /sbin/init and LSB/SysV compatibility symlinks
121 Summary(pl.UTF-8):      /sbin/init z systemd i dowiązania dla kompatybilności z LSB/SysV
122 Group:          Base
123 Requires:       systemd
124 Provides:       readahead = 1:1.5.7-3
125 Provides:       virtual(init-daemon)
126 Obsoletes:      SysVinit
127 Obsoletes:      readahead < 1:1.5.7-3
128 Obsoletes:      virtual(init-daemon)
129 Conflicts:      upstart
130
131 %description init
132 Install this package when you are ready to final switch to systemd.
133
134 %description init -l pl.UTF-8
135 Ten pakiet należy zainstalować po przygotowaniu się do ostatecznego
136 przejścia na systemd.
137
138 %package units
139 Summary:        Configuration files, directories and installation tool for systemd
140 Summary(pl.UTF-8):      Pliki konfiguracyjne, katalogi i narzędzie instalacyjne dla systemd
141 Group:          Base
142 Requires(post): coreutils
143 Requires(post): /bin/awk
144
145 %description units
146 Basic configuration files, directories and installation tool for the
147 systemd system and service manager.
148
149 This is common config, use %{_sysconfdir}/systemd/system to override.
150
151 %description units -l pl.UTF-8
152 Podstawowe pliki konfiguracyjne, katalogi i narzędzie instalacyjne dla
153 zarządcy systemu i usług systemd.
154
155 Ten pakiet zawiera ogólną konfigurację, ustawienia można nadpisać
156 poprzez katalog %{_sysconfdir}/systemd/system.
157
158 %package plymouth
159 Summary:        Plymouth support units for systemd
160 Summary(pl.UTF-8):      Jednostki wspierające Plymouth dla systemd
161 Group:          Base
162 Requires:       %{name}-units = %{version}-%{release}
163 Requires:       plymouth
164
165 %description plymouth
166 Plymouth (graphical boot) support units for systemd.
167
168 %description plymouth -l pl.UTF-8
169 Jednostki wspierające Plymouth (graficzny start systemu) dla systemd.
170
171 %package analyze
172 Summary:        Tool for processing systemd profiling information
173 Group:          Base
174 Requires:       %{name} = %{version}-%{release}
175 Requires:       python-dbus
176 Requires:       python-modules
177 Requires:       python-pycairo
178 Conflicts:      %{name} < 44-3
179
180 %description analyze
181 'systemd-analyze blame' lists which systemd unit needed how much time
182 to finish initialization at boot. 'systemd-analyze plot' renders an
183 SVG visualizing the parallel start of units at boot.
184
185 %package libs
186 Summary:        Shared systemd libraries
187 Summary(pl.UTF-8):      Biblioteki współdzielone systemd
188 Group:          Libraries
189
190 %description libs
191 Shared systemd libraries.
192
193 %description libs -l pl.UTF-8
194 Biblioteki współdzielone systemd.
195
196 %package devel
197 Summary:        Header files for systemd libraries
198 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek systemd
199 Group:          Development/Libraries
200 Requires:       %{name}-libs = %{version}-%{release}
201
202 %description devel
203 Header files for systemd libraries.
204
205 %description devel -l pl.UTF-8
206 Pliki nagłówkowe bibliotek systemd.
207
208 %package -n bash-completion-systemd
209 Summary:        bash-completion for systemd
210 Summary(pl.UTF-8):      Bashowe dopełnianie składni dla systemd
211 Group:          Applications/Shells
212 Requires:       %{name}
213 Requires:       bash-completion
214
215 %description -n bash-completion-systemd
216 bash-completion for systemd.
217
218 %description -n bash-completion-systemd -l pl.UTF-8
219 Bashowe dopełnianie składni dla systemd
220
221 %package no-compat-tmpfiles
222 Summary:        Force update of packages that provide tmpfiles.d configuration
223 Group:          Base
224 Requires(post): sed > 4.0
225 Conflicts:      ConsoleKit-dirs < 0.4.5-7
226 Conflicts:      NetworkManager < 2:0.9.2.0-3
227 Conflicts:      Zope < 2.11.8-2
228 Conflicts:      amavisd-new < 1:2.7.0-1
229 Conflicts:      apache-base < 2.2.21-4
230 Conflicts:      apache-mod_bw < 0.92-3
231 Conflicts:      apache-mod_fastcgi < 2.4.6-6
232 Conflicts:      apache1-base < 1.3.42-5
233 Conflicts:      apache1-mod_fastcgi < 2.4.6-2
234 Conflicts:      asterisk < 10.0.1-2
235 Conflicts:      autossh-init < 1.4b-3
236 Conflicts:      balance < 3.54-2
237 Conflicts:      bind < 7:9.8.1.P1-4
238 Conflicts:      bopm < 3.1.3-4
239 Conflicts:      callweaver < 1.2.1-9
240 Conflicts:      cassandra-bin < 0.8.9-2
241 Conflicts:      clamav < 0.97.3-3
242 Conflicts:      cups < 1:1.5.0-10
243 Conflicts:      dbus < 1.4.16-4
244 Conflicts:      dovecot < 1:2.0.16-3
245 Conflicts:      dspam < 3.9.0-6
246 Conflicts:      fail2ban < 0.8.4-4
247 Conflicts:      filesystem < 4.0-3
248 Conflicts:      gammu-smsd < 1:1.31.0-3
249 # Break gdm2.20 installs
250 #Conflicts:     gdm < 2:3.2.1.1-9
251 Conflicts:      greylistd < 0.8.8-2
252 Conflicts:      inn < 2.4.6-7
253 Conflicts:      ipsec-tools < 0.8.0-3
254 Conflicts:      jabber-common < 0-9
255 Conflicts:      laptop-mode-tools < 1.58-2
256 Conflicts:      libgpod < 0.8.0-6
257 Conflicts:      libvirt-utils < 0.9.9-4
258 Conflicts:      lighttpd < 1.4.30-5
259 Conflicts:      lirc < 0.9.0-20
260 Conflicts:      mailman < 5:2.1.14-4
261 Conflicts:      memcached < 1.4.11-2
262 Conflicts:      mpd < 0.16.5-4
263 Conflicts:      mrtg < 2.17.0-3
264 Conflicts:      munin-common < 1.4.5-5
265 Conflicts:      nagios-nrpe < 2.13-2
266 Conflicts:      ndisc6-rdnssd < 1.0.1-3
267 Conflicts:      nscd < 6:2.14.1-5
268 Conflicts:      nss_ldapd-nslcd < 0.8.4-2
269 Conflicts:      openct < 0.6.20-3
270 Conflicts:      openl2tp < 1.8-3
271 Conflicts:      openldap-overlay-nssov < 2.4.28-4
272 Conflicts:      openldap-servers < 2.4.28-4
273 Conflicts:      openvpn < 2.2.2-2
274 Conflicts:      pam-pam_mount < 2.12-3
275 Conflicts:      pam-pam_ssh < 1.97-2
276 Conflicts:      pcsc-lite < 1.8.1-2
277 Conflicts:      php-dirs < 1.2-3
278 Conflicts:      policyd < 2.0.10-3
279 Conflicts:      pound < 2.6-2
280 Conflicts:      pptp < 1.7.2-3
281 Conflicts:      proftpd-common < 2:1.3.4a-2
282 Conflicts:      pulseaudio-server < 1.1-2
283 Conflicts:      quagga < 0.99.20-3
284 Conflicts:      radvd < 1.8.5-2
285 Conflicts:      rc-scripts < 0.4.5.2-3
286 Conflicts:      red5 < 0.9.0-2
287 Conflicts:      redis-server < 2.4.2-4
288 Conflicts:      smokeping < 2.4.2-10
289 Conflicts:      smtp-gated < 1.4.17-2
290 Conflicts:      socat < 1.7.2.0-2
291 Conflicts:      speech-dispatcher < 0.7.1-2
292 Conflicts:      sphinx < 2.0.3-4
293 Conflicts:      splashutils < 1.5.4.3-3
294 Conflicts:      stunnel < 4.50-2
295 Conflicts:      tenshi < 0.12-2
296 Conflicts:      tor < 0.2.2.35-2
297 Conflicts:      ucarp < 1.5.2-3
298 Conflicts:      udisks < 1.0.4-3
299 Conflicts:      util-vserver < 0.30.216-1.pre3002.3
300 Conflicts:      vpnc < 0.5.3-2
301 Conflicts:      web2ldap < 1.1.0rc1-2
302 Conflicts:      wesnoth-server < 1:1.10-2
303 Conflicts:      wpa_supplicant < 0.7.3-10
304 Conflicts:      xl2tpd < 1.3.0-2
305
306 %description no-compat-tmpfiles
307 Force update of packages that provide tmpfiles.d configuration
308
309 %prep
310 %setup -q
311 %patch0 -p1
312 %patch1 -p1
313 %patch2 -p1
314 %patch3 -p1
315 %patch4 -p1
316 %patch5 -p1
317 %patch6 -p1
318 cp -p %{SOURCE2} src/systemd_booted.c
319
320 %build
321 %{__aclocal} -I m4
322 %{__autoconf}
323 %{__autoheader}
324 %{__automake}
325 %configure \
326         %{__enable_disable audit} \
327         %{__enable_disable cryptsetup libcryptsetup} \
328         --disable-gtk \
329         %{__enable_disable pam} \
330         %{__enable_disable plymouth} \
331         %{__enable_disable selinux} \
332         %{__enable_disable tcpd tcpwrap} \
333         --disable-silent-rules \
334         --disable-static \
335         --with-distro=pld \
336         --with-rootprefix= \
337         --with-rootlibdir=/%{_lib} \
338         --enable-split-usr
339
340 %{__make}
341 ./libtool --mode=link --tag=CC %{__cc} %{rpmcppflags} %{rpmcflags} -o systemd_booted %{rpmldflags} src/systemd_booted.c -L. -lsystemd-daemon
342
343 %install
344 rm -rf $RPM_BUILD_ROOT
345 install -d $RPM_BUILD_ROOT/var/lib/%{name}/coredump
346
347 %{__make} install \
348         DESTDIR=$RPM_BUILD_ROOT
349
350 ./libtool --mode=install install -p -m755 systemd_booted $RPM_BUILD_ROOT/bin/systemd_booted
351
352 # Main binary has been moved, but we don't want to break existing installs
353 ln -s ../lib/systemd/systemd $RPM_BUILD_ROOT/bin/systemd
354
355 # Create SysV compatibility symlinks. systemctl/systemd are smart
356 # enough to detect the way they were called
357 install -d $RPM_BUILD_ROOT/sbin
358 ln -s ../lib/systemd/systemd $RPM_BUILD_ROOT/sbin/init
359 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/halt
360 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/poweroff
361 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/reboot
362 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/runlevel
363 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/shutdown
364 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/telinit
365
366 ln -s ../modules $RPM_BUILD_ROOT%{_sysconfdir}/modules-load.d/modules.conf
367
368 # disable redundant SYSV services
369 ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/allowlogin.service
370 ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/console.service
371 ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/cpusets.service
372 ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/killall.service
373 ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/netfs.service
374 ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/random.service
375
376 # add static (non-NetworkManager) networking
377 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{systemdunitdir}/network.service
378
379 # install compatibility tmpfiles configs
380 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/tmpfiles.d/compat-pld-media.conf
381 cp -p %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/tmpfiles.d/compat-pld-var-run.conf
382
383 # Install and enable storage subsystems support services (RAID, LVM, etc.)
384 cp -p %{SOURCE10} $RPM_BUILD_ROOT%{systemdunitdir}/pld-storage-init-late.service
385 cp -p %{SOURCE11} $RPM_BUILD_ROOT%{systemdunitdir}/pld-storage-init.service
386 cp -p %{SOURCE12} $RPM_BUILD_ROOT%{systemdunitdir}/pld-wait-storage.service
387 cp -p %{SOURCE14} $RPM_BUILD_ROOT%{systemdunitdir}/pld-clean-tmp.service
388 install -p %{SOURCE13} $RPM_BUILD_ROOT/lib/systemd/pld-storage-init
389 install -p %{SOURCE15} $RPM_BUILD_ROOT/lib/systemd/pld-clean-tmp
390
391 ln -s ../pld-storage-init-late.service $RPM_BUILD_ROOT%{systemdunitdir}/local-fs.target.wants
392 ln -s ../pld-storage-init.service $RPM_BUILD_ROOT%{systemdunitdir}/local-fs.target.wants
393 ln -s ../pld-clean-tmp.service $RPM_BUILD_ROOT%{systemdunitdir}/local-fs.target.wants
394
395 # handled by rc-local sysv service, no need for generator
396 %{__rm} $RPM_BUILD_ROOT/lib/systemd/system-generators/systemd-rc-local-generator
397
398 # Make sure these directories are properly owned:
399 #       - halt,kexec,poweroff,reboot: generic ones used by ConsoleKit-systemd,
400 #       - syslog _might_ be used by some syslog implementation (none for now),
401 #       - isn't dbus populated by dbus-systemd only (so to be moved there)?
402 install -d $RPM_BUILD_ROOT%{systemdunitdir}/{dbus,halt,kexec,poweroff,reboot,syslog}.target.wants
403
404 # Create new-style configuration files so that we can ghost-own them
405 touch $RPM_BUILD_ROOT%{_sysconfdir}/{hostname,locale.conf,machine-id,machine-info,timezone,vconsole.conf}
406
407 # Install SysV conversion tool for systemd
408 install -p %{SOURCE1} $RPM_BUILD_ROOT%{_bindir}
409
410 install -d $RPM_BUILD_ROOT/var/log
411 :> $RPM_BUILD_ROOT/var/log/btmp
412 :> $RPM_BUILD_ROOT/var/log/wtmp
413
414 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/systemadm.1*
415
416 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
417 %{__rm} $RPM_BUILD_ROOT/%{_lib}/security/pam_systemd.la
418 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
419
420 %clean
421 rm -rf $RPM_BUILD_ROOT
422
423 %post
424 /bin/systemd-machine-id-setup > /dev/null 2>&1 || :
425 /bin/systemctl daemon-reexec > /dev/null 2>&1 || :
426
427 %postun
428 if [ $1 -ge 1 ]; then
429         /bin/systemctl try-restart systemd-logind.service >/dev/null 2>&1 || :
430 fi
431
432 %post   libs -p /sbin/ldconfig
433 %postun libs -p /sbin/ldconfig
434
435 %post units
436 if [ $1 -eq 1 ]; then
437         # Try to read default runlevel from the old inittab if it exists
438         runlevel=$(/bin/awk -F ':' '$3 == "initdefault" && $1 !~ "^#" { print $2 }' /etc/inittab 2> /dev/null)
439         if [ -z "$runlevel" ] ; then
440                 target="%{systemdunitdir}/graphical.target"
441         else
442                 target="%{systemdunitdir}/runlevel$runlevel.target"
443         fi
444
445         # And symlink what we found to the new-style default.target
446         ln -s "$target" %{_sysconfdir}/systemd/system/default.target >/dev/null 2>&1 || :
447
448         # Setup hostname
449         [ -f /etc/sysconfig/network ] && . /etc/sysconfig/network
450         if [ -n "$HOSTNAME" -a "$HOSTNAME" != "pldmachine" ]; then
451                 [ -f /etc/hostname ] && mv -f /etc/hostname /etc/hostname.rpmsave
452                 echo $HOSTNAME > /etc/hostname
453                 chmod 644 /etc/hostname
454         fi
455
456         # Enable the services we install by default.
457         /bin/systemctl enable \
458                 getty@.service \
459                 network.service \
460                 remote-fs.target \
461                 systemd-readahead-replay.service \
462                 systemd-readahead-collect.service >/dev/null 2>&1 || :
463 fi
464
465 %preun units
466 if [ $1 -eq 0 ] ; then
467         /bin/systemctl disable \
468                 getty@.service \
469                 network.service \
470                 remote-fs.target \
471                 systemd-readahead-replay.service \
472                 systemd-readahead-collect.service >/dev/null 2>&1 || :
473
474         %{__rm} -f %{_sysconfdir}/systemd/system/default.target >/dev/null 2>&1 || :
475 fi
476
477 %postun units
478 if [ $1 -ge 1 ]; then
479         /bin/systemctl daemon-reload > /dev/null 2>&1 || :
480 fi
481
482 %triggerpostun units -- %{name}-units < 43-7
483 # Remove design fialures
484 rm -f %{_sysconfdir}/systemd/system/network.target.wants/ifcfg@*.service >/dev/null 2>&1 || :
485 rm -f %{_sysconfdir}/systemd/system/network.target.wants/network-post.service >/dev/null 2>&1 || :
486 rm -f %{_sysconfdir}/systemd/system/multi-user.target.wants/network-post.service >/dev/null 2>&1 || :
487 /bin/systemctl reenable network.service >/dev/null 2>&1 || :
488
489 %post no-compat-tmpfiles
490 %{__sed} -i -e '/^#/!s/^/# /g' %{_sysconfdir}/tmpfiles.d/compat-pld-var-run.conf
491
492 %post plymouth
493 %systemd_reload
494
495 %postun plymouth
496 %systemd_reload
497
498 %files
499 %defattr(644,root,root,755)
500 %doc DISTRO_PORTING README TODO
501 /etc/dbus-1/system.d/org.freedesktop.hostname1.conf
502 /etc/dbus-1/system.d/org.freedesktop.locale1.conf
503 /etc/dbus-1/system.d/org.freedesktop.login1.conf
504 /etc/dbus-1/system.d/org.freedesktop.systemd1.conf
505 /etc/dbus-1/system.d/org.freedesktop.timedate1.conf
506 %ghost %config(noreplace) %{_sysconfdir}/machine-id
507 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/hostname
508 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/locale.conf
509 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/machine-info
510 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/timezone
511 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/vconsole.conf
512 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/systemd/*.conf
513 %dir %{_sysconfdir}/systemd/user
514 %dir %{_sysconfdir}/systemd/system/*.target.wants
515 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/systemd/system/*.target.wants/*.service
516 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/systemd/system/*.target.wants/*.target
517 /etc/xdg/systemd
518 %attr(755,root,root) /bin/systemd
519 %attr(755,root,root) /bin/systemd-ask-password
520 %attr(755,root,root) /bin/systemd-journalctl
521 %attr(755,root,root) /bin/systemd-loginctl
522 %attr(755,root,root) /bin/systemd-machine-id-setup
523 %attr(755,root,root) /bin/systemd-notify
524 %attr(755,root,root) /bin/systemd-tty-ask-password-agent
525 %attr(755,root,root) %{_bindir}/systemd-cat
526 %attr(755,root,root) %{_bindir}/systemd-cgtop
527 %attr(755,root,root) %{_bindir}/systemd-cgls
528 %attr(755,root,root) %{_bindir}/systemd-nspawn
529 %attr(755,root,root) %{_bindir}/systemd-stdio-bridge
530 %attr(755,root,root) %{_bindir}/systemd-sysv-convert
531 %attr(755,root,root) /lib/systemd/pld-storage-init
532 %attr(755,root,root) /lib/systemd/systemd-*
533 %dir /lib/systemd/system-generators
534 %attr(755,root,root) /lib/systemd/systemd
535 %attr(755,root,root) /lib/systemd/system-generators/systemd-*-generator
536 %dir /lib/systemd/system-shutdown
537 /lib/udev/rules.d/99-systemd.rules
538 /lib/udev/rules.d/70-uaccess.rules
539 /lib/udev/rules.d/71-seat.rules
540 /lib/udev/rules.d/73-seat-late.rules
541 %dir %{_libexecdir}/systemd
542 %{_libexecdir}/systemd/user
543 %dir %{_libexecdir}/systemd/user-generators
544 %config(noreplace,missingok) %{_libexecdir}/tmpfiles.d/*.conf
545 %{_datadir}/dbus-1/interfaces/org.freedesktop.hostname1.xml
546 %{_datadir}/dbus-1/interfaces/org.freedesktop.locale1.xml
547 %{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.*.xml
548 %{_datadir}/dbus-1/interfaces/org.freedesktop.timedate1.xml
549 %{_datadir}/dbus-1/services/org.freedesktop.systemd1.service
550 %{_datadir}/dbus-1/system-services/org.freedesktop.hostname1.service
551 %{_datadir}/dbus-1/system-services/org.freedesktop.locale1.service
552 %{_datadir}/dbus-1/system-services/org.freedesktop.login1.service
553 %{_datadir}/dbus-1/system-services/org.freedesktop.systemd1.service
554 %{_datadir}/dbus-1/system-services/org.freedesktop.timedate1.service
555 %{_datadir}/polkit-1/actions/org.freedesktop.hostname1.policy
556 %{_datadir}/polkit-1/actions/org.freedesktop.locale1.policy
557 %{_datadir}/polkit-1/actions/org.freedesktop.login1.policy
558 %{_datadir}/polkit-1/actions/org.freedesktop.systemd1.policy
559 %{_datadir}/polkit-1/actions/org.freedesktop.timedate1.policy
560 %dir %{_datadir}/systemd
561 %{_datadir}/systemd/kbd-model-map
562 %{_mandir}/man1/systemd.1*
563 %{_mandir}/man1/systemd-*.1*
564 %{_mandir}/man5/binfmt.d.5*
565 %{_mandir}/man5/hostname.5*
566 %{_mandir}/man5/locale.conf.5*
567 %{_mandir}/man5/machine-id.5*
568 %{_mandir}/man5/machine-info.5*
569 %{_mandir}/man5/modules-load.d.5*
570 %{_mandir}/man5/os-release.5*
571 %{_mandir}/man5/sysctl.d.5*
572 %{_mandir}/man5/systemd.*.5*
573 %{_mandir}/man5/systemd-journald.conf.5*
574 %{_mandir}/man5/systemd-logind.conf.5*
575 %{_mandir}/man5/timezone.5*
576 %{_mandir}/man5/vconsole.conf.5*
577 %{_mandir}/man7/daemon.7*
578 %{_mandir}/man7/sd-daemon.7*
579 %{_mandir}/man7/sd-login.7*
580 %{_mandir}/man7/sd-readahead.7*
581 %{_mandir}/man7/systemd.special.7*
582 %dir /var/lib/%{name}
583 %dir /var/lib/%{name}/coredump
584 %attr(640,root,root) %ghost /var/log/btmp
585 %attr(664,root,utmp) %ghost /var/log/wtmp
586
587 %if %{with pam}
588 %attr(755,root,root) /%{_lib}/security/pam_systemd.so
589 %{_mandir}/man8/pam_systemd.8*
590 %endif
591
592 %files init
593 %defattr(644,root,root,755)
594 %attr(755,root,root) /sbin/halt
595 %attr(755,root,root) /sbin/init
596 %attr(755,root,root) /sbin/poweroff
597 %attr(755,root,root) /sbin/reboot
598 %attr(755,root,root) /sbin/runlevel
599 %attr(755,root,root) /sbin/shutdown
600 %attr(755,root,root) /sbin/telinit
601 %{_mandir}/man1/init.1
602 %{_mandir}/man8/halt.8*
603 %{_mandir}/man8/poweroff.8
604 %{_mandir}/man8/reboot.8
605 %{_mandir}/man8/runlevel.8*
606 %{_mandir}/man8/shutdown.8*
607 %{_mandir}/man8/telinit.8*
608
609 %files units
610 %defattr(644,root,root,755)
611 %dir %{_sysconfdir}/binfmt.d
612 %dir %{_sysconfdir}/modules-load.d
613 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/modules-load.d/modules.conf
614 %dir %{_sysconfdir}/sysctl.d
615 %dir %{_sysconfdir}/systemd
616 %dir %{_sysconfdir}/systemd/system
617 %dir %{_sysconfdir}/tmpfiles.d
618 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/tmpfiles.d/*.conf
619 %dir %{_libexecdir}/binfmt.d
620 %dir %{_libexecdir}/modules-load.d
621 %dir %{_libexecdir}/sysctl.d
622 %{_libexecdir}/sysctl.d/coredump.conf
623 %attr(755,root,root) /bin/systemctl
624 %attr(755,root,root) /bin/systemd-tmpfiles
625 %attr(755,root,root) /bin/systemd_booted
626 %{_mandir}/man1/systemctl.1*
627 %{_mandir}/man5/tmpfiles.d.5*
628 %{_mandir}/man8/systemd-tmpfiles.8*
629 %{_npkgconfigdir}/systemd.pc
630
631 %{systemdunitdir}/*.automount
632 %{systemdunitdir}/*.mount
633 %{systemdunitdir}/*.path
634 %{systemdunitdir}/*.service
635 %{systemdunitdir}/*.socket
636 %{systemdunitdir}/*.target
637 %{systemdunitdir}/*.timer
638 %if %{with plymouth}
639 %exclude %{systemdunitdir}/plymouth*.service
640 %exclude %{systemdunitdir}/systemd-ask-password-plymouth.*
641 %endif
642 %dir %{systemdunitdir}/basic.target.wants
643 %dir %{systemdunitdir}/dbus.target.wants
644 %dir %{systemdunitdir}/final.target.wants
645 %dir %{systemdunitdir}/graphical.target.wants
646 %dir %{systemdunitdir}/halt.target.wants
647 %dir %{systemdunitdir}/kexec.target.wants
648 %dir %{systemdunitdir}/local-fs.target.wants
649 %dir %{systemdunitdir}/multi-user.target.wants
650 %dir %{systemdunitdir}/poweroff.target.wants
651 %dir %{systemdunitdir}/reboot.target.wants
652 %dir %{systemdunitdir}/runlevel[12345].target.wants
653 %dir %{systemdunitdir}/shutdown.target.wants
654 %dir %{systemdunitdir}/sockets.target.wants
655 %dir %{systemdunitdir}/sysinit.target.wants
656 %dir %{systemdunitdir}/syslog.target.wants
657 %config(noreplace,missingok) %{systemdunitdir}/basic.target.wants/*
658 %config(noreplace,missingok) %{systemdunitdir}/final.target.wants/*
659 %config(noreplace,missingok) %{systemdunitdir}/graphical.target.wants/*
660 %config(noreplace,missingok) %{systemdunitdir}/local-fs.target.wants/*
661 %config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/getty.target
662 %config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/rc-local.service
663 %config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/systemd-ask-password-wall.path
664 %config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/systemd-logind.service
665 %config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/systemd-user-sessions.service
666 %config(noreplace,missingok) %{systemdunitdir}/runlevel[12345].target.wants/*
667 %config(noreplace,missingok) %{systemdunitdir}/shutdown.target.wants/*
668 %config(noreplace,missingok) %{systemdunitdir}/sockets.target.wants/*
669 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/cryptsetup.target
670 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/dev-hugepages.mount
671 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/dev-mqueue.mount
672 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/proc-sys-fs-binfmt_misc.automount
673 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/sys-*.mount
674 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/systemd-*
675
676 %if %{with plymouth}
677 %files plymouth
678 %defattr(644,root,root,755)
679 %{systemdunitdir}/plymouth-halt.service
680 %{systemdunitdir}/plymouth-kexec.service
681 %{systemdunitdir}/plymouth-poweroff.service
682 %{systemdunitdir}/plymouth-quit-wait.service
683 %{systemdunitdir}/plymouth-quit.service
684 %{systemdunitdir}/plymouth-read-write.service
685 %{systemdunitdir}/plymouth-reboot.service
686 %{systemdunitdir}/plymouth-start.service
687 %{systemdunitdir}/systemd-ask-password-plymouth.path
688 %{systemdunitdir}/systemd-ask-password-plymouth.service
689 %config(noreplace,missingok) %{systemdunitdir}/halt.target.wants/plymouth-halt.service
690 %config(noreplace,missingok) %{systemdunitdir}/kexec.target.wants/plymouth-kexec.service
691 %config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/plymouth-quit.service
692 %config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/plymouth-quit-wait.service
693 %config(noreplace,missingok) %{systemdunitdir}/poweroff.target.wants/plymouth-poweroff.service
694 %config(noreplace,missingok) %{systemdunitdir}/reboot.target.wants/plymouth-reboot.service
695 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/plymouth-read-write.service
696 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/plymouth-start.service
697 %endif
698
699 %files analyze
700 %defattr(644,root,root,755)
701 %attr(755,root,root) %{_bindir}/systemd-analyze
702
703 %files libs
704 %defattr(644,root,root,755)
705 %attr(755,root,root) /%{_lib}/libsystemd-daemon.so.*.*.*
706 %attr(755,root,root) %ghost /%{_lib}/libsystemd-daemon.so.0
707 %attr(755,root,root) /%{_lib}/libsystemd-id128.so.*.*.*
708 %attr(755,root,root) %ghost /%{_lib}/libsystemd-id128.so.0
709 %attr(755,root,root) /%{_lib}/libsystemd-journal.so.*.*.*
710 %attr(755,root,root) %ghost /%{_lib}/libsystemd-journal.so.0
711 %attr(755,root,root) /%{_lib}/libsystemd-login.so.*.*.*
712 %attr(755,root,root) %ghost /%{_lib}/libsystemd-login.so.0
713
714 %files devel
715 %defattr(644,root,root,755)
716 %attr(755,root,root) %{_libdir}/libsystemd-daemon.so
717 %attr(755,root,root) %{_libdir}/libsystemd-id128.so
718 %attr(755,root,root) %{_libdir}/libsystemd-journal.so
719 %attr(755,root,root) %{_libdir}/libsystemd-login.so
720 %{_includedir}/%{name}
721 %{_pkgconfigdir}/libsystemd-daemon.pc
722 %{_pkgconfigdir}/libsystemd-id128.pc
723 %{_pkgconfigdir}/libsystemd-journal.pc
724 %{_pkgconfigdir}/libsystemd-login.pc
725 %{_mandir}/man3/sd_booted.3*
726 %{_mandir}/man3/sd_get_seats.3*
727 %{_mandir}/man3/sd_get_sessions.3*
728 %{_mandir}/man3/sd_get_uids.3*
729 %{_mandir}/man3/sd_is_fifo.3*
730 %{_mandir}/man3/sd_is_mq.3*
731 %{_mandir}/man3/sd_is_socket.3
732 %{_mandir}/man3/sd_is_socket_inet.3
733 %{_mandir}/man3/sd_is_socket_unix.3
734 %{_mandir}/man3/sd_listen_fds.3*
735 %{_mandir}/man3/sd_login_monitor_flush.3*
736 %{_mandir}/man3/sd_login_monitor_get_fd.3*
737 %{_mandir}/man3/sd_login_monitor_new.3*
738 %{_mandir}/man3/sd_login_monitor_unref.3*
739 %{_mandir}/man3/sd_notify.3*
740 %{_mandir}/man3/sd_notifyf.3
741 %{_mandir}/man3/sd_pid_get_owner_uid.3*
742 %{_mandir}/man3/sd_pid_get_session.3*
743 %{_mandir}/man3/sd_pid_get_unit.3*
744 %{_mandir}/man3/sd_readahead.3*
745 %{_mandir}/man3/sd_seat_can_multi_session.3*
746 %{_mandir}/man3/sd_seat_get_active.3*
747 %{_mandir}/man3/sd_seat_get_sessions.3*
748 %{_mandir}/man3/sd_session_get_class.3*
749 %{_mandir}/man3/sd_session_get_display.3*
750 %{_mandir}/man3/sd_session_get_seat.3*
751 %{_mandir}/man3/sd_session_get_service.3*
752 %{_mandir}/man3/sd_session_get_type.3*
753 %{_mandir}/man3/sd_session_get_uid.3*
754 %{_mandir}/man3/sd_session_is_active.3*
755 %{_mandir}/man3/sd_uid_get_seats.3*
756 %{_mandir}/man3/sd_uid_get_sessions.3*
757 %{_mandir}/man3/sd_uid_get_state.3*
758 %{_mandir}/man3/sd_uid_is_on_seat.3*
759
760 %files -n bash-completion-systemd
761 %defattr(644,root,root,755)
762 /etc/bash_completion.d/systemd-bash-completion.sh
763
764 %files no-compat-tmpfiles
765 %defattr(644,root,root,755)
766 # empty package
This page took 0.077868 seconds and 3 git commands to generate.