]> git.pld-linux.org Git - packages/sysstat.git/commitdiff
- gcc4 patch added
authorAdam Gołębiowski <adamg@pld-linux.org>
Tue, 24 May 2005 13:26:28 +0000 (13:26 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    sysstat-gcc4.patch -> 1.1
    sysstat.spec -> 1.58

sysstat-gcc4.patch [new file with mode: 0644]
sysstat.spec

diff --git a/sysstat-gcc4.patch b/sysstat-gcc4.patch
new file mode 100644 (file)
index 0000000..6a9f570
--- /dev/null
@@ -0,0 +1,169 @@
+diff --exclude='*~' --exclude='.*' -I '$Id:' -urN sysstat-6.0.0.orig/iostat.c sysstat-6.0.0/iostat.c
+--- sysstat-6.0.0.orig/iostat.c        2005-05-16 16:20:24.000000000 -0400
++++ sysstat-6.0.0/iostat.c     2005-05-16 16:48:06.000000000 -0400
+@@ -958,7 +958,7 @@
+    /* Print time stamp */
+    if (DISPLAY_TIMESTAMP(flags)) {
+-      strftime(timestamp, sizeof(timestamp), "%X", loc_time);
++      strftime((char *)timestamp, sizeof(timestamp), "%X", loc_time);
+       printf(_("Time: %s\n"), timestamp);
+    }
+diff --exclude='*~' --exclude='.*' -I '$Id:' -urN sysstat-6.0.0.orig/sa_common.c sysstat-6.0.0/sa_common.c
+--- sysstat-6.0.0.orig/sa_common.c     2005-05-16 16:20:24.000000000 -0400
++++ sysstat-6.0.0/sa_common.c  2005-05-16 16:42:31.000000000 -0400
+@@ -380,7 +380,7 @@
+       mktime(loc_time);
+    }
+    else
+-      loc_time = localtime(&(file_hdr->sa_ust_time));
++      loc_time = localtime((time_t *)(&(file_hdr->sa_ust_time)));
+    if (!format)
+       /* No output format (we are not using sadf) */
+@@ -406,7 +406,7 @@
+    while (index < file_hdr->sa_iface) {
+       st_net_dev_j = st_net_dev[ref] + index;
+-      if (!strcmp(st_net_dev_i->interface, st_net_dev_j->interface)) {
++      if (!strcmp((char *)st_net_dev_i->interface, (char *)st_net_dev_j->interface)) {
+        /*
+         * Network interface found.
+         * If a counter has decreased, then we may assume that the
+@@ -465,7 +465,7 @@
+           if (!ovfw) {
+              /* OK: assume here that the device was actually unregistered */
+              memset(st_net_dev_j, 0, STATS_NET_DEV_SIZE);
+-             strcpy(st_net_dev_j->interface, st_net_dev_i->interface);
++             strcpy((char *)st_net_dev_j->interface, (char *)st_net_dev_i->interface);
+           }
+        }
+        return index;
+@@ -476,9 +476,9 @@
+    /* Network interface not found: Look for the first free structure */
+    for (index = 0; index < file_hdr->sa_iface; index++) {
+       st_net_dev_j = st_net_dev[ref] + index;
+-      if (!strcmp(st_net_dev_j->interface, "?")) {
++      if (!strcmp((char *)st_net_dev_j->interface, "?")) {
+        memset(st_net_dev_j, 0, STATS_NET_DEV_SIZE);
+-       strcpy(st_net_dev_j->interface, st_net_dev_i->interface);
++       strcpy((char *)st_net_dev_j->interface, (char *)st_net_dev_i->interface);
+        break;
+       }
+    }
+@@ -489,7 +489,7 @@
+    st_net_dev_j = st_net_dev[ref] + index;
+    /* Since the name is not the same, reset all the structure */
+    memset(st_net_dev_j, 0, STATS_NET_DEV_SIZE);
+-   strcpy(st_net_dev_j->interface, st_net_dev_i->interface);
++   strcpy((char *)st_net_dev_j->interface, (char *)st_net_dev_i->interface);
+    return  index;
+ }
+diff --exclude='*~' --exclude='.*' -I '$Id:' -urN sysstat-6.0.0.orig/sadc.c sysstat-6.0.0/sadc.c
+--- sysstat-6.0.0.orig/sadc.c  2005-05-16 16:20:24.000000000 -0400
++++ sysstat-6.0.0/sadc.c       2005-05-16 16:33:19.000000000 -0400
+@@ -1419,7 +1419,7 @@
+         * old file with more interfaces than are actually available now.
+         */
+        st_net_dev_i = st_net_dev + dev++;
+-       strcpy(st_net_dev_i->interface, "?");
++       strcpy((char *)(st_net_dev_i->interface), "?");
+       }
+    }
+ }
+diff --exclude='*~' --exclude='.*' -I '$Id:' -urN sysstat-6.0.0.orig/sadf.c sysstat-6.0.0/sadf.c
+--- sysstat-6.0.0.orig/sadf.c  2005-05-16 16:20:24.000000000 -0400
++++ sysstat-6.0.0/sadf.c       2005-05-16 16:47:18.000000000 -0400
+@@ -136,10 +136,10 @@
+    if (PRINT_TRUE_TIME(flags) &&
+        ((format == S_O_DB_OPTION) || (format == S_O_XML_OPTION)))
+       /* '-d -t' or '-x -t' */
+-      ltm = localtime(&file_stats[curr].ust_time);
++      ltm = localtime((time_t *)(&file_stats[curr].ust_time));
+    else
+       /* '-p' or '-p -t' or '-d' or '-x' */
+-      ltm = gmtime(&file_stats[curr].ust_time);
++      ltm = gmtime((time_t *)(&file_stats[curr].ust_time));
+    loc_time = *ltm;
+ }
+@@ -675,7 +675,7 @@
+       for (i = 0; i < file_hdr.sa_iface; i++, ++sndi) {
+-       if (!strcmp((ifc = sndi->interface), "?"))
++       if (!strcmp((ifc = (char *)sndi->interface), "?"))
+           continue;
+        j = check_iface_reg(&file_hdr, st_net_dev, curr, !curr, i);
+@@ -722,7 +722,7 @@
+       for (i = 0; i < file_hdr.sa_iface; i++, ++sndi) {
+-       if (!strcmp((ifc = sndi->interface), "?"))
++       if (!strcmp((ifc = (char *)sndi->interface), "?"))
+           continue;
+        j = check_iface_reg(&file_hdr, st_net_dev, curr, !curr, i);
+@@ -1231,7 +1231,7 @@
+       for (i = 0; i < file_hdr.sa_iface; i++, sndi++) {
+       
+-       if (!strcmp(sndi->interface, "?"))
++       if (!strcmp((char *)sndi->interface, "?"))
+           continue;
+        j = check_iface_reg(&file_hdr, st_net_dev, curr, !curr, i);
+        sndj = st_net_dev[!curr] + j;
+@@ -1411,7 +1411,7 @@
+ {
+    printf("File: %s (%#x)\n", dfile, file_hdr->sa_magic);
+-   print_gal_header(localtime(&(file_hdr->sa_ust_time)), file_hdr->sa_sysname,
++   print_gal_header(localtime((time_t *)(&(file_hdr->sa_ust_time))), file_hdr->sa_sysname,
+                   file_hdr->sa_release, file_hdr->sa_nodename);
+    printf("Activity flag: %#x\n", file_hdr->sa_actflag);
+diff --exclude='*~' --exclude='.*' -I '$Id:' -urN sysstat-6.0.0.orig/sa.h sysstat-6.0.0/sa.h
+--- sysstat-6.0.0.orig/sa.h    2005-05-16 16:20:24.000000000 -0400
++++ sysstat-6.0.0/sa.h 2005-05-16 16:38:10.000000000 -0400
+@@ -489,7 +489,7 @@
+                                        struct stats_one_cpu *);
+ extern char      *get_devname(unsigned int, unsigned int, int);
+ extern void       init_bitmap(unsigned char [], unsigned char, unsigned int);
+-extern void       init_stats(struct file_stats [], unsigned int [][]);
++extern void       init_stats(struct file_stats [], unsigned int [DIM][NR_IRQS]);
+ extern int        next_slice(unsigned long long, unsigned long long,
+                              struct file_hdr *, int, long);
+ extern int        parse_sar_opt(char * [], int, unsigned int *,
+diff --exclude='*~' --exclude='.*' -I '$Id:' -urN sysstat-6.0.0.orig/sar.c sysstat-6.0.0/sar.c
+--- sysstat-6.0.0.orig/sar.c   2005-05-16 16:20:24.000000000 -0400
++++ sysstat-6.0.0/sar.c        2005-05-16 16:43:19.000000000 -0400
+@@ -213,7 +213,7 @@
+       loc_time.tm_sec  = file_stats[curr].second;
+    }
+    else {
+-      ltm = localtime(&file_stats[curr].ust_time);
++      ltm = localtime((time_t *)(&file_stats[curr].ust_time));
+       loc_time = *ltm;
+    }
+ }
+@@ -577,7 +577,7 @@
+       for (i = 0; i < file_hdr.sa_iface; i++, sndi++) {
+-       if (!strcmp(sndi->interface, "?"))
++       if (!strcmp((char *)sndi->interface, "?"))
+           continue;
+        j = check_iface_reg(&file_hdr, st_net_dev, curr, prev, i);
+        sndj = st_net_dev[prev] + j;
+@@ -608,7 +608,7 @@
+       for (i = 0; i < file_hdr.sa_iface; i++, sndi++) {
+-       if (!strcmp(sndi->interface, "?"))
++       if (!strcmp((char *)sndi->interface, "?"))
+           continue;
+        j = check_iface_reg(&file_hdr, st_net_dev, curr, prev, i);
+        sndj = st_net_dev[prev] + j;
index 5b53f36b63915173834126f17bb4ee69780904f0..dad0acc6fdb17c0a6fb72c68af7307e581d993ea 100644 (file)
@@ -14,6 +14,7 @@ Source1:      %{name}.crond
 Source2:       %{name}.init
 Source3:       %{name}.sysconfig
 Patch0:                %{name}-opt.patch
+Patch1:                %{name}-gcc4.patch
 URL:           http://perso.wanadoo.fr/sebastien.godard/
 BuildRequires: gettext-devel
 PreReq:                rc-scripts
@@ -49,6 +50,7 @@ sieciowych i innych operacji wej
 %prep
 %setup -q
 %patch0 -p1
+%patch1 -p1
 
 %build
 echo "%{_prefix}
This page took 0.040915 seconds and 4 git commands to generate.