]> git.pld-linux.org Git - packages/sysstat.git/commitdiff
fix libdir issues auto/th/sysstat-11.0.8-3
authorElan Ruusamäe <glen@delfi.ee>
Wed, 28 Oct 2015 11:30:00 +0000 (13:30 +0200)
committerElan Ruusamäe <glen@delfi.ee>
Wed, 28 Oct 2015 11:30:00 +0000 (13:30 +0200)
crontab
sysstat.init
sysstat.spec

diff --git a/crontab b/crontab
index 405d26ac2ae26d6ce695699421b3bb2f8c87727f..f84eb4d84a0e85d5f8622cb55fedf73c001249b0 100644 (file)
--- a/crontab
+++ b/crontab
@@ -1,16 +1,16 @@
 # Crontab
 #
 # 8am-7pm activity reports every 20 minutes during weekdays.
-# 0 8-18 * * 1-5 /bin/systemd_booted || /usr/lib64/sa/sa1 1200 3
+# 0 8-18 * * 1-5 /bin/systemd_booted || /usr/lib/sa/sa1 1200 3
 # activity reports every 10 minutes everyday.
-0 * * * * /bin/systemd_booted || /usr/lib64/sa/sa1 600 6
+0 * * * * /bin/systemd_booted || /usr/lib/sa/sa1 600 6
 #
 # Activity reports every an hour on Saturday and Sunday.
-# 0 * * * 0,6 /bin/systemd_booted || /usr/lib64/sa/sa1
+# 0 * * * 0,6 /bin/systemd_booted || /usr/lib/sa/sa1
 #
 # 7pm-8am activity reports every an hour during weekdays.
-# 0 19-7 * * 1-5 /bin/systemd_booted || /usr/lib64/sa/sa1
+# 0 19-7 * * 1-5 /bin/systemd_booted || /usr/lib/sa/sa1
 #
 # Daily summary prepared at 19:05.
-# 5 19 * * 1-5 /bin/systemd_booted || /usr/lib64/sa/sa2 -A
-5 19 * * * /bin/systemd_booted || /usr/lib64/sa/sa2 -A
+# 5 19 * * 1-5 /bin/systemd_booted || /usr/lib/sa/sa2 -A
+5 19 * * * /bin/systemd_booted || /usr/lib/sa/sa2 -A
index 7f2e568a6d6ad8f725a36fe952f9613ac62dfebc..d9b60f5d6633d854d2ed5cebc58cae2744782799 100755 (executable)
@@ -6,7 +6,6 @@
 #
 # description: Sysstat system monitoring tools (sar,iostat,mpstat)
 #
-# $Id$
 
 # Source function library
 . /etc/rc.d/init.d/functions
index 51f865891edb772f89bef8419c3e6d4af1a8d33b..03d5722543fe9a5f62b4292642a1bfda57ae9c9a 100644 (file)
@@ -10,7 +10,7 @@ Summary(zh_CN.UTF-8): sar, iostat 等系统监视工具
 # Sysstat 11.0.x (stable version).
 Name:          sysstat
 Version:       11.0.8
-Release:       2
+Release:       3
 License:       GPL v2
 Group:         Applications/System
 Source0:       http://pagesperso-orange.fr/sebastien.godard/%{name}-%{version}.tar.xz
@@ -34,6 +34,8 @@ Requires:     systemd-units >= 38
 Obsoletes:     iostat
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+%define                _libexecdir     %{_prefix}/lib/sa
+
 %description
 This package provides the sar and iostat commands for the Linux
 operating system, similar to their traditional UNIX counterparts. They
@@ -71,7 +73,7 @@ sieciowych i innych operacji wejścia/wyjścia.
        compressafter=31 \
        cron_owner=root \
        cron_interval=10 \
-       sa_lib_dir=%{_libdir}/sa \
+       sa_lib_dir=%{_libexecdir} \
        --enable-install-cron \
        --disable-stripping \
        --with-systemdsystemunitdir=%{systemdunitdir}
@@ -93,8 +95,6 @@ install -d $RPM_BUILD_ROOT{/etc/{cron.d,rc.d/init.d,sysconfig},/var/log/sa,%{sys
        DESTDIR=$RPM_BUILD_ROOT
 
 install -p %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/sysstat
-%{__sed} i -e 's|/usr/lib/sa|%{_libdir}/sa|g' $RPM_BUILD_ROOT/etc/rc.d/init.d/sysstat
-
 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/cron.d/%{name}
 
 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}
@@ -132,9 +132,10 @@ fi
 %attr(755,root,root) %{_bindir}/pidstat
 %attr(755,root,root) %{_bindir}/sadf
 %attr(755,root,root) %{_bindir}/sar
-%dir %{_libdir}/sa
-%attr(755,root,root) %{_libdir}/sa/sa*
-%attr(750,root,root) %dir /var/log/sa
+%dir %{_libexecdir}
+%attr(755,root,root) %{_libexecdir}/sa1
+%attr(755,root,root) %{_libexecdir}/sa2
+%attr(755,root,root) %{_libexecdir}/sadc
 %attr(754,root,root) /etc/rc.d/init.d/sysstat
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/sysstat
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/sysstat
@@ -155,3 +156,4 @@ fi
 %{_mandir}/man8/sa1.8*
 %{_mandir}/man8/sa2.8*
 %{_mandir}/man8/sadc.8*
+%attr(750,root,root) %dir /var/log/sa
This page took 0.030578 seconds and 4 git commands to generate.