]> git.pld-linux.org Git - packages/sysprof.git/blob - sysprof.spec
35c81bf9058b96f435cf7c19ac7abb3e34014667
[packages/sysprof.git] / sysprof.spec
1 #
2 # Conditional build:
3 %bcond_without  sysprofd        # daemon to run UI without root permissions
4 #
5 Summary:        Sampling CPU profiler for Linux
6 Summary(pl.UTF-8):      Próbkujący profiler procesora dla Linuksa
7 Name:           sysprof
8 Version:        3.34.1
9 Release:        1
10 License:        GPL v3+
11 Group:          Applications/System
12 Source0:        http://ftp.gnome.org/pub/GNOME/sources/sysprof/3.34/%{name}-%{version}.tar.xz
13 # Source0-md5:  cc32455277b31afb1965d627ae3e3629
14 URL:            http://sysprof.com/
15 # -std=gnu11 + C11 atomics
16 BuildRequires:  gcc >= 6:4.9
17 BuildRequires:  gdk-pixbuf2-devel >= 2.0
18 BuildRequires:  gettext-tools >= 0.19.6
19 BuildRequires:  glib2-devel >= 1:2.61.3
20 BuildRequires:  gobject-introspection-devel >= 1.42.0
21 BuildRequires:  gtk+3-devel >= 3.22
22 BuildRequires:  libdazzle-devel >= 3.30.0
23 BuildRequires:  libstdc++-devel >= 6:4.7
24 BuildRequires:  meson >= 0.50.0
25 BuildRequires:  ninja >= 1.5
26 BuildRequires:  pango-devel
27 BuildRequires:  pkgconfig >= 1:0.22
28 %{?with_sysprofd:BuildRequires: polkit-devel >= 0.105}
29 BuildRequires:  rpmbuild(macros) >= 1.736
30 %{?with_sysprofd:BuildRequires: systemd-devel >= 1:222}
31 BuildRequires:  tar >= 1:1.22
32 BuildRequires:  vala
33 BuildRequires:  xz
34 BuildRequires:  yelp-tools
35 Requires:       %{name}-libs = %{version}-%{release}
36 %{?with_sysprofd:Requires:      polkit >= 0.105}
37 %{?with_sysprofd:Requires:      systemd-units >= 1:222}
38 Requires:       uname(release) >= 2.6.31
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %description
42 Sysprof is a sampling CPU profiler for Linux that uses a kernel module
43 to profile the entire system, not just a single application. Sysprof
44 handles shared libraries and applications do not need to be
45 recompiled. In fact they don't even have to be restarted.
46
47 Just insert the kernel module and start sysprof.
48
49 %description -l pl.UTF-8
50 Sysprof to próbkujący profiler procesora dla Linuksa wykorzystujący
51 moduł jądra do profilowania całego systemu, nie tylko pojedynczej
52 aplikacji. Sysprof obsługuje biblioteki współdzielone, a aplikacje nie
53 wymagają rekompilacji. Właściwie nawet nie trzeba ich restartować.
54
55 Wystarczy załadować moduł jądra i uruchomić sysprof.
56
57 %package libs
58 Summary:        The sysprof profiler library
59 Summary(pl.UTF-8):      Biblioteka profilera sysprof
60 Group:          Libraries
61 Requires:       glib2 >= 1:2.61.3
62
63 %description libs
64 The sysprof profiler library.
65
66 %description libs -l pl.UTF-8
67 Biblioteka profilera sysprof.
68
69 %package devel
70 Summary:        Header files for sysprof library
71 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki sysprof
72 Group:          Development/Libraries
73 Requires:       %{name}-libs = %{version}-%{release}
74 Requires:       glib2-devel >= 1:2.61.3
75
76 %description devel
77 Header files for sysprof library.
78
79 %description devel -l pl.UTF-8
80 Pliki nagłówkowe biblioteki sysprof.
81
82 %package ui
83 Summary:        The sysprof graphical user interface
84 Summary(pl.UTF-8):      Graficzny interfejs użytkownika profilera sysprof
85 Group:          Applications/System
86 Requires(post,postun):  desktop-file-utils
87 Requires(post,postun):  glib2 >= 1:2.61.3
88 Requires(post,postun):  gtk-update-icon-cache
89 Requires:       %{name} = %{version}-%{release}
90 Requires:       %{name}-ui-libs = %{version}-%{release}
91 Requires:       hicolor-icon-theme
92 Requires:       shared-mime-info
93
94 %description ui
95 The sysprof graphical user interface.
96
97 %description ui -l pl.UTF-8
98 Graficzny interfejs użytkownika profilera sysprof.
99
100 %package ui-libs
101 Summary:        The sysprof library containing reusable GTK+ widgets
102 Summary(pl.UTF-8):      Biblioteka sysprofa zawierająca widgety GTK+ wielokrotnego użytku
103 Group:          X11/Libraries
104 Requires:       %{name}-libs = %{version}-%{release}
105 Requires:       gtk+3 >= 3.22
106 Requires:       libdazzle >= 3.30.0
107
108 %description ui-libs
109 The sysprof library containing reusable GTK+ widgets.
110
111 %description ui-libs -l pl.UTF-8
112 Biblioteka sysprofa zawierająca widgety GTK+ wielokrotnego użytku.
113
114 %package ui-devel
115 Summary:        Header files for sysprof-ui library
116 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki sysprof-ui
117 Group:          X11/Development/Libraries
118 Requires:       %{name}-devel = %{version}-%{release}
119 Requires:       %{name}-ui-libs = %{version}-%{release}
120 Requires:       gtk+3-devel >= 3.22
121
122 %description ui-devel
123 Header files for sysprof-ui library.
124
125 %description ui-devel -l pl.UTF-8
126 Pliki nagłówkowe biblioteki sysprof-ui.
127
128 %prep
129 %setup -q
130
131 %build
132 %meson build \
133         %{!?with_sysprofd:-Dwith_sysprofd=host}
134
135 %ninja_build -C build
136
137 %install
138 rm -rf $RPM_BUILD_ROOT
139
140 %ninja_install -C build
141
142 %find_lang %{name} -o %{name}-ui.lang --with-gnome --without-mo
143 %find_lang %{name}
144
145 %clean
146 rm -rf $RPM_BUILD_ROOT
147
148 %if %{with sysprofd}
149 %post
150 %systemd_post sysprof2.service
151
152 %preun
153 %systemd_preun sysprof2.service
154
155 %postun
156 %systemd_reload
157 %endif
158
159 %post   libs -p /sbin/ldconfig
160 %postun libs -p /sbin/ldconfig
161
162 %post ui
163 %glib_compile_schemas
164 %update_icon_cache hicolor
165 %update_mime_database
166 %update_desktop_database
167
168 %postun ui
169 %glib_compile_schemas
170 %update_icon_cache hicolor
171 %update_mime_database
172 %update_desktop_database
173
174 %post   ui-libs -p /sbin/ldconfig
175 %postun ui-libs -p /sbin/ldconfig
176
177 %files -f %{name}.lang
178 %defattr(644,root,root,755)
179 %doc AUTHORS NEWS TODO
180 %attr(755,root,root) %{_bindir}/sysprof-cli
181 %if %{with sysprofd}
182 %attr(755,root,root) %{_libexecdir}/sysprofd
183 %{systemdunitdir}/sysprof2.service
184 %{systemdunitdir}/sysprof3.service
185 %{_datadir}/dbus-1/system-services/org.gnome.Sysprof2.service
186 %{_datadir}/dbus-1/system-services/org.gnome.Sysprof3.service
187 %{_datadir}/dbus-1/system.d/org.gnome.Sysprof2.conf
188 %{_datadir}/dbus-1/system.d/org.gnome.Sysprof3.conf
189 %{_datadir}/polkit-1/actions/org.gnome.sysprof3.policy
190 %endif
191
192 %files libs
193 %defattr(644,root,root,755)
194 %attr(755,root,root) %{_libdir}/libsysprof-3.so
195
196 %files devel
197 %defattr(644,root,root,755)
198 %{_libdir}/libsysprof-capture-3.a
199 %dir %{_includedir}/sysprof-3
200 %{_includedir}/sysprof-3/sysprof.h
201 %{_includedir}/sysprof-3/sysprof-address.h
202 %{_includedir}/sysprof-3/sysprof-battery-source.h
203 %{_includedir}/sysprof-3/sysprof-callgraph-profile.h
204 %{_includedir}/sysprof-3/sysprof-capture*.h
205 %{_includedir}/sysprof-3/sysprof-check.h
206 %{_includedir}/sysprof-3/sysprof-clock.h
207 %{_includedir}/sysprof-3/sysprof-diskstat-source.h
208 %{_includedir}/sysprof-3/sysprof-elf-symbol-resolver.h
209 %{_includedir}/sysprof-3/sysprof-gjs-source.h
210 %{_includedir}/sysprof-3/sysprof-governor-source.h
211 %{_includedir}/sysprof-3/sysprof-hostinfo-source.h
212 %{_includedir}/sysprof-3/sysprof-jitmap-symbol-resolver.h
213 %{_includedir}/sysprof-3/sysprof-kernel-symbol.h
214 %{_includedir}/sysprof-3/sysprof-kernel-symbol-resolver.h
215 %{_includedir}/sysprof-3/sysprof-local-profiler.h
216 %{_includedir}/sysprof-3/sysprof-memory-source.h
217 %{_includedir}/sysprof-3/sysprof-model-filter.h
218 %{_includedir}/sysprof-3/sysprof-netdev-source.h
219 %{_includedir}/sysprof-3/sysprof-perf-counter.h
220 %{_includedir}/sysprof-3/sysprof-perf-source.h
221 %{_includedir}/sysprof-3/sysprof-platform.h
222 %{_includedir}/sysprof-3/sysprof-proc-source.h
223 %{_includedir}/sysprof-3/sysprof-process-model.h
224 %{_includedir}/sysprof-3/sysprof-process-model-item.h
225 %{_includedir}/sysprof-3/sysprof-profile.h
226 %{_includedir}/sysprof-3/sysprof-profiler.h
227 %{_includedir}/sysprof-3/sysprof-proxy-source.h
228 %{_includedir}/sysprof-3/sysprof-selection.h
229 %{_includedir}/sysprof-3/sysprof-source.h
230 %{_includedir}/sysprof-3/sysprof-spawnable.h
231 %{_includedir}/sysprof-3/sysprof-symbol-resolver.h
232 %{_includedir}/sysprof-3/sysprof-symbols-source.h
233 %{_includedir}/sysprof-3/sysprof-tracefd-source.h
234 %{_includedir}/sysprof-3/sysprof-version.h
235 %{_includedir}/sysprof-3/sysprof-version-macros.h
236 %{_pkgconfigdir}/sysprof-3.pc
237 %{_pkgconfigdir}/sysprof-capture-3.pc
238 %{_datadir}/dbus-1/interfaces/org.gnome.Sysprof2.xml
239 %{_datadir}/dbus-1/interfaces/org.gnome.Sysprof3.Profiler.xml
240 %{_datadir}/dbus-1/interfaces/org.gnome.Sysprof3.Service.xml
241
242 %files ui -f %{name}-ui.lang
243 %defattr(644,root,root,755)
244 %attr(755,root,root) %{_bindir}/sysprof
245 %{_datadir}/glib-2.0/schemas/org.gnome.sysprof3.gschema.xml
246 %{_datadir}/metainfo/org.gnome.Sysprof3.appdata.xml
247 %{_datadir}/mime/packages/sysprof-mime.xml
248 %{_desktopdir}/org.gnome.Sysprof3.desktop
249 %{_iconsdir}/hicolor/scalable/actions/sysprof-trace-app.svg
250 %{_iconsdir}/hicolor/scalable/apps/org.gnome.Sysprof.svg
251 %{_iconsdir}/hicolor/symbolic/apps/org.gnome.Sysprof-symbolic.svg
252
253 %files ui-libs
254 %defattr(644,root,root,755)
255 %attr(755,root,root) %{_libdir}/libsysprof-ui-3.so
256
257 %files ui-devel
258 %defattr(644,root,root,755)
259 %{_includedir}/sysprof-3/sysprof-display.h
260 %{_includedir}/sysprof-3/sysprof-notebook.h
261 %{_includedir}/sysprof-3/sysprof-page.h
262 %{_includedir}/sysprof-3/sysprof-process-model-row.h
263 %{_includedir}/sysprof-3/sysprof-ui.h
264 %{_includedir}/sysprof-3/sysprof-visualizer.h
265 %{_includedir}/sysprof-3/sysprof-visualizer-group.h
266 %{_includedir}/sysprof-3/sysprof-zoom-manager.h
267 %{_pkgconfigdir}/sysprof-ui-3.pc
This page took 0.134177 seconds and 2 git commands to generate.