]> git.pld-linux.org Git - packages/synapse.git/blob - synapse.spec
macros for __enable_disable
[packages/synapse.git] / synapse.spec
1 #
2 # Conditional build:
3 %bcond_without  appindicator    # build without appindicator support
4 %bcond_with     zeitgeist       # build with zeitgeist support (causes stability issues)
5
6 Summary:        Application launcher
7 Name:           synapse
8 Version:        0.2.99.4
9 Release:        1
10 License:        GPL v3+
11 Group:          X11/Applications
12 Source0:        https://launchpad.net/synapse-project/0.3/%{version}/+download/%{name}-%{version}.tar.xz
13 # Source0-md5:  38105c87200d82cf2066fb70cc9af59f
14 Patch0:         %{name}-mate.patch
15 URL:            https://launchpad.net/synapse-project
16 BuildRequires:  autoconf >= 2.65
17 BuildRequires:  automake >= 1:1.11
18 BuildRequires:  gettext-tools >= 0.19.6
19 BuildRequires:  glib2-devel >= 1:2.28.0
20 BuildRequires:  gtk+3-devel
21 BuildRequires:  json-glib-devel >= 0.10.0
22 BuildRequires:  keybinder3-devel
23 %{?with_appindicator:BuildRequires:     libappindicator-gtk3-devel}
24 BuildRequires:  libgee-devel >= 0.5.2
25 BuildRequires:  libnotify-devel
26 BuildRequires:  libtool
27 BuildRequires:  pkgconfig >= 1:0.21
28 BuildRequires:  rest-devel >= 0.7
29 BuildRequires:  rpmbuild(macros) >= 1.527
30 BuildRequires:  vala >= 0.16.0
31 %{?with_appindicator:BuildRequires:     vala-libappindicator-gtk3}
32 BuildRequires:  vala-libgee >= 0.6.4
33 %if %{with zeitgeist}
34 BuildRequires:  vala-zeitgeist >= 0.9.14
35 BuildRequires:  zeitgeist-devel >= 0.9.14
36 %endif
37 Requires:       glib2 >= 1:2.28.0
38 Requires:       json-glib >= 0.10.0
39 Requires:       libgee >= 0.5.2
40 Requires:       rest >= 0.7
41 %if %{with zeitgeist}
42 Requires:       zeitgeist-libs >= 0.9.14
43 %endif
44 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46 %description
47 Synapse is a semantic launcher written in Vala that you can use to
48 start applications as well as find and access relevant documents and
49 files by making use of the Zeitgeist engine.
50
51 %prep
52 %setup -q
53 %patch0 -p1
54
55 %build
56 %{__gettextize}
57 %{__libtoolize}
58 %{__aclocal}
59 %{__autoconf}
60 %{__autoheader}
61 %{__automake}
62 %configure \
63         --disable-silent-rules \
64         --enable-librest=yes \
65         %{__enable_disable appindicator indicator} \
66         %{__enable_disable zeitgeist}
67 %{__make}
68
69 %install
70 rm -rf $RPM_BUILD_ROOT
71
72 %{__make} install \
73         DESTDIR=$RPM_BUILD_ROOT
74
75 %find_lang %{name}
76
77 %clean
78 rm -rf $RPM_BUILD_ROOT
79
80 %post
81 %update_icon_cache hicolor
82 %update_desktop_database
83
84 %postun
85 %update_icon_cache hicolor
86 %update_desktop_database_postun
87
88 %files -f %{name}.lang
89 %defattr(644,root,root,755)
90 %attr(755,root,root) %{_bindir}/synapse
91 %{_iconsdir}/hicolor/scalable/apps/*.svg
92 %{_desktopdir}/*.desktop
93 %{_mandir}/man1/synapse.*
This page took 0.029158 seconds and 3 git commands to generate.