]> git.pld-linux.org Git - packages/sword.git/blob - sword.spec
- BR: libicu-devel
[packages/sword.git] / sword.spec
1 #
2 # TODO:
3 # - Split out subpackages for tests, examples
4 # - Fix debug package. Patch Makefile so debugfiles.list is generated?
5 # - Package icu-sword and add bcond for it here
6 #
7 %define debug_package 0
8
9 %bcond_with             examples
10 #%bcond_with    icusword
11 %bcond_with             tests
12 %bcond_without  clucene
13 %bcond_without  curl
14 %bcond_without  icu
15 %bcond_without  utilities
16
17 Summary:        The SWORD Project framework for manipulating Bible texts
18 Name:           sword
19 Version:        1.6.1
20 Release:        0.3
21 License:        GPL
22 Group:          Libraries
23 Source0:        http://www.crosswire.org/ftpmirror/pub/sword/source/v1.6/%{name}-%{version}.tar.gz
24 # Source0-md5:  347e72f73313ff3ba700368db76a5d50
25 Patch0:         %{name}-curl.patch
26 URL:            http://www.crosswire.org/sword
27 %{?with_clucene:BuildRequires:  clucene-core-devel}
28 %{?with_clucene:Requires:       clucene-core}
29 %{?with_curl:BuildRequires:     curl-devel}
30 %{?with_curl:Requires:  curl}
31 %{?with_icu:BuildRequires:      icu}
32 %{?with_icu:BuildRequires:      libicu-devel}
33 %{?with_icu:Requires:   icu}
34 BuildRequires:  pkgconfig
35 #%{?with_icusword:BuildRequires:        icu-sword}
36 #%{?with_icusword:Requires:     icu-sword}
37 Requires:       zlib
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %description
41 The SWORD Project is an effort to create an ever expanding software
42 package for research and study of God and His Word. The SWORD Bible
43 Framework allows easy manipulation of Bible texts, commentaries,
44 lexicons, dictionaries, etc. Many frontends are build using this
45 framework. An installed module set may be shared between any frontend
46 using the framework.
47
48 %package utilities
49 Summary:        Utility programes using the sword libraries.
50 Group:          Applications
51 Provides:       diatheke
52 Requires:       %{name} = %{version}-%{release}
53
54 %description utilities
55 Utility programes using the sword libraries.
56
57 %package devel
58 Summary:        Include files and static libraries for developing sword applications
59 Group:          Development/Libraries
60 Requires:       curl-devel >= 7.10.5
61 Requires:       %{name} = %{version}-%{release}
62 Requires:       zlib-devel
63
64 %description devel
65 Include files and static libraries for developing sword applications.
66 This package is required to compile Sword frontends, too.
67
68 %prep
69 %setup -q
70 %if %{with_curl}
71 %patch0 -p0
72 %endif
73
74 %build
75 %{configure} \
76         --with%{!?with_clucene:out}-clucene \
77         --with%{!?with_curl:out}-curl \
78         --with%{!?with_icu:out}-icu \
79         --%{?with_utilities:en}%{!?with_utilities:dis}able-utilities \
80         --%{?with_tests:en}%{!?with_tests:dis}able-tests \
81         --with-conf \
82         --disable-debug \
83         --disable-dependency-tracking
84         #--with%{!?with_icusword:out}-icusword \
85
86 %{__make}
87
88 %install
89 rm -rf $RPM_BUILD_ROOT
90
91 %{__make} install-strip \
92         DESTDIR=$RPM_BUILD_ROOT
93
94 %{__make} install_config \
95         DESTDIR=$RPM_BUILD_ROOT
96
97 install -d $RPM_BUILD_ROOT%{_libdir}/sword
98 exit 0
99
100 %post devel -p /sbin/ldconfig
101
102 %postun devel -p /sbin/ldconfig
103
104 %files
105 %defattr(644,root,root,755)
106 %config %{_sysconfdir}/sword.conf
107 %dir %{_datadir}/sword
108 %dir %{_datadir}/sword/mods.d
109 %dir %{_datadir}/sword/locales.d
110 %config %{_datadir}/sword/mods.d/globals.conf
111 %config %{_datadir}/sword/locales.d/*.conf
112 %doc README AUTHORS NEWS INSTALL
113 %attr(755,root,root) %{_libdir}/libsword*.so*
114 %dir %{_libdir}/sword
115 %dir %{_libdir}/sword/*icu*
116 %{_libdir}/sword/*/*.res
117
118 %files utilities
119 %defattr(644,root,root,755)
120 %attr(755,root,root) %{_bindir}/*
121
122 %files devel
123 %defattr(644,root,root,755)
124 %doc doc/*
125 %{_pkgconfigdir}/sword.pc
126 %{_includedir}/sword
127 %{_libdir}/libsword*.*a
128
129 %clean
130 rm -rf $RPM_BUILD_ROOT
This page took 0.21913 seconds and 3 git commands to generate.