]> git.pld-linux.org Git - packages/sword.git/blob - sword.spec
a3e259b27c8295eafc360c3610b11fa599dc2fa3
[packages/sword.git] / sword.spec
1 #
2 # TODO:
3 # - Split out subpackages for tests, examples
4 # - Fix debug package. Patch Makefile so debugfiles.list is generated?
5 # - Package icu-sword and add bcond for it here
6 #
7 %define debug_package 0
8
9 %bcond_with             examples
10 #%bcond_with    icusword
11 %bcond_with             tests
12 %bcond_without  clucene
13 %bcond_without  curl
14 %bcond_without  icu
15 %bcond_without  utilities
16
17 Summary:        The SWORD Project framework for manipulating Bible texts
18 Name:           sword
19 Version:        1.6.1
20 Release:        0.2
21 License:        GPL
22 Group:          Libraries
23 Source0:        http://www.crosswire.org/ftpmirror/pub/sword/source/v1.6/%{name}-%{version}.tar.gz
24 # Source0-md5:  347e72f73313ff3ba700368db76a5d50
25 Patch0:         %{name}-curl.patch
26 URL:            http://www.crosswire.org/sword
27 %{?with_clucene:BuildRequires:  clucene-core-devel}
28 %{?with_clucene:Requires:       clucene-core}
29 %{?with_curl:BuildRequires:     curl-devel}
30 %{?with_curl:Requires:  curl}
31 %{?with_icu:BuildRequires:      icu}
32 %{?with_icu:Requires:   icu}
33 BuildRequires:  pkgconfig
34 #%{?with_icusword:BuildRequires:        icu-sword}
35 #%{?with_icusword:Requires:     icu-sword}
36 Requires:       zlib
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %description
40 The SWORD Project is an effort to create an ever expanding software
41 package for research and study of God and His Word. The SWORD Bible
42 Framework allows easy manipulation of Bible texts, commentaries,
43 lexicons, dictionaries, etc. Many frontends are build using this
44 framework. An installed module set may be shared between any frontend
45 using the framework.
46
47 %package utilities
48 Summary:        Utility programes using the sword libraries.
49 Group:          Applications
50 Provides:       diatheke
51 Requires:       %{name} = %{version}-%{release}
52
53 %description utilities
54 Utility programes using the sword libraries.
55
56 %package devel
57 Summary:        Include files and static libraries for developing sword applications
58 Group:          Development/Libraries
59 Requires:       curl-devel >= 7.10.5
60 Requires:       %{name} = %{version}-%{release}
61 Requires:       zlib-devel
62
63 %description devel
64 Include files and static libraries for developing sword applications.
65 This package is required to compile Sword frontends, too.
66
67 %prep
68 %setup -q
69 %if %{with_curl}
70 %patch0 -p0
71 %endif
72
73 %build
74 %{configure} \
75         --with%{!?with_clucene:out}-clucene \
76         --with%{!?with_curl:out}-curl \
77         --with%{!?with_icu:out}-icu \
78         --%{?with_utilities:en}%{!?with_utilities:dis}able-utilities \
79         --%{?with_tests:en}%{!?with_tests:dis}able-tests \
80         --with-conf \
81         --disable-debug \
82         --disable-dependency-tracking
83         #--with%{!?with_icusword:out}-icusword \
84
85 %{__make}
86
87 %install
88 rm -rf $RPM_BUILD_ROOT
89
90 %{__make} install-strip \
91         DESTDIR=$RPM_BUILD_ROOT
92
93 %{__make} install_config \
94         DESTDIR=$RPM_BUILD_ROOT
95
96 install -d $RPM_BUILD_ROOT%{_libdir}/sword
97 exit 0
98
99 %post devel -p /sbin/ldconfig
100
101 %postun devel -p /sbin/ldconfig
102
103 %files
104 %defattr(644,root,root,755)
105 %config %{_sysconfdir}/sword.conf
106 %dir %{_datadir}/sword
107 %dir %{_datadir}/sword/mods.d
108 %dir %{_datadir}/sword/locales.d
109 %config %{_datadir}/sword/mods.d/globals.conf
110 %config %{_datadir}/sword/locales.d/*.conf
111 %doc README AUTHORS NEWS INSTALL
112 %attr(755,root,root) %{_libdir}/libsword*.so*
113 %dir %{_libdir}/sword
114 %dir %{_libdir}/sword/*icu*
115 %{_libdir}/sword/*/*.res
116
117 %files utilities
118 %defattr(644,root,root,755)
119 %attr(755,root,root) %{_bindir}/*
120
121 %files devel
122 %defattr(644,root,root,755)
123 %doc doc/*
124 %{_pkgconfigdir}/sword.pc
125 %{_includedir}/sword
126 %{_libdir}/libsword*.*a
127
128 %clean
129 rm -rf $RPM_BUILD_ROOT
This page took 0.306122 seconds and 2 git commands to generate.