]> git.pld-linux.org Git - packages/sword.git/blob - sword.spec
- release 6
[packages/sword.git] / sword.spec
1 # TODO:
2 # - Package icu-sword and add bcond for it here
3 #
4 # Conditional build:
5 #%bcond_with    icusword
6 %bcond_without  clucene
7 %bcond_without  curl
8 %bcond_without  icu
9 %bcond_without  utilities
10
11 %define debug_package 0
12
13 Summary:        The SWORD Project framework for manipulating Bible texts
14 Name:           sword
15 Version:        1.6.2
16 Release:        6
17 License:        GPL
18 Group:          Libraries
19 Source0:        http://www.crosswire.org/ftpmirror/pub/sword/source/v1.6/%{name}-%{version}.tar.gz
20 # Source0-md5:  a7dc4456e20e915fec46d774b690e305
21 Patch0:         %{name}-curl.patch
22 URL:            http://www.crosswire.org/sword
23 BuildRequires:  pakchois-devel
24 BuildRequires:  pkgconfig
25 BuildRequires:  sqlite3-devel
26 BuildRequires:  xulrunner-devel >= 1.9.2.3
27 %{?with_clucene:BuildRequires:  clucene-core-devel}
28 %{?with_clucene:Requires:       clucene-core}
29 %{?with_curl:BuildRequires:     curl-devel}
30 %{?with_curl:Requires:  curl}
31 %{?with_icu:BuildRequires:      icu}
32 %{?with_icu:BuildRequires:      libicu-devel}
33 %{?with_icu:Requires:   icu}
34 #%{?with_icusword:BuildRequires:        icu-sword}
35 #%{?with_icusword:Requires:     icu-sword}
36 Requires:       xulrunner >= 1.9.2.3
37 Requires:       zlib
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %description
41 The SWORD Project is an effort to create an ever expanding software
42 package for research and study of God and His Word. The SWORD Bible
43 Framework allows easy manipulation of Bible texts, commentaries,
44 lexicons, dictionaries, etc. Many frontends are build using this
45 framework. An installed module set may be shared between any frontend
46 using the framework.
47
48 %package utilities
49 Summary:        Utility programes using the sword libraries.
50 Group:          Applications
51 Provides:       diatheke
52 Requires:       %{name} = %{version}-%{release}
53
54 %description utilities
55 Utility programes using the sword libraries.
56
57 %package devel
58 Summary:        Include files and static libraries for developing sword applications
59 Group:          Development/Libraries
60 Requires:       curl-devel >= 7.10.5
61 Requires:       %{name} = %{version}-%{release}
62 Requires:       zlib-devel
63
64 %description devel
65 Include files and static libraries for developing sword applications.
66 This package is required to compile Sword frontends, too.
67
68 %prep
69 %setup -q
70 %if %{with_curl}
71 %patch0 -p0
72 %endif
73
74 %build
75 %{configure} \
76         --with-conf \
77         --with%{!?with_clucene:out}-clucene \
78         --with%{!?with_curl:out}-curl \
79         --with%{!?with_icu:out}-icu \
80         --disable-debug \
81         --disable-dependency-tracking \
82         --disable-examples \
83         --disable-tests \
84         --%{?with_utilities:en}%{!?with_utilities:dis}able-utilities \
85         #--with%{!?with_icusword:out}-icusword \
86
87 %{__make}
88
89 %install
90 rm -rf $RPM_BUILD_ROOT
91
92 %{__make} install-strip \
93         DESTDIR=$RPM_BUILD_ROOT
94
95 %{__make} install_config \
96         DESTDIR=$RPM_BUILD_ROOT
97
98 install -d $RPM_BUILD_ROOT%{_libdir}/sword
99 exit 0
100
101 %post devel -p /sbin/ldconfig
102
103 %postun devel -p /sbin/ldconfig
104
105 %files
106 %defattr(644,root,root,755)
107 %config %{_sysconfdir}/sword.conf
108 %dir %{_datadir}/sword
109 %dir %{_datadir}/sword/mods.d
110 %dir %{_datadir}/sword/locales.d
111 %config %{_datadir}/sword/mods.d/globals.conf
112 %config %{_datadir}/sword/locales.d/*.conf
113 %doc README AUTHORS NEWS INSTALL
114 %attr(755,root,root) %{_libdir}/libsword*.so*
115 %dir %{_libdir}/sword
116 %dir %{_libdir}/sword/*icu*
117 %{_libdir}/sword/*/*.res
118
119 %files utilities
120 %defattr(644,root,root,755)
121 %attr(755,root,root) %{_bindir}/*
122
123 %files devel
124 %defattr(644,root,root,755)
125 %doc doc/*
126 %{_pkgconfigdir}/sword.pc
127 %{_includedir}/sword
128 %{_libdir}/libsword*.*a
129
130 %clean
131 rm -rf $RPM_BUILD_ROOT
This page took 0.082233 seconds and 3 git commands to generate.