]> git.pld-linux.org Git - packages/sword.git/blob - sword.spec
- Disable tests and examples, not installed anyway.
[packages/sword.git] / sword.spec
1 #
2 # TODO:
3 # - Fix debug package. Patch Makefile so debugfiles.list is generated?
4 # - Package icu-sword and add bcond for it here
5
6 %define debug_package 0
7
8 #%bcond_with    icusword
9 %bcond_without  clucene
10 %bcond_without  curl
11 %bcond_without  icu
12 %bcond_without  utilities
13
14 Summary:        The SWORD Project framework for manipulating Bible texts
15 Name:           sword
16 Version:        1.6.1
17 Release:        0.4
18 License:        GPL
19 Group:          Libraries
20 Source0:        http://www.crosswire.org/ftpmirror/pub/sword/source/v1.6/%{name}-%{version}.tar.gz
21 # Source0-md5:  347e72f73313ff3ba700368db76a5d50
22 Patch0:         %{name}-curl.patch
23 URL:            http://www.crosswire.org/sword
24 %{?with_clucene:BuildRequires:  clucene-core-devel}
25 %{?with_clucene:Requires:       clucene-core}
26 %{?with_curl:BuildRequires:     curl-devel}
27 %{?with_curl:Requires:  curl}
28 %{?with_icu:BuildRequires:      icu}
29 %{?with_icu:BuildRequires:      libicu-devel}
30 %{?with_icu:Requires:   icu}
31 BuildRequires:  pkgconfig
32 #%{?with_icusword:BuildRequires:        icu-sword}
33 #%{?with_icusword:Requires:     icu-sword}
34 Requires:       zlib
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 The SWORD Project is an effort to create an ever expanding software
39 package for research and study of God and His Word. The SWORD Bible
40 Framework allows easy manipulation of Bible texts, commentaries,
41 lexicons, dictionaries, etc. Many frontends are build using this
42 framework. An installed module set may be shared between any frontend
43 using the framework.
44
45 %package utilities
46 Summary:        Utility programes using the sword libraries.
47 Group:          Applications
48 Provides:       diatheke
49 Requires:       %{name} = %{version}-%{release}
50
51 %description utilities
52 Utility programes using the sword libraries.
53
54 %package devel
55 Summary:        Include files and static libraries for developing sword applications
56 Group:          Development/Libraries
57 Requires:       curl-devel >= 7.10.5
58 Requires:       %{name} = %{version}-%{release}
59 Requires:       zlib-devel
60
61 %description devel
62 Include files and static libraries for developing sword applications.
63 This package is required to compile Sword frontends, too.
64
65 %prep
66 %setup -q
67 %if %{with_curl}
68 %patch0 -p0
69 %endif
70
71 %build
72 %{configure} \
73         --with-conf \
74         --with%{!?with_clucene:out}-clucene \
75         --with%{!?with_curl:out}-curl \
76         --with%{!?with_icu:out}-icu \
77         --disable-debug \
78         --disable-dependency-tracking \
79         --disable-examples \
80         --disable-tests \
81         --%{?with_utilities:en}%{!?with_utilities:dis}able-utilities \
82         #--with%{!?with_icusword:out}-icusword \
83
84 %{__make}
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88
89 %{__make} install-strip \
90         DESTDIR=$RPM_BUILD_ROOT
91
92 %{__make} install_config \
93         DESTDIR=$RPM_BUILD_ROOT
94
95 install -d $RPM_BUILD_ROOT%{_libdir}/sword
96 exit 0
97
98 %post devel -p /sbin/ldconfig
99
100 %postun devel -p /sbin/ldconfig
101
102 %files
103 %defattr(644,root,root,755)
104 %config %{_sysconfdir}/sword.conf
105 %dir %{_datadir}/sword
106 %dir %{_datadir}/sword/mods.d
107 %dir %{_datadir}/sword/locales.d
108 %config %{_datadir}/sword/mods.d/globals.conf
109 %config %{_datadir}/sword/locales.d/*.conf
110 %doc README AUTHORS NEWS INSTALL
111 %attr(755,root,root) %{_libdir}/libsword*.so*
112 %dir %{_libdir}/sword
113 %dir %{_libdir}/sword/*icu*
114 %{_libdir}/sword/*/*.res
115
116 %files utilities
117 %defattr(644,root,root,755)
118 %attr(755,root,root) %{_bindir}/*
119
120 %files devel
121 %defattr(644,root,root,755)
122 %doc doc/*
123 %{_pkgconfigdir}/sword.pc
124 %{_includedir}/sword
125 %{_libdir}/libsword*.*a
126
127 %clean
128 rm -rf $RPM_BUILD_ROOT
This page took 0.062321 seconds and 3 git commands to generate.