]> git.pld-linux.org Git - packages/sword.git/blob - sword.spec
- Up to 1.6.2
[packages/sword.git] / sword.spec
1 #
2 # TODO:
3 # - Package icu-sword and add bcond for it here
4
5 %define debug_package 0
6
7 #%bcond_with    icusword
8 %bcond_without  clucene
9 %bcond_without  curl
10 %bcond_without  icu
11 %bcond_without  utilities
12
13 Summary:        The SWORD Project framework for manipulating Bible texts
14 Name:           sword
15 Version:        1.6.2
16 Release:        1
17 License:        GPL
18 Group:          Libraries
19 Source0:        http://www.crosswire.org/ftpmirror/pub/sword/source/v1.6/%{name}-%{version}.tar.gz
20 # Source0-md5:  a7dc4456e20e915fec46d774b690e305
21 Patch0:         %{name}-curl.patch
22 URL:            http://www.crosswire.org/sword
23 BuildRequires:  pkgconfig
24 BuildRequires:  xulrunner-devel >= 1.9.2.3
25 %{?with_clucene:BuildRequires:  clucene-core-devel}
26 %{?with_clucene:Requires:       clucene-core}
27 %{?with_curl:BuildRequires:     curl-devel}
28 %{?with_curl:Requires:  curl}
29 %{?with_icu:BuildRequires:      icu}
30 %{?with_icu:BuildRequires:      libicu-devel}
31 %{?with_icu:Requires:   icu}
32 #%{?with_icusword:BuildRequires:        icu-sword}
33 #%{?with_icusword:Requires:     icu-sword}
34 Requires:       xulrunner >= 1.9.2.3
35 Requires:       zlib
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 The SWORD Project is an effort to create an ever expanding software
40 package for research and study of God and His Word. The SWORD Bible
41 Framework allows easy manipulation of Bible texts, commentaries,
42 lexicons, dictionaries, etc. Many frontends are build using this
43 framework. An installed module set may be shared between any frontend
44 using the framework.
45
46 %package utilities
47 Summary:        Utility programes using the sword libraries.
48 Group:          Applications
49 Provides:       diatheke
50 Requires:       %{name} = %{version}-%{release}
51
52 %description utilities
53 Utility programes using the sword libraries.
54
55 %package devel
56 Summary:        Include files and static libraries for developing sword applications
57 Group:          Development/Libraries
58 Requires:       curl-devel >= 7.10.5
59 Requires:       %{name} = %{version}-%{release}
60 Requires:       zlib-devel
61
62 %description devel
63 Include files and static libraries for developing sword applications.
64 This package is required to compile Sword frontends, too.
65
66 %prep
67 %setup -q
68 %if %{with_curl}
69 %patch0 -p0
70 %endif
71
72 %build
73 %{configure} \
74         --with-conf \
75         --with%{!?with_clucene:out}-clucene \
76         --with%{!?with_curl:out}-curl \
77         --with%{!?with_icu:out}-icu \
78         --disable-debug \
79         --disable-dependency-tracking \
80         --disable-examples \
81         --disable-tests \
82         --%{?with_utilities:en}%{!?with_utilities:dis}able-utilities \
83         #--with%{!?with_icusword:out}-icusword \
84
85 %{__make}
86
87 %install
88 rm -rf $RPM_BUILD_ROOT
89
90 %{__make} install-strip \
91         DESTDIR=$RPM_BUILD_ROOT
92
93 %{__make} install_config \
94         DESTDIR=$RPM_BUILD_ROOT
95
96 install -d $RPM_BUILD_ROOT%{_libdir}/sword
97 exit 0
98
99 %post devel -p /sbin/ldconfig
100
101 %postun devel -p /sbin/ldconfig
102
103 %files
104 %defattr(644,root,root,755)
105 %config %{_sysconfdir}/sword.conf
106 %dir %{_datadir}/sword
107 %dir %{_datadir}/sword/mods.d
108 %dir %{_datadir}/sword/locales.d
109 %config %{_datadir}/sword/mods.d/globals.conf
110 %config %{_datadir}/sword/locales.d/*.conf
111 %doc README AUTHORS NEWS INSTALL
112 %attr(755,root,root) %{_libdir}/libsword*.so*
113 %dir %{_libdir}/sword
114 %dir %{_libdir}/sword/*icu*
115 %{_libdir}/sword/*/*.res
116
117 %files utilities
118 %defattr(644,root,root,755)
119 %attr(755,root,root) %{_bindir}/*
120
121 %files devel
122 %defattr(644,root,root,755)
123 %doc doc/*
124 %{_pkgconfigdir}/sword.pc
125 %{_includedir}/sword
126 %{_libdir}/libsword*.*a
127
128 %clean
129 rm -rf $RPM_BUILD_ROOT
This page took 0.077844 seconds and 3 git commands to generate.