]> git.pld-linux.org Git - packages/swig.git/blob - swig.spec
- updated to 1.3.12
[packages/swig.git] / swig.spec
1 Summary:        Interface generator for Perl, Tcl, Guile and Python
2 Summary(pl):    Generator interfejsów do Perla, Tcl-a, Guile'a i Pythona
3 Summary(pt_BR): Gerador de Interfaces e "Wrappers" Simplificado (SWIG)
4 Name:           swig
5 Version:        1.3.12
6 Release:        1
7 License:        distributable
8 Group:          Development/Languages
9 Source0:        http://prdownloads.sourceforge.net/swig/%{name}-%{version}.tar.gz
10 Patch0:         %{name}-configure.patch
11 URL:            http://www.swig.org/
12 Icon:           swig.gif
13 BuildRequires:  autoconf
14 BuildRequires:  guile-devel
15 BuildRequires:  libstdc++-devel
16 BuildRequires:  perl-devel >= 5.6.1
17 BuildRequires:  php-devel >= 4.1.0
18 BuildRequires:  python >= 2.2
19 BuildRequires:  ruby >= 1.6.3
20 BuildRequires:  tcl >= 8.3.3
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 SWIG is a compiler that attempts to make it easy to integrate C, C++,
25 or Objective-C code with scripting languages including Perl, Tcl, and
26 Python. In a nutshell, you give it a bunch of ANSI C/C++ declarations
27 and it generates an interface between C and your favorite scripting
28 language. However, this is only scratching the surface of what SWIG
29 can do--some of its more advanced features include automatic
30 documentation generation, module and library management, extensive
31 customization options, and more.
32
33 SWIG is entirely the product of users who have used the system and
34 suggested new idea. There are far too many people to thank
35 individually, but without this support, SWIG would be not be nearly as
36 powerful or fun to use as it is now. Many thanks!
37
38 %description -l pl
39 SWIG jesk kompilatorem, który próbuje u³atwiæ integrowanie kodu
40 napisanego w C, C++ lub Objective-C z jêzykami skryptowymi, takimi jak
41 Perl, Tcl i Python. Mówi±c najpro¶ciej, je¶li dostarczysz mu zestaw
42 zadeklarowanych w ANSI C/C++ funkcji, SWIG wygeneruje Ci interfejs
43 pomiêdzy C a Twoim ulubionym jêzykiem skryptowym. To tylko drobna
44 czê¶æ tego co SWIG potrafi robiæ, bardziej zaawansowane zastosowania
45 to automatyczne generowanie dokumentacji, zarz±dzanie bibliotekami i
46 modu³ami i wiele innych.
47
48 SWIG jest w ca³o¶ci dzie³em ludzi, którzy go u¿ywali i wprowadzali
49 nowe pomys³y. Zbyt wielu ich jest, aby dziêkowaæ ka¿demu z nich
50 osobno, ale bez ich wsparcia SWIG nie by³by ani tak potê¿nym
51 narzêdziem, ani tak fajnym w u¿yciu jak jest teraz. Wiekie dziêki!
52
53 %description -l pt_BR
54 O SWIG gera interfaces para perl, python e tcl a partir de uma arquivo 
55 com uma interface de descrição que consiste de uma combinação de C/C++
56 e diretivas especiais. Permite que linguagens tipo script usem C/C++
57 com um mínimo de esforço.
58
59 %package guile
60 Summary:        SWIG library: guile
61 Summary(pl):    Biblioteka SWIG: guile
62 Group:          Libraries
63
64 %description guile
65 SWIG library: guile.
66
67 %description guile -l pl
68 Biblioteka SWIG: guile.
69
70 %package perl
71 Summary:        SWIG library: Perl
72 Summary(pl):    Biblioteka SWIG: Perl
73 Group:          Libraries
74
75 %description perl
76 SWIG library: perl.
77
78 %description perl -l pl
79 Biblioteka SWIG: perl.
80
81 %package python
82 Summary:        SWIG library: python
83 Summary(pl):    Biblioteka SWIG: python
84 Group:          Libraries
85
86 %description python
87 SWIG library: python.
88
89 %description python -l pl
90 Biblioteka SWIG: python.
91
92 %package ruby
93 Summary:        SWIG library: ruby
94 Summary(pl):    Biblioteka SWIG: ruby
95 Group:          Libraries
96
97 %description ruby
98 SWIG library: ruby.
99
100 %description ruby -l pl
101 Biblioteka SWIG: ruby.
102
103 %package tcl
104 Summary:        SWIG library: tcl
105 Summary(pl):    Biblioteka SWIG: tcl
106 Group:          Libraries
107
108 %description tcl
109 SWIG library: tcl.
110
111 %description tcl -l pl
112 Biblioteka SWIG: tcl.
113
114 %prep
115 %setup -q -n SWIG-%{version}
116 %patch0 -p1
117
118 %build
119 oldpwd=$PWD
120 for i in . Source/DOH Tools Examples/GIFPlot; do
121   cd $i
122   aclocal
123   autoconf
124   cd $oldpwd
125 done
126 %configure
127 %{__make} OPT="%{rpmcflags}"
128
129
130 %install
131 rm -rf $RPM_BUILD_ROOT
132 install -d $RPM_BUILD_ROOT{%{_mandir}/man1,%{_examplesdir}/%{name}-%{version}}
133
134 %{__make} install \
135         DESTDIR=$RPM_BUILD_ROOT
136
137 cp -a Examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
138
139 gzip -9nf CHANGES NEW README ANNOUNCE TODO LICENSE
140
141 %clean
142 rm -rf $RPM_BUILD_ROOT
143
144 %post   -p /sbin/ldconfig
145 %postun -p /sbin/ldconfig
146
147 %files
148 %defattr(644,root,root,755)
149 %doc Doc *.gz
150 %{_libdir}/%{name}*
151 %attr(755,root,root) %{_bindir}/swig
152 %{_examplesdir}/%{name}-%{version}
153
154 %files guile
155 %defattr(644,root,root,755)
156 %attr(755,root,root) %{_libdir}/lib*guile.so
157 %attr(755,root,root) %{_libdir}/lib*guile.la
158
159 %files perl
160 %defattr(644,root,root,755)
161 %attr(755,root,root) %{_libdir}/lib*pl.so
162 %attr(755,root,root) %{_libdir}/lib*pl.la
163
164 %files python
165 %defattr(644,root,root,755)
166 %attr(755,root,root) %{_libdir}/lib*py.so
167 %attr(755,root,root) %{_libdir}/lib*py.la
168
169 %files ruby
170 %defattr(644,root,root,755)
171 %attr(755,root,root) %{_libdir}/lib*rb.so
172 %attr(755,root,root) %{_libdir}/lib*rb.la
173
174 %files tcl
175 %defattr(644,root,root,755)
176 %attr(755,root,root) %{_libdir}/lib*tcl*.so
177 %attr(755,root,root) %{_libdir}/lib*tcl*.la
This page took 0.128684 seconds and 4 git commands to generate.