]> git.pld-linux.org Git - packages/swig.git/blob - swig.spec
- BR fixes, rel. 2
[packages/swig.git] / swig.spec
1 Summary:        Interface generator for Perl, Tcl, Guile and Python
2 Summary(pl):    Generator interfejsów do Perla, Tcl-a, Guile'a i Pythona
3 Summary(pt_BR): Gerador de Interfaces e "Wrappers" Simplificado (SWIG)
4 Name:           swig
5 Version:        1.3.21
6 Release:        2
7 License:        distributable
8 Group:          Development/Languages
9 Source0:        http://dl.sourceforge.net/swig/%{name}-%{version}.tar.gz
10 # Source0-md5:  88ff5b99be3eafebb8a6e20f4f986c04
11 Patch0:         %{name}-format.patch
12 Patch1:         %{name}-php.patch
13 Patch2:         %{name}-php-tsrm.patch
14 Patch3:         %{name}-php-freearg.patch
15 Patch4:         %{name}-php-vdecl.patch
16 Patch5:         %{name}-python-lib64.patch
17 URL:            http://www.swig.org/
18 Icon:           swig.gif
19 BuildRequires:  autoconf
20 BuildRequires:  automake
21 BuildRequires:  guile-devel
22 BuildRequires:  libstdc++-devel
23 BuildRequires:  libtool
24 BuildRequires:  ocaml
25 BuildRequires:  perl-devel >= 1:5.6.1
26 BuildRequires:  php-devel >= 4.1.0
27 BuildRequires:  php-cgi
28 BuildRequires:  python-devel >= 2.3.2
29 BuildRequires:  ruby >= 1.6.3
30 BuildRequires:  tcl-devel >= 8.3.3
31 Obsoletes:      swig-ocaml
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 SWIG is a compiler that attempts to make it easy to integrate C, C++,
36 or Objective-C code with scripting languages including Perl, Tcl, and
37 Python. In a nutshell, you give it a bunch of ANSI C/C++ declarations
38 and it generates an interface between C and your favorite scripting
39 language. However, this is only scratching the surface of what SWIG
40 can do--some of its more advanced features include automatic
41 documentation generation, module and library management, extensive
42 customization options, and more.
43
44 SWIG is entirely the product of users who have used the system and
45 suggested new idea. There are far too many people to thank
46 individually, but without this support, SWIG would be not be nearly as
47 powerful or fun to use as it is now. Many thanks!
48
49 %description -l pl
50 SWIG jesk kompilatorem, który próbuje u³atwiæ integrowanie kodu
51 napisanego w C, C++ lub Objective-C z jêzykami skryptowymi, takimi jak
52 Perl, Tcl i Python. Mówi±c najpro¶ciej, je¶li dostarczysz mu zestaw
53 zadeklarowanych w ANSI C/C++ funkcji, SWIG wygeneruje Ci interfejs
54 pomiêdzy C a Twoim ulubionym jêzykiem skryptowym. To tylko drobna
55 czê¶æ tego co SWIG potrafi robiæ, bardziej zaawansowane zastosowania
56 to automatyczne generowanie dokumentacji, zarz±dzanie bibliotekami i
57 modu³ami i wiele innych.
58
59 SWIG jest w ca³o¶ci dzie³em ludzi, którzy go u¿ywali i wprowadzali
60 nowe pomys³y. Zbyt wielu ich jest, aby dziêkowaæ ka¿demu z nich
61 osobno, ale bez ich wsparcia SWIG nie by³by ani tak potê¿nym
62 narzêdziem, ani tak fajnym w u¿yciu jak jest teraz. Wiekie dziêki!
63
64 %description -l pt_BR
65 O SWIG gera interfaces para perl, python e tcl a partir de uma arquivo
66 com uma interface de descrição que consiste de uma combinação de C/C++
67 e diretivas especiais. Permite que linguagens tipo script usem C/C++
68 com um mínimo de esforço.
69
70 %package guile
71 Summary:        SWIG library: guile
72 Summary(pl):    Biblioteka SWIG: guile
73 Group:          Libraries
74
75 %description guile
76 SWIG library: guile.
77
78 %description guile -l pl
79 Biblioteka SWIG: guile.
80
81 %package perl
82 Summary:        SWIG library: Perl
83 Summary(pl):    Biblioteka SWIG: Perl
84 Group:          Libraries
85
86 %description perl
87 SWIG library: perl.
88
89 %description perl -l pl
90 Biblioteka SWIG: perl.
91
92 %package php
93 Summary:        SWIG library: php
94 Summary(pl):    Biblioteka SWIG: php
95 Group:          Libraries
96
97 %description php
98 SWIG library: php.
99
100 %description php -l pl
101 Biblioteka SWIG: php.
102
103 %package python
104 Summary:        SWIG library: python
105 Summary(pl):    Biblioteka SWIG: python
106 Group:          Libraries
107
108 %description python
109 SWIG library: python.
110
111 %description python -l pl
112 Biblioteka SWIG: python.
113
114 %package ruby
115 Summary:        SWIG library: ruby
116 Summary(pl):    Biblioteka SWIG: ruby
117 Group:          Libraries
118
119 %description ruby
120 SWIG library: ruby.
121
122 %description ruby -l pl
123 Biblioteka SWIG: ruby.
124
125 %package tcl
126 Summary:        SWIG library: tcl
127 Summary(pl):    Biblioteka SWIG: tcl
128 Group:          Libraries
129
130 %description tcl
131 SWIG library: tcl.
132
133 %description tcl -l pl
134 Biblioteka SWIG: tcl.
135
136 %prep
137 %setup -q -n SWIG-%{version}
138 %patch0 -p1
139 %patch1 -p1
140 %patch2 -p1
141 %patch3 -p1
142 %patch4 -p1
143 %if "%{_lib}" == "lib64"
144 %patch5 -p1
145 %endif
146
147 %build
148 %{__libtoolize}
149 %{__aclocal} -I Tools/config
150 %{__autoconf}
151 %configure
152
153 %{__make} source runtime \
154         OPT="%{rpmcflags}"
155
156 %install
157 rm -rf $RPM_BUILD_ROOT
158 install -d $RPM_BUILD_ROOT{%{_mandir}/man1,%{_examplesdir}/%{name}-%{version}}
159
160 %{__make} install install-runtime \
161         DESTDIR=$RPM_BUILD_ROOT \
162         M4_INSTALL_DIR=$RPM_BUILD_ROOT%{_aclocaldir}
163
164 cp -a Examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
165
166 %clean
167 rm -rf $RPM_BUILD_ROOT
168
169 %post   -p /sbin/ldconfig
170 %postun -p /sbin/ldconfig
171
172 %post   guile -p /sbin/ldconfig
173 %postun guile -p /sbin/ldconfig
174
175 %post   perl -p /sbin/ldconfig
176 %postun perl -p /sbin/ldconfig
177
178 %post   php -p /sbin/ldconfig
179 %postun php -p /sbin/ldconfig
180
181 %post   python -p /sbin/ldconfig
182 %postun python -p /sbin/ldconfig
183
184 %post   ruby -p /sbin/ldconfig
185 %postun ruby -p /sbin/ldconfig
186
187 %post   tcl -p /sbin/ldconfig
188 %postun tcl -p /sbin/ldconfig
189
190 %files
191 %defattr(644,root,root,755)
192 %doc Doc CHANGES NEW README ANNOUNCE TODO LICENSE
193 %{_libdir}/%{name}*
194 %attr(755,root,root) %{_bindir}/swig
195 %{_aclocaldir}/swig.m4
196 %{_examplesdir}/%{name}-%{version}
197
198 %files guile
199 %defattr(644,root,root,755)
200 %attr(755,root,root) %{_libdir}/libswigguile*.so.*.*.*
201 %attr(755,root,root) %{_libdir}/libswigguile*.so
202 %{_libdir}/libswigguile*.la
203
204 %files perl
205 %defattr(644,root,root,755)
206 %attr(755,root,root) %{_libdir}/libswigpl.so.*.*.*
207 %attr(755,root,root) %{_libdir}/libswigpl.so
208 %{_libdir}/libswigpl.la
209
210 %files php
211 %defattr(644,root,root,755)
212 %attr(755,root,root) %{_libdir}/libswigphp4.so.*.*.*
213 %attr(755,root,root) %{_libdir}/libswigphp4.so
214 %{_libdir}/libswigphp4.la
215
216 %files python
217 %defattr(644,root,root,755)
218 %attr(755,root,root) %{_libdir}/libswigpy.so.*.*.*
219 %attr(755,root,root) %{_libdir}/libswigpy.so
220 %{_libdir}/libswigpy.la
221
222 %files ruby
223 %defattr(644,root,root,755)
224 %attr(755,root,root) %{_libdir}/libswigrb.so.*.*.*
225 %attr(755,root,root) %{_libdir}/libswigrb.so
226 %{_libdir}/libswigrb.la
227
228 %files tcl
229 %defattr(644,root,root,755)
230 %attr(755,root,root) %{_libdir}/libswigtcl*.so.*.*.*
231 %attr(755,root,root) %{_libdir}/libswigtcl*.so
232 %{_libdir}/libswigtcl*.la
This page took 0.046238 seconds and 4 git commands to generate.