]> git.pld-linux.org Git - packages/swig.git/blob - swig.spec
- up to 1.3.36
[packages/swig.git] / swig.spec
1 #
2 # Conditional build:
3 %bcond_without  guile   # disable guile support
4 %bcond_without  ocaml   # disable ocaml support
5 %bcond_without  perl    # disable perl support
6 %bcond_without  php     # disable php support
7 %bcond_without  ruby    # disable ruby support
8 %bcond_without  tcl     # disable tcl support
9 #
10 Summary:        Interface generator for Perl, Tcl, Guile and Python
11 Summary(pl.UTF-8):      Generator interfejsów do Perla, Tcl-a, Guile'a i Pythona
12 Summary(pt_BR.UTF-8):   Gerador de Interfaces e "Wrappers" Simplificado (SWIG)
13 Name:           swig
14 Version:        1.3.36
15 Release:        1
16 License:        distributable
17 Group:          Development/Languages
18 Source0:        http://dl.sourceforge.net/swig/%{name}-%{version}.tar.gz
19 # Source0-md5:  8f30aa4130b62404099bbcba1bf429b1
20 Patch0:         %{name}-format.patch
21 Patch1:         %{name}-php-freearg.patch
22 Patch2:         %{name}-php-vdecl.patch
23 URL:            http://www.swig.org/
24 BuildRequires:  autoconf
25 BuildRequires:  automake
26 %{?with_guile:BuildRequires:    guile-devel}
27 BuildRequires:  libstdc++-devel
28 BuildRequires:  libtool
29 %{?with_ocaml:BuildRequires:    ocaml}
30 %{?with_perl:BuildRequires:     perl-devel >= 1:5.6.1}
31 %{?with_php:BuildRequires:      php-cli}
32 %{?with_php:BuildRequires:      php-devel >= 4.1.0}
33 BuildRequires:  python-devel >= 1:2.3.2
34 %if %{with ruby}
35 BuildRequires:  rpmbuild(macros) >= 1.277
36 BuildRequires:  ruby-devel >= 1:1.6.3
37 %endif
38 %{?with_tcl:BuildRequires:      tcl-devel >= 8.3.3}
39 Obsoletes:      swig-ocaml
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %description
43 SWIG is a compiler that attempts to make it easy to integrate C, C++,
44 or Objective-C code with scripting languages including Perl, Tcl, and
45 Python. In a nutshell, you give it a bunch of ANSI C/C++ declarations
46 and it generates an interface between C and your favorite scripting
47 language. However, this is only scratching the surface of what SWIG
48 can do--some of its more advanced features include automatic
49 documentation generation, module and library management, extensive
50 customization options, and more.
51
52 SWIG is entirely the product of users who have used the system and
53 suggested new idea. There are far too many people to thank
54 individually, but without this support, SWIG would be not be nearly as
55 powerful or fun to use as it is now. Many thanks!
56
57 %description -l pl.UTF-8
58 SWIG jesk kompilatorem, który próbuje ułatwić integrowanie kodu
59 napisanego w C, C++ lub Objective-C z językami skryptowymi, takimi jak
60 Perl, Tcl i Python. Mówiąc najprościej, jeśli dostarczysz mu zestaw
61 zadeklarowanych w ANSI C/C++ funkcji, SWIG wygeneruje Ci interfejs
62 pomiędzy C a Twoim ulubionym językiem skryptowym. To tylko drobna
63 część tego co SWIG potrafi robić, bardziej zaawansowane zastosowania
64 to automatyczne generowanie dokumentacji, zarządzanie bibliotekami i
65 modułami i wiele innych.
66
67 SWIG jest w całości dziełem ludzi, którzy go używali i wprowadzali
68 nowe pomysły. Zbyt wielu ich jest, aby dziękować każdemu z nich
69 osobno, ale bez ich wsparcia SWIG nie byłby ani tak potężnym
70 narzędziem, ani tak fajnym w użyciu jak jest teraz. Wiekie dzięki!
71
72 %description -l pt_BR.UTF-8
73 O SWIG gera interfaces para perl, python e Tcl a partir de uma arquivo
74 com uma interface de descrição que consiste de uma combinação de C/C++
75 e diretivas especiais. Permite que linguagens tipo script usem C/C++
76 com um mínimo de esforço.
77
78 %package guile
79 Summary:        SWIG library: guile
80 Summary(pl.UTF-8):      Biblioteka SWIG: guile
81 Group:          Libraries
82 Requires:       %{name} = %{version}-%{release}
83
84 %description guile
85 SWIG library: guile.
86
87 %description guile -l pl.UTF-8
88 Biblioteka SWIG: guile.
89
90 %package perl
91 Summary:        SWIG library: Perl
92 Summary(pl.UTF-8):      Biblioteka SWIG: Perl
93 Group:          Libraries
94 Requires:       %{name} = %{version}-%{release}
95
96 %description perl
97 SWIG library: perl.
98
99 %description perl -l pl.UTF-8
100 Biblioteka SWIG: perl.
101
102 %package php
103 Summary:        SWIG library: php
104 Summary(pl.UTF-8):      Biblioteka SWIG: php
105 Group:          Libraries
106 Requires:       %{name} = %{version}-%{release}
107
108 %description php
109 SWIG library: php.
110
111 %description php -l pl.UTF-8
112 Biblioteka SWIG: php.
113
114 %package python
115 Summary:        SWIG library: python
116 Summary(pl.UTF-8):      Biblioteka SWIG: python
117 Group:          Libraries
118 Requires:       %{name} = %{version}-%{release}
119
120 %description python
121 SWIG library: python.
122
123 %description python -l pl.UTF-8
124 Biblioteka SWIG: python.
125
126 %package ruby
127 Summary:        SWIG library: ruby
128 Summary(pl.UTF-8):      Biblioteka SWIG: ruby
129 Group:          Libraries
130 Requires:       %{name} = %{version}-%{release}
131 %{?ruby_mod_ver_requires_eq}
132
133 %description ruby
134 SWIG library: ruby.
135
136 %description ruby -l pl.UTF-8
137 Biblioteka SWIG: ruby.
138
139 %package tcl
140 Summary:        SWIG library: tcl
141 Summary(pl.UTF-8):      Biblioteka SWIG: tcl
142 Group:          Libraries
143 Requires:       %{name} = %{version}-%{release}
144
145 %description tcl
146 SWIG library: tcl.
147
148 %description tcl -l pl.UTF-8
149 Biblioteka SWIG: tcl.
150
151 %prep
152 %setup -q
153 %patch0 -p1
154 %patch1 -p1
155 %patch2 -p1
156
157 %build
158 %{__libtoolize}
159 %{__aclocal} -I Tools/config
160 %{__autoconf}
161 %{__automake}
162 %configure
163
164 %{__make} \
165         OPT="%{rpmcflags}"
166
167 %install
168 rm -rf $RPM_BUILD_ROOT
169 install -d $RPM_BUILD_ROOT{%{_mandir}/man1,%{_examplesdir}/%{name}-%{version}}
170
171 %{__make} install \
172         DESTDIR=$RPM_BUILD_ROOT \
173         M4_INSTALL_DIR=$RPM_BUILD_ROOT%{_aclocaldir}
174
175 cp -a Examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
176
177 %clean
178 rm -rf $RPM_BUILD_ROOT
179
180 %files
181 %defattr(644,root,root,755)
182 %doc Doc CHANGES CHANGES.current NEW README ANNOUNCE TODO LICENSE
183 %attr(755,root,root) %{_bindir}/swig
184 %{_datadir}/%{name}
185 %{?with_guile:%exclude %{_datadir}/%{name}/%{version}/guile}
186 %{?with_perl:%exclude %{_datadir}/%{name}/%{version}/perl5}
187 %{?with_php:%exclude %{_datadir}/%{name}/%{version}/php4}
188 %exclude %{_datadir}/%{name}/%{version}/python
189 %{?with_ruby:%exclude %{_datadir}/%{name}/%{version}/ruby}
190 %{?with_tcl:%exclude %{_datadir}/%{name}/%{version}/tcl}
191 %{_examplesdir}/%{name}-%{version}
192
193 %if %{with guile}
194 %files guile
195 %defattr(644,root,root,755)
196 %{_datadir}/%{name}/%{version}/guile
197 %endif
198
199 %if %{with perl}
200 %files perl
201 %defattr(644,root,root,755)
202 %{_datadir}/%{name}/%{version}/perl5
203 %endif
204
205 %if %{with php}
206 %files php
207 %defattr(644,root,root,755)
208 %{_datadir}/%{name}/%{version}/php4
209 %endif
210
211 %files python
212 %defattr(644,root,root,755)
213 %{_datadir}/%{name}/%{version}/python
214
215 %if %{with ruby}
216 %files ruby
217 %defattr(644,root,root,755)
218 %{_datadir}/%{name}/%{version}/ruby
219 %endif
220
221 %if %{with tcl}
222 %files tcl
223 %defattr(644,root,root,755)
224 %{_datadir}/%{name}/%{version}/tcl
225 %endif
This page took 0.055404 seconds and 4 git commands to generate.