]> git.pld-linux.org Git - packages/swig.git/blob - swig.spec
- added php support
[packages/swig.git] / swig.spec
1 Summary:        Interface generator for Perl, Tcl, Guile and Python
2 Summary(pl):    Generator interfejsów do Perla, Tcl-a, Guile'a i Pythona
3 Summary(pt_BR): Gerador de Interfaces e "Wrappers" Simplificado (SWIG)
4 Name:           swig
5 Version:        1.3.19
6 Release:        2
7 License:        distributable
8 Group:          Development/Languages
9 Source0:        http://dl.sourceforge.net/swig/%{name}-%{version}.tar.gz
10 # Source0-md5:  a733455544426b31868dd87fc162e750
11 Patch0:         %{name}-format.patch
12 Patch1:         %{name}-php.patch
13 URL:            http://www.swig.org/
14 Icon:           swig.gif
15 BuildRequires:  autoconf
16 BuildRequires:  automake
17 BuildRequires:  guile-devel
18 BuildRequires:  libstdc++-devel
19 BuildRequires:  libtool
20 BuildRequires:  perl-devel >= 5.6.1
21 BuildRequires:  php-devel >= 4.1.0
22 BuildRequires:  python >= 2.2
23 BuildRequires:  php-devel
24 BuildRequires:  ruby >= 1.6.3
25 BuildRequires:  tcl-devel >= 8.3.3
26 BuildRequires:  ocaml
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 SWIG is a compiler that attempts to make it easy to integrate C, C++,
31 or Objective-C code with scripting languages including Perl, Tcl, and
32 Python. In a nutshell, you give it a bunch of ANSI C/C++ declarations
33 and it generates an interface between C and your favorite scripting
34 language. However, this is only scratching the surface of what SWIG
35 can do--some of its more advanced features include automatic
36 documentation generation, module and library management, extensive
37 customization options, and more.
38
39 SWIG is entirely the product of users who have used the system and
40 suggested new idea. There are far too many people to thank
41 individually, but without this support, SWIG would be not be nearly as
42 powerful or fun to use as it is now. Many thanks!
43
44 %description -l pl
45 SWIG jesk kompilatorem, który próbuje u³atwiæ integrowanie kodu
46 napisanego w C, C++ lub Objective-C z jêzykami skryptowymi, takimi jak
47 Perl, Tcl i Python. Mówi±c najpro¶ciej, je¶li dostarczysz mu zestaw
48 zadeklarowanych w ANSI C/C++ funkcji, SWIG wygeneruje Ci interfejs
49 pomiêdzy C a Twoim ulubionym jêzykiem skryptowym. To tylko drobna
50 czê¶æ tego co SWIG potrafi robiæ, bardziej zaawansowane zastosowania
51 to automatyczne generowanie dokumentacji, zarz±dzanie bibliotekami i
52 modu³ami i wiele innych.
53
54 SWIG jest w ca³o¶ci dzie³em ludzi, którzy go u¿ywali i wprowadzali
55 nowe pomys³y. Zbyt wielu ich jest, aby dziêkowaæ ka¿demu z nich
56 osobno, ale bez ich wsparcia SWIG nie by³by ani tak potê¿nym
57 narzêdziem, ani tak fajnym w u¿yciu jak jest teraz. Wiekie dziêki!
58
59 %description -l pt_BR
60 O SWIG gera interfaces para perl, python e tcl a partir de uma arquivo
61 com uma interface de descrição que consiste de uma combinação de C/C++
62 e diretivas especiais. Permite que linguagens tipo script usem C/C++
63 com um mínimo de esforço.
64
65 %package guile
66 Summary:        SWIG library: guile
67 Summary(pl):    Biblioteka SWIG: guile
68 Group:          Libraries
69
70 %description guile
71 SWIG library: guile.
72
73 %description guile -l pl
74 Biblioteka SWIG: guile.
75
76 %package perl
77 Summary:        SWIG library: Perl
78 Summary(pl):    Biblioteka SWIG: Perl
79 Group:          Libraries
80
81 %description perl
82 SWIG library: perl.
83
84 %description perl -l pl
85 Biblioteka SWIG: perl.
86
87 %package php
88 Summary:        SWIG library: php
89 Summary(pl):    Biblioteka SWIG: php
90 Group:          Libraries
91
92 %description php
93 SWIG library: php.
94
95 %description php -l pl
96 Biblioteka SWIG: php.
97
98 %package python
99 Summary:        SWIG library: python
100 Summary(pl):    Biblioteka SWIG: python
101 Group:          Libraries
102
103 %description python
104 SWIG library: python.
105
106 %description python -l pl
107 Biblioteka SWIG: python.
108
109 %package ruby
110 Summary:        SWIG library: ruby
111 Summary(pl):    Biblioteka SWIG: ruby
112 Group:          Libraries
113
114 %description ruby
115 SWIG library: ruby.
116
117 %description ruby -l pl
118 Biblioteka SWIG: ruby.
119
120 %package tcl
121 Summary:        SWIG library: tcl
122 Summary(pl):    Biblioteka SWIG: tcl
123 Group:          Libraries
124
125 %description tcl
126 SWIG library: tcl.
127
128 %description tcl -l pl
129 Biblioteka SWIG: tcl.
130
131 %package ocaml
132 Summary:        SWIG library: ocaml
133 Summary(pl):    Biblioteka SWIG: ocaml
134 Group:          Libraries
135
136 %description ocaml
137 SWIG library: ocaml.
138
139 %description ocaml -l pl
140 Biblioteka SWIG: ocaml.
141
142 %prep
143 %setup -q -n SWIG-%{version}
144 %patch0 -p1
145 %patch1 -p1
146
147 %build
148 oldpwd=$PWD
149 for i in . Tools; do
150   cd $i
151   %{__libtoolize}
152   %{__aclocal}
153   %{__autoconf}
154   cd $oldpwd
155 done
156 %configure
157
158 %{__make} OPT="%{rpmcflags}"
159
160 %install
161 rm -rf $RPM_BUILD_ROOT
162 install -d $RPM_BUILD_ROOT{%{_mandir}/man1,%{_examplesdir}/%{name}-%{version}}
163
164 %{__make} install \
165         DESTDIR=$RPM_BUILD_ROOT
166
167 cp -a Examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
168
169 %clean
170 rm -rf $RPM_BUILD_ROOT
171
172 %post   -p /sbin/ldconfig
173 %postun -p /sbin/ldconfig
174
175 %files
176 %defattr(644,root,root,755)
177 %doc Doc CHANGES NEW README ANNOUNCE TODO LICENSE
178 %{_libdir}/%{name}*
179 %attr(755,root,root) %{_bindir}/swig
180 %{_examplesdir}/%{name}-%{version}
181
182 %files guile
183 %defattr(644,root,root,755)
184 %attr(755,root,root) %{_libdir}/lib*guile.so
185 %{_libdir}/lib*guile.la
186
187 %files perl
188 %defattr(644,root,root,755)
189 %attr(755,root,root) %{_libdir}/lib*pl.so
190 %{_libdir}/lib*pl.la
191
192 %files php
193 %defattr(644,root,root,755)
194 %attr(755,root,root) %{_libdir}/lib*php4.so
195 %{_libdir}/lib*php4.la
196
197 %files python
198 %defattr(644,root,root,755)
199 %attr(755,root,root) %{_libdir}/lib*py.so
200 %{_libdir}/lib*py.la
201
202 %files ruby
203 %defattr(644,root,root,755)
204 %attr(755,root,root) %{_libdir}/lib*rb.so
205 %{_libdir}/lib*rb.la
206
207 %files tcl
208 %defattr(644,root,root,755)
209 %attr(755,root,root) %{_libdir}/lib*tcl*.so
210 %{_libdir}/lib*tcl*.la
211
212 %files ocaml
213 %defattr(644,root,root,755)
214 %attr(755,root,root) %{_libdir}/lib*ocaml*.so*
215 %{_libdir}/lib*ocaml*.la
This page took 0.103976 seconds and 4 git commands to generate.