]> git.pld-linux.org Git - packages/sway.git/commitdiff
- make x32 patch rely on compiler, not rpm
authorJan Rękorajski <baggins@pld-linux.org>
Fri, 5 Feb 2021 19:25:40 +0000 (20:25 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Fri, 5 Feb 2021 19:25:40 +0000 (20:25 +0100)
sway.spec
x32.patch

index 82343a8d53242054570d0f4eb475f0ce10c72a56..1b7c61f2cadf94c7a8db78bde2da45fd4b84a629 100644 (file)
--- a/sway.spec
+++ b/sway.spec
@@ -85,9 +85,7 @@ ZSH completion for sway.
 
 %prep
 %setup -q
-%ifarch x32
 %patch0 -p1
-%endif
 
 %build
 %meson build
index e1cad37d2ee630db777f944839086bf678876590..6761cb676f1f96d334645703c2f2234fdae8ebfe 100644 (file)
--- a/x32.patch
+++ b/x32.patch
@@ -1,11 +1,14 @@
 --- sway-1.5.1/common/log.c.orig       2020-11-10 17:47:31.000000000 +0100
 +++ sway-1.5.1/common/log.c    2021-02-03 11:01:15.711496602 +0100
-@@ -75,7 +75,7 @@
+@@ -75,7 +75,11 @@
        clock_gettime(CLOCK_MONOTONIC, &ts);
        timespec_sub(&ts, &ts, &start_time);
  
--      fprintf(stderr, "%02d:%02d:%02d.%03ld ", (int)(ts.tv_sec / 60 / 60),
++#ifdef __ILP32__
 +      fprintf(stderr, "%02d:%02d:%02d.%03lld ", (int)(ts.tv_sec / 60 / 60),
++#else
+       fprintf(stderr, "%02d:%02d:%02d.%03ld ", (int)(ts.tv_sec / 60 / 60),
++#endif
                (int)(ts.tv_sec / 60 % 60), (int)(ts.tv_sec % 60),
                ts.tv_nsec / 1000000);
  
This page took 0.134185 seconds and 4 git commands to generate.