]> git.pld-linux.org Git - packages/suil.git/blob - suil.spec
fc9df972f35b92e7c8068ac2a8781254e7112d51
[packages/suil.git] / suil.spec
1 #
2 # Conditional build:
3 %bcond_without  gtk     # GTK+ (2,3) support
4 %bcond_without  qt4     # Qt4 support
5 %bcond_without  qt5     # Qt5 support
6
7 Summary:        Lightweight C library for loading and wrapping LV2 plugin UIs
8 Summary(pl.UTF-8):      Lekka biblioteka C do ładowania i obudowywania UI wtyczek LV2
9 Name:           suil
10 Version:        0.10.6
11 Release:        1
12 License:        ISC
13 Group:          Libraries
14 Source0:        http://download.drobilla.net/%{name}-%{version}.tar.bz2
15 # Source0-md5:  12c87f830c06d280e2826fae7bc6dd86
16 URL:            http://drobilla.net/software/suil/
17 %{?with_qt4:BuildRequires:      QtGui-devel >= 4.4.0}
18 %{?with_qt5:BuildRequires:      Qt5Widgets-devel >= 5.1.0}
19 %{?with_gtk:BuildRequires:      gtk+2-devel >= 2:2.18.0}
20 %{?with_gtk:BuildRequires:      gtk+3-devel >= 3.14.0}
21 BuildRequires:  libstdc++-devel
22 BuildRequires:  lv2-devel >= 1.16.0
23 BuildRequires:  python
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 Suil is a lightweight C library for loading and wrapping LV2 plugin
28 UIs.
29
30 Suil makes it possible to load a UI of any toolkit in a host using any
31 other toolkit (assuming the toolkits are both supported by Suil).
32 Hosts do not need to build against or link to foreign toolkit
33 libraries to use UIs written with that toolkit (Suil performs its
34 magic at runtime using dynamically loaded modules). The API is
35 designed such that hosts do not need to explicitly support particular
36 toolkits whatsoever - if Suil supports a particular toolkit, then all
37 hosts that use Suil will support that toolkit "for free".
38
39 %description -l pl.UTF-8
40 Suil to lekka biblioteka C do ładowania i obudowywania interfejsów
41 użytkownika (UI) wtyczek LV2.
42
43 Suil umożliwia wczytanie UI dowolnego toolkitu do hosta
44 wykorzystującego dowolny inny toolkit (zakładając, że oba toolkity są
45 obsługiwane prez Suil). Hosty nie muszą być budowane z obsługą obcych
46 bibliotek toolkitów, aby można było używać UI napisanego z użyciem
47 danego toolkitu (Suil wykonuje całą potrzebną magię w czasie działania
48 przy użyciu modułów ładowanych dynamicznie). API jest zaprojektowane
49 tak, że hosty nie muszą jawnie obsługiwać konkretnego toolkitu - jeśli
50 Suil obsługuje ten toolkit, to wszystkie hosty wykorzystujące Suil
51 będą obsługiwały ten toolkit za darmo.
52
53 %package modules
54 Summary:        UI wrapper modules for suil library
55 Summary(pl.UTF-8):      Moduły obudowujące UI dla biblioteki suil
56 Group:          Libraries
57 Requires:       %{name} = %{version}-%{release}
58 %{?with_qt4:Requires:   QtGui >= 4.4.0}
59 %{?with_qt5:Requires:   Qt5Widgets >= 5.1.0}
60 %{?with_gtk:Requires:   gtk+2 >= 2:2.18.0}
61 %{?with_gtk:Requires:   gtk+3 >= 3.14.0}
62
63 %description modules
64 Dynamically loaded modules for suil library, allowing to use X11
65 UIs in GTK+ or Qt host, GTK+ UI in Qt host, Qt UI in GTK+ host.
66
67 %description modules -l pl.UTF-8
68 Dynamicznie wczytywane moduły dla biblioteki suil, pozwalające na
69 używanie interfejsów użytkownika X11 w hostach GTK+ lub Qt,
70 interfejsów GTK+ w hostach Qt oraz  interfejsów Qt w hostach GTK+.
71
72 %package devel
73 Summary:        Header files for suil library
74 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki suil
75 Group:          Development/Libraries
76 Requires:       %{name} = %{version}-%{release}
77 Requires:       lv2-devel >= 1.16.0
78
79 %description devel
80 Header files for suil library.
81
82 %description devel -l pl.UTF-8
83 Pliki nagłówkowe biblioteki suil.
84
85 %prep
86 %setup -q
87
88 %build
89 CC="%{__cc}" \
90 CFLAGS="%{rpmcflags}" \
91 ./waf configure \
92         --prefix=%{_prefix} \
93         --libdir=%{_libdir} \
94         --gtk2-lib-name=libgtk-x11-2.0.so.0 \
95         --gtk3-lib-name=libgtk-3.so.0 \
96         %{!?with_gtk:--no-gtk} \
97         %{!?with_qt4:--no-qt4} \
98         %{!?with_qt4:--no-qt4} \
99         %{!?with_qt5:--no-qt5}
100
101 ./waf -v
102
103 %install
104 rm -rf $RPM_BUILD_ROOT
105
106 ./waf install \
107         --destdir=$RPM_BUILD_ROOT
108
109 %clean
110 rm -rf $RPM_BUILD_ROOT
111
112 %post   -p /sbin/ldconfig
113 %postun -p /sbin/ldconfig
114
115 %files
116 %defattr(644,root,root,755)
117 %doc AUTHORS COPYING NEWS README.md
118 %attr(755,root,root) %{_libdir}/libsuil-0.so.*.*.*
119 %attr(755,root,root) %ghost %{_libdir}/libsuil-0.so.0
120 %dir %{_libdir}/suil-0
121
122 %files modules
123 %defattr(644,root,root,755)
124 %attr(755,root,root) %{_libdir}/suil-0/libsuil_x11.so
125 %if %{with gtk}
126 %attr(755,root,root) %{_libdir}/suil-0/libsuil_x11_in_gtk2.so
127 %attr(755,root,root) %{_libdir}/suil-0/libsuil_x11_in_gtk3.so
128 %endif
129 %if %{with qt4}
130 %attr(755,root,root) %{_libdir}/suil-0/libsuil_x11_in_qt4.so
131 %endif
132 %if %{with qt5}
133 %attr(755,root,root) %{_libdir}/suil-0/libsuil_x11_in_qt5.so
134 %endif
135 %if %{with gtk} && %{with qt4}
136 %attr(755,root,root) %{_libdir}/suil-0/libsuil_gtk2_in_qt4.so
137 %attr(755,root,root) %{_libdir}/suil-0/libsuil_qt4_in_gtk2.so
138 %endif
139 %if %{with gtk} && %{with qt5}
140 %attr(755,root,root) %{_libdir}/suil-0/libsuil_gtk2_in_qt5.so
141 %attr(755,root,root) %{_libdir}/suil-0/libsuil_qt5_in_gtk2.so
142 %attr(755,root,root) %{_libdir}/suil-0/libsuil_qt5_in_gtk3.so
143 %endif
144
145 %files devel
146 %defattr(644,root,root,755)
147 %attr(755,root,root) %{_libdir}/libsuil-0.so
148 %{_includedir}/suil-0
149 %{_pkgconfigdir}/suil-0.pc
This page took 1.814716 seconds and 2 git commands to generate.