]> git.pld-linux.org Git - packages/sudo.git/commitdiff
use upstream fix for x32 build failure; rel 3
authorJan Palus <atler@pld-linux.org>
Sun, 12 Jun 2022 08:17:36 +0000 (10:17 +0200)
committerJan Palus <atler@pld-linux.org>
Sun, 12 Jun 2022 08:18:15 +0000 (10:18 +0200)
sudo.spec
x32.patch

index 907c0cf92a981d8ad2d315f1b7c8f44f62011a0d..0c267897dcf7b39f601c5b86123799dd2710a134 100644 (file)
--- a/sudo.spec
+++ b/sudo.spec
@@ -30,7 +30,7 @@ Summary(uk.UTF-8):    Дозволяє вказаним користувачам в
 Name:          sudo
 # please see docs/UPGRADE.md for important changes each time updating sudo
 Version:       1.9.11p1
 Name:          sudo
 # please see docs/UPGRADE.md for important changes each time updating sudo
 Version:       1.9.11p1
-Release:       2
+Release:       3
 Epoch:         1
 License:       BSD
 Group:         Applications/System
 Epoch:         1
 License:       BSD
 Group:         Applications/System
index cc2b1fcf9a978fa7e096b513e72933da3c3b49b2..0c4394d16f276606d80e7e6696c6a20ffdc5d3f2 100644 (file)
--- a/x32.patch
+++ b/x32.patch
@@ -1,21 +1,26 @@
---- sudo-1.9.11p1/src/exec_ptrace.c~   2022-06-06 16:42:01.000000000 +0200
-+++ sudo-1.9.11p1/src/exec_ptrace.c    2022-06-11 21:36:12.498210857 +0200
-@@ -1035,14 +1035,16 @@
-       switch (syscallno) {
- # ifdef X32_execve
-       case X32_execve:
--# endif
-+# else
-       case __NR_execve:
+From dfee181d1579a24c679eff960c85bc659c56993f Mon Sep 17 00:00:00 2001
+From: "Todd C. Miller" <Todd.Miller@sudo.ws>
+Date: Sat, 11 Jun 2022 16:59:18 -0600
+Subject: [PATCH] Fix compilation on Linux/x32; GitHub issue #158
+
+---
+ src/exec_ptrace.h | 6 ++++--
+ 1 file changed, 4 insertions(+), 2 deletions(-)
+
+diff --git a/src/exec_ptrace.h b/src/exec_ptrace.h
+index 4a5a86581..4340a48ea 100644
+--- a/src/exec_ptrace.h
++++ b/src/exec_ptrace.h
+@@ -64,8 +64,10 @@
+  */
+ #if defined(__x86_64__)
+ # define SECCOMP_AUDIT_ARCH   AUDIT_ARCH_X86_64
+-# define X32_execve           __X32_SYSCALL_BIT + 520
+-# define X32_execveat         __X32_SYSCALL_BIT + 545
++# ifndef __ILP32__
++#  define X32_execve          __X32_SYSCALL_BIT + 520
++#  define X32_execveat                __X32_SYSCALL_BIT + 545
 +# endif
 +# endif
-           /* Handled below. */
-           break;
- # ifdef X32_execveat
-       case X32_execveat:
--# endif
-+# else
-       case __NR_execveat:
-+# endif
-           /* We don't currently check execveat(2). */
-           debug_return_bool(true);
-           break;
+ # define sudo_pt_regs         struct user_regs_struct
+ # define reg_syscall(x)               (x).orig_rax
+ # define reg_retval(x)                (x).rax
This page took 0.285805 seconds and 4 git commands to generate.