]> git.pld-linux.org Git - packages/sudo.git/blob - sudo.spec
- added using CVS keywords in %changelog (for automating them).
[packages/sudo.git] / sudo.spec
1 Summary:        Allows command execution as root for specified users
2 Summary(pl):    Umo¿liwia wykonywaniew poleceñ jako root dla konkretnych u¿ytkowników
3 Name:           sudo
4 Version:        1.5.9p2
5 Release:        1
6 Copyright:      GPL
7 Group:          Utilities/System
8 Group(pl):      Narzêdzia/Systemowe
9 Source:         ftp://ftp.cs.colorado.edu/pub/sudo/cu-sudo.v%{version}.tar.gz
10 URL:            http://www.courtesan.com/courtesan/products/sudo/
11 BuildRoot:      /tmp/%{name}-%{version}-root
12
13 %define _sysconfdir     /etc
14
15 %description
16 Sudo (superuser do) allows a permitted user to execute a command as the
17 superuser (real and effective uid and gid are set to 0 and root's group as
18 set in the passwd file respectively).
19                                                                                                               
20 Sudo determines who is an authorized user by consulting the file
21 /etc/sudoers.  By giving sudo the -v flag a user can update the time stamp
22 without running a command.  The password prompt itself will also time out if
23 the password is not entered with N minutes (again, this is defined at
24 installation time and defaults to 5 minutes).
25
26 %description -l pl
27 Sudo (superuser do) umo¿liwia wykonywanie konkretnych poleceñ jako root dla
28 wyspecyfikowanych u¿ytkowników (rzeczywiste i efektywne uid/gid podczas
29 wykonywania tych programów jest 0).
30
31 To kto mo¿e wykonywaæ konkretne polecenia i w jaki sposób ma byæ
32 autoryzowany jest opisane w pliku /etc/sudoers.
33
34 %prep
35 %setup -q -n %{name}.v%{version}
36
37 %build
38 autoconf
39 CFLAGS="$RPM_OPT_FLAGS" LDFLAGS="-s" \
40 ./configure %{_target_platform} \
41         --prefix=%{_prefix} \
42         --sbindir=%{_sbindir} \
43         --with-timedir=/var/run \
44         --with-C2 \
45         --with-pam \
46         --with-logging=both \
47         --with-logfac=LOG_AUTH \
48         --with-logpath=/var/log/sudo.log \
49         --with-message=full \
50         --with-ignore-dot \
51         --with-env-editor \
52         --with-insults \
53         --with-all-insults \
54         --with-classic-insults \
55         --with-csops-insults \
56         --with-hal-insults \
57         --with-goons-insults \
58         --with-secure-path="/bin:/sbin:/usr/bin:/usr/sbin" \
59         --with-loglen=320 \
60
61 make CFLAGS="$RPM_OPT_FLAGS"
62
63 %install
64 rm -rf $RPM_BUILD_ROOT
65 install -d $RPM_BUILD_ROOT%{_sysconfdir}/pam.d,/var/log
66
67 make install \
68         prefix=$RPM_BUILD_ROOT%{_prefix} \
69         visudodir=$RPM_BUILD_ROOT%{_sbindir} \
70         sysconfdir=$RPM_BUILD_ROOT%{_sysconfdir} \
71         install_uid=`id -u` \
72         install_gid=`id -g` \
73         sudoers_uid=`id -u` \
74         sudoers_gid=`id -g`
75
76 install sample.pam $RPM_BUILD_ROOT%{_sysconfdir}/pam.d/sudo
77 touch $RPM_BUILD_ROOT/var/log/sudo.log
78
79 gzip -9nf $RPM_BUILD_ROOT%{_mandir}/man{5,8}/* \
80         BUGS CHANGES HISTORY README TODO TROUBLESHOOTING
81
82 chmod -R +r $RPM_BUILD_ROOT%{_prefix}
83
84 %clean
85 rm -rf $RPM_BUILD_ROOT
86
87 %files
88 %defattr(644,root,root,755)
89 %doc *.gz sample.sudoers
90 %attr(0400,root,root) %verify(not md5 size mtime) %config(noreplace) %{_sysconfdir}/sudoers
91 %attr(0600,root,root) %config %{_sysconfdir}/pam.d/sudo
92 %attr(4555,root,root) %{_bindir}/sudo
93 %attr(0555,root,root) %{_sbindir}/visudo
94 %{_mandir}/man*/*
95 %attr(0600,root,root) %ghost /var/log/sudo.log
This page took 0.061226 seconds and 4 git commands to generate.