]> git.pld-linux.org Git - packages/sudo.git/blob - sudo.spec
s/%{_target}/%{_target_platform}/
[packages/sudo.git] / sudo.spec
1 Summary:        Allows command execution as root for specified users
2 Summary(pl):    Umo¿liwia wykonywaniew poleceñ jako root dla konkretnych u¿ytkowników
3 Name:           sudo
4 Version:        1.5.9p2
5 Release:        1
6 Copyright:      GPL
7 Group:          Utilities/System
8 Group(pl):      Narzêdzia/Systemowe
9 Source:         ftp://ftp.cs.colorado.edu/pub/sudo/cu-sudo.v%{version}.tar.gz
10 URL:            http://www.courtesan.com/courtesan/products/sudo/
11 BuildRoot:      /tmp/%{name}-%{version}-root
12
13 %description
14 Sudo (superuser do) allows a permitted user to execute a command as the
15 superuser (real and effective uid and gid are set to 0 and root's group as
16 set in the passwd file respectively).
17                                                                                                               
18 Sudo determines who is an authorized user by consulting the file
19 /etc/sudoers.  By giving sudo the -v flag a user can update the time stamp
20 without running a command.  The password prompt itself will also time out if
21 the password is not entered with N minutes (again, this is defined at
22 installation time and defaults to 5 minutes).
23
24 %description -l pl
25 Sudo (superuser do) umo¿liwia wykonywanie konkretnych poleceñ jako root dla
26 wyspecyfikowanych u¿ytkowników (rzeczywiste i efektywne uid/gid podczas
27 wykonywania tych programów jest 0).
28
29 To kto mo¿e wykonywaæ konkretne polecenia i w jaki sposób ma byæ
30 autoryzowany jest opisane w pliku /etc/sudoers.
31
32 %prep
33 %setup -q -n %{name}.v%{version}
34
35 %build
36 autoconf
37 CFLAGS="$RPM_OPT_FLAGS" LDFLAGS="-s" \
38 ./configure %{_target_platform} \
39         --prefix=/usr \
40         --sbindir=%{_sbindir} \
41         --with-timedir=/var/run \
42         --with-C2 \
43         --with-pam \
44         --with-logging=both \
45         --with-logfac=LOG_AUTH \
46         --with-logpath=/var/log/sudo.log \
47         --with-message=full \
48         --with-ignore-dot \
49         --with-env-editor \
50         --with-insults \
51         --with-all-insults \
52         --with-classic-insults \
53         --with-csops-insults \
54         --with-hal-insults \
55         --with-goons-insults \
56         --with-secure-path="/bin:/sbin:/usr/bin:/usr/sbin" \
57         --with-loglen=320 \
58
59 make CFLAGS="$RPM_OPT_FLAGS"
60
61 %install
62 rm -rf $RPM_BUILD_ROOT
63 install -d $RPM_BUILD_ROOT/{etc/pam.d,var/log}
64
65 make install \
66         prefix=$RPM_BUILD_ROOT/usr \
67         visudodir=$RPM_BUILD_ROOT%{_sbindir} \
68         sysconfdir=$RPM_BUILD_ROOT/etc \
69         install_uid=`id -u` \
70         install_gid=`id -g` \
71         sudoers_uid=`id -u` \
72         sudoers_gid=`id -g`
73
74 install sample.pam $RPM_BUILD_ROOT/etc/pam.d/sudo
75 touch $RPM_BUILD_ROOT/var/log/sudo.log
76
77 gzip -9nf $RPM_BUILD_ROOT%{_mandir}/man{5,8}/* \
78         BUGS CHANGES HISTORY README TODO TROUBLESHOOTING
79
80 chmod -R +r $RPM_BUILD_ROOT/usr
81
82 %clean
83 rm -rf $RPM_BUILD_ROOT
84
85 %files
86 %defattr(644,root,root,755)
87 %doc *.gz sample.sudoers
88 %attr(0400,root,root) %verify(not md5 size mtime) %config(noreplace) /etc/sudoers
89 %attr(0600,root,root) %config /etc/pam.d/sudo
90 %attr(4555,root,root) %{_bindir}/sudo
91 %attr(0555,root,root) %{_sbindir}/visudo
92 %{_mandir}/man*/*
93 %attr(0600,root,root) %ghost /var/log/sudo.log
94
95 %changelog
96 * Sun May 30 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
97   [1.5.9p2-1]
98 - added more rpm macros.
99
100 * Wed Apr  7 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
101   [1.5.9p1-1]
102 - added gzipping %doc
103 - removed man group from man pages.
104
105 * Sun Nov 29 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
106   [1.5.7p2-1]
107 - added gzipping man pages,
108 - changed Buildroot to /tmp/%%{name}-%%{version}-root,
109 - added "not size mtime" to %verify rule for /etc/sudoers,
110 - changed way passing $RPM_OPT_FLAGS,
111 - rewrited %description,
112 - rewrited %build and %install using new autoconf sheme,
113 - added pl translation.
114
115 * Tue Sep 21 1998 Ian Macdonald <ianmacd@xs4all.nl>
116 - upgraded to 1.5.6p2
117 - built with PAM support
118 - removed SUDO_LDFLAGS="-static" from make: would no longer build with it
119
120 * Wed May  6 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
121 - %%{version} macro instead %%{PACKAGE_VERSION},
122 - added -q %setup parameter,
123 - added using %%{name} macro in Buildroot.
124
125 * Mon Apr 27 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
126   [1.5.4-3]
127 - Buildroot changed to /tmp/sudo-%%{PACKAGE_VERSION}-root,
128 - added %%{PACKAGE_VERSION} to Source url and %setup macro,
129 - removed sudo-1.5.4-buildroot.patch and instead this added few parameters
130   to "make install",
131 - SUDO_LDFLAGS="-static" and CFLAGS="$RPM_OPT_FLAGS" is passed as make 
132   arguments,
133 - removed COPYING from %doc (Copyright statement is in Copyright field),
134 - removed from %doc *.pod and options.h and added sample.sudoers,
135 - added /var/log/sudo.log as %ghost file,
136 - added %verify(not md5) for /etc/sudoers (allow modify this file without
137   display warning on verify with using rpm),
138 - added noreplace parameter for /etc/sudoers %config file,
139 - removed sudo.v1.5.4-glibc.diff because sudo compiles on glibc 2.0.7,
140 - added %defattr and %attr macros in %files (allows building package from
141   non-root account); %defattr requires rpm >= 2.4.99.
142
143 * Fri Jan 23 1998 Ian Macdonald <ianmacd@xs4all.nl>
144   [1.5.4-2]
145 - glibc build was broken; added patch to fix it
146
147 * Tue Nov 18 1997 Otto Hammersmith <otto@redhat.com>
148 - built for glibc, no problems
149
150 * Fri Apr 25 1997 Michael Fulbright <msf@redhat.com>
151 - Fixed for 4.2 PowerTools 
152 - Still need to be pamified
153 - Still need to move stmp file to /var/log
154
155 * Mon Feb 17 1997 Michael Fulbright <msf@redhat.com>
156 - First version for PowerCD.
This page took 0.092288 seconds and 4 git commands to generate.