]> git.pld-linux.org Git - packages/sudo.git/blob - sudo.spec
- switch to DESTDIR style %install.
[packages/sudo.git] / sudo.spec
1 Summary:        Allows command execution as root for specified users
2 Summary(pl):    Umo¿liwia wykonywaniew poleceñ jako root dla konkretnych u¿ytkowników
3 Name:           sudo
4 Version:        1.5.9p4
5 Release:        1
6 Copyright:      GPL
7 Group:          Utilities/System
8 Group(pl):      Narzêdzia/Systemowe
9 Source0:        ftp://ftp.cs.colorado.edu/pub/sudo/cu-sudo.v%{version}.tar.gz
10 Source1:        sudo.pamd
11 Patch:          sudo-DESTDIR.patch
12 URL:            http://www.courtesan.com/courtesan/products/sudo/
13 BuildRoot:      /tmp/%{name}-%{version}-root
14
15 %define         _sysconfdir     /etc
16
17 %description
18 Sudo (superuser do) allows a permitted user to execute a command as the
19 superuser (real and effective uid and gid are set to 0 and root's group as
20 set in the passwd file respectively).
21                                                                                                               
22 Sudo determines who is an authorized user by consulting the file
23 /etc/sudoers.  By giving sudo the -v flag a user can update the time stamp
24 without running a command.  The password prompt itself will also time out if
25 the password is not entered with N minutes (again, this is defined at
26 installation time and defaults to 5 minutes).
27
28 %description -l pl
29 Sudo (superuser do) umo¿liwia wykonywanie konkretnych poleceñ jako root dla
30 wyspecyfikowanych u¿ytkowników (rzeczywiste i efektywne uid/gid podczas
31 wykonywania tych programów jest 0).
32
33 To kto mo¿e wykonywaæ konkretne polecenia i w jaki sposób ma byæ
34 autoryzowany jest opisane w pliku /etc/sudoers.
35
36 %prep
37 %setup -q -n %{name}.v%{version}
38 %patch -p1
39
40 %build
41 autoconf
42 LDFLAGS="-s"; export LDFLAGS
43 %configure \
44         --with-timedir=/var/run/sudo \
45         --with-C2 \
46         --with-pam \
47         --with-logging=both \
48         --with-logfac=LOG_AUTH \
49         --with-logpath=/var/log/sudo.log \
50         --with-message=full \
51         --with-ignore-dot \
52         --with-env-editor \
53         --with-insults \
54         --with-all-insults \
55         --with-classic-insults \
56         --with-csops-insults \
57         --with-hal-insults \
58         --with-goons-insults \
59         --with-secure-path="/bin:/sbin:/usr/bin:/usr/sbin" \
60         --with-loglen=320 \
61
62 make CFLAGS="$RPM_OPT_FLAGS"
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/pam.d,/var/{log,run/sudo}}
67
68 make install \
69         DESTDIR=$RPM_BUILD_ROOT \
70         install_uid=`id -u` \
71         install_gid=`id -g` \
72         sudoers_uid=`id -u` \
73         sudoers_gid=`id -g`
74
75 install %{SOURCE1}  $RPM_BUILD_ROOT%{_sysconfdir}/pam.d/sudo
76 touch $RPM_BUILD_ROOT/var/log/sudo.log
77
78 gzip -9nf $RPM_BUILD_ROOT%{_mandir}/man{5,8}/* \
79         BUGS CHANGES HISTORY README TODO TROUBLESHOOTING
80
81 chmod -R +r $RPM_BUILD_ROOT%{_prefix}
82
83 %clean
84 rm -rf $RPM_BUILD_ROOT
85
86 %files
87 %defattr(644,root,root,755)
88 %doc *.gz sample.sudoers
89 %attr(0400,root,root) %verify(not md5 size mtime) %config(noreplace) %{_sysconfdir}/sudoers
90 %attr(0600,root,root) %config %{_sysconfdir}/pam.d/sudo
91 %attr(4555,root,root) %{_bindir}/sudo
92 %attr(0555,root,root) %{_sbindir}/visudo
93 %{_mandir}/man*/*
94 %attr(0600,root,root) %ghost /var/log/sudo.log
95 %attr(0700,root,root) %dir /var/run/sudo
This page took 0.076567 seconds and 4 git commands to generate.