]> git.pld-linux.org Git - packages/sudo.git/blob - sudo.spec
[1.5.9p1-1]
[packages/sudo.git] / sudo.spec
1 Summary:        Allows command execution as root for specified users
2 Summary(pl):    Umo¿liwia wykonywaniew poleceñ jako root dla konkretnych u¿ytkowników
3 Name:           sudo
4 Version:        1.5.9p1
5 Release:        1
6 Copyright:      GPL
7 Group:          Utilities/System
8 Group(pl):      Narzêdzia/Systemowe
9 Source:         ftp://ftp.cs.colorado.edu/pub/sudo/cu-sudo.v%{version}.tar.gz
10 URL:            http://www.courtesan.com/courtesan/products/sudo/
11 BuildRoot:      /tmp/%{name}-%{version}-root
12
13 %description
14 Sudo (superuser do) allows a permitted user to execute a command as the
15 superuser (real and effective uid and gid are set to 0 and root's group as
16 set in the passwd file respectively).
17                                                                                                               
18 Sudo determines who is an authorized user by consulting the file
19 /etc/sudoers.  By giving sudo the -v flag a user can update the time stamp
20 without running a command.  The password prompt itself will also time out if
21 the password is not entered with N minutes (again, this is defined at
22 installation time and defaults to 5 minutes).
23
24 %description -l pl
25 Sudo (superuser do) umo¿liwia wykonywanie konkretnych poleceñ jako root dla
26 wyspecyfikowanych u¿ytkowników (rzeczywiste i efektywne uid/gid podczas
27 wykonywania tych programów jest 0).
28
29 To kto mo¿e wykonywaæ konkretne polecenia i w jaki sposób ma byæ
30 autoryzowany jest opisane w pliku /etc/sudoers.
31
32 %prep
33 %setup -q -n %{name}.v%{version}
34
35 %build
36 CFLAGS="$RPM_OPT_FLAGS" LDFLAGS="-s" \
37 ./configure \
38         --prefix=/usr \
39         --sbindir=/usr/sbin \
40         --with-timedir=/var/run \
41         --with-C2 \
42         --with-pam \
43         --with-logging=both \
44         --with-logfac=LOG_AUTH \
45         --with-logpath=/var/log/sudo.log \
46         --with-message=full \
47         --with-ignore-dot \
48         --with-env-editor \
49         --with-insults \
50         --with-all-insults \
51         --with-classic-insults \
52         --with-csops-insults \
53         --with-hal-insults \
54         --with-goons-insults \
55         --with-secure-path="/bin:/sbin:/usr/bin:/usr/sbin" \
56         --with-loglen=320 \
57
58 make CFLAGS="$RPM_OPT_FLAGS"
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62 install -d $RPM_BUILD_ROOT/{etc/pam.d,var/log}
63
64 make install \
65         prefix=$RPM_BUILD_ROOT/usr \
66         visudodir=$RPM_BUILD_ROOT/usr/sbin \
67         sysconfdir=$RPM_BUILD_ROOT/etc \
68         install_uid=`id -u` \
69         install_gid=`id -g` \
70         sudoers_uid=`id -u` \
71         sudoers_gid=`id -g`
72
73 install sample.pam $RPM_BUILD_ROOT/etc/pam.d/sudo
74 touch $RPM_BUILD_ROOT/var/log/sudo.log
75
76 gzip -9nf $RPM_BUILD_ROOT/usr/man/man{5,8}/* \
77         BUGS CHANGES HISTORY README TODO TROUBLESHOOTING
78
79 chmod -R +r $RPM_BUILD_ROOT/usr
80
81 %clean
82 rm -rf $RPM_BUILD_ROOT
83
84 %files
85 %defattr(644,root,root,755)
86 %doc *.gz sample.sudoers
87 %attr(0400,root,root) %verify(not md5 size mtime) %config(noreplace) /etc/sudoers
88 %attr(0600,root,root) %config /etc/pam.d/sudo
89 %attr(4555,root,root) /usr/bin/sudo
90 %attr(0555,root,root) /usr/sbin/visudo
91 /usr/man/man*/*
92 %attr(0600,root,root) %ghost /var/log/sudo.log
93
94 %changelog
95 * Wed Apr  7 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
96   [1.5.9p1-1]
97 - added gzipping %doc
98 - removed man group from man pages.
99
100 * Sun Nov 29 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
101   [1.5.7p2-1]
102 - added gzipping man pages,
103 - changed Buildroot to /tmp/%%{name}-%%{version}-root,
104 - added "not size mtime" to %verify rule for /etc/sudoers,
105 - changed way passing $RPM_OPT_FLAGS,
106 - rewrited %description,
107 - rewrited %build and %install using new autoconf sheme,
108 - added pl translation.
109
110 * Tue Sep 21 1998 Ian Macdonald <ianmacd@xs4all.nl>
111 - upgraded to 1.5.6p2
112 - built with PAM support
113 - removed SUDO_LDFLAGS="-static" from make: would no longer build with it
114
115 * Wed May  6 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
116 - %%{version} macro instead %%{PACKAGE_VERSION},
117 - added -q %setup parameter,
118 - added using %%{name} macro in Buildroot.
119
120 * Mon Apr 27 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
121   [1.5.4-3]
122 - Buildroot changed to /tmp/sudo-%%{PACKAGE_VERSION}-root,
123 - added %%{PACKAGE_VERSION} to Source url and %setup macro,
124 - removed sudo-1.5.4-buildroot.patch and instead this added few parameters
125   to "make install",
126 - SUDO_LDFLAGS="-static" and CFLAGS="$RPM_OPT_FLAGS" is passed as make 
127   arguments,
128 - removed COPYING from %doc (Copyright statement is in Copyright field),
129 - removed from %doc *.pod and options.h and added sample.sudoers,
130 - added /var/log/sudo.log as %ghost file,
131 - added %verify(not md5) for /etc/sudoers (allow modify this file without
132   display warning on verify with using rpm),
133 - added noreplace parameter for /etc/sudoers %config file,
134 - removed sudo.v1.5.4-glibc.diff because sudo compiles on glibc 2.0.7,
135 - added %defattr and %attr macros in %files (allows building package from
136   non-root account); %defattr requires rpm >= 2.4.99.
137
138 * Fri Jan 23 1998 Ian Macdonald <ianmacd@xs4all.nl>
139   [1.5.4-2]
140 - glibc build was broken; added patch to fix it
141
142 * Tue Nov 18 1997 Otto Hammersmith <otto@redhat.com>
143 - built for glibc, no problems
144
145 * Fri Apr 25 1997 Michael Fulbright <msf@redhat.com>
146 - Fixed for 4.2 PowerTools 
147 - Still need to be pamified
148 - Still need to move stmp file to /var/log
149
150 * Mon Feb 17 1997 Michael Fulbright <msf@redhat.com>
151 - First version for PowerCD.
This page took 0.285595 seconds and 4 git commands to generate.