]> git.pld-linux.org Git - packages/sudo.git/blob - sudo.spec
- merge translations from CNV.
[packages/sudo.git] / sudo.spec
1 Summary:        Allows command execution as root for specified users
2 Summary(es):    Permite que usuarios específicos ejecuten comandos como se fueran el root
3 Summary(pl):    Umo¿liwia wykonywaniew poleceñ jako root dla konkretnych u¿ytkowników
4 Summary(pt_BR): Permite que usuários específicos executem comandos como se fossem o root
5 Name:           sudo
6 Version:        1.6.3p7
7 Release:        3
8 License:        BSD
9 Group:          Applications/System
10 Group(de):      Applikationen/System
11 Group(pl):      Aplikacje/System
12 Source0:        ftp://ftp.courtesan.com/pub/sudo/%{name}-%{version}.tar.gz
13 Source1:        %{name}.pamd
14 Patch0:         %{name}-DESTDIR.patch
15 URL:            http://www.courtesan.com/sudo/
16 BuildRequires:  autoconf
17 BuildRequires:  pam-devel
18 BuildRequires:  /bin/vi
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20 Obsoletes:      cu-sudo
21
22 %define         _sysconfdir     /etc
23
24 %description
25 Sudo (superuser do) allows a permitted user to execute a command as
26 the superuser (real and effective uid and gid are set to 0 and root's
27 group as set in the passwd file respectively).
28
29 Sudo determines who is an authorized user by consulting the file
30 /etc/sudoers. By giving sudo the -v flag a user can update the time
31 stamp without running a command. The password prompt itself will also
32 time out if the password is not entered with N minutes (again, this is
33 defined at installation time and defaults to 5 minutes).
34
35 %description -l es
36 Sudo (superuser do) permite que el administrador del sistema otorga a
37 ciertos usuarios (o grupos de usuarios) la habilidad para ejecutar
38 algunos (o todos) comandos como root, registrando todos los comandos y
39 argumentos. Sudo opera en una base por comando, no siendo un
40 substituto para la shell.
41
42 %description -l pl
43 Sudo (superuser do) umo¿liwia wykonywanie konkretnych poleceñ jako
44 root dla wyspecyfikowanych u¿ytkowników (rzeczywiste i efektywne
45 uid/gid podczas wykonywania tych programów jest 0). To kto mo¿e
46 wykonywaæ konkretne polecenia i w jaki sposób ma byæ autoryzowany jest
47 opisane w pliku /etc/sudoers.
48
49 %description -l pt_BR
50 Sudo (superuser do) permite que o administrador do sistema dê a certos
51 usuários (ou grupos de usuários) a habilidade para rodar alguns (ou
52 todos) comandos como root, registrando todos os comandos e argumentos.
53 Sudo opera numa base por comando, não sendo um substituto para a
54 shell.
55
56 %prep
57 %setup -q
58 %patch -p1
59
60 %build
61 %configure2_13 \
62         --with-timedir=/var/run/sudo \
63         --with-C2 \
64         --with-pam \
65         --with-logging=both \
66         --with-logfac=auth \
67         --with-logpath=/var/log/sudo.log \
68         --with-message=full \
69         --with-ignore-dot \
70         --with-env-editor \
71         --with-insults \
72         --with-all-insults \
73         --with-classic-insults \
74         --with-csops-insults \
75         --with-hal-insults \
76         --with-goons-insults \
77         --with-secure-path="/bin:/sbin:%{_bindir}:%{_sbindir}" \
78         --with-loglen=320 \
79
80 %{__make}
81
82 %install
83 rm -rf $RPM_BUILD_ROOT
84 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/pam.d,/var/{log,run/sudo}}
85
86 %{__make} install \
87         DESTDIR=$RPM_BUILD_ROOT \
88         install_uid=`id -u` \
89         install_gid=`id -g` \
90         sudoers_uid=`id -u` \
91         sudoers_gid=`id -g`
92
93 install %{SOURCE1}  $RPM_BUILD_ROOT%{_sysconfdir}/pam.d/sudo
94 touch $RPM_BUILD_ROOT/var/log/sudo.log
95
96 gzip -9nf BUGS CHANGES HISTORY README TODO TROUBLESHOOTING
97
98 chmod -R +r $RPM_BUILD_ROOT%{_prefix}
99
100 %clean
101 rm -rf $RPM_BUILD_ROOT
102
103 %files
104 %defattr(644,root,root,755)
105 %doc *.gz sample.sudoers
106 %attr(0440,root,root) %verify(not md5 size mtime) %config(noreplace) %{_sysconfdir}/sudoers
107 %attr(0600,root,root) %config %verify(not size mtime md5) %{_sysconfdir}/pam.d/sudo
108 %attr(4555,root,root) %{_bindir}/sudo
109 %attr(0555,root,root) %{_sbindir}/visudo
110 %{_mandir}/man*/*
111 %attr(0600,root,root) %ghost /var/log/sudo.log
112 %attr(0700,root,root) %dir /var/run/sudo
This page took 0.17364 seconds and 4 git commands to generate.