]> git.pld-linux.org Git - packages/sudo.git/blob - sudo.spec
- release 2,
[packages/sudo.git] / sudo.spec
1 Summary:        Allows command execution as root for specified users
2 Summary(pl):    Umo¿liwia wykonywaniew poleceñ jako root dla konkretnych u¿ytkowników
3 Name:           sudo
4 Version:        1.6.3p5
5 Release:        2
6 License:        GPL
7 Group:          Applications/System
8 Group(de):      Applikationen/System
9 Group(pl):      Aplikacje/System
10 Source0:        ftp://ftp.courtesan.com/pub/sudo/%{name}-%{version}.tar.gz
11 Source1:        %{name}.pamd
12 Patch0:         %{name}-DESTDIR.patch
13 URL:            http://www.courtesan.com/sudo/
14 BuildRequires:  pam-devel
15 BuildRequires:  /bin/vi
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17 Obsoletes:      cu-sudo
18
19 %define         _sysconfdir     /etc
20
21 %description
22 Sudo (superuser do) allows a permitted user to execute a command as
23 the superuser (real and effective uid and gid are set to 0 and root's
24 group as set in the passwd file respectively).
25
26 Sudo determines who is an authorized user by consulting the file
27 /etc/sudoers. By giving sudo the -v flag a user can update the time
28 stamp without running a command. The password prompt itself will also
29 time out if the password is not entered with N minutes (again, this is
30 defined at installation time and defaults to 5 minutes).
31
32 %description -l pl
33 Sudo (superuser do) umo¿liwia wykonywanie konkretnych poleceñ jako
34 root dla wyspecyfikowanych u¿ytkowników (rzeczywiste i efektywne
35 uid/gid podczas wykonywania tych programów jest 0). To kto mo¿e
36 wykonywaæ konkretne polecenia i w jaki sposób ma byæ autoryzowany jest
37 opisane w pliku /etc/sudoers.
38
39 %prep
40 %setup -q
41 %patch -p1
42
43 %build
44 autoconf
45 %configure \
46         --with-timedir=/var/run/sudo \
47         --with-C2 \
48         --with-pam \
49         --with-logging=both \
50         --with-logfac=auth \
51         --with-logpath=/var/log/sudo.log \
52         --with-message=full \
53         --with-ignore-dot \
54         --with-env-editor \
55         --with-insults \
56         --with-all-insults \
57         --with-classic-insults \
58         --with-csops-insults \
59         --with-hal-insults \
60         --with-goons-insults \
61         --with-secure-path="/bin:/sbin:%{_bindir}:%{_sbindir}" \
62         --with-loglen=320 \
63
64 %{__make} CFLAGS="$RPM_OPT_FLAGS"
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/pam.d,/var/{log,run/sudo}}
69
70 %{__make} install \
71         DESTDIR=$RPM_BUILD_ROOT \
72         install_uid=`id -u` \
73         install_gid=`id -g` \
74         sudoers_uid=`id -u` \
75         sudoers_gid=`id -g`
76
77 install %{SOURCE1}  $RPM_BUILD_ROOT%{_sysconfdir}/pam.d/sudo
78 touch $RPM_BUILD_ROOT/var/log/sudo.log
79
80 gzip -9nf $RPM_BUILD_ROOT%{_mandir}/man{5,8}/* \
81         BUGS CHANGES HISTORY README TODO TROUBLESHOOTING
82
83 chmod -R +r $RPM_BUILD_ROOT%{_prefix}
84
85 %clean
86 rm -rf $RPM_BUILD_ROOT
87
88 %files
89 %defattr(644,root,root,755)
90 %doc *.gz sample.sudoers
91 %attr(0400,root,root) %verify(not md5 size mtime) %config(noreplace) %{_sysconfdir}/sudoers
92 %attr(0600,root,root) %config %verify(not size mtime md5) %{_sysconfdir}/pam.d/sudo
93 %attr(4555,root,root) %{_bindir}/sudo
94 %attr(0555,root,root) %{_sbindir}/visudo
95 %{_mandir}/man*/*
96 %attr(0600,root,root) %ghost /var/log/sudo.log
97 %attr(0700,root,root) %dir /var/run/sudo
This page took 0.149334 seconds and 3 git commands to generate.