]> git.pld-linux.org Git - packages/sudo.git/blob - sudo.spec
timestamp dir changed to /var/run/sudo (must be 0700 root.root)
[packages/sudo.git] / sudo.spec
1 Summary:        Allows command execution as root for specified users
2 Summary(pl):    Umo¿liwia wykonywaniew poleceñ jako root dla konkretnych u¿ytkowników
3 Name:           sudo
4 Version:        1.5.9p2
5 Release:        1
6 Copyright:      GPL
7 Group:          Utilities/System
8 Group(pl):      Narzêdzia/Systemowe
9 Source0:        ftp://ftp.cs.colorado.edu/pub/sudo/cu-sudo.v%{version}.tar.gz
10 Source1:        sudo.pamd
11 URL:            http://www.courtesan.com/courtesan/products/sudo/
12 BuildRoot:      /tmp/%{name}-%{version}-root
13
14 %define _sysconfdir     /etc
15
16 %description
17 Sudo (superuser do) allows a permitted user to execute a command as the
18 superuser (real and effective uid and gid are set to 0 and root's group as
19 set in the passwd file respectively).
20                                                                                                               
21 Sudo determines who is an authorized user by consulting the file
22 /etc/sudoers.  By giving sudo the -v flag a user can update the time stamp
23 without running a command.  The password prompt itself will also time out if
24 the password is not entered with N minutes (again, this is defined at
25 installation time and defaults to 5 minutes).
26
27 %description -l pl
28 Sudo (superuser do) umo¿liwia wykonywanie konkretnych poleceñ jako root dla
29 wyspecyfikowanych u¿ytkowników (rzeczywiste i efektywne uid/gid podczas
30 wykonywania tych programów jest 0).
31
32 To kto mo¿e wykonywaæ konkretne polecenia i w jaki sposób ma byæ
33 autoryzowany jest opisane w pliku /etc/sudoers.
34
35 %prep
36 %setup -q -n %{name}.v%{version}
37
38 %build
39 autoconf
40 CFLAGS="$RPM_OPT_FLAGS" LDFLAGS="-s" \
41 ./configure %{_target_platform} \
42         --prefix=%{_prefix} \
43         --sbindir=%{_sbindir} \
44         --with-timedir=/var/run/sudo \
45         --with-C2 \
46         --with-pam \
47         --with-logging=both \
48         --with-logfac=LOG_AUTH \
49         --with-logpath=/var/log/sudo.log \
50         --with-message=full \
51         --with-ignore-dot \
52         --with-env-editor \
53         --with-insults \
54         --with-all-insults \
55         --with-classic-insults \
56         --with-csops-insults \
57         --with-hal-insults \
58         --with-goons-insults \
59         --with-secure-path="/bin:/sbin:/usr/bin:/usr/sbin" \
60         --with-loglen=320 \
61
62 make CFLAGS="$RPM_OPT_FLAGS"
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/pam.d,/var/{log,run/sudo}}
67
68 make install \
69         prefix=$RPM_BUILD_ROOT%{_prefix} \
70         visudodir=$RPM_BUILD_ROOT%{_sbindir} \
71         sysconfdir=$RPM_BUILD_ROOT%{_sysconfdir} \
72         install_uid=`id -u` \
73         install_gid=`id -g` \
74         sudoers_uid=`id -u` \
75         sudoers_gid=`id -g`
76
77 install %{SOURCE1}  $RPM_BUILD_ROOT%{_sysconfdir}/pam.d/sudo
78 touch $RPM_BUILD_ROOT/var/log/sudo.log
79
80 gzip -9nf $RPM_BUILD_ROOT%{_mandir}/man{5,8}/* \
81         BUGS CHANGES HISTORY README TODO TROUBLESHOOTING
82
83 chmod -R +r $RPM_BUILD_ROOT%{_prefix}
84
85 %clean
86 rm -rf $RPM_BUILD_ROOT
87
88 %files
89 %defattr(644,root,root,755)
90 %doc *.gz sample.sudoers
91 %attr(0400,root,root) %verify(not md5 size mtime) %config(noreplace) %{_sysconfdir}/sudoers
92 %attr(0600,root,root) %config %{_sysconfdir}/pam.d/sudo
93 %attr(4555,root,root) %{_bindir}/sudo
94 %attr(0555,root,root) %{_sbindir}/visudo
95 %{_mandir}/man*/*
96 %attr(0600,root,root) %ghost /var/log/sudo.log
97 %attr(0700,root,root) %dir /var/run/sudo
This page took 0.058386 seconds and 3 git commands to generate.