]> git.pld-linux.org Git - packages/subversion.git/blob - subversion.spec
disable more features with net_client_only
[packages/subversion.git] / subversion.spec
1 # Conditional build:
2 %bcond_with     net_client_only         # build only net client
3 %bcond_without  swig                    # disable bindings generation with Swig
4 %bcond_without  python                  # build without Python bindings (broken)
5 %bcond_without  csvn                    # build Python csvn bindings
6 %bcond_without  perl                    # build without Perl bindings
7 %bcond_without  ruby                    # build without Ruby bindings
8 %bcond_without  apache                  # build without Apache support (webdav, etc)
9 %bcond_without  javahl                  # build without javahl support (Java high-level bindings)
10 %bcond_without  tests                   # don't perform "make check"
11 %bcond_without  kwallet                 # build without kde4 wallet support
12 %bcond_without  kde                     # build without kde4 support (alias for kwallet)
13 %bcond_without  gnome                   # build without gnome keyring support
14 %bcond_without  db                      # disable Subversion Berkeley DB based filesystem library
15 %bcond_with     db6                     # allow BDB6 (not tested by upstream, released on AGPL)
16
17 # for AC: --without csvn,gnome,javahl,kde,ruby
18
19 %if %{with net_client_only}
20 %undefine       with_apache
21 %undefine       with_db
22 %undefine       with_swig
23 %undefine       with_javahl
24 %undefine       with_csvn
25 %undefine       with_gnome
26 %undefine       with_kde
27 %endif
28
29 %if %{without swig}
30 %undefine       with_perl
31 %undefine       with_python
32 %undefine       with_ruby
33 %endif
34
35 %if %{without kde}
36 %undefine       with_kwallet
37 %endif
38
39 %if %{without python} && %{without perl} && %{without ruby}
40 %undefine       with_swig
41 %endif
42
43 %define apxs    /usr/sbin/apxs
44 %define pdir    SVN
45 %define pnam    _Core
46
47 %{?with_perl:%include   /usr/lib/rpm/macros.perl}
48 Summary:        A Concurrent Versioning system similar to but better than CVS
49 Summary(pl.UTF-8):      System kontroli wersji podobny, ale lepszy, niż CVS
50 Summary(pt_BR.UTF-8):   Sistema de versionamento concorrente
51 Name:           subversion
52 Version:        1.8.8
53 Release:        1
54 License:        Apache v2.0
55 Group:          Development/Version Control
56 Source0:        http://www.apache.org/dist/subversion/%{name}-%{version}.tar.bz2
57 # Source0-md5:  db04a587c68e38da6d0e342e6508f514
58 Source1:        %{name}-dav_svn.conf
59 Source2:        %{name}-authz_svn.conf
60 Source3:        %{name}-svnserve.init
61 Source4:        %{name}-svnserve.sysconfig
62 # current subversion tarball has correct *.swg files
63 # but after regeneration these are broken again, so
64 # we still need this script
65 Source5:        %{name}-convert-typemaps-to-ifdef.py
66 Patch0:         %{name}-home_etc.patch
67 Patch1:         %{name}-DESTDIR.patch
68 Patch2:         %{name}-ruby-datadir-path.patch
69 Patch3:         %{name}-tests.patch
70 URL:            http://subversion.apache.org/
71 %{?with_apache:BuildRequires:   apache-devel >= 2.2.0-8}
72 BuildRequires:  apr-devel >= 1:1.0.0
73 BuildRequires:  apr-util-devel >= 1:1.2.8-3
74 BuildRequires:  autoconf >= 2.59
75 BuildRequires:  automake
76 BuildRequires:  bison
77 BuildRequires:  cyrus-sasl-devel
78 %if %{with kwallet} || %{with gnome}
79 BuildRequires:  dbus-devel
80 %endif
81 BuildRequires:  db-devel >= 4.1.25
82 BuildRequires:  expat-devel
83 BuildRequires:  gettext-devel
84 %{?with_kwallet:BuildRequires:  kde4-kdelibs-devel}
85 %{?with_gnome:BuildRequires:    libgnome-keyring-devel}
86 BuildRequires:  libmagic-devel
87 BuildRequires:  libtool >= 1.4-9
88 BuildRequires:  pkgconfig
89 %{?with_csvn:BuildRequires:     python-ctypesgen}
90 BuildRequires:  rpm-pythonprov
91 BuildRequires:  rpmbuild(macros) >= 1.656
92 BuildRequires:  sed >= 4.0
93 BuildRequires:  serf-devel >= 1.2.1
94 BuildRequires:  sqlite3-devel >= 3.6.18
95 BuildRequires:  texinfo
96 BuildRequires:  which
97 %if %{with javahl}
98 BuildRequires:  jdk >= 1.5
99 BuildRequires:  libstdc++-devel
100 %endif
101 %if %{with perl}
102 BuildRequires:  perl-devel >= 1:5.8.0
103 BuildRequires:  rpm-perlprov >= 4.1-13
104 BuildRequires:  swig-perl >= 1.3.24
105 %endif
106 %if %{with python}
107 BuildRequires:  python-devel >= 1:2.4
108 BuildRequires:  swig-python >= 1.3.24
109 %endif
110 %if %{with ruby}
111 BuildRequires:  rpm-rubyprov
112 BuildRequires:  ruby-devel >= 1:1.8.2
113 BuildRequires:  ruby-irb
114 BuildRequires:  ruby-rubygems
115 BuildRequires:  swig-ruby >= 1.3.24
116 %endif
117 Requires:       %{name}-libs = %{version}-%{release}
118 %requires_ge    sqlite3
119 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
120
121 %define         _libexecdir             %{_libdir}/svn
122 %define         apacheconfdir   %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
123 %define         apachelibdir    %(%{apxs} -q LIBEXECDIR 2>/dev/null)
124
125 %define         skip_post_check_so      libsvn_swig_py-1.so.* libsvn_swig_perl-1.so.*
126
127 %description
128 The goal of the Subversion project is to build a version control
129 system that is a compelling replacement for CVS in the open source
130 community.
131
132 Our goals are:
133 - All current CVS features.
134 - Directories, renames, and file meta-data are versioned.
135 - Symbolic links, etc, are supported
136 - Commits are truly atomic.
137 - Branching and tagging are cheap (constant time) operations
138 - Repeated merges are handled gracefully
139 - Support for plug-in client side diff programs
140 - Natively client/server
141 - Client/server protocol sends diffs in both directions
142 - Costs are proportional to change size, not project size
143 - Internationalization
144 - Progressive multi-lingual support
145
146 %description -l pl.UTF-8
147 Celem projektu Subversion jest stworzenie systemu kontroli wersji jako
148 zamiennika dla CVS.
149
150 Cele projektu to:
151 - Wszystkie aktualne możliwości CVS.
152 - Katalogi, zmiany nazw oraz metadane plików są wersjonowane.
153 - Obsługa dowiązań symbolicznych itp.
154 - Commity są w pełni atomowe.
155 - Branchowanie oraz tagowanie są tanimi (stałymi w czasie) operacjami.
156 - Dobra obsługa powtarzanego łączenia (merge).
157 - Obsługa wtyczek diff po stronie klienta.
158 - Natywny klient/serwer.
159 - Klient/Serwer przesyłają diffy w obu kierunkach.
160 - Koszty proporcjonalne do rozmiaru zmiany, a nie rozmiaru projektu.
161 - Internacjonalizacja.
162 - Postępujące wsparcie dla wielu języków.
163
164 %description -l pt_BR.UTF-8
165 O objetivo do projeto Subversion é construir um sistema de controle de
166 versões que seja um substituto para o CVS (Concurrent Versioning
167 System) na comunidade opensource, fornecendo grandes melhorias.
168
169 %package libs
170 Summary:        Subversion libraries and modules
171 Summary(pl.UTF-8):      Biblioteka subversion oraz ładowalne moduły
172 Group:          Libraries
173 Requires:       serf >= 1.2.1
174 Obsoletes:      libsubversion0
175
176 %description libs
177 Subversion libraries and modules.
178
179 %description libs -l pl.UTF-8
180 Biblioteka subversion oraz ładowalne moduły.
181
182 %package devel
183 Summary:        Header files and develpment documentation for subversion
184 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumetacja do subversion
185 Summary(pt_BR.UTF-8):   Arquivos de desenvolvimento para o Subversion
186 Group:          Development/Libraries
187 Requires:       %{name}-libs = %{version}-%{release}
188 Requires:       apr-util-devel >= 1:1.0.0
189 Requires:       serf-devel >= 1.2.1
190 Obsoletes:      libsubversion0-devel
191
192 %description devel
193 Header files and develpment documentation for subversion.
194
195 %description devel -l pl.UTF-8
196 Pliki nagłówkowe i dokumetacja do subversion.
197
198 %description devel -l pt_BR.UTF-8
199 Este pacote provê os arquivos necessários para desenvolvedores
200 interagirem com o Subversion.
201
202 %package static
203 Summary:        Static subversion library
204 Summary(pl.UTF-8):      Biblioteka statyczna subversion
205 Summary(pt_BR.UTF-8):   Sistema de versionamento concorrente
206 Group:          Development/Libraries
207 Requires:       %{name}-devel = %{version}
208 Obsoletes:      libsubversion0-static-devel
209
210 %description static
211 Static subversion library.
212
213 %description static -l pl.UTF-8
214 Biblioteka statyczna subversion.
215
216 %description static -l pt_BR.UTF-8
217 Este pacote provê um cliente estático do subversion.
218
219 %package svnserve
220 Summary:        Subversion svnserve
221 Summary(pl.UTF-8):      Subversion svnserve
222 Group:          Networking/Daemons
223 Requires(post,preun):   /sbin/chkconfig
224 Requires(postun):       /usr/sbin/groupdel
225 Requires(postun):       /usr/sbin/userdel
226 Requires(pre):  /bin/id
227 Requires(pre):  /usr/bin/getgid
228 Requires(pre):  /usr/lib/rpm/user_group.sh
229 Requires(pre):  /usr/sbin/groupadd
230 Requires(pre):  /usr/sbin/useradd
231 Requires(pre):  /usr/sbin/usermod
232 Requires:       %{name} = %{version}-%{release}
233 Requires:       rc-scripts
234 Provides:       group(svn)
235 Provides:       user(svn)
236
237 %description svnserve
238 Subversion svnserve server.
239
240 %description svnserve -l pl.UTF-8
241 Serwer subversion svnserve.
242
243 %package tools
244 Summary:        Subversion tools and scripts
245 Summary(pl.UTF-8):      Narzędzia oraz skrypty dla subversion
246 Summary(pt_BR.UTF-8):   Módulos python para acessar os recursos do Subversion
247 Group:          Applications
248 Requires:       %{name} = %{version}-%{release}
249 Requires:       python
250 Requires:       python-subversion = %{version}
251
252 %description tools
253 Subversion tools and scripts.
254
255 %description tools -l pl.UTF-8
256 Narzędzia oraz skrypty dla subversion.
257
258 %package -n bash-completion-subversion
259 Summary:        bash completion for subversion
260 Summary(pl.UTF-8):      Dopełnienia basha dla subversion
261 Group:          Applications/Shells
262 Requires:       %{name} = %{version}-%{release}
263 Requires:       bash-completion
264 Conflicts:      %{name}-tools <= 1.1.0-0.rc6.1
265 %if "%{_rpmversion}" >= "5"
266 BuildArch:      noarch
267 %endif
268
269 %description -n bash-completion-subversion
270 Bash completion for subversion.
271
272 %description -n bash-completion-subversion -l pl.UTF-8
273 Dopełnienia basha dla subversion.
274
275 %package -n java-subversion
276 Summary:        Subversion Java bindings
277 Summary(pl.UTF-8):      Dowiązania do Subversion dla Javy
278 Group:          Development/Languages/Java
279 Requires:       %{name}-libs = %{version}-%{release}
280
281 %description -n java-subversion
282 This is a set of Java classes which provide the functionality of
283 subversion-libs, the Subversion libraries. It is useful if you want
284 to, for example, write a Java class that manipulates a Subversion
285 repository or working copy. See the 'subversion' package for more
286 information.
287
288 %description -n java-subversion -l pl.UTF-8
289 Ten pakiet zawiera zestaw klas Javy udostępniających funkcjonalność
290 subversion-libs, czyli bibliotek Subversion. Jest przydatny przy
291 pisaniu klas Javy np. modyfikujących repozytorium Subversion lub kopię
292 roboczą. Więcej informacji w pakiecie subversion.
293
294 %package -n python-subversion
295 Summary:        Subversion Python bindings
296 Summary(pl.UTF-8):      Dowiązania do Subversion dla Pythona
297 Summary(pt_BR.UTF-8):   Módulos Python para acessar os recursos do Subversion
298 Group:          Development/Languages/Python
299 Requires:       %{name}-libs = %{version}-%{release}
300 Requires:       python
301 Obsoletes:      subversion-python
302
303 %description -n python-subversion
304 Subversion Python bindings.
305
306 %description -n python-subversion -l pl.UTF-8
307 Dowiązania do Subversion dla Pythona.
308
309 %description -n python-subversion -l pt_BR.UTF-8
310 Módulos Python para acessar os recursos do Subversion.
311
312 %package -n python-csvn
313 Summary:        CTypes Subversion Python bindings
314 Summary(pl.UTF-8):      Dowiązania do Subversion dla Pythona
315 Summary(pt_BR.UTF-8):   Módulos Python para acessar os recursos do Subversion
316 Group:          Development/Languages/Python
317 Requires:       %{name}-libs = %{version}-%{release}
318 Requires:       python
319
320 %description -n python-csvn
321 Subversion CTypes Python bindings.
322
323 %description -n python-csvn -l pl.UTF-8
324 Dowiązania do Subversion dla Pythona używające CTypes.
325
326 %description -n python-csvn -l pt_BR.UTF-8
327 Módulos Python para acessar os recursos do Subversion.
328
329 %package -n perl-subversion
330 Summary:        Subversion Perl bindings
331 Summary(pl.UTF-8):      Dowiązania do Subversion dla Perla
332 Summary(pt_BR.UTF-8):   Módulos Perl para acessar os recursos do Subversion
333 Group:          Development/Languages/Perl
334 Requires:       %{name}-libs = %{version}-%{release}
335 Obsoletes:      subversion-perl
336
337 %description -n perl-subversion
338 Subversion Perl bindings.
339
340 %description -n perl-subversion -l pl.UTF-8
341 Dowiązania do Subversion dla Perla.
342
343 %description -n perl-subversion -l pt_BR.UTF-8
344 Módulos Perl para acessar os recursos do Subversion.
345
346 %package -n ruby-subversion
347 Summary:        Subversion Ruby bindings
348 Summary(pl.UTF-8):      Dowiązania do Subversion dla języka Ruby
349 Summary(pt_BR.UTF-8):   Módulos Ruby para acessar os recursos do Subversion
350 Group:          Development/Languages
351 Requires:       %{name}-libs = %{version}-%{release}
352 Obsoletes:      subversion-ruby
353
354 %description -n ruby-subversion
355 Subversion Ruby bindings.
356
357 %description -n ruby-subversion -l pl.UTF-8
358 Dowiązania do Subversion dla języka Ruby.
359
360 %description -n ruby-subversion -l pt_BR.UTF-8
361 Módulos Ruby para acessar os recursos do Subversion.
362
363 %package -n apache-mod_dav_svn
364 Summary:        Apache module: Subversion Server
365 Summary(pl.UTF-8):      Moduł Apache'a: serwer Subversion
366 Group:          Networking/Daemons
367 Requires:       %{name} = %{version}-%{release}
368 Requires:       apache(modules-api) = %apache_modules_api
369 Requires:       apache-mod_dav
370
371 %description -n apache-mod_dav_svn
372 Apache module: Subversion Server.
373
374 %description -n apache-mod_dav_svn -l pl.UTF-8
375 Moduł Apache'a: serwer Subversion.
376
377 %package -n apache-mod_authz_svn
378 Summary:        Apache module: Subversion Server - path-based authorization
379 Summary(pl.UTF-8):      Moduł Apache'a: autoryzacja na podstawie ścieżki dla serwera Subversion
380 Group:          Networking/Daemons
381 Requires:       %{name}-libs = %{version}-%{release}
382 Requires:       apache(modules-api) = %apache_modules_api
383 Requires:       apache-mod_dav_svn = %{version}-%{release}
384
385 %description -n apache-mod_authz_svn
386 Apache module: Subversion Server - path-based authorization.
387
388 %description -n apache-mod_authz_svn -l pl.UTF-8
389 Moduł Apache'a: autoryzacja na podstawie ścieżki dla serwera
390 Subversion.
391
392 %package -n apache-mod_dontdothat_svn
393 Summary:        Apache module: Allows you to block specific svn requests
394 Summary(pl.UTF-8):      Moduł Apache'a pozwalający na blokowanie pewnych zapytań svn
395 Group:          Networking/Daemons
396 Requires:       %{name}-libs = %{version}-%{release}
397 Requires:       apache(modules-api) = %apache_modules_api
398 Requires:       apache-mod_dav_svn = %{version}-%{release}
399
400 %description -n apache-mod_dontdothat_svn
401 Apache module: Allows you to block specific svn requests.
402
403 %description -n apache-mod_dontdothat_svn -l pl.UTF-8
404 Moduł Apache'a pozwalający na blokowanie pewnych zapytań svn.
405
406 %package -n gnome-keyring-subversion
407 Summary:        GNOME Keyring authentication provider for Subversion
408 Summary(pl.UTF-8):      Moduł uwierzytelniający GNOME Keyring dla Subversion
409 Group:          X11/Applications
410 Requires:       %{name}-libs = %{version}-%{release}
411
412 %description -n gnome-keyring-subversion
413 Authentication provider module for Subversion which allows SVN client
414 to authenticate using GNOME Keyring.
415
416 %description -n gnome-keyring-subversion -l pl.UTF-8
417 Moduł uwierzytelniający dla Subversion pozwalający klientom SVN
418 uwierzytelniać się przy użyciu mechanizmu GNOME Keyring.
419
420 %package -n kde4-kwallet-subversion
421 Summary:        KDE Wallet authentication provider for Subversion
422 Summary(pl.UTF-8):      Moduł uwierzytelniający dla Subversion wykorzystujący Portfel KDE
423 Group:          X11/Applications
424 Requires:       %{name}-libs = %{version}-%{release}
425
426 %description -n kde4-kwallet-subversion
427 Authentication provider module for Subversion which allows SVN client
428 to authenticate using KDE Wallet.
429
430 %description -n kde4-kwallet-subversion -l pl.UTF-8
431 Moduł uwierzytelniający dla Subversion pozwalający klientom SVN
432 uwierzytelniać się przy użyciu Portfela KDE.
433
434 %prep
435 %setup -q
436 %patch0 -p0
437 %patch1 -p1
438 %patch2 -p0
439 %patch3 -p1
440
441 sed -i -e 's#serf_prefix/lib#serf_prefix/%{_lib}#g' build/ac-macros/serf.m4
442
443 %build
444 # disabled regeneration - subversion 1.6.13 is not ready for swig 2.0.x
445 #%{__rm} subversion/bindings/swig/proxy/*.swg
446 #cd subversion/bindings/swig && python "%{SOURCE5}" && cd ../../..
447 chmod +x ./autogen.sh && ./autogen.sh
448 %{__libtoolize}
449 %configure \
450         --with-editor=vi \
451         --with-zlib=%{_libdir} \
452         --disable-runtime-module-search \
453         --disable-mod-activation \
454 %if %{with db}
455         --with-berkeley-db="db.h:%{_includedir}:%{_libdir}:db" \
456         %{?with_db6:--enable-bdb6} \
457 %else
458         --without-berkeley-db \
459 %endif
460 %if %{with apache}
461         --with-apache-libexecdir="$(%{_sbindir}/apxs -q LIBEXECDIR)" \
462         --with-apxs=%{_sbindir}/apxs \
463 %else
464         --without-apxs \
465 %endif
466 %if %{without swig}
467         --without-swig \
468 %endif
469 %if %{with ruby}
470         svn_cv_ruby_sitedir_libsuffix="" \
471         svn_cv_ruby_sitedir_archsuffix="" \
472         --with-ruby-sitedir=%{ruby_vendorarchdir} \
473 %else
474         ac_cv_path_RUBY=none \
475 %endif
476 %if %{with csvn}
477         --with-ctypesgen=%{_bindir}/ctypesgen.py \
478 %endif
479 %if %{with javahl}
480         --enable-javahl \
481         --with-jdk="%{java_home}" \
482         --without-jikes \
483 %else
484         --disable-javahl \
485 %endif
486         --with-serf=%{_prefix} \
487         --with-apr=%{_bindir}/apr-1-config \
488         --with-apr-util=%{_bindir}/apu-1-config \
489 %if %{with kwallet}
490         --with-kwallet \
491 %endif
492 %if %{with gnome}
493         --with-gnome-keyring
494 %endif
495
496 %{__make} -j1
497
498 %{__make} tools
499
500 %if %{with csvn}
501 # Python ctypes bindings
502 %{__make} ctypes-python
503 %endif
504 %if %{with python}
505 # Python swig bindings
506 %{__make} swig-py \
507         swig_pydir=%{py_sitedir}/libsvn \
508         swig_pydir_extra=%{py_sitedir}/svn
509 %endif
510 %if %{with perl}
511 # Perl swig bindings
512 %{__make} -j1 swig-pl-lib
513 cd subversion/bindings/swig/perl/native
514 %{__perl} Makefile.PL INSTALLDIRS=vendor
515 %{__make} -j1
516 cd -
517 %endif
518 %if %{with javahl}
519 %{__make} -j1 javahl \
520         javahl_javadir="%{_javadir}"
521 %endif
522 # ruby
523 %if %{with ruby}
524 %{__make} swig-rb
525 %endif
526
527 %if %{with tests}
528 %{__make} -j1 check
529 %if %{with csvn}
530 %{__make} -j1 check-ctypes-python
531 %endif
532 %if %{with python}
533 %{__make} -j1 check-swig-py
534 %endif
535 %if %{with perl}
536 %{__make} -j1 check-swig-pl
537 %endif
538 %if %{with ruby}
539 # disabled, see https://bugs.launchpad.net/pld-linux/+bug/734340
540 #%{__make} check-swig-rb
541 %endif
542 %endif
543
544 %install
545 rm -rf $RPM_BUILD_ROOT
546 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,bash_completion.d} \
547         $RPM_BUILD_ROOT{%{apacheconfdir},%{apachelibdir},%{_infodir}} \
548         $RPM_BUILD_ROOT%{_examplesdir}/{%{name}-%{version},python-%{name}-%{version}} \
549         $RPM_BUILD_ROOT%{_sysconfdir}/%{name} \
550         $RPM_BUILD_ROOT/home/services/subversion{,/repos}
551
552 %{__make} install -j1 \
553         toolsdir=%{_bindir} \
554         DESTDIR=$RPM_BUILD_ROOT \
555         APACHE_LIBEXECDIR="$(%{_sbindir}/apxs -q LIBEXECDIR)" \
556 %if %{with javahl}
557         install-javahl \
558         javahl_javadir="%{_javadir}" \
559 %endif
560 %if %{with python}
561         install-swig-py \
562         swig_pydir=%{py_sitedir}/libsvn \
563         swig_pydir_extra=%{py_sitedir}/svn \
564 %endif
565 %if %{with csvn}
566         install-ctypes-python \
567 %endif
568         install-tools
569
570 %if %{with ruby}
571 %{__make} install -j1 \
572         DESTDIR=$RPM_BUILD_ROOT \
573         install-swig-rb install-swig-rb-doc \
574
575 # not our package
576 %{__rm} -r $RPM_BUILD_ROOT%{ruby_ridir}/OptionParser
577 %{__rm} -r $RPM_BUILD_ROOT%{ruby_ridir}/Time
578 %{__rm} $RPM_BUILD_ROOT%{ruby_ridir}/cache.ri
579 %{__rm} $RPM_BUILD_ROOT%{ruby_ridir}/created.rid
580 %endif
581
582 %if %{with perl}
583 %{__make} install-swig-pl-lib \
584         DESTDIR=$RPM_BUILD_ROOT
585 %{__make} -C subversion/bindings/swig/perl/native install \
586         DESTDIR=$RPM_BUILD_ROOT \
587         PREFIX=$RPM_BUILD_ROOT%{_prefix} \
588         LIBDIR=$RPM_BUILD_ROOT%{_libdir}
589 %endif
590
591 %if %{with apache}
592 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{apacheconfdir}/65_mod_dav_svn.conf
593 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{apacheconfdir}/66_mod_authz_svn.conf
594 cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/svnserve
595 install -p %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/svnserve
596 %endif
597
598 %if %{without net_client_only}
599 install -p tools/backup/hot-backup.py $RPM_BUILD_ROOT%{_bindir}/svn-hot-backup
600 %endif
601
602 # rename not to conflict with standard packages. (are these needed at all?)
603 mv $RPM_BUILD_ROOT%{_bindir}/{,svn}diff
604 mv $RPM_BUILD_ROOT%{_bindir}/{,svn}diff3
605 mv $RPM_BUILD_ROOT%{_bindir}/{,svn}diff4
606
607 %if %{with python} || %{with csvn}
608 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
609 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
610 %py_postclean
611 %endif
612 %if %{with python}
613 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/libsvn/*.la
614 # .a created on ac only
615 %{__rm} -f $RPM_BUILD_ROOT%{py_sitedir}/libsvn/*.a
616 cp -p tools/examples/*.py $RPM_BUILD_ROOT%{_examplesdir}/python-%{name}-%{version}
617 %endif
618
619 cp -p tools/client-side/bash_completion $RPM_BUILD_ROOT/etc/bash_completion.d/%{name}
620 cp -p tools/examples/*.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
621
622 %if %{with javahl}
623 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libsvnjavahl*.{la,a}
624 %endif
625 %if %{with swig}
626 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libsvn_swig*.{la,a}
627 %if %{with ruby}
628 %{__rm} $RPM_BUILD_ROOT%{ruby_vendorarchdir}/svn/ext/*.la
629 %endif
630 %endif
631 %if %{with gnome} || %{with kwallet}
632 # dlopened by soname (libsvn_auth_*-1.so.0)
633 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libsvn_auth_*-1.{so,la,a}
634 %endif
635
636 %find_lang %{name}
637
638 %clean
639 rm -rf $RPM_BUILD_ROOT
640
641 %pre svnserve
642 %groupadd -g 86 svn
643 %useradd -u 180 -d /home/services/subversion -c "Subversion svnserve" -g svn svn
644
645 %post   libs -p /sbin/ldconfig
646 %postun libs -p /sbin/ldconfig
647
648 %post   devel -p /sbin/postshell
649 -/usr/sbin/fix-info-dir -c %{_infodir}
650
651 %postun devel -p /sbin/postshell
652 -/usr/sbin/fix-info-dir -c %{_infodir}
653
654 %post   -n java-subversion -p /sbin/ldconfig
655 %postun -n java-subversion -p /sbin/ldconfig
656
657 %post   -n perl-subversion -p /sbin/ldconfig
658 %postun -n perl-subversion -p /sbin/ldconfig
659
660 %post   -n python-subversion -p /sbin/ldconfig
661 %postun -n python-subversion -p /sbin/ldconfig
662
663 %post   -n ruby-subversion -p /sbin/ldconfig
664 %postun -n ruby-subversion -p /sbin/ldconfig
665
666 %post   -n gnome-keyring-subversion -p /sbin/ldconfig
667 %postun -n gnome-keyring-subversion -p /sbin/ldconfig
668
669 %post   -n kde4-kwallet-subversion -p /sbin/ldconfig
670 %postun -n kde4-kwallet-subversion -p /sbin/ldconfig
671
672 %post svnserve
673 /sbin/chkconfig --add svnserve
674 %service svnserve restart "svnserve daemon"
675
676 %preun svnserve
677 if [ "$1" = "0" ]; then
678         %service svnserve stop
679         /sbin/chkconfig --del svnserve
680 fi
681
682 %postun svnserve
683 if [ "$1" = "0" ]; then
684         %userremove svn
685         %groupremove svn
686 fi
687
688 %post -n apache-mod_dav_svn
689 %service -q httpd restart
690
691 %postun -n apache-mod_dav_svn
692 if [ "$1" = "0" ]; then
693         %service -q httpd restart
694 fi
695
696 %post -n apache-mod_authz_svn
697 %service -q httpd restart
698
699 %postun -n apache-mod_authz_svn
700 if [ "$1" = "0" ]; then
701         %service -q httpd restart
702 fi
703
704 %post -n apache-mod_dontdothat_svn
705 %service -q httpd restart
706
707 %postun -n apache-mod_dontdothat_svn
708 if [ "$1" = "0" ]; then
709         %service -q httpd restart
710 fi
711
712 %files
713 %defattr(644,root,root,755)
714 %doc BUGS CHANGES INSTALL README
715 %doc doc/*/*.html
716 %doc tools/hook-scripts/*.{pl,py,example}
717 %doc tools/hook-scripts/mailer/*.{py,example}
718 %doc tools/xslt/*
719 %attr(755,root,root) %{_bindir}/svn
720 %attr(755,root,root) %{_bindir}/svnadmin
721 %attr(755,root,root) %{_bindir}/svndumpfilter
722 %attr(755,root,root) %{_bindir}/svnlook
723 %attr(755,root,root) %{_bindir}/svnmucc
724 %attr(755,root,root) %{_bindir}/svnrdump
725 %attr(755,root,root) %{_bindir}/svnsync
726 %attr(755,root,root) %{_bindir}/svnversion
727 %{_mandir}/man1/svn.1*
728 %{_mandir}/man1/svnadmin.1*
729 %{_mandir}/man1/svndumpfilter.1*
730 %{_mandir}/man1/svnrdump.1*
731 %{_mandir}/man1/svnlook.1*
732 %{_mandir}/man1/svnmucc.1*
733 %{_mandir}/man1/svnsync.1*
734 %{_mandir}/man1/svnversion.1*
735
736 %files libs -f %{name}.lang
737 %defattr(644,root,root,755)
738 %dir %{_sysconfdir}/%{name}
739 %attr(755,root,root) %{_libdir}/libsvn_client-1.so.*.*.*
740 %attr(755,root,root) %ghost %{_libdir}/libsvn_client-1.so.0
741 %attr(755,root,root) %{_libdir}/libsvn_delta-1.so.*.*.*
742 %attr(755,root,root) %ghost %{_libdir}/libsvn_delta-1.so.0
743 %attr(755,root,root) %{_libdir}/libsvn_diff-1.so.*.*.*
744 %attr(755,root,root) %ghost %{_libdir}/libsvn_diff-1.so.0
745 %attr(755,root,root) %{_libdir}/libsvn_fs-1.so.*.*.*
746 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs-1.so.0
747 %if %{without net_client_only}
748 %attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so.*.*.*
749 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_base-1.so.0
750 %endif
751 %attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so.*.*.*
752 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_fs-1.so.0
753 %attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so.*.*.*
754 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_util-1.so.0
755 %attr(755,root,root) %{_libdir}/libsvn_ra-1.so.*.*.*
756 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra-1.so.0
757 %attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so.*.*.*
758 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_local-1.so.0
759 %attr(755,root,root) %{_libdir}/libsvn_ra_serf-1.so.*.*.*
760 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_serf-1.so.0
761 %attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so.*.*.*
762 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_svn-1.so.0
763 %attr(755,root,root) %{_libdir}/libsvn_repos-1.so.*.*.*
764 %attr(755,root,root) %ghost %{_libdir}/libsvn_repos-1.so.0
765 %attr(755,root,root) %{_libdir}/libsvn_subr-1.so.*.*.*
766 %attr(755,root,root) %ghost %{_libdir}/libsvn_subr-1.so.0
767 %attr(755,root,root) %{_libdir}/libsvn_wc-1.so.*.*.*
768 %attr(755,root,root) %ghost %{_libdir}/libsvn_wc-1.so.0
769
770 %files devel
771 %defattr(644,root,root,755)
772 %attr(755,root,root) %{_libdir}/libsvn_client-1.so
773 %attr(755,root,root) %{_libdir}/libsvn_delta-1.so
774 %attr(755,root,root) %{_libdir}/libsvn_diff-1.so
775 %attr(755,root,root) %{_libdir}/libsvn_fs-1.so
776 %if %{without net_client_only}
777 %attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so
778 %endif
779 %attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so
780 %attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so
781 %attr(755,root,root) %{_libdir}/libsvn_ra-1.so
782 %attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so
783 %attr(755,root,root) %{_libdir}/libsvn_ra_serf-1.so
784 %attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so
785 %attr(755,root,root) %{_libdir}/libsvn_repos-1.so
786 %attr(755,root,root) %{_libdir}/libsvn_subr-1.so
787 %attr(755,root,root) %{_libdir}/libsvn_wc-1.so
788 %{_libdir}/libsvn_client-1.la
789 %{_libdir}/libsvn_delta-1.la
790 %{_libdir}/libsvn_diff-1.la
791 %{_libdir}/libsvn_fs-1.la
792 %if %{without net_client_only}
793 %{_libdir}/libsvn_fs_base-1.la
794 %endif
795 %{_libdir}/libsvn_fs_fs-1.la
796 %{_libdir}/libsvn_fs_util-1.la
797 %{_libdir}/libsvn_ra-1.la
798 %{_libdir}/libsvn_ra_local-1.la
799 %{_libdir}/libsvn_ra_serf-1.la
800 %{_libdir}/libsvn_ra_svn-1.la
801 %{_libdir}/libsvn_repos-1.la
802 %{_libdir}/libsvn_subr-1.la
803 %{_libdir}/libsvn_wc-1.la
804 %{_includedir}/%{name}-1
805 %{_examplesdir}/%{name}-%{version}
806
807 %files static
808 %defattr(644,root,root,755)
809 %{_libdir}/libsvn_client-1.a
810 %{_libdir}/libsvn_delta-1.a
811 %{_libdir}/libsvn_diff-1.a
812 %{_libdir}/libsvn_fs-1.a
813 %if %{without net_client_only}
814 %{_libdir}/libsvn_fs_base-1.a
815 %endif
816 %{_libdir}/libsvn_fs_fs-1.a
817 %{_libdir}/libsvn_fs_util-1.a
818 %{_libdir}/libsvn_ra-1.a
819 %{_libdir}/libsvn_ra_local-1.a
820 %{_libdir}/libsvn_ra_serf-1.a
821 %{_libdir}/libsvn_ra_svn-1.a
822 %{_libdir}/libsvn_repos-1.a
823 %{_libdir}/libsvn_subr-1.a
824 %{_libdir}/libsvn_wc-1.a
825
826 %if %{with gnome}
827 %files -n gnome-keyring-subversion
828 %defattr(644,root,root,755)
829 %attr(755,root,root) %{_libdir}/libsvn_auth_gnome_keyring-1.so.*.*.*
830 %attr(755,root,root) %ghost %{_libdir}/libsvn_auth_gnome_keyring-1.so.0
831 %endif
832
833 %if %{with kwallet}
834 %files -n kde4-kwallet-subversion
835 %defattr(644,root,root,755)
836 %attr(755,root,root) %{_libdir}/libsvn_auth_kwallet-1.so.*.*.*
837 %attr(755,root,root) %ghost %{_libdir}/libsvn_auth_kwallet-1.so.0
838 %endif
839
840 %if %{without net_client_only}
841 %files svnserve
842 %defattr(644,root,root,755)
843 %attr(755,root,root) %{_bindir}/svnserve
844 %{_mandir}/man5/svnserve.conf.5*
845 %{_mandir}/man8/svnserve.8*
846 %dir %attr(750,svn,svn) /home/services/subversion
847 %dir %attr(750,svn,svn) /home/services/subversion/repos
848 %if %{with apache}
849 %attr(754,root,root) /etc/rc.d/init.d/svnserve
850 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/svnserve
851 %endif
852
853 %files tools
854 %defattr(644,root,root,755)
855 # tools/backup/hot-backup.py
856 %attr(755,root,root) %{_bindir}/svn-hot-backup
857
858 # tools/diff
859 %attr(755,root,root) %{_bindir}/svndiff
860 %attr(755,root,root) %{_bindir}/svndiff3
861 %attr(755,root,root) %{_bindir}/svndiff4
862
863 # tools/server-side
864 %attr(755,root,root) %{_bindir}/fsfs-stats
865 %attr(755,root,root) %{_bindir}/svn-populate-node-origins-index
866 %attr(755,root,root) %{_bindir}/svn-rep-sharing-stats
867 %attr(755,root,root) %{_bindir}/svnauthz
868 %attr(755,root,root) %{_bindir}/svnauthz-validate
869
870 # tools/client-side
871 %attr(755,root,root) %{_bindir}/svn-bench
872
873 # tools/dev/svnraisetreeconflict
874 %attr(755,root,root) %{_bindir}/svnraisetreeconflict
875
876 # tools/dev/
877 %attr(755,root,root) %{_bindir}/fsfs-access-map
878 %attr(755,root,root) %{_bindir}/fsfs-reorg
879
880 %files -n bash-completion-subversion
881 %defattr(644,root,root,755)
882 /etc/bash_completion.d/%{name}
883
884 %endif # net_client_only
885
886 %if %{with javahl}
887 %files -n java-subversion
888 %defattr(644,root,root,755)
889 %attr(755,root,root) %{_libdir}/libsvnjavahl-1.so.*.*.*
890 %attr(755,root,root) %ghost %{_libdir}/libsvnjavahl-1.so.0
891 %attr(755,root,root) %{_libdir}/libsvnjavahl-1.so
892 %{_javadir}/svn-javahl.jar
893 %endif
894
895 %if %{with python}
896 %files -n python-subversion
897 %defattr(644,root,root,755)
898 %doc tools/backup/*.py
899 %attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so.*.*.*
900 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_py-1.so.0
901 %attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so
902 %dir %{py_sitedir}/libsvn
903 %attr(755,root,root) %{py_sitedir}/libsvn/_*.so
904 %{py_sitedir}/libsvn/*.py[co]
905 %dir %{py_sitedir}/svn
906 %{py_sitedir}/svn/*.py[co]
907 %{_examplesdir}/python-%{name}-%{version}
908 %endif
909
910 %if %{with csvn}
911 %files -n python-csvn
912 %defattr(644,root,root,755)
913 %doc subversion/bindings/ctypes-python/{README,TODO}
914 %doc subversion/bindings/ctypes-python/examples/*.py
915 %dir %{py_sitescriptdir}/csvn
916 %{py_sitescriptdir}/csvn/*.py[co]
917 %dir %{py_sitescriptdir}/csvn/core
918 %{py_sitescriptdir}/csvn/core/*.py[co]
919 %dir %{py_sitescriptdir}/csvn/ext
920 %{py_sitescriptdir}/csvn/ext/*.py[co]
921 %{py_sitescriptdir}/svn_ctypes_python_bindings-0.1-py*.egg-info
922 %endif
923
924 %if %{with perl}
925 %files -n perl-subversion
926 %defattr(644,root,root,755)
927 %attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so.*.*.*
928 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_perl-1.so.0
929 %attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so
930 %{perl_vendorarch}/SVN
931 %dir %{perl_vendorarch}/auto/SVN
932 %dir %{perl_vendorarch}/auto/SVN/*
933 %attr(755,root,root) %{perl_vendorarch}/auto/SVN/*/*.so
934 %{perl_vendorarch}/auto/SVN/*/*.bs
935 %{_mandir}/man3/*.3pm*
936 %endif
937
938 %if %{with ruby}
939 %files -n ruby-subversion
940 %defattr(644,root,root,755)
941 %attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so.*.*.*
942 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_ruby-1.so.0
943 %attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so
944 %dir %{ruby_vendorarchdir}/svn
945 %{ruby_vendorarchdir}/svn/*.rb
946 %dir %{ruby_vendorarchdir}/svn/ext
947 %attr(755,root,root) %{ruby_vendorarchdir}/svn/ext/*.so
948 %{ruby_ridir}/Svn
949 %endif
950
951 %if %{with apache}
952 %files -n apache-mod_dav_svn
953 %defattr(644,root,root,755)
954 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_dav_svn.conf
955 %attr(755,root,root) %{apachelibdir}/mod_dav_svn.so
956
957 %files -n apache-mod_authz_svn
958 %defattr(644,root,root,755)
959 %doc subversion/mod_authz_svn/INSTALL
960 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_authz_svn.conf
961 %attr(755,root,root) %{apachelibdir}/mod_authz_svn.so
962
963 %files -n apache-mod_dontdothat_svn
964 %defattr(644,root,root,755)
965 %doc tools/server-side/mod_dontdothat/README
966 %attr(755,root,root) %{apachelibdir}/mod_dontdothat.so
967 %endif
This page took 0.125763 seconds and 4 git commands to generate.