]> git.pld-linux.org Git - packages/subversion.git/blob - subversion.spec
- rel 1
[packages/subversion.git] / subversion.spec
1 # Conditional build:
2 %bcond_with     net_client_only         # build only net client
3 %bcond_without  swig                    # disable bindings generation with Swig
4 %bcond_without  python                  # build without Python bindings (broken)
5 %bcond_without  csvn                    # build Python csvn bindings
6 %bcond_without  perl                    # build without Perl bindings
7 %bcond_without  ruby                    # build without Ruby bindings
8 %bcond_without  apache                  # build without Apache support (webdav, etc)
9 %bcond_without  javahl                  # build without javahl support (Java high-level bindings)
10 %bcond_without  tests                   # don't perform "make check"
11 %bcond_without  kwallet                 # build without kde4 wallet support
12 %bcond_without  kde                     # build without kde4 support (alias for kwallet)
13 %bcond_without  gnome                   # build without gnome keyring support
14 %bcond_without  db                      # disable Subversion Berkeley DB based filesystem library
15
16 # for AC: --without csvn,gnome,javahl,kde,ruby
17
18 %if %{with net_client_only}
19 %undefine       with_apache
20 %undefine       with_db
21 %undefine       with_swig
22 %undefine       with_javahl
23 %endif
24
25 %if %{without swig}
26 %undefine       with_perl
27 %undefine       with_python
28 %undefine       with_ruby
29 %endif
30
31 %if %{without kde}
32 %undefine       with_kwallet
33 %endif
34
35 %if %{without python} && %{without perl} && %{without ruby}
36 %undefine       with_swig
37 %endif
38
39 %define apxs    /usr/sbin/apxs
40 %define pdir    SVN
41 %define pnam    _Core
42
43 %{?with_perl:%include   /usr/lib/rpm/macros.perl}
44 Summary:        A Concurrent Versioning system similar to but better than CVS
45 Summary(pl.UTF-8):      System kontroli wersji podobny, ale lepszy, niż CVS
46 Summary(pt_BR.UTF-8):   Sistema de versionamento concorrente
47 Name:           subversion
48 Version:        1.8.0
49 Release:        1
50 License:        Apache v2.0
51 Group:          Development/Version Control
52 Source0:        http://www.idg.pl/mirrors/apache/subversion/%{name}-%{version}.tar.bz2
53 # Source0-md5:  f053a9948dfe5c70eff5c00509723214
54 Source1:        %{name}-dav_svn.conf
55 Source2:        %{name}-authz_svn.conf
56 Source3:        %{name}-svnserve.init
57 Source4:        %{name}-svnserve.sysconfig
58 # current subversion tarball has correct *.swg files
59 # but after regeneration these are broken again, so
60 # we still need this script
61 Source5:        %{name}-convert-typemaps-to-ifdef.py
62 Patch0:         %{name}-home_etc.patch
63 Patch1:         %{name}-DESTDIR.patch
64 Patch2:         %{name}-ruby-datadir-path.patch
65 Patch3:         %{name}-tests.patch
66 URL:            http://subversion.apache.org/
67 %{?with_apache:BuildRequires:   apache-devel >= 2.2.0-8}
68 BuildRequires:  apr-devel >= 1:1.0.0
69 BuildRequires:  apr-util-devel >= 1:1.2.8-3
70 BuildRequires:  autoconf >= 2.59
71 BuildRequires:  automake
72 BuildRequires:  bison
73 BuildRequires:  cyrus-sasl-devel
74 %if %{with kwallet} || %{with gnome}
75 BuildRequires:  dbus-devel
76 %endif
77 BuildRequires:  db-devel >= 4.1.25
78 BuildRequires:  expat-devel
79 BuildRequires:  gettext-devel
80 %{?with_kwallet:BuildRequires:  kde4-kdelibs-devel}
81 %{?with_gnome:BuildRequires:    libgnome-keyring-devel}
82 BuildRequires:  libmagic-devel
83 BuildRequires:  libtool >= 1.4-9
84 BuildRequires:  pkgconfig
85 %{?with_csvn:BuildRequires:     python-ctypesgen}
86 BuildRequires:  rpm-pythonprov
87 BuildRequires:  rpmbuild(macros) >= 1.656
88 BuildRequires:  sed >= 4.0
89 BuildRequires:  sqlite3-devel >= 3.6.18
90 BuildRequires:  texinfo
91 BuildRequires:  which
92 BuildRequires:  serf-devel >= 1.2.1
93 %if %{with javahl}
94 BuildRequires:  jdk >= 1.5
95 BuildRequires:  libstdc++-devel
96 %endif
97 %if %{with perl}
98 BuildRequires:  perl-devel >= 1:5.8.0
99 BuildRequires:  rpm-perlprov >= 4.1-13
100 BuildRequires:  swig-perl >= 1.3.24
101 %endif
102 %if %{with python}
103 BuildRequires:  python-devel >= 1:2.4
104 BuildRequires:  swig-python >= 1.3.24
105 %endif
106 %if %{with ruby}
107 BuildRequires:  rpm-rubyprov
108 BuildRequires:  ruby-devel >= 1:1.8.2
109 BuildRequires:  ruby-rubygems
110 BuildRequires:  swig-ruby >= 1.3.24
111 %endif
112 Requires:       %{name}-libs = %{version}-%{release}
113 %requires_ge    sqlite3
114 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
115
116 %define         _libexecdir             %{_libdir}/svn
117 %define         apacheconfdir   %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
118 %define         apachelibdir    %(%{apxs} -q LIBEXECDIR 2>/dev/null)
119
120 %define         skip_post_check_so      libsvn_swig_py-1.so.* libsvn_swig_perl-1.so.*
121
122 %description
123 The goal of the Subversion project is to build a version control
124 system that is a compelling replacement for CVS in the open source
125 community.
126
127 Our goals are:
128 - All current CVS features.
129 - Directories, renames, and file meta-data are versioned.
130 - Symbolic links, etc, are supported
131 - Commits are truly atomic.
132 - Branching and tagging are cheap (constant time) operations
133 - Repeated merges are handled gracefully
134 - Support for plug-in client side diff programs
135 - Natively client/server
136 - Client/server protocol sends diffs in both directions
137 - Costs are proportional to change size, not project size
138 - Internationalization
139 - Progressive multi-lingual support
140
141 %description -l pl.UTF-8
142 Celem projektu Subversion jest stworzenie systemu kontroli wersji jako
143 zamiennika dla CVS.
144
145 Cele projektu to:
146 - Wszystkie aktualne możliwości CVS.
147 - Katalogi, zmiany nazw oraz metadane plików są wersjonowane.
148 - Obsługa dowiązań symbolicznych itp.
149 - Commity są w pełni atomowe.
150 - Branchowanie oraz tagowanie są tanimi (stałymi w czasie) operacjami.
151 - Dobra obsługa powtarzanego łączenia (merge).
152 - Obsługa wtyczek diff po stronie klienta.
153 - Natywny klient/serwer.
154 - Klient/Serwer przesyłają diffy w obu kierunkach.
155 - Koszty proporcjonalne do rozmiaru zmiany, a nie rozmiaru projektu.
156 - Internacjonalizacja.
157 - Postępujące wsparcie dla wielu języków.
158
159 %description -l pt_BR.UTF-8
160 O objetivo do projeto Subversion é construir um sistema de controle de
161 versões que seja um substituto para o CVS (Concurrent Versioning
162 System) na comunidade opensource, fornecendo grandes melhorias.
163
164 %package libs
165 Summary:        Subversion libraries and modules
166 Summary(pl.UTF-8):      Biblioteka subversion oraz ładowalne moduły
167 Group:          Libraries
168 Requires:       serf >= 1.2.1
169 Obsoletes:      libsubversion0
170
171 %description libs
172 Subversion libraries and modules.
173
174 %description libs -l pl.UTF-8
175 Biblioteka subversion oraz ładowalne moduły.
176
177 %package devel
178 Summary:        Header files and develpment documentation for subversion
179 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumetacja do subversion
180 Summary(pt_BR.UTF-8):   Arquivos de desenvolvimento para o Subversion
181 Group:          Development/Libraries
182 Requires:       %{name}-libs = %{version}-%{release}
183 Requires:       apr-util-devel >= 1:1.0.0
184 Obsoletes:      libsubversion0-devel
185
186 %description devel
187 Header files and develpment documentation for subversion.
188
189 %description devel -l pl.UTF-8
190 Pliki nagłówkowe i dokumetacja do subversion.
191
192 %description devel -l pt_BR.UTF-8
193 Este pacote provê os arquivos necessários para desenvolvedores
194 interagirem com o Subversion.
195
196 %package static
197 Summary:        Static subversion library
198 Summary(pl.UTF-8):      Biblioteka statyczna subversion
199 Summary(pt_BR.UTF-8):   Sistema de versionamento concorrente
200 Group:          Development/Libraries
201 Requires:       %{name}-devel = %{version}
202 Obsoletes:      libsubversion0-static-devel
203
204 %description static
205 Static subversion library.
206
207 %description static -l pl.UTF-8
208 Biblioteka statyczna subversion.
209
210 %description static -l pt_BR.UTF-8
211 Este pacote provê um cliente estático do subversion.
212
213 %package svnserve
214 Summary:        Subversion svnserve
215 Summary(pl.UTF-8):      Subversion svnserve
216 Group:          Networking/Daemons
217 Requires(post,preun):   /sbin/chkconfig
218 Requires(postun):       /usr/sbin/groupdel
219 Requires(postun):       /usr/sbin/userdel
220 Requires(pre):  /bin/id
221 Requires(pre):  /usr/bin/getgid
222 Requires(pre):  /usr/lib/rpm/user_group.sh
223 Requires(pre):  /usr/sbin/groupadd
224 Requires(pre):  /usr/sbin/useradd
225 Requires(pre):  /usr/sbin/usermod
226 Requires:       %{name} = %{version}-%{release}
227 Requires:       rc-scripts
228 Provides:       group(svn)
229 Provides:       user(svn)
230
231 %description svnserve
232 Subversion svnserve server.
233
234 %description svnserve -l pl.UTF-8
235 Serwer subversion svnserve.
236
237 %package tools
238 Summary:        Subversion tools and scripts
239 Summary(pl.UTF-8):      Narzędzia oraz skrypty dla subversion
240 Summary(pt_BR.UTF-8):   Módulos python para acessar os recursos do Subversion
241 Group:          Applications
242 Requires:       %{name} = %{version}-%{release}
243 Requires:       python
244 Requires:       python-subversion = %{version}
245
246 %description tools
247 Subversion tools and scripts.
248
249 %description tools -l pl.UTF-8
250 Narzędzia oraz skrypty dla subversion.
251
252 %package -n bash-completion-subversion
253 Summary:        bash completion for subversion
254 Summary(pl.UTF-8):      Dopełnienia basha dla subversion
255 Group:          Applications/Shells
256 Requires:       %{name} = %{version}-%{release}
257 Requires:       bash-completion
258 Conflicts:      %{name}-tools <= 1.1.0-0.rc6.1
259
260 %description -n bash-completion-subversion
261 Bash completion for subversion.
262
263 %description -n bash-completion-subversion -l pl.UTF-8
264 Dopełnienia basha dla subversion.
265
266 %package -n java-subversion
267 Summary:        Subversion Java bindings
268 Summary(pl.UTF-8):      Dowiązania do Subversion dla Javy
269 Group:          Development/Languages/Java
270 Requires:       %{name}-libs = %{version}-%{release}
271
272 %description -n java-subversion
273 This is a set of Java classes which provide the functionality of
274 subversion-libs, the Subversion libraries. It is useful if you want
275 to, for example, write a Java class that manipulates a Subversion
276 repository or working copy. See the 'subversion' package for more
277 information.
278
279 %description -n java-subversion -l pl.UTF-8
280 Ten pakiet zawiera zestaw klas Javy udostępniających funkcjonalność
281 subversion-libs, czyli bibliotek Subversion. Jest przydatny przy
282 pisaniu klas Javy np. modyfikujących repozytorium Subversion lub kopię
283 roboczą. Więcej informacji w pakiecie subversion.
284
285 %package -n python-subversion
286 Summary:        Subversion Python bindings
287 Summary(pl.UTF-8):      Dowiązania do Subversion dla Pythona
288 Summary(pt_BR.UTF-8):   Módulos Python para acessar os recursos do Subversion
289 Group:          Development/Languages/Python
290 Requires:       %{name}-libs = %{version}-%{release}
291 Requires:       python
292 Obsoletes:      subversion-python
293
294 %description -n python-subversion
295 Subversion Python bindings.
296
297 %description -n python-subversion -l pl.UTF-8
298 Dowiązania do Subversion dla Pythona.
299
300 %description -n python-subversion -l pt_BR.UTF-8
301 Módulos Python para acessar os recursos do Subversion.
302
303 %package -n python-csvn
304 Summary:        CTypes Subversion Python bindings
305 Summary(pl.UTF-8):      Dowiązania do Subversion dla Pythona
306 Summary(pt_BR.UTF-8):   Módulos Python para acessar os recursos do Subversion
307 Group:          Development/Languages/Python
308 Requires:       %{name}-libs = %{version}-%{release}
309 Requires:       python
310
311 %description -n python-csvn
312 Subversion CTypes Python bindings.
313
314 %description -n python-csvn -l pl.UTF-8
315 Dowiązania do Subversion dla Pythona używające CTypes.
316
317 %description -n python-csvn -l pt_BR.UTF-8
318 Módulos Python para acessar os recursos do Subversion.
319
320 %package -n perl-subversion
321 Summary:        Subversion Perl bindings
322 Summary(pl.UTF-8):      Dowiązania do Subversion dla Perla
323 Summary(pt_BR.UTF-8):   Módulos Perl para acessar os recursos do Subversion
324 Group:          Development/Languages/Perl
325 Requires:       %{name}-libs = %{version}-%{release}
326 Obsoletes:      subversion-perl
327
328 %description -n perl-subversion
329 Subversion Perl bindings.
330
331 %description -n perl-subversion -l pl.UTF-8
332 Dowiązania do Subversion dla Perla.
333
334 %description -n perl-subversion -l pt_BR.UTF-8
335 Módulos Perl para acessar os recursos do Subversion.
336
337 %package -n ruby-subversion
338 Summary:        Subversion Ruby bindings
339 Summary(pl.UTF-8):      Dowiązania do Subversion dla języka Ruby
340 Summary(pt_BR.UTF-8):   Módulos Ruby para acessar os recursos do Subversion
341 Group:          Development/Languages
342 Requires:       %{name}-libs = %{version}-%{release}
343 Obsoletes:      subversion-ruby
344
345 %description -n ruby-subversion
346 Subversion Ruby bindings.
347
348 %description -n ruby-subversion -l pl.UTF-8
349 Dowiązania do Subversion dla języka Ruby.
350
351 %description -n ruby-subversion -l pt_BR.UTF-8
352 Módulos Ruby para acessar os recursos do Subversion.
353
354 %package -n apache-mod_dav_svn
355 Summary:        Apache module: Subversion Server
356 Summary(pl.UTF-8):      Moduł Apache'a: serwer Subversion
357 Group:          Networking/Daemons
358 Requires:       %{name} = %{version}-%{release}
359 Requires:       apache(modules-api) = %apache_modules_api
360 Requires:       apache-mod_dav
361
362 %description -n apache-mod_dav_svn
363 Apache module: Subversion Server.
364
365 %description -n apache-mod_dav_svn -l pl.UTF-8
366 Moduł Apache'a: serwer Subversion.
367
368 %package -n apache-mod_authz_svn
369 Summary:        Apache module: Subversion Server - path-based authorization
370 Summary(pl.UTF-8):      Moduł Apache'a: autoryzacja na podstawie ścieżki dla serwera Subversion
371 Group:          Networking/Daemons
372 Requires:       %{name}-libs = %{version}-%{release}
373 Requires:       apache(modules-api) = %apache_modules_api
374 Requires:       apache-mod_dav_svn = %{version}-%{release}
375
376 %description -n apache-mod_authz_svn
377 Apache module: Subversion Server - path-based authorization.
378
379 %description -n apache-mod_authz_svn -l pl.UTF-8
380 Moduł Apache'a: autoryzacja na podstawie ścieżki dla serwera
381 Subversion.
382
383 %package -n apache-mod_dontdothat_svn
384 Summary:        Apache module: Allows you to block specific svn requests
385 Summary(pl.UTF-8):      Moduł Apache'a pozwalający na blokowanie pewnych zapytań svn
386 Group:          Networking/Daemons
387 Requires:       %{name}-libs = %{version}-%{release}
388 Requires:       apache(modules-api) = %apache_modules_api
389 Requires:       apache-mod_dav_svn = %{version}-%{release}
390
391 %description -n apache-mod_dontdothat_svn
392 Apache module: Allows you to block specific svn requests.
393
394 %description -n apache-mod_dontdothat_svn -l pl.UTF-8
395 Moduł Apache'a pozwalający na blokowanie pewnych zapytań svn.
396
397 %package -n gnome-keyring-subversion
398 Summary:        GNOME Keyring authentication provider for Subversion
399 Summary(pl.UTF-8):      Moduł uwierzytelniający GNOME Keyring dla Subversion
400 Group:          X11/Applications
401 Requires:       %{name}-libs = %{version}-%{release}
402
403 %description -n gnome-keyring-subversion
404 Authentication provider module for Subversion which allows SVN client
405 to authenticate using GNOME Keyring.
406
407 %description -n gnome-keyring-subversion -l pl.UTF-8
408 Moduł uwierzytelniający dla Subversion pozwalający klientom SVN
409 uwierzytelniać się przy użyciu mechanizmu GNOME Keyring.
410
411 %package -n kde4-kwallet-subversion
412 Summary:        KDE Wallet authentication provider for Subversion
413 Summary(pl.UTF-8):      Moduł uwierzytelniający dla Subversion wykorzystujący Portfel KDE
414 Group:          X11/Applications
415 Requires:       %{name}-libs = %{version}-%{release}
416
417 %description -n kde4-kwallet-subversion
418 Authentication provider module for Subversion which allows SVN client
419 to authenticate using KDE Wallet.
420
421 %description -n kde4-kwallet-subversion -l pl.UTF-8
422 Moduł uwierzytelniający dla Subversion pozwalający klientom SVN
423 uwierzytelniać się przy użyciu Portfela KDE.
424
425 %prep
426 %setup -q
427 %patch0 -p0
428 %patch1 -p1
429 %patch2 -p0
430 %patch3 -p1
431
432 sed -i -e 's#serf_prefix/lib#serf_prefix/%{_lib}#g' build/ac-macros/serf.m4
433
434 %build
435 # disabled regeneration - subversion 1.6.13 is not ready for swig 2.0.x
436 #%{__rm} subversion/bindings/swig/proxy/*.swg
437 #cd subversion/bindings/swig && python "%{SOURCE5}" && cd ../../..
438 chmod +x ./autogen.sh && ./autogen.sh
439 %{__libtoolize}
440 %configure \
441         --with-editor=vi \
442         --with-zlib=%{_libdir} \
443         --disable-runtime-module-search \
444         --disable-mod-activation \
445 %if %{with db}
446         --with-berkeley-db="db.h:%{_includedir}:%{_libdir}:db" \
447 %else
448         --without-berkeley-db \
449 %endif
450 %if %{with apache}
451         --with-apache-libexecdir="$(%{_sbindir}/apxs -q LIBEXECDIR)" \
452         --with-apxs=%{_sbindir}/apxs \
453 %else
454         --without-apxs \
455 %endif
456 %if %{without swig}
457         --without-swig \
458 %endif
459 %if %{with ruby}
460         svn_cv_ruby_sitedir_libsuffix="" \
461         svn_cv_ruby_sitedir_archsuffix="" \
462         --with-ruby-sitedir=%{ruby_vendorarchdir} \
463 %else
464         ac_cv_path_RUBY=none \
465 %endif
466 %if %{with csvn}
467         --with-ctypesgen=%{_bindir}/ctypesgen.py \
468 %endif
469 %if %{with javahl}
470         --enable-javahl \
471         --with-jdk="%{java_home}" \
472         --without-jikes \
473 %else
474         --disable-javahl \
475 %endif
476         --with-serf=%{_prefix} \
477         --with-apr=%{_bindir}/apr-1-config \
478         --with-apr-util=%{_bindir}/apu-1-config \
479 %if %{with kwallet}
480         --with-kwallet \
481 %endif
482 %if %{with gnome}
483         --with-gnome-keyring
484 %endif
485
486 %{__make} -j1
487
488 %{__make} tools
489
490 %if %{with csvn}
491 # Python ctypes bindings
492 %{__make} ctypes-python
493 %endif
494 %if %{with python}
495 # Python swig bindings
496 %{__make} swig-py \
497         swig_pydir=%{py_sitedir}/libsvn \
498         swig_pydir_extra=%{py_sitedir}/svn
499 %endif
500 %if %{with perl}
501 # Perl swig bindings
502 %{__make} -j1 swig-pl-lib
503 cd subversion/bindings/swig/perl/native
504 %{__perl} Makefile.PL INSTALLDIRS=vendor
505 %{__make} -j1
506 cd -
507 %endif
508 %if %{with javahl}
509 %{__make} -j1 javahl \
510         javahl_javadir="%{_javadir}"
511 %endif
512 # ruby
513 %if %{with ruby}
514 %{__make} swig-rb
515 %endif
516
517 %if %{with tests}
518 %{__make} -j1 check
519 %if %{with csvn}
520 %{__make} -j1 check-ctypes-python
521 %endif
522 %if %{with python}
523 %{__make} -j1 check-swig-py
524 %endif
525 %if %{with perl}
526 %{__make} -j1 check-swig-pl
527 %endif
528 %if %{with ruby}
529 # disabled, see https://bugs.launchpad.net/pld-linux/+bug/734340
530 #%{__make} check-swig-rb
531 %endif
532 %endif
533
534 %install
535 rm -rf $RPM_BUILD_ROOT
536 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,bash_completion.d} \
537         $RPM_BUILD_ROOT{%{apacheconfdir},%{apachelibdir},%{_infodir}} \
538         $RPM_BUILD_ROOT%{_examplesdir}/{%{name}-%{version},python-%{name}-%{version}} \
539         $RPM_BUILD_ROOT%{_sysconfdir}/%{name} \
540         $RPM_BUILD_ROOT/home/services/subversion{,/repos}
541
542 %{__make} install -j1 \
543         toolsdir=%{_bindir} \
544         DESTDIR=$RPM_BUILD_ROOT \
545         APACHE_LIBEXECDIR="$(%{_sbindir}/apxs -q LIBEXECDIR)" \
546 %if %{with javahl}
547         install-javahl \
548         javahl_javadir="%{_javadir}" \
549 %endif
550 %if %{with python}
551         install-swig-py \
552         swig_pydir=%{py_sitedir}/libsvn \
553         swig_pydir_extra=%{py_sitedir}/svn \
554 %endif
555 %if %{with csvn}
556         install-ctypes-python \
557 %endif
558         install-tools
559
560 %if %{with ruby}
561 %{__make} install -j1 \
562         DESTDIR=$RPM_BUILD_ROOT \
563         install-swig-rb install-swig-rb-doc \
564
565 # not our package
566 %{__rm} -r $RPM_BUILD_ROOT%{ruby_ridir}/OptionParser
567 %{__rm} -r $RPM_BUILD_ROOT%{ruby_ridir}/Time
568 %{__rm} $RPM_BUILD_ROOT%{ruby_ridir}/cache.ri
569 %{__rm} $RPM_BUILD_ROOT%{ruby_ridir}/created.rid
570 %endif
571
572 %if %{with perl}
573 %{__make} install-swig-pl-lib \
574         DESTDIR=$RPM_BUILD_ROOT
575 %{__make} -C subversion/bindings/swig/perl/native install \
576         DESTDIR=$RPM_BUILD_ROOT \
577         PREFIX=$RPM_BUILD_ROOT%{_prefix} \
578         LIBDIR=$RPM_BUILD_ROOT%{_libdir}
579 %endif
580
581 %if %{with apache}
582 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{apacheconfdir}/65_mod_dav_svn.conf
583 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{apacheconfdir}/66_mod_authz_svn.conf
584 cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/svnserve
585 install -p %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/svnserve
586 %endif
587
588 %if %{without net_client_only}
589 install -p tools/backup/hot-backup.py $RPM_BUILD_ROOT%{_bindir}/svn-hot-backup
590 %endif
591
592 # rename not to conflict with standard packages. (are these needed at all?)
593 mv $RPM_BUILD_ROOT%{_bindir}/{,svn}diff
594 mv $RPM_BUILD_ROOT%{_bindir}/{,svn}diff3
595 mv $RPM_BUILD_ROOT%{_bindir}/{,svn}diff4
596
597 %if %{with python} || %{with csvn}
598 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
599 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
600 %py_postclean
601 %endif
602 %if %{with python}
603 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/libsvn/*.la
604 # .a created on ac only
605 %{__rm} -f $RPM_BUILD_ROOT%{py_sitedir}/libsvn/*.a
606 cp -p tools/examples/*.py $RPM_BUILD_ROOT%{_examplesdir}/python-%{name}-%{version}
607 %endif
608
609 cp -p tools/client-side/bash_completion $RPM_BUILD_ROOT/etc/bash_completion.d/%{name}
610 cp -p tools/examples/*.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
611
612 %if %{with javahl}
613 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libsvnjavahl*.{la,a}
614 %endif
615 %if %{with swig}
616 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libsvn_swig*.{la,a}
617 %if %{with ruby}
618 %{__rm} $RPM_BUILD_ROOT%{ruby_vendorarchdir}/svn/ext/*.la
619 %endif
620 %endif
621 %if %{with gnome} || %{with kwallet}
622 # dlopened by soname (libsvn_auth_*-1.so.0)
623 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libsvn_auth_*-1.{so,la,a}
624 %endif
625
626 %find_lang %{name}
627
628 %clean
629 rm -rf $RPM_BUILD_ROOT
630
631 %pre svnserve
632 %groupadd -g 86 svn
633 %useradd -u 180 -d /home/services/subversion -c "Subversion svnserve" -g svn svn
634
635 %post   libs -p /sbin/ldconfig
636 %postun libs -p /sbin/ldconfig
637
638 %post   devel -p /sbin/postshell
639 -/usr/sbin/fix-info-dir -c %{_infodir}
640
641 %postun devel -p /sbin/postshell
642 -/usr/sbin/fix-info-dir -c %{_infodir}
643
644 %post   -n java-subversion -p /sbin/ldconfig
645 %postun -n java-subversion -p /sbin/ldconfig
646
647 %post   -n perl-subversion -p /sbin/ldconfig
648 %postun -n perl-subversion -p /sbin/ldconfig
649
650 %post   -n python-subversion -p /sbin/ldconfig
651 %postun -n python-subversion -p /sbin/ldconfig
652
653 %post   -n ruby-subversion -p /sbin/ldconfig
654 %postun -n ruby-subversion -p /sbin/ldconfig
655
656 %post   -n gnome-keyring-subversion -p /sbin/ldconfig
657 %postun -n gnome-keyring-subversion -p /sbin/ldconfig
658
659 %post   -n kde4-kwallet-subversion -p /sbin/ldconfig
660 %postun -n kde4-kwallet-subversion -p /sbin/ldconfig
661
662 %post svnserve
663 /sbin/chkconfig --add svnserve
664 %service svnserve restart "svnserve daemon"
665
666 %preun svnserve
667 if [ "$1" = "0" ]; then
668         %service svnserve stop
669         /sbin/chkconfig --del svnserve
670 fi
671
672 %postun svnserve
673 if [ "$1" = "0" ]; then
674         %userremove svn
675         %groupremove svn
676 fi
677
678 %post -n apache-mod_dav_svn
679 %service -q httpd restart
680
681 %postun -n apache-mod_dav_svn
682 if [ "$1" = "0" ]; then
683         %service -q httpd restart
684 fi
685
686 %post -n apache-mod_authz_svn
687 %service -q httpd restart
688
689 %postun -n apache-mod_authz_svn
690 if [ "$1" = "0" ]; then
691         %service -q httpd restart
692 fi
693
694 %post -n apache-mod_dontdothat_svn
695 %service -q httpd restart
696
697 %postun -n apache-mod_dontdothat_svn
698 if [ "$1" = "0" ]; then
699         %service -q httpd restart
700 fi
701
702 %files
703 %defattr(644,root,root,755)
704 %doc BUGS CHANGES INSTALL README
705 %doc doc/*/*.html
706 %doc tools/hook-scripts/*.{pl,py,example}
707 %doc tools/hook-scripts/mailer/*.{py,example}
708 %doc tools/xslt/*
709 %attr(755,root,root) %{_bindir}/svn
710 %attr(755,root,root) %{_bindir}/svnadmin
711 %attr(755,root,root) %{_bindir}/svndumpfilter
712 %attr(755,root,root) %{_bindir}/svnlook
713 %attr(755,root,root) %{_bindir}/svnmucc
714 %attr(755,root,root) %{_bindir}/svnrdump
715 %attr(755,root,root) %{_bindir}/svnsync
716 %attr(755,root,root) %{_bindir}/svnversion
717 %{_mandir}/man1/svn.1*
718 %{_mandir}/man1/svnadmin.1*
719 %{_mandir}/man1/svndumpfilter.1*
720 %{_mandir}/man1/svnrdump.1*
721 %{_mandir}/man1/svnlook.1*
722 %{_mandir}/man1/svnmucc.1*
723 %{_mandir}/man1/svnsync.1*
724 %{_mandir}/man1/svnversion.1*
725
726 %files libs -f %{name}.lang
727 %defattr(644,root,root,755)
728 %dir %{_sysconfdir}/%{name}
729 %attr(755,root,root) %{_libdir}/libsvn_client-1.so.*.*.*
730 %attr(755,root,root) %ghost %{_libdir}/libsvn_client-1.so.0
731 %attr(755,root,root) %{_libdir}/libsvn_delta-1.so.*.*.*
732 %attr(755,root,root) %ghost %{_libdir}/libsvn_delta-1.so.0
733 %attr(755,root,root) %{_libdir}/libsvn_diff-1.so.*.*.*
734 %attr(755,root,root) %ghost %{_libdir}/libsvn_diff-1.so.0
735 %attr(755,root,root) %{_libdir}/libsvn_fs-1.so.*.*.*
736 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs-1.so.0
737 %if %{without net_client_only}
738 %attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so.*.*.*
739 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_base-1.so.0
740 %endif
741 %attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so.*.*.*
742 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_fs-1.so.0
743 %attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so.*.*.*
744 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_util-1.so.0
745 %attr(755,root,root) %{_libdir}/libsvn_ra-1.so.*.*.*
746 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra-1.so.0
747 %attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so.*.*.*
748 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_local-1.so.0
749 %attr(755,root,root) %{_libdir}/libsvn_ra_serf-1.so.*.*.*
750 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_serf-1.so.0
751 %attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so.*.*.*
752 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_svn-1.so.0
753 %attr(755,root,root) %{_libdir}/libsvn_repos-1.so.*.*.*
754 %attr(755,root,root) %ghost %{_libdir}/libsvn_repos-1.so.0
755 %attr(755,root,root) %{_libdir}/libsvn_subr-1.so.*.*.*
756 %attr(755,root,root) %ghost %{_libdir}/libsvn_subr-1.so.0
757 %attr(755,root,root) %{_libdir}/libsvn_wc-1.so.*.*.*
758 %attr(755,root,root) %ghost %{_libdir}/libsvn_wc-1.so.0
759
760 %files devel
761 %defattr(644,root,root,755)
762 %attr(755,root,root) %{_libdir}/libsvn_client-1.so
763 %attr(755,root,root) %{_libdir}/libsvn_delta-1.so
764 %attr(755,root,root) %{_libdir}/libsvn_diff-1.so
765 %attr(755,root,root) %{_libdir}/libsvn_fs-1.so
766 %if %{without net_client_only}
767 %attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so
768 %endif
769 %attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so
770 %attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so
771 %attr(755,root,root) %{_libdir}/libsvn_ra-1.so
772 %attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so
773 %attr(755,root,root) %{_libdir}/libsvn_ra_serf-1.so
774 %attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so
775 %attr(755,root,root) %{_libdir}/libsvn_repos-1.so
776 %attr(755,root,root) %{_libdir}/libsvn_subr-1.so
777 %attr(755,root,root) %{_libdir}/libsvn_wc-1.so
778 %{_libdir}/libsvn_client-1.la
779 %{_libdir}/libsvn_delta-1.la
780 %{_libdir}/libsvn_diff-1.la
781 %{_libdir}/libsvn_fs-1.la
782 %if %{without net_client_only}
783 %{_libdir}/libsvn_fs_base-1.la
784 %endif
785 %{_libdir}/libsvn_fs_fs-1.la
786 %{_libdir}/libsvn_fs_util-1.la
787 %{_libdir}/libsvn_ra-1.la
788 %{_libdir}/libsvn_ra_local-1.la
789 %{_libdir}/libsvn_ra_serf-1.la
790 %{_libdir}/libsvn_ra_svn-1.la
791 %{_libdir}/libsvn_repos-1.la
792 %{_libdir}/libsvn_subr-1.la
793 %{_libdir}/libsvn_wc-1.la
794 %{_includedir}/%{name}-1
795 %{_examplesdir}/%{name}-%{version}
796
797 %files static
798 %defattr(644,root,root,755)
799 %{_libdir}/libsvn_client-1.a
800 %{_libdir}/libsvn_delta-1.a
801 %{_libdir}/libsvn_diff-1.a
802 %{_libdir}/libsvn_fs-1.a
803 %if %{without net_client_only}
804 %{_libdir}/libsvn_fs_base-1.a
805 %endif
806 %{_libdir}/libsvn_fs_fs-1.a
807 %{_libdir}/libsvn_fs_util-1.a
808 %{_libdir}/libsvn_ra-1.a
809 %{_libdir}/libsvn_ra_local-1.a
810 %{_libdir}/libsvn_ra_serf-1.a
811 %{_libdir}/libsvn_ra_svn-1.a
812 %{_libdir}/libsvn_repos-1.a
813 %{_libdir}/libsvn_subr-1.a
814 %{_libdir}/libsvn_wc-1.a
815
816 %if %{with gnome}
817 %files -n gnome-keyring-subversion
818 %defattr(644,root,root,755)
819 %attr(755,root,root) %{_libdir}/libsvn_auth_gnome_keyring-1.so.*.*.*
820 %attr(755,root,root) %ghost %{_libdir}/libsvn_auth_gnome_keyring-1.so.0
821 %endif
822
823 %if %{with kwallet}
824 %files -n kde4-kwallet-subversion
825 %defattr(644,root,root,755)
826 %attr(755,root,root) %{_libdir}/libsvn_auth_kwallet-1.so.*.*.*
827 %attr(755,root,root) %ghost %{_libdir}/libsvn_auth_kwallet-1.so.0
828 %endif
829
830 %if %{without net_client_only}
831 %files svnserve
832 %defattr(644,root,root,755)
833 %attr(755,root,root) %{_bindir}/svnserve
834 %{_mandir}/man5/svnserve.conf.5*
835 %{_mandir}/man8/svnserve.8*
836 %dir %attr(750,svn,svn) /home/services/subversion
837 %dir %attr(750,svn,svn) /home/services/subversion/repos
838 %if %{with apache}
839 %attr(754,root,root) /etc/rc.d/init.d/svnserve
840 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/svnserve
841 %endif
842
843 %files tools
844 %defattr(644,root,root,755)
845 # tools/backup/hot-backup.py
846 %attr(755,root,root) %{_bindir}/svn-hot-backup
847
848 # tools/diff
849 %attr(755,root,root) %{_bindir}/svndiff
850 %attr(755,root,root) %{_bindir}/svndiff3
851 %attr(755,root,root) %{_bindir}/svndiff4
852
853 # tools/server-side
854 %attr(755,root,root) %{_bindir}/fsfs-stats
855 %attr(755,root,root) %{_bindir}/svn-populate-node-origins-index
856 %attr(755,root,root) %{_bindir}/svn-rep-sharing-stats
857 %attr(755,root,root) %{_bindir}/svnauthz
858 %attr(755,root,root) %{_bindir}/svnauthz-validate
859
860 # tools/client-side
861 %attr(755,root,root) %{_bindir}/svn-bench
862
863 # tools/dev/svnraisetreeconflict
864 %attr(755,root,root) %{_bindir}/svnraisetreeconflict
865
866 # tools/dev/
867 %attr(755,root,root) %{_bindir}/fsfs-access-map
868 %attr(755,root,root) %{_bindir}/fsfs-reorg
869
870 %files -n bash-completion-subversion
871 %defattr(644,root,root,755)
872 /etc/bash_completion.d/%{name}
873
874 %endif # net_client_only
875
876 %if %{with javahl}
877 %files -n java-subversion
878 %defattr(644,root,root,755)
879 %attr(755,root,root) %{_libdir}/libsvnjavahl-1.so.*.*.*
880 %attr(755,root,root) %ghost %{_libdir}/libsvnjavahl-1.so.0
881 %attr(755,root,root) %{_libdir}/libsvnjavahl-1.so
882 %{_javadir}/svn-javahl.jar
883 %endif
884
885 %if %{with python}
886 %files -n python-subversion
887 %defattr(644,root,root,755)
888 %doc tools/backup/*.py
889 %attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so.*.*.*
890 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_py-1.so.0
891 %attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so
892 %dir %{py_sitedir}/libsvn
893 %attr(755,root,root) %{py_sitedir}/libsvn/_*.so
894 %{py_sitedir}/libsvn/*.py[co]
895 %dir %{py_sitedir}/svn
896 %{py_sitedir}/svn/*.py[co]
897 %{_examplesdir}/python-%{name}-%{version}
898 %endif
899
900 %if %{with csvn}
901 %files -n python-csvn
902 %defattr(644,root,root,755)
903 %doc subversion/bindings/ctypes-python/{README,TODO}
904 %doc subversion/bindings/ctypes-python/examples/*.py
905 %dir %{py_sitescriptdir}/csvn
906 %{py_sitescriptdir}/csvn/*.py[co]
907 %dir %{py_sitescriptdir}/csvn/core
908 %{py_sitescriptdir}/csvn/core/*.py[co]
909 %dir %{py_sitescriptdir}/csvn/ext
910 %{py_sitescriptdir}/csvn/ext/*.py[co]
911 %{py_sitescriptdir}/svn_ctypes_python_bindings-0.1-py*.egg-info
912 %endif
913
914 %if %{with perl}
915 %files -n perl-subversion
916 %defattr(644,root,root,755)
917 %attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so.*.*.*
918 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_perl-1.so.0
919 %attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so
920 %{perl_vendorarch}/SVN
921 %dir %{perl_vendorarch}/auto/SVN
922 %dir %{perl_vendorarch}/auto/SVN/*
923 %attr(755,root,root) %{perl_vendorarch}/auto/SVN/*/*.so
924 %{perl_vendorarch}/auto/SVN/*/*.bs
925 %{_mandir}/man3/*.3pm*
926 %endif
927
928 %if %{with ruby}
929 %files -n ruby-subversion
930 %defattr(644,root,root,755)
931 %attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so.*.*.*
932 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_ruby-1.so.0
933 %attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so
934 %dir %{ruby_vendorarchdir}/svn
935 %{ruby_vendorarchdir}/svn/*.rb
936 %dir %{ruby_vendorarchdir}/svn/ext
937 %attr(755,root,root) %{ruby_vendorarchdir}/svn/ext/*.so
938 %{ruby_ridir}/Svn
939 %endif
940
941 %if %{with apache}
942 %files -n apache-mod_dav_svn
943 %defattr(644,root,root,755)
944 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_dav_svn.conf
945 %attr(755,root,root) %{apachelibdir}/mod_dav_svn.so
946
947 %files -n apache-mod_authz_svn
948 %defattr(644,root,root,755)
949 %doc subversion/mod_authz_svn/INSTALL
950 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_authz_svn.conf
951 %attr(755,root,root) %{apachelibdir}/mod_authz_svn.so
952
953 %files -n apache-mod_dontdothat_svn
954 %defattr(644,root,root,755)
955 %doc tools/server-side/mod_dontdothat/README
956 %attr(755,root,root) %{apachelibdir}/mod_dontdothat.so
957 %endif
This page took 0.096672 seconds and 4 git commands to generate.