]> git.pld-linux.org Git - packages/subversion.git/blob - subversion.spec
- don't run checks in parallerl - eats so many resources
[packages/subversion.git] / subversion.spec
1 #
2 # Conditional build:
3 %bcond_with     net_client_only         # build only net client
4 %bcond_without  neon                    # use serf instead of neon
5 %bcond_without  swig                    # disable bindings generation with Swig
6 %bcond_without  python                  # build without Python bindings (broken)
7 %bcond_without  csvn                    # build Python csvn bindings
8 %bcond_without  perl                    # build without Perl bindings
9 %bcond_with     ruby                    # build without Ruby bindings
10 %bcond_without  apache                  # build without Apache support (webdav, etc)
11 %bcond_without  javahl                  # build without javahl support (Java high-level bindings)
12 %bcond_without  tests                   # don't perform "make check"
13 %bcond_without  kwallet                 # build without kde4 wallet support
14 %bcond_without  kde                             # build without kde4 support (alias for kwallet)
15 %bcond_without  gnome                   # build without gnome keyring support
16 %bcond_without  db                              # disable Subversion Berkeley DB based filesystem library
17
18 %if %{with net_client_only}
19 %undefine       with_apache
20 %undefine       with_db
21 %undefine       with_swig
22 %undefine       with_javahl
23 %endif
24
25 %if %{without swig}
26 %undefine       with_perl
27 %undefine       with_python
28 %undefine       with_ruby
29 %endif
30
31 %if %{without kde}
32 %undefine       with_kwallet
33 %endif
34
35 %if %{without python} && %{without perl} && %{without ruby}
36 %undefine       with_swig
37 %endif
38
39 %define apxs    /usr/sbin/apxs
40 %define pdir    SVN
41 %define pnam    _Core
42
43 %if %{with neon}
44 %define webdavlib       neon
45 %else
46 %define webdavlib       serf
47 %endif
48 %{?with_perl:%include   /usr/lib/rpm/macros.perl}
49 Summary:        A Concurrent Versioning system similar to but better than CVS
50 Summary(pl.UTF-8):      System kontroli wersji podobny, ale lepszy, niż CVS
51 Summary(pt_BR.UTF-8):   Sistema de versionamento concorrente
52 Name:           subversion
53 Version:        1.7.0
54 Release:        1
55 License:        Apache/BSD-like
56 Group:          Development/Version Control
57 Source0:        http://www.apache.org/dist/subversion/%{name}-%{version}.tar.bz2
58 # Source0-md5:  930e6644a1b6094efd268fde6a318f04
59 Source1:        %{name}-dav_svn.conf
60 Source2:        %{name}-authz_svn.conf
61 Source3:        %{name}-svnserve.init
62 Source4:        %{name}-svnserve.sysconfig
63 # current subversion tarball has correct *.swg files
64 # but after regeneration these are broken again, so
65 # we still need this script
66 Source5:        %{name}-convert-typemaps-to-ifdef.py
67 Patch0:         %{name}-home_etc.patch
68 Patch1:         %{name}-DESTDIR.patch
69 Patch2:         %{name}-ruby-datadir-path.patch
70 Patch3:         %{name}-tests.patch
71 URL:            http://subversion.apache.org/
72 %{?with_apache:BuildRequires:   apache-devel >= 2.2.0-8}
73 BuildRequires:  autoconf
74 BuildRequires:  automake
75 BuildRequires:  db-devel >= 4.1.25
76 BuildRequires:  libtool
77 BuildRequires:  rpmbuild(macros) >= 1.583
78 %if %{with perl}
79 BuildRequires:  perl-devel >= 1:5.8.0
80 BuildRequires:  rpm-perlprov >= 4.1-13
81 BuildRequires:  swig-perl >= 1.3.24
82 %endif
83 %if %{with csvn}
84 BuildRequires:  python-ctypesgen
85 %endif
86 %if %{with python}
87 BuildRequires:  python-devel >= 1:2.4
88 BuildRequires:  swig-python >= 1.3.24
89 %endif
90 %if %{with ruby}
91 BuildRequires:  ruby-devel >= 1:1.8
92 BuildRequires:  ruby-devel < 1:1.9
93 BuildRequires:  ruby-rubygems
94 BuildRequires:  swig-ruby >= 1.3.24
95 %endif
96 %if %{with javahl}
97 BuildRequires:  jdk
98 BuildRequires:  libstdc++-devel
99 %endif
100 BuildRequires:  apr-devel >= 1:1.0.0
101 BuildRequires:  apr-util-devel >= 1:1.2.8-3
102 BuildRequires:  autoconf >= 2.59
103 BuildRequires:  bison
104 BuildRequires:  cyrus-sasl-devel
105 BuildRequires:  expat-devel
106 BuildRequires:  gettext-devel
107 %{?with_kwallet:BuildRequires:  kde4-kdelibs-devel}
108 BuildRequires:  libmagic-devel
109 %{?with_gnome:BuildRequires:    libgnome-keyring-devel}
110 BuildRequires:  libtool >= 1.4-9
111 BuildRequires:  pkgconfig
112 BuildRequires:  rpm-pythonprov
113 BuildRequires:  rpmbuild(macros) >= 1.559
114 BuildRequires:  sed >= 4.0
115 BuildRequires:  sqlite3-devel >= 3.6.11
116 BuildRequires:  texinfo
117 BuildRequires:  which
118 %if %{with neon}
119 BuildRequires:  neon-devel >= 0.26.0
120 %else
121 BuildRequires:  serf-devel
122 %endif
123 Requires:       %{name}-libs = %{version}-%{release}
124 %requires_ge    sqlite3
125 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
126
127 %define         _libexecdir             %{_libdir}/svn
128 %define         apacheconfdir   %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
129 %define         apachelibdir    %(%{apxs} -q LIBEXECDIR 2>/dev/null)
130
131 %define         skip_post_check_so      libsvn_swig_py-1.so.* libsvn_swig_perl-1.so.*
132
133 %description
134 The goal of the Subversion project is to build a version control
135 system that is a compelling replacement for CVS in the open source
136 community.
137
138 Our goals are:
139 - All current CVS features.
140 - Directories, renames, and file meta-data are versioned.
141 - Symbolic links, etc, are supported
142 - Commits are truly atomic.
143 - Branching and tagging are cheap (constant time) operations
144 - Repeated merges are handled gracefully
145 - Support for plug-in client side diff programs
146 - Natively client/server
147 - Client/server protocol sends diffs in both directions
148 - Costs are proportional to change size, not project size
149 - Internationalization
150 - Progressive multi-lingual support
151
152 %description -l pl.UTF-8
153 Celem projektu Subversion jest stworzenie systemu kontroli wersji jako
154 zamiennika dla CVS.
155
156 Cele projektu to:
157 - Wszystkie aktualne możliwości CVS.
158 - Katalogi, zmiany nazw oraz metadane plików są wersjonowane.
159 - Obsługa dowiązań symbolicznych itp.
160 - Commity są w pełni atomowe.
161 - Branchowanie oraz tagowanie są tanimi (stałymi w czasie) operacjami.
162 - Dobra obsługa powtarzanego łączenia (merge).
163 - Obsługa wtyczek diff po stronie klienta.
164 - Natywny klient/serwer.
165 - Klient/Serwer przesyłają diffy w obu kierunkach.
166 - Koszty proporcjonalne do rozmiaru zmiany, a nie rozmiaru projektu.
167 - Internacjonalizacja.
168 - Postępujące wsparcie dla wielu języków.
169
170 %description -l pt_BR.UTF-8
171 O objetivo do projeto Subversion é construir um sistema de controle de
172 versões que seja um substituto para o CVS (Concurrent Versioning
173 System) na comunidade opensource, fornecendo grandes melhorias.
174
175 %package libs
176 Summary:        Subversion libraries and modules
177 Summary(pl.UTF-8):      Biblioteka subversion oraz ładowalne moduły
178 Group:          Libraries
179 %{?with_neon:Requires:  neon >= 0.26.0}
180 Obsoletes:      libsubversion0
181
182 %description libs
183 Subversion libraries and modules.
184
185 %description libs -l pl.UTF-8
186 Biblioteka subversion oraz ładowalne moduły.
187
188 %package devel
189 Summary:        Header files and develpment documentation for subversion
190 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumetacja do subversion
191 Summary(pt_BR.UTF-8):   Arquivos de desenvolvimento para o Subversion
192 Group:          Development/Libraries
193 Requires:       %{name}-libs = %{version}-%{release}
194 Requires:       apr-util-devel >= 1:1.0.0
195 %{?with_neon:Requires:  neon-devel >= 0.26.0}
196 Obsoletes:      libsubversion0-devel
197
198 %description devel
199 Header files and develpment documentation for subversion.
200
201 %description devel -l pl.UTF-8
202 Pliki nagłówkowe i dokumetacja do subversion.
203
204 %description devel -l pt_BR.UTF-8
205 Este pacote provê os arquivos necessários para desenvolvedores
206 interagirem com o Subversion.
207
208 %package static
209 Summary:        Static subversion library
210 Summary(pl.UTF-8):      Biblioteka statyczna subversion
211 Summary(pt_BR.UTF-8):   Sistema de versionamento concorrente
212 Group:          Development/Libraries
213 Requires:       %{name}-devel = %{version}
214 Obsoletes:      libsubversion0-static-devel
215
216 %description static
217 Static subversion library.
218
219 %description static -l pl.UTF-8
220 Biblioteka statyczna subversion.
221
222 %description static -l pt_BR.UTF-8
223 Este pacote provê um cliente estático do subversion.
224
225 %package svnserve
226 Summary:        Subversion svnserve
227 Summary(pl.UTF-8):      Subversion svnserve
228 Group:          Networking/Daemons
229 Requires(post,preun):   /sbin/chkconfig
230 Requires(postun):       /usr/sbin/groupdel
231 Requires(postun):       /usr/sbin/userdel
232 Requires(pre):  /bin/id
233 Requires(pre):  /usr/bin/getgid
234 Requires(pre):  /usr/lib/rpm/user_group.sh
235 Requires(pre):  /usr/sbin/groupadd
236 Requires(pre):  /usr/sbin/useradd
237 Requires(pre):  /usr/sbin/usermod
238 Requires:       %{name} = %{version}-%{release}
239 Requires:       rc-scripts
240 Provides:       group(svn)
241 Provides:       user(svn)
242
243 %description svnserve
244 Subversion svnserve server.
245
246 %description svnserve -l pl.UTF-8
247 Serwer subversion svnserve.
248
249 %package tools
250 Summary:        Subversion tools and scripts
251 Summary(pl.UTF-8):      Narzędzia oraz skrypty dla subversion
252 Summary(pt_BR.UTF-8):   Módulos python para acessar os recursos do Subversion
253 Group:          Applications
254 %pyrequires_eq  python
255 Requires:       %{name} = %{version}-%{release}
256 Requires:       python-subversion = %{version}
257
258 %description tools
259 Subversion tools and scripts.
260
261 %description tools -l pl.UTF-8
262 Narzędzia oraz skrypty dla subversion.
263
264 %package -n bash-completion-subversion
265 Summary:        bash completion for subversion
266 Summary(pl.UTF-8):      Dopełnienia basha dla subversion
267 Group:          Applications/Shells
268 Requires:       %{name} = %{version}-%{release}
269 Requires:       bash-completion
270 Conflicts:      %{name}-tools <= 1.1.0-0.rc6.1
271
272 %description -n bash-completion-subversion
273 Bash completion for subversion.
274
275 %description -n bash-completion-subversion -l pl.UTF-8
276 Dopełnienia basha dla subversion.
277
278 %package -n java-subversion
279 Summary:        Subversion Java bindings
280 Summary(pl.UTF-8):      Dowiązania do Subversion dla Javy
281 Group:          Development/Languages/Java
282 Requires:       %{name}-libs = %{version}-%{release}
283
284 %description -n java-subversion
285 This is a set of Java classes which provide the functionality of
286 subversion-libs, the Subversion libraries. It is useful if you want
287 to, for example, write a Java class that manipulates a Subversion
288 repository or working copy. See the 'subversion' package for more
289 information.
290
291 %description -n java-subversion -l pl.UTF-8
292 Ten pakiet zawiera zestaw klas Javy udostępniających funkcjonalność
293 subversion-libs, czyli bibliotek Subversion. Jest przydatny przy
294 pisaniu klas Javy np. modyfikujących repozytorium Subversion lub kopię
295 roboczą. Więcej informacji w pakiecie subversion.
296
297 %package -n python-subversion
298 Summary:        Subversion Python bindings
299 Summary(pl.UTF-8):      Dowiązania do Subversion dla Pythona
300 Summary(pt_BR.UTF-8):   Módulos Python para acessar os recursos do Subversion
301 Group:          Development/Languages/Python
302 %pyrequires_eq  python
303 Requires:       %{name}-libs = %{version}-%{release}
304 Obsoletes:      subversion-python
305
306 %description -n python-subversion
307 Subversion Python bindings.
308
309 %description -n python-subversion -l pl.UTF-8
310 Dowiązania do Subversion dla Pythona.
311
312 %description -n python-subversion -l pt_BR.UTF-8
313 Módulos Python para acessar os recursos do Subversion.
314
315 %package -n python-csvn
316 Summary:        CTypes Subversion Python bindings
317 Summary(pl.UTF-8):      Dowiązania do Subversion dla Pythona
318 Summary(pt_BR.UTF-8):   Módulos Python para acessar os recursos do Subversion
319 Group:          Development/Languages/Python
320 %pyrequires_eq  python
321 Requires:       %{name}-libs = %{version}-%{release}
322
323 %description -n python-csvn
324 Subversion CTypes Python bindings.
325
326 %description -n python-csvn -l pl.UTF-8
327 Dowiązania do Subversion dla Pythona używające CTypes.
328
329 %description -n python-csvn -l pt_BR.UTF-8
330 Módulos Python para acessar os recursos do Subversion.
331
332 %package -n perl-subversion
333 Summary:        Subversion Perl bindings
334 Summary(pl.UTF-8):      Dowiązania do Subversion dla Perla
335 Summary(pt_BR.UTF-8):   Módulos Perl para acessar os recursos do Subversion
336 Group:          Development/Languages/Perl
337 Requires:       %{name}-libs = %{version}-%{release}
338 Obsoletes:      subversion-perl
339
340 %description -n perl-subversion
341 Subversion Perl bindings.
342
343 %description -n perl-subversion -l pl.UTF-8
344 Dowiązania do Subversion dla Perla.
345
346 %description -n perl-subversion -l pt_BR.UTF-8
347 Módulos Perl para acessar os recursos do Subversion.
348
349 %package -n ruby-subversion
350 Summary:        Subversion Ruby bindings
351 Summary(pl.UTF-8):      Dowiązania do Subversion dla języka Ruby
352 Summary(pt_BR.UTF-8):   Módulos Ruby para acessar os recursos do Subversion
353 Group:          Development/Languages
354 Requires:       %{name}-libs = %{version}-%{release}
355 Obsoletes:      subversion-ruby
356
357 %description -n ruby-subversion
358 Subversion Ruby bindings.
359
360 %description -n ruby-subversion -l pl.UTF-8
361 Dowiązania do Subversion dla języka Ruby.
362
363 %description -n ruby-subversion -l pt_BR.UTF-8
364 Módulos Ruby para acessar os recursos do Subversion.
365
366 %package -n apache-mod_dav_svn
367 Summary:        Apache module: Subversion Server
368 Summary(pl.UTF-8):      Moduł apache: Serwer Subversion
369 Group:          Networking/Daemons
370 Requires:       %{name} = %{version}-%{release}
371 Requires:       apache(modules-api) = %apache_modules_api
372 Requires:       apache-mod_dav
373
374 %description -n apache-mod_dav_svn
375 Apache module: Subversion Server.
376
377 %description -n apache-mod_dav_svn -l pl.UTF-8
378 Moduł apache: Serwer Subversion.
379
380 %package -n apache-mod_authz_svn
381 Summary:        Apache module: Subversion Server - path-based authorization
382 Summary(pl.UTF-8):      Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion
383 Group:          Networking/Daemons
384 Requires:       apache(modules-api) = %apache_modules_api
385 Requires:       apache-mod_dav_svn = %{version}-%{release}
386
387 %description -n apache-mod_authz_svn
388 Apache module: Subversion Server - path-based authorization.
389
390 %description -n apache-mod_authz_svn -l pl.UTF-8
391 Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion.
392
393 %package -n gnome-keyring-subversion
394 Summary:        GNOME Keyring authentication provider for Subversion
395 Summary(pl.UTF-8):      Moduł uwierzytelniający GNOME Keyring dla Subversion
396 Group:          X11/Applications
397
398 %description -n gnome-keyring-subversion
399 Authentication provider module for Subversion which allows SVN client
400 to authenticate using GNOME Keyring.
401
402 %description -n gnome-keyring-subversion -l pl.UTF-8
403 Moduł uwierzytelniający dla Subversion pozwalający klientom SVN
404 uwierzytelniać się przy użyciu mechanizmu GNOME Keyring.
405
406 %package -n kde4-kwallet-subversion
407 Summary:        KDE Wallet authentication provider for Subversion
408 Summary(pl.UTF-8):      Moduł uwierzytelniający dla Subversion wykorzystujący Portfel KDE
409 Group:          X11/Applications
410
411 %description -n kde4-kwallet-subversion
412 Authentication provider module for Subversion which allows SVN client
413 to authenticate using KDE Wallet.
414
415 %description -n kde4-kwallet-subversion -l pl.UTF-8
416 Moduł uwierzytelniający dla Subversion pozwalający klientom SVN
417 uwierzytelniać się przy użyciu Portfela KDE.
418
419 %prep
420 %setup -q
421 %patch0 -p0
422 %patch1 -p1
423 %patch2 -p0
424 %patch3 -p1
425
426 sed -i -e 's#serf_prefix/lib#serf_prefix/%{_lib}#g' build/ac-macros/serf.m4
427
428 # serf.m4 macro is broken and ignores --without serf
429 %{?with_neon:sed -i -e 's#serf_found="yes"#serf_found="no"#g' build/ac-macros/serf.m4}
430
431 %build
432 # disabled regeneration - subversion 1.6.13 is not ready for swig 2.0.x
433 #%{__rm} subversion/bindings/swig/proxy/*.swg
434 #cd subversion/bindings/swig && python "%{SOURCE5}" && cd ../../..
435 chmod +x ./autogen.sh && ./autogen.sh
436 %{__libtoolize}
437 %configure \
438         --with-editor=vi \
439         --with-zlib=%{_libdir} \
440         --disable-runtime-module-search \
441         --disable-mod-activation \
442 %if %{with db}
443         --with-berkeley-db="db.h:%{_includedir}:%{_libdir}:db" \
444 %else
445         --without-berkeley-db \
446 %endif
447 %if %{with apache}
448         --with-apxs=%{_sbindir}/apxs \
449 %else
450         --without-apxs \
451 %endif
452 %if %{without swig}
453         --without-swig \
454 %endif
455 %if %{without ruby}
456         ac_cv_path_RUBY=none \
457 %endif
458 %if %{with csvn}
459         --with-ctypesgen=%{_bindir}/ctypesgen.py \
460 %endif
461 %if %{with javahl}
462         --enable-javahl \
463         --with-jdk="%{java_home}" \
464         --without-jikes \
465 %else
466         --disable-javahl \
467 %endif
468 %if %{with neon}
469         --without-serf \
470         --with-neon=%{_prefix} \
471         --disable-neon-version-check \
472 %else
473         --with-serf=%{_prefix} \
474         --without-neon \
475 %endif
476         --with-apr=%{_bindir}/apr-1-config \
477         --with-apr-util=%{_bindir}/apu-1-config \
478 %if %{with kwallet}
479         --with-kwallet \
480 %endif
481 %if %{with gnome}
482         --with-gnome-keyring
483 %endif
484
485 %{__make} -j1
486
487 %if %{with csvn}
488 # Python ctypes bindings
489 %{__make} ctypes-python
490 %endif
491 %if %{with python}
492 # Python swig bindings
493 %{__make} swig-py \
494         swig_pydir=%{py_sitedir}/libsvn \
495         swig_pydir_extra=%{py_sitedir}/svn
496 %endif
497 %if %{with perl}
498 # Perl swig bindings
499 %{__make} -j1 swig-pl-lib
500 cd subversion/bindings/swig/perl/native
501 %{__perl} Makefile.PL INSTALLDIRS=vendor
502 %{__make} -j1
503 cd -
504 %endif
505 %if %{with javahl}
506 %{__make} -j1 javahl \
507         javahl_javadir="%{_javadir}"
508 %endif
509 # ruby
510 %if %{with ruby}
511 %{__make} swig-rb
512 %endif
513
514 %if %{with tests}
515 %{__make} -j1 check
516 %if %{with csvn}
517 %{__make} -j1 check-ctypes-python
518 %endif
519 %if %{with python}
520 %{__make} -j1 check-swig-py
521 %endif
522 %if %{with perl}
523 %{__make} -j1 check-swig-pl
524 %endif
525 %if %{with ruby}
526 # disabled, see https://bugs.launchpad.net/pld-linux/+bug/734340
527 #%{__make} check-swig-rb
528 %endif
529 %endif
530
531 %install
532 rm -rf $RPM_BUILD_ROOT
533 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,bash_completion.d} \
534         $RPM_BUILD_ROOT{%{apacheconfdir},%{apachelibdir},%{_infodir}} \
535         $RPM_BUILD_ROOT%{_examplesdir}/{%{name}-%{version},python-%{name}-%{version}} \
536         $RPM_BUILD_ROOT%{_sysconfdir}/%{name} \
537         $RPM_BUILD_ROOT/home/services/subversion{,/repos}
538
539 %{__make} install -j1 \
540         DESTDIR=$RPM_BUILD_ROOT \
541         APACHE_LIBEXECDIR="$(%{_sbindir}/apxs -q LIBEXECDIR)" \
542 %if %{with javahl}
543         install-javahl \
544         javahl_javadir="%{_javadir}" \
545 %endif
546 %if %{with python}
547         install-swig-py \
548         swig_pydir=%{py_sitedir}/libsvn \
549         swig_pydir_extra=%{py_sitedir}/svn \
550 %endif
551 %if %{with csvn}
552         install-ctypes-python \
553 %endif
554
555 %if %{with ruby}
556 %{__make} install -j1 \
557         DESTDIR=$RPM_BUILD_ROOT \
558         install-swig-rb install-swig-rb-doc \
559
560 # not our package
561 %{__rm} -r $RPM_BUILD_ROOT%{ruby_ridir}/Kernel
562 %{__rm} -r $RPM_BUILD_ROOT%{ruby_ridir}/OptionParser
563 %{__rm} -r $RPM_BUILD_ROOT%{ruby_ridir}/Time
564 %{__rm} -r $RPM_BUILD_ROOT%{ruby_ridir}/Uconv
565 %{__rm} $RPM_BUILD_ROOT%{ruby_ridir}/cache.ri
566 %{__rm} $RPM_BUILD_ROOT%{ruby_ridir}/created.rid
567 %endif
568
569 %if %{with perl}
570 %{__make} install-swig-pl-lib \
571         DESTDIR=$RPM_BUILD_ROOT
572 %{__make} -C subversion/bindings/swig/perl/native install \
573         DESTDIR=$RPM_BUILD_ROOT \
574         PREFIX=$RPM_BUILD_ROOT%{_prefix} \
575         LIBDIR=$RPM_BUILD_ROOT%{_libdir}
576 %endif
577
578 %if %{with apache}
579 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{apacheconfdir}/65_mod_dav_svn.conf
580 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{apacheconfdir}/66_mod_authz_svn.conf
581 cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/svnserve
582 install -p %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/svnserve
583 %endif
584
585 %if %{without net_client_only}
586 install -p tools/backup/hot-backup.py $RPM_BUILD_ROOT%{_bindir}/svn-hot-backup
587 %endif
588 %if %{with python} || %{with csvn}
589 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
590 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
591 %py_postclean
592 %endif
593 %if %{with python}
594 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/libsvn/*.la
595 # .a created on ac only
596 %{__rm} -f $RPM_BUILD_ROOT%{py_sitedir}/libsvn/*.a
597 cp -p tools/examples/*.py $RPM_BUILD_ROOT%{_examplesdir}/python-%{name}-%{version}
598 %endif
599
600 cp -p tools/client-side/bash_completion $RPM_BUILD_ROOT/etc/bash_completion.d/%{name}
601 cp -p tools/examples/*.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
602
603 %if %{with javahl}
604 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libsvnjavahl*.{la,a}
605 %endif
606 %if %{with swig}
607 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libsvn_swig*.{la,a}
608 %if %{with ruby}
609 %{__rm} $RPM_BUILD_ROOT%{_libdir}/ruby/site_ruby/*/*/svn/ext/*.la
610 %endif
611 %endif
612 %if %{with gnome} || %{with kwallet}
613 # dlopened by soname (libsvn_auth_*-1.so.0)
614 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libsvn_auth_*-1.{so,la,a}
615 %endif
616
617 %find_lang %{name}
618
619 %clean
620 rm -rf $RPM_BUILD_ROOT
621
622 %pre svnserve
623 %groupadd -g 86 svn
624 %useradd -u 180 -d /home/services/subversion -c "Subversion svnserve" -g svn svn
625
626 %post   libs -p /sbin/ldconfig
627 %postun libs -p /sbin/ldconfig
628
629 %post   devel -p /sbin/postshell
630 -/usr/sbin/fix-info-dir -c %{_infodir}
631
632 %postun devel -p /sbin/postshell
633 -/usr/sbin/fix-info-dir -c %{_infodir}
634
635 %post   -n java-subversion -p /sbin/ldconfig
636 %postun -n java-subversion -p /sbin/ldconfig
637
638 %post   -n perl-subversion -p /sbin/ldconfig
639 %postun -n perl-subversion -p /sbin/ldconfig
640
641 %post   -n python-subversion -p /sbin/ldconfig
642 %postun -n python-subversion -p /sbin/ldconfig
643
644 %post   -n ruby-subversion -p /sbin/ldconfig
645 %postun -n ruby-subversion -p /sbin/ldconfig
646
647 %post   -n gnome-keyring-subversion -p /sbin/ldconfig
648 %postun -n gnome-keyring-subversion -p /sbin/ldconfig
649
650 %post   -n kde4-kwallet-subversion -p /sbin/ldconfig
651 %postun -n kde4-kwallet-subversion -p /sbin/ldconfig
652
653 %post svnserve
654 /sbin/chkconfig --add svnserve
655 %service svnserve restart "svnserve daemon"
656
657 %preun svnserve
658 if [ "$1" = "0" ]; then
659         %service svnserve stop
660         /sbin/chkconfig --del svnserve
661 fi
662
663 %postun svnserve
664 if [ "$1" = "0" ]; then
665         %userremove svn
666         %groupremove svn
667 fi
668
669 %post -n apache-mod_dav_svn
670 %service -q httpd restart
671
672 %postun -n apache-mod_dav_svn
673 if [ "$1" = "0" ]; then
674         %service -q httpd restart
675 fi
676
677 %post -n apache-mod_authz_svn
678 %service -q httpd restart
679
680 %postun -n apache-mod_authz_svn
681 if [ "$1" = "0" ]; then
682         %service -q httpd restart
683 fi
684
685 %files
686 %defattr(644,root,root,755)
687 %doc BUGS CHANGES INSTALL README
688 %doc doc/*/*.html
689 %doc tools/hook-scripts/*.{pl,py,example}
690 %doc tools/hook-scripts/mailer/*.{py,example}
691 %doc tools/xslt/*
692 %attr(755,root,root) %{_bindir}/svn
693 %attr(755,root,root) %{_bindir}/svnadmin
694 %attr(755,root,root) %{_bindir}/svndumpfilter
695 %attr(755,root,root) %{_bindir}/svnrdump
696 %attr(755,root,root) %{_bindir}/svnlook
697 %attr(755,root,root) %{_bindir}/svnsync
698 %attr(755,root,root) %{_bindir}/svnversion
699 %{_mandir}/man1/svn.1*
700 %{_mandir}/man1/svnadmin.1*
701 %{_mandir}/man1/svndumpfilter.1*
702 %{_mandir}/man1/svnrdump.1*
703 %{_mandir}/man1/svnlook.1*
704 %{_mandir}/man1/svnsync.1*
705 %{_mandir}/man1/svnversion.1*
706
707 %files libs -f %{name}.lang
708 %defattr(644,root,root,755)
709 %dir %{_sysconfdir}/%{name}
710 %attr(755,root,root) %{_libdir}/libsvn_client-1.so.*.*.*
711 %attr(755,root,root) %ghost %{_libdir}/libsvn_client-1.so.0
712 %attr(755,root,root) %{_libdir}/libsvn_delta-1.so.*.*.*
713 %attr(755,root,root) %ghost %{_libdir}/libsvn_delta-1.so.0
714 %attr(755,root,root) %{_libdir}/libsvn_diff-1.so.*.*.*
715 %attr(755,root,root) %ghost %{_libdir}/libsvn_diff-1.so.0
716 %attr(755,root,root) %{_libdir}/libsvn_fs-1.so.*.*.*
717 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs-1.so.0
718 %if %{without net_client_only}
719 %attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so.*.*.*
720 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_base-1.so.0
721 %endif
722 %attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so.*.*.*
723 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_fs-1.so.0
724 %attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so.*.*.*
725 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_util-1.so.0
726 %attr(755,root,root) %{_libdir}/libsvn_ra-1.so.*.*.*
727 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra-1.so.0
728 %attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so.*.*.*
729 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_local-1.so.0
730 %attr(755,root,root) %{_libdir}/libsvn_ra_%{webdavlib}-1.so.*.*.*
731 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_%{webdavlib}-1.so.0
732 %attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so.*.*.*
733 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_svn-1.so.0
734 %attr(755,root,root) %{_libdir}/libsvn_repos-1.so.*.*.*
735 %attr(755,root,root) %ghost %{_libdir}/libsvn_repos-1.so.0
736 %attr(755,root,root) %{_libdir}/libsvn_subr-1.so.*.*.*
737 %attr(755,root,root) %ghost %{_libdir}/libsvn_subr-1.so.0
738 %attr(755,root,root) %{_libdir}/libsvn_wc-1.so.*.*.*
739 %attr(755,root,root) %ghost %{_libdir}/libsvn_wc-1.so.0
740
741 %files devel
742 %defattr(644,root,root,755)
743 %attr(755,root,root) %{_libdir}/libsvn_client-1.so
744 %attr(755,root,root) %{_libdir}/libsvn_delta-1.so
745 %attr(755,root,root) %{_libdir}/libsvn_diff-1.so
746 %attr(755,root,root) %{_libdir}/libsvn_fs-1.so
747 %if %{without net_client_only}
748 %attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so
749 %endif
750 %attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so
751 %attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so
752 %attr(755,root,root) %{_libdir}/libsvn_ra-1.so
753 %attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so
754 %attr(755,root,root) %{_libdir}/libsvn_ra_%{webdavlib}-1.so
755 %attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so
756 %attr(755,root,root) %{_libdir}/libsvn_repos-1.so
757 %attr(755,root,root) %{_libdir}/libsvn_subr-1.so
758 %attr(755,root,root) %{_libdir}/libsvn_wc-1.so
759 %{_libdir}/libsvn_client-1.la
760 %{_libdir}/libsvn_delta-1.la
761 %{_libdir}/libsvn_diff-1.la
762 %{_libdir}/libsvn_fs-1.la
763 %if %{without net_client_only}
764 %{_libdir}/libsvn_fs_base-1.la
765 %endif
766 %{_libdir}/libsvn_fs_fs-1.la
767 %{_libdir}/libsvn_fs_util-1.la
768 %{_libdir}/libsvn_ra-1.la
769 %{_libdir}/libsvn_ra_local-1.la
770 %{_libdir}/libsvn_ra_%{webdavlib}-1.la
771 %{_libdir}/libsvn_ra_svn-1.la
772 %{_libdir}/libsvn_repos-1.la
773 %{_libdir}/libsvn_subr-1.la
774 %{_libdir}/libsvn_wc-1.la
775 %{_includedir}/%{name}-1
776 %{_examplesdir}/%{name}-%{version}
777
778 %files static
779 %defattr(644,root,root,755)
780 %{_libdir}/libsvn_client-1.a
781 %{_libdir}/libsvn_delta-1.a
782 %{_libdir}/libsvn_diff-1.a
783 %{_libdir}/libsvn_fs-1.a
784 %if %{without net_client_only}
785 %{_libdir}/libsvn_fs_base-1.a
786 %endif
787 %{_libdir}/libsvn_fs_fs-1.a
788 %{_libdir}/libsvn_fs_util-1.a
789 %{_libdir}/libsvn_ra-1.a
790 %{_libdir}/libsvn_ra_local-1.a
791 %{_libdir}/libsvn_ra_%{webdavlib}-1.a
792 %{_libdir}/libsvn_ra_svn-1.a
793 %{_libdir}/libsvn_repos-1.a
794 %{_libdir}/libsvn_subr-1.a
795 %{_libdir}/libsvn_wc-1.a
796
797 %if %{with gnome}
798 %files -n gnome-keyring-subversion
799 %defattr(644,root,root,755)
800 %attr(755,root,root) %{_libdir}/libsvn_auth_gnome_keyring-1.so.*.*.*
801 %attr(755,root,root) %ghost %{_libdir}/libsvn_auth_gnome_keyring-1.so.0
802 %endif
803
804 %if %{with kwallet}
805 %files -n kde4-kwallet-subversion
806 %defattr(644,root,root,755)
807 %attr(755,root,root) %{_libdir}/libsvn_auth_kwallet-1.so.*.*.*
808 %attr(755,root,root) %ghost %{_libdir}/libsvn_auth_kwallet-1.so.0
809 %endif
810
811 %if %{without net_client_only}
812 %files svnserve
813 %defattr(644,root,root,755)
814 %attr(755,root,root) %{_bindir}/svnserve
815 %{_mandir}/man5/svnserve.conf.5*
816 %{_mandir}/man8/svnserve.8*
817 %dir %attr(750,svn,svn) /home/services/subversion
818 %dir %attr(750,svn,svn) /home/services/subversion/repos
819 %if %{with apache}
820 %attr(754,root,root) /etc/rc.d/init.d/svnserve
821 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/svnserve
822 %endif
823
824 %files tools
825 %defattr(644,root,root,755)
826 %attr(755,root,root) %{_bindir}/svn-hot-backup
827
828 %files -n bash-completion-subversion
829 %defattr(644,root,root,755)
830 /etc/bash_completion.d/%{name}
831
832 %endif # net_client_only
833
834 %if %{with javahl}
835 %files -n java-subversion
836 %defattr(644,root,root,755)
837 %attr(755,root,root) %{_libdir}/libsvnjavahl-1.so.*.*.*
838 %attr(755,root,root) %ghost %{_libdir}/libsvnjavahl-1.so.0
839 %attr(755,root,root) %{_libdir}/libsvnjavahl-1.so
840 %{_javadir}/svn-javahl.jar
841 %endif
842
843 %if %{with python}
844 %files -n python-subversion
845 %defattr(644,root,root,755)
846 %doc tools/backup/*.py
847 %attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so.*.*.*
848 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_py-1.so.0
849 %attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so
850 %dir %{py_sitedir}/libsvn
851 %attr(755,root,root) %{py_sitedir}/libsvn/_*.so
852 %{py_sitedir}/libsvn/*.py[co]
853 %dir %{py_sitedir}/svn
854 %{py_sitedir}/svn/*.py[co]
855 %{_examplesdir}/python-%{name}-%{version}
856 %endif
857
858 %if %{with csvn}
859 %files -n python-csvn
860 %defattr(644,root,root,755)
861 %doc subversion/bindings/ctypes-python/{README,TODO}
862 %doc subversion/bindings/ctypes-python/examples/*.py
863 %dir %{py_sitescriptdir}/csvn
864 %{py_sitescriptdir}/csvn/*.py[co]
865 %dir %{py_sitescriptdir}/csvn/core
866 %{py_sitescriptdir}/csvn/core/*.py[co]
867 %dir %{py_sitescriptdir}/csvn/ext
868 %{py_sitescriptdir}/csvn/ext/*.py[co]
869 %{py_sitescriptdir}/svn_ctypes_python_bindings-0.1-py*.egg-info
870 %endif
871
872 %if %{with perl}
873 %files -n perl-subversion
874 %defattr(644,root,root,755)
875 %attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so.*.*.*
876 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_perl-1.so.0
877 %attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so
878 %{perl_vendorarch}/SVN
879 %dir %{perl_vendorarch}/auto/SVN
880 %dir %{perl_vendorarch}/auto/SVN/*
881 %attr(755,root,root) %{perl_vendorarch}/auto/SVN/*/*.so
882 %{perl_vendorarch}/auto/SVN/*/*.bs
883 %{_mandir}/man3/*.3pm*
884 %endif
885
886 %if %{with ruby}
887 %files -n ruby-subversion
888 %defattr(644,root,root,755)
889 %attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so.*.*.*
890 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_ruby-1.so.0
891 %attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so
892 %dir %{ruby_sitelibdir}/svn
893 %{ruby_sitelibdir}/svn/*.rb
894 %dir %{ruby_sitearchdir}/svn
895 %dir %{ruby_sitearchdir}/svn/ext
896 %attr(755,root,root) %{ruby_sitearchdir}/svn/ext/*.so
897 %{ruby_ridir}/Svn
898 %endif
899
900 %if %{with apache}
901 %files -n apache-mod_dav_svn
902 %defattr(644,root,root,755)
903 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_dav_svn.conf
904 %attr(755,root,root) %{apachelibdir}/mod_dav_svn.so
905
906 %files -n apache-mod_authz_svn
907 %defattr(644,root,root,755)
908 %doc subversion/mod_authz_svn/INSTALL
909 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_authz_svn.conf
910 %attr(755,root,root) %{apachelibdir}/mod_authz_svn.so
911 %endif
This page took 0.149814 seconds and 4 git commands to generate.