]> git.pld-linux.org Git - packages/subversion.git/blob - subversion.spec
- updated to 0.14.3-r3252
[packages/subversion.git] / subversion.spec
1 %define repov   3252
2 %include        /usr/lib/rpm/macros.python
3 Summary:        A Concurrent Versioning system similar to but better than CVS
4 Summary(pl):    System kontroli wersji ale lepszy ni¿ CVS
5 Name:           subversion
6 Version:        0.14.3
7 Release:        r%{repov}.0
8 License:        Apache/BSD Style
9 Group:          Development/Version Control
10 Source0:        svn://svn.collab.net/repos/svn/trunk/%{name}-r%{repov}.tar.gz
11 Source1:        %{name}-dav_svn.conf
12 Patch0:         %{name}-lib.patch
13 Patch1:         %{name}-python.patch
14 URL:            http://subversion.tigris.org/
15 BuildRequires:  apache-devel >= 2.0.42
16 BuildRequires:  apr-devel >= 2.0.42
17 BuildRequires:  autoconf >= 2.53
18 BuildRequires:  bison
19 BuildRequires:  db4-devel >= 4.0.14
20 BuildRequires:  expat-devel
21 BuildRequires:  libtool >= 1.4-9
22 BuildRequires:  neon-devel >= 0.23.4
23 BuildRequires:  python >= 2.2
24 BuildRequires:  rpm-pythonprov >= 4.0.2-50
25 BuildRequires:  swig >= 1.3.15
26 BuildRequires:  texinfo
27 Requires(post): /usr/sbin/fix-info-dir
28 Requires(postun):       /usr/sbin/fix-info-dir
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %define         _apachelibdir   /usr/lib/apache
32 %define         _libexecdir     %{_libdir}/svn
33
34 %description
35 The goal of the Subversion project is to build a version control
36 system that is a compelling replacement for CVS in the open source
37 community.
38
39 Our goals are:
40 - All current CVS features.
41 - Directories, renames, and file meta-data are versioned.
42 - Symbolic links, etc, are supported
43 - Commits are truly atomic.
44 - Branching and tagging are cheap (constant time) operations
45 - Repeated merges are handled gracefully
46 - Support for plug-in client side diff programs
47 - Natively client/server
48 - Client/server protocol sends diffs in both directions
49 - Costs are proportional to change size, not project size
50 - Internationalization
51 - Progressive multi-lingual support
52
53 %description -l pl
54 Celem projektu Subversion jest stworzenie systemu kontroli wersji jako
55 zamiennika dla CVS.
56
57 Cele projektu to:
58 - Wszystkie aktualne mo¿liwo¶ci CVS.
59 - Katalogi, zmiany nazw oraz meta-dane plików s± wersjonowane.
60 - Wsparcie dla linków symbolicznych itp.
61 - Commity s± w pe³ni atomowe.
62 - Branchowanie oraz tagowanie s± tanimi (sta³ymi w czasie) operacjami.
63 - Powtarzaj±ce merge.
64 - Wsparcie dla pluginów diff'a po stronie klienta.
65 - Natywny klient/serwer.
66 - Klient/Serwer przesy³aj± diffy w obu kierunkach.
67 - Koszty proporcjonalne do rozmiaru zmiany, a nie rozmiaru projektu.
68 - Internacjonalizacja.
69 - Postêpuj±ce wsparcie dla wielu jêzyków.
70
71 %package libs
72 Summary:        Subversion libraries and modules
73 Summary(pl):    Biblioteka subversion oraz ³adowalne modu³y
74 Group:          Libraries
75
76 %description libs
77 Subversion libraries and modules.
78
79 %description libs -l pl
80 Biblioteka subversion oraz ³adowalne modu³y.
81
82 %package devel
83 Summary:        Header files and develpment documentation for subversion
84 Summary(pl):    Pliki nag³ówkowe i dokumetacja do subversion
85 Group:          Development/Libraries
86 Requires:       %{name}-libs = %{version}
87
88 %description devel
89 Header files and develpment documentation for subversion.
90
91 %description devel -l pl
92 Pliki nag³ówkowe i dokumetacja do subversion.
93
94 %package static
95 Summary:        Static subversion library
96 Summary(pl):    Biblioteka statyczna subversion
97 Group:          Development/Libraries
98 Requires:       %{name}-devel = %{version}
99
100 %description static
101 Static subversion library.
102
103 %description static -l pl
104 Biblioteka statyczna subversion.
105
106 %package -n python-subversion
107 Summary:        Subversion python bindings
108 Summary(pl):    Dowi±zania do subversion dla pythona
109 Group:          Development/Languages/Python
110 Requires:       python >= 2.2
111 Obsoletes:      subversion-python
112 %pyrequires_eq  python
113
114 %description -n python-subversion
115 Subversion python bindings.
116
117 %description -n python-subversion -l pl
118 Dowi±zania do subversion dla pythona.
119
120 %package -n apache-mod_dav_svn
121 Summary:        Apache module: Subversion Server
122 Summary(pl):    Modu³ apache: Serwer Subversion
123 Group:          Networking/Daemons
124 %requires_eq    apache
125 %requires_eq    apache-mod_dav
126
127 %description -n apache-mod_dav_svn
128 Apache module: Subversion Server.
129
130 %description -n apache-mod_dav_svn
131 Modu³ apache: Serwer Subversion.
132
133 %prep
134 %setup -q -n %{name}-r%{repov}
135 %patch0 -p1
136 %patch1 -p1
137
138 %build
139 chmod +x ./autogen.sh && ./autogen.sh
140 # don't enable dso - currently it's broken
141 %configure \
142         --disable-dso \
143         --disable-mod-activation \
144         --with-neon=%{_prefix} \
145         --with-apr=%{_bindir}/apr-config \
146         --with-apr-util=%{_bindir}/apu-config \
147         --with-apxs=%{_sbindir}/apxs \
148         --with-berkeley-db=%{_includedir}/db4:%{_libdir}
149 %{__make}
150
151 cd subversion/bindings/swig/python
152 CFLAGS="%{rpmcflags}" python setup.py build
153
154 %install
155 rm -rf $RPM_BUILD_ROOT
156 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/httpd/httpd.conf,%{_apachelibdir}}
157
158 %{__make} install \
159         INSTALL_MOD_SHARED=echo \
160         DESTDIR=$RPM_BUILD_ROOT
161
162 install subversion/mod_dav_svn/.libs/*.so $RPM_BUILD_ROOT%{_apachelibdir}
163 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd/httpd.conf/65_mod_dav_svn.conf
164
165 cd subversion/bindings/swig/python
166 python setup.py install --root=$RPM_BUILD_ROOT
167
168 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
169 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
170
171 %post
172 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
173
174 %postun
175 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
176
177 %post libs -p /sbin/ldconfig
178 %postun libs -p /sbin/ldconfig
179
180 %post -n apache-mod_dav_svn
181 if [ -f /var/lock/subsys/httpd ]; then
182         /etc/rc.d/init.d/httpd restart 1>&2
183 else
184         echo "Run \"/etc/rc.d/init.d/httpd start\" to start apache http daemon."
185 fi
186
187 %preun -n apache-mod_dav_svn
188 if [ "$1" = "0" ]; then
189         if [ -f /var/lock/subsys/httpd ]; then
190                 /etc/rc.d/init.d/httpd restart 1>&2
191         fi
192 fi
193
194 %clean
195 rm -rf $RPM_BUILD_ROOT
196
197 %files
198 %defattr(644,root,root,755)
199 %doc  BUGS CHANGES IDEAS INSTALL README
200 %attr(755,root,root) %{_bindir}/svn*
201 %exclude %{_bindir}/svn-config
202 %{_mandir}/man1/*
203 %{_infodir}/svn*
204
205 %files libs
206 %defattr(644,root,root,755)
207 %attr(755,root,root) %{_libdir}/lib*.so.*
208
209 %files devel
210 %defattr(644,root,root,755)
211 %{_includedir}/%{name}*
212 %attr(755,root,root) %{_bindir}/svn-config
213 %attr(755,root,root) %{_libdir}/lib*.so
214 %attr(755,root,root) %{_libdir}/lib*.la
215
216 %files static
217 %defattr(644,root,root,755)
218 %{_libdir}/lib*.a
219
220 %files -n python-subversion
221 %defattr(644,root,root,755)
222 %doc tools/backup tools/cvs2svn/*.py tools/examples/*.py
223 %dir %{py_sitedir}/svn
224 %{py_sitedir}/svn/*.py[co]
225 %attr(755,root,root) %{py_sitedir}/svn/*.so
226
227 %files -n apache-mod_dav_svn
228 %defattr(644,root,root,755)
229 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/httpd/httpd.conf/*_mod_dav_svn.conf
230 %attr(755,root,root) %{_apachelibdir}/*.so
This page took 0.066656 seconds and 3 git commands to generate.