]> git.pld-linux.org Git - packages/subversion.git/blob - subversion.spec
c8b03951351d8971adac1c04129ce7de57071f27
[packages/subversion.git] / subversion.spec
1 # Conditional build:
2 %bcond_with     net_client_only         # build only net client
3 %bcond_without  swig                    # disable bindings generation with Swig
4 %bcond_without  python                  # build without Python bindings (broken)
5 %bcond_without  csvn                    # build Python csvn bindings
6 %bcond_without  perl                    # build without Perl bindings
7 %bcond_without  ruby                    # build without Ruby bindings
8 %bcond_without  apache                  # build without Apache support (webdav, etc)
9 %bcond_without  javahl                  # build without javahl support (Java high-level bindings)
10 %bcond_without  tests                   # don't perform "make check"
11 %bcond_without  kwallet                 # build without kde4 wallet support
12 %bcond_without  kde                     # build without kde4 support (alias for kwallet)
13 %bcond_without  gnome                   # build without gnome keyring support
14 %bcond_without  db                      # disable Subversion Berkeley DB based filesystem library
15 %bcond_with     db6                     # allow BDB6 (not tested by upstream, released on AGPL)
16
17 # for AC: --without csvn,gnome,javahl,kde,ruby
18
19 %if %{with net_client_only}
20 %undefine       with_apache
21 %undefine       with_db
22 %undefine       with_swig
23 %undefine       with_javahl
24 %endif
25
26 %if %{without swig}
27 %undefine       with_perl
28 %undefine       with_python
29 %undefine       with_ruby
30 %endif
31
32 %if %{without kde}
33 %undefine       with_kwallet
34 %endif
35
36 %if %{without python} && %{without perl} && %{without ruby}
37 %undefine       with_swig
38 %endif
39
40 %define apxs    /usr/sbin/apxs
41 %define pdir    SVN
42 %define pnam    _Core
43
44 %{?with_perl:%include   /usr/lib/rpm/macros.perl}
45 Summary:        A Concurrent Versioning system similar to but better than CVS
46 Summary(pl.UTF-8):      System kontroli wersji podobny, ale lepszy, niż CVS
47 Summary(pt_BR.UTF-8):   Sistema de versionamento concorrente
48 Name:           subversion
49 Version:        1.8.4
50 Release:        1
51 License:        Apache v2.0
52 Group:          Development/Version Control
53 Source0:        http://www.apache.org/dist/subversion/%{name}-%{version}.tar.bz2
54 # Source0-md5:  a73a5caad3c442fe88e1f9c0e794d212
55 Source1:        %{name}-dav_svn.conf
56 Source2:        %{name}-authz_svn.conf
57 Source3:        %{name}-svnserve.init
58 Source4:        %{name}-svnserve.sysconfig
59 # current subversion tarball has correct *.swg files
60 # but after regeneration these are broken again, so
61 # we still need this script
62 Source5:        %{name}-convert-typemaps-to-ifdef.py
63 Patch0:         %{name}-home_etc.patch
64 Patch1:         %{name}-DESTDIR.patch
65 Patch2:         %{name}-ruby-datadir-path.patch
66 Patch3:         %{name}-tests.patch
67 URL:            http://subversion.apache.org/
68 %{?with_apache:BuildRequires:   apache-devel >= 2.2.0-8}
69 BuildRequires:  apr-devel >= 1:1.0.0
70 BuildRequires:  apr-util-devel >= 1:1.2.8-3
71 BuildRequires:  autoconf >= 2.59
72 BuildRequires:  automake
73 BuildRequires:  bison
74 BuildRequires:  cyrus-sasl-devel
75 %if %{with kwallet} || %{with gnome}
76 BuildRequires:  dbus-devel
77 %endif
78 BuildRequires:  db-devel >= 4.1.25
79 BuildRequires:  expat-devel
80 BuildRequires:  gettext-devel
81 %{?with_kwallet:BuildRequires:  kde4-kdelibs-devel}
82 %{?with_gnome:BuildRequires:    libgnome-keyring-devel}
83 BuildRequires:  libmagic-devel
84 BuildRequires:  libtool >= 1.4-9
85 BuildRequires:  pkgconfig
86 %{?with_csvn:BuildRequires:     python-ctypesgen}
87 BuildRequires:  rpm-pythonprov
88 BuildRequires:  rpmbuild(macros) >= 1.656
89 BuildRequires:  sed >= 4.0
90 BuildRequires:  sqlite3-devel >= 3.6.18
91 BuildRequires:  texinfo
92 BuildRequires:  which
93 BuildRequires:  serf-devel >= 1.2.1
94 %if %{with javahl}
95 BuildRequires:  jdk >= 1.5
96 BuildRequires:  libstdc++-devel
97 %endif
98 %if %{with perl}
99 BuildRequires:  perl-devel >= 1:5.8.0
100 BuildRequires:  rpm-perlprov >= 4.1-13
101 BuildRequires:  swig-perl >= 1.3.24
102 %endif
103 %if %{with python}
104 BuildRequires:  python-devel >= 1:2.4
105 BuildRequires:  swig-python >= 1.3.24
106 %endif
107 %if %{with ruby}
108 BuildRequires:  rpm-rubyprov
109 BuildRequires:  ruby-devel >= 1:1.8.2
110 BuildRequires:  ruby-irb
111 BuildRequires:  ruby-rubygems
112 BuildRequires:  swig-ruby >= 1.3.24
113 %endif
114 Requires:       %{name}-libs = %{version}-%{release}
115 %requires_ge    sqlite3
116 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
117
118 %define         _libexecdir             %{_libdir}/svn
119 %define         apacheconfdir   %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
120 %define         apachelibdir    %(%{apxs} -q LIBEXECDIR 2>/dev/null)
121
122 %define         skip_post_check_so      libsvn_swig_py-1.so.* libsvn_swig_perl-1.so.*
123
124 %description
125 The goal of the Subversion project is to build a version control
126 system that is a compelling replacement for CVS in the open source
127 community.
128
129 Our goals are:
130 - All current CVS features.
131 - Directories, renames, and file meta-data are versioned.
132 - Symbolic links, etc, are supported
133 - Commits are truly atomic.
134 - Branching and tagging are cheap (constant time) operations
135 - Repeated merges are handled gracefully
136 - Support for plug-in client side diff programs
137 - Natively client/server
138 - Client/server protocol sends diffs in both directions
139 - Costs are proportional to change size, not project size
140 - Internationalization
141 - Progressive multi-lingual support
142
143 %description -l pl.UTF-8
144 Celem projektu Subversion jest stworzenie systemu kontroli wersji jako
145 zamiennika dla CVS.
146
147 Cele projektu to:
148 - Wszystkie aktualne możliwości CVS.
149 - Katalogi, zmiany nazw oraz metadane plików są wersjonowane.
150 - Obsługa dowiązań symbolicznych itp.
151 - Commity są w pełni atomowe.
152 - Branchowanie oraz tagowanie są tanimi (stałymi w czasie) operacjami.
153 - Dobra obsługa powtarzanego łączenia (merge).
154 - Obsługa wtyczek diff po stronie klienta.
155 - Natywny klient/serwer.
156 - Klient/Serwer przesyłają diffy w obu kierunkach.
157 - Koszty proporcjonalne do rozmiaru zmiany, a nie rozmiaru projektu.
158 - Internacjonalizacja.
159 - Postępujące wsparcie dla wielu języków.
160
161 %description -l pt_BR.UTF-8
162 O objetivo do projeto Subversion é construir um sistema de controle de
163 versões que seja um substituto para o CVS (Concurrent Versioning
164 System) na comunidade opensource, fornecendo grandes melhorias.
165
166 %package libs
167 Summary:        Subversion libraries and modules
168 Summary(pl.UTF-8):      Biblioteka subversion oraz ładowalne moduły
169 Group:          Libraries
170 Requires:       serf >= 1.2.1
171 Obsoletes:      libsubversion0
172
173 %description libs
174 Subversion libraries and modules.
175
176 %description libs -l pl.UTF-8
177 Biblioteka subversion oraz ładowalne moduły.
178
179 %package devel
180 Summary:        Header files and develpment documentation for subversion
181 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumetacja do subversion
182 Summary(pt_BR.UTF-8):   Arquivos de desenvolvimento para o Subversion
183 Group:          Development/Libraries
184 Requires:       %{name}-libs = %{version}-%{release}
185 Requires:       apr-util-devel >= 1:1.0.0
186 Obsoletes:      libsubversion0-devel
187
188 %description devel
189 Header files and develpment documentation for subversion.
190
191 %description devel -l pl.UTF-8
192 Pliki nagłówkowe i dokumetacja do subversion.
193
194 %description devel -l pt_BR.UTF-8
195 Este pacote provê os arquivos necessários para desenvolvedores
196 interagirem com o Subversion.
197
198 %package static
199 Summary:        Static subversion library
200 Summary(pl.UTF-8):      Biblioteka statyczna subversion
201 Summary(pt_BR.UTF-8):   Sistema de versionamento concorrente
202 Group:          Development/Libraries
203 Requires:       %{name}-devel = %{version}
204 Obsoletes:      libsubversion0-static-devel
205
206 %description static
207 Static subversion library.
208
209 %description static -l pl.UTF-8
210 Biblioteka statyczna subversion.
211
212 %description static -l pt_BR.UTF-8
213 Este pacote provê um cliente estático do subversion.
214
215 %package svnserve
216 Summary:        Subversion svnserve
217 Summary(pl.UTF-8):      Subversion svnserve
218 Group:          Networking/Daemons
219 Requires(post,preun):   /sbin/chkconfig
220 Requires(postun):       /usr/sbin/groupdel
221 Requires(postun):       /usr/sbin/userdel
222 Requires(pre):  /bin/id
223 Requires(pre):  /usr/bin/getgid
224 Requires(pre):  /usr/lib/rpm/user_group.sh
225 Requires(pre):  /usr/sbin/groupadd
226 Requires(pre):  /usr/sbin/useradd
227 Requires(pre):  /usr/sbin/usermod
228 Requires:       %{name} = %{version}-%{release}
229 Requires:       rc-scripts
230 Provides:       group(svn)
231 Provides:       user(svn)
232
233 %description svnserve
234 Subversion svnserve server.
235
236 %description svnserve -l pl.UTF-8
237 Serwer subversion svnserve.
238
239 %package tools
240 Summary:        Subversion tools and scripts
241 Summary(pl.UTF-8):      Narzędzia oraz skrypty dla subversion
242 Summary(pt_BR.UTF-8):   Módulos python para acessar os recursos do Subversion
243 Group:          Applications
244 Requires:       %{name} = %{version}-%{release}
245 Requires:       python
246 Requires:       python-subversion = %{version}
247
248 %description tools
249 Subversion tools and scripts.
250
251 %description tools -l pl.UTF-8
252 Narzędzia oraz skrypty dla subversion.
253
254 %package -n bash-completion-subversion
255 Summary:        bash completion for subversion
256 Summary(pl.UTF-8):      Dopełnienia basha dla subversion
257 Group:          Applications/Shells
258 Requires:       %{name} = %{version}-%{release}
259 Requires:       bash-completion
260 Conflicts:      %{name}-tools <= 1.1.0-0.rc6.1
261
262 %description -n bash-completion-subversion
263 Bash completion for subversion.
264
265 %description -n bash-completion-subversion -l pl.UTF-8
266 Dopełnienia basha dla subversion.
267
268 %package -n java-subversion
269 Summary:        Subversion Java bindings
270 Summary(pl.UTF-8):      Dowiązania do Subversion dla Javy
271 Group:          Development/Languages/Java
272 Requires:       %{name}-libs = %{version}-%{release}
273
274 %description -n java-subversion
275 This is a set of Java classes which provide the functionality of
276 subversion-libs, the Subversion libraries. It is useful if you want
277 to, for example, write a Java class that manipulates a Subversion
278 repository or working copy. See the 'subversion' package for more
279 information.
280
281 %description -n java-subversion -l pl.UTF-8
282 Ten pakiet zawiera zestaw klas Javy udostępniających funkcjonalność
283 subversion-libs, czyli bibliotek Subversion. Jest przydatny przy
284 pisaniu klas Javy np. modyfikujących repozytorium Subversion lub kopię
285 roboczą. Więcej informacji w pakiecie subversion.
286
287 %package -n python-subversion
288 Summary:        Subversion Python bindings
289 Summary(pl.UTF-8):      Dowiązania do Subversion dla Pythona
290 Summary(pt_BR.UTF-8):   Módulos Python para acessar os recursos do Subversion
291 Group:          Development/Languages/Python
292 Requires:       %{name}-libs = %{version}-%{release}
293 Requires:       python
294 Obsoletes:      subversion-python
295
296 %description -n python-subversion
297 Subversion Python bindings.
298
299 %description -n python-subversion -l pl.UTF-8
300 Dowiązania do Subversion dla Pythona.
301
302 %description -n python-subversion -l pt_BR.UTF-8
303 Módulos Python para acessar os recursos do Subversion.
304
305 %package -n python-csvn
306 Summary:        CTypes Subversion Python bindings
307 Summary(pl.UTF-8):      Dowiązania do Subversion dla Pythona
308 Summary(pt_BR.UTF-8):   Módulos Python para acessar os recursos do Subversion
309 Group:          Development/Languages/Python
310 Requires:       %{name}-libs = %{version}-%{release}
311 Requires:       python
312
313 %description -n python-csvn
314 Subversion CTypes Python bindings.
315
316 %description -n python-csvn -l pl.UTF-8
317 Dowiązania do Subversion dla Pythona używające CTypes.
318
319 %description -n python-csvn -l pt_BR.UTF-8
320 Módulos Python para acessar os recursos do Subversion.
321
322 %package -n perl-subversion
323 Summary:        Subversion Perl bindings
324 Summary(pl.UTF-8):      Dowiązania do Subversion dla Perla
325 Summary(pt_BR.UTF-8):   Módulos Perl para acessar os recursos do Subversion
326 Group:          Development/Languages/Perl
327 Requires:       %{name}-libs = %{version}-%{release}
328 Obsoletes:      subversion-perl
329
330 %description -n perl-subversion
331 Subversion Perl bindings.
332
333 %description -n perl-subversion -l pl.UTF-8
334 Dowiązania do Subversion dla Perla.
335
336 %description -n perl-subversion -l pt_BR.UTF-8
337 Módulos Perl para acessar os recursos do Subversion.
338
339 %package -n ruby-subversion
340 Summary:        Subversion Ruby bindings
341 Summary(pl.UTF-8):      Dowiązania do Subversion dla języka Ruby
342 Summary(pt_BR.UTF-8):   Módulos Ruby para acessar os recursos do Subversion
343 Group:          Development/Languages
344 Requires:       %{name}-libs = %{version}-%{release}
345 Obsoletes:      subversion-ruby
346
347 %description -n ruby-subversion
348 Subversion Ruby bindings.
349
350 %description -n ruby-subversion -l pl.UTF-8
351 Dowiązania do Subversion dla języka Ruby.
352
353 %description -n ruby-subversion -l pt_BR.UTF-8
354 Módulos Ruby para acessar os recursos do Subversion.
355
356 %package -n apache-mod_dav_svn
357 Summary:        Apache module: Subversion Server
358 Summary(pl.UTF-8):      Moduł Apache'a: serwer Subversion
359 Group:          Networking/Daemons
360 Requires:       %{name} = %{version}-%{release}
361 Requires:       apache(modules-api) = %apache_modules_api
362 Requires:       apache-mod_dav
363
364 %description -n apache-mod_dav_svn
365 Apache module: Subversion Server.
366
367 %description -n apache-mod_dav_svn -l pl.UTF-8
368 Moduł Apache'a: serwer Subversion.
369
370 %package -n apache-mod_authz_svn
371 Summary:        Apache module: Subversion Server - path-based authorization
372 Summary(pl.UTF-8):      Moduł Apache'a: autoryzacja na podstawie ścieżki dla serwera Subversion
373 Group:          Networking/Daemons
374 Requires:       %{name}-libs = %{version}-%{release}
375 Requires:       apache(modules-api) = %apache_modules_api
376 Requires:       apache-mod_dav_svn = %{version}-%{release}
377
378 %description -n apache-mod_authz_svn
379 Apache module: Subversion Server - path-based authorization.
380
381 %description -n apache-mod_authz_svn -l pl.UTF-8
382 Moduł Apache'a: autoryzacja na podstawie ścieżki dla serwera
383 Subversion.
384
385 %package -n apache-mod_dontdothat_svn
386 Summary:        Apache module: Allows you to block specific svn requests
387 Summary(pl.UTF-8):      Moduł Apache'a pozwalający na blokowanie pewnych zapytań svn
388 Group:          Networking/Daemons
389 Requires:       %{name}-libs = %{version}-%{release}
390 Requires:       apache(modules-api) = %apache_modules_api
391 Requires:       apache-mod_dav_svn = %{version}-%{release}
392
393 %description -n apache-mod_dontdothat_svn
394 Apache module: Allows you to block specific svn requests.
395
396 %description -n apache-mod_dontdothat_svn -l pl.UTF-8
397 Moduł Apache'a pozwalający na blokowanie pewnych zapytań svn.
398
399 %package -n gnome-keyring-subversion
400 Summary:        GNOME Keyring authentication provider for Subversion
401 Summary(pl.UTF-8):      Moduł uwierzytelniający GNOME Keyring dla Subversion
402 Group:          X11/Applications
403 Requires:       %{name}-libs = %{version}-%{release}
404
405 %description -n gnome-keyring-subversion
406 Authentication provider module for Subversion which allows SVN client
407 to authenticate using GNOME Keyring.
408
409 %description -n gnome-keyring-subversion -l pl.UTF-8
410 Moduł uwierzytelniający dla Subversion pozwalający klientom SVN
411 uwierzytelniać się przy użyciu mechanizmu GNOME Keyring.
412
413 %package -n kde4-kwallet-subversion
414 Summary:        KDE Wallet authentication provider for Subversion
415 Summary(pl.UTF-8):      Moduł uwierzytelniający dla Subversion wykorzystujący Portfel KDE
416 Group:          X11/Applications
417 Requires:       %{name}-libs = %{version}-%{release}
418
419 %description -n kde4-kwallet-subversion
420 Authentication provider module for Subversion which allows SVN client
421 to authenticate using KDE Wallet.
422
423 %description -n kde4-kwallet-subversion -l pl.UTF-8
424 Moduł uwierzytelniający dla Subversion pozwalający klientom SVN
425 uwierzytelniać się przy użyciu Portfela KDE.
426
427 %prep
428 %setup -q
429 %patch0 -p0
430 %patch1 -p1
431 %patch2 -p0
432 %patch3 -p1
433
434 sed -i -e 's#serf_prefix/lib#serf_prefix/%{_lib}#g' build/ac-macros/serf.m4
435
436 %build
437 # disabled regeneration - subversion 1.6.13 is not ready for swig 2.0.x
438 #%{__rm} subversion/bindings/swig/proxy/*.swg
439 #cd subversion/bindings/swig && python "%{SOURCE5}" && cd ../../..
440 chmod +x ./autogen.sh && ./autogen.sh
441 %{__libtoolize}
442 %configure \
443         --with-editor=vi \
444         --with-zlib=%{_libdir} \
445         --disable-runtime-module-search \
446         --disable-mod-activation \
447 %if %{with db}
448         --with-berkeley-db="db.h:%{_includedir}:%{_libdir}:db" \
449         %{?with_db6:--enable-bdb6} \
450 %else
451         --without-berkeley-db \
452 %endif
453 %if %{with apache}
454         --with-apache-libexecdir="$(%{_sbindir}/apxs -q LIBEXECDIR)" \
455         --with-apxs=%{_sbindir}/apxs \
456 %else
457         --without-apxs \
458 %endif
459 %if %{without swig}
460         --without-swig \
461 %endif
462 %if %{with ruby}
463         svn_cv_ruby_sitedir_libsuffix="" \
464         svn_cv_ruby_sitedir_archsuffix="" \
465         --with-ruby-sitedir=%{ruby_vendorarchdir} \
466 %else
467         ac_cv_path_RUBY=none \
468 %endif
469 %if %{with csvn}
470         --with-ctypesgen=%{_bindir}/ctypesgen.py \
471 %endif
472 %if %{with javahl}
473         --enable-javahl \
474         --with-jdk="%{java_home}" \
475         --without-jikes \
476 %else
477         --disable-javahl \
478 %endif
479         --with-serf=%{_prefix} \
480         --with-apr=%{_bindir}/apr-1-config \
481         --with-apr-util=%{_bindir}/apu-1-config \
482 %if %{with kwallet}
483         --with-kwallet \
484 %endif
485 %if %{with gnome}
486         --with-gnome-keyring
487 %endif
488
489 %{__make} -j1
490
491 %{__make} tools
492
493 %if %{with csvn}
494 # Python ctypes bindings
495 %{__make} ctypes-python
496 %endif
497 %if %{with python}
498 # Python swig bindings
499 %{__make} swig-py \
500         swig_pydir=%{py_sitedir}/libsvn \
501         swig_pydir_extra=%{py_sitedir}/svn
502 %endif
503 %if %{with perl}
504 # Perl swig bindings
505 %{__make} -j1 swig-pl-lib
506 cd subversion/bindings/swig/perl/native
507 %{__perl} Makefile.PL INSTALLDIRS=vendor
508 %{__make} -j1
509 cd -
510 %endif
511 %if %{with javahl}
512 %{__make} -j1 javahl \
513         javahl_javadir="%{_javadir}"
514 %endif
515 # ruby
516 %if %{with ruby}
517 %{__make} swig-rb
518 %endif
519
520 %if %{with tests}
521 %{__make} -j1 check
522 %if %{with csvn}
523 %{__make} -j1 check-ctypes-python
524 %endif
525 %if %{with python}
526 %{__make} -j1 check-swig-py
527 %endif
528 %if %{with perl}
529 %{__make} -j1 check-swig-pl
530 %endif
531 %if %{with ruby}
532 # disabled, see https://bugs.launchpad.net/pld-linux/+bug/734340
533 #%{__make} check-swig-rb
534 %endif
535 %endif
536
537 %install
538 rm -rf $RPM_BUILD_ROOT
539 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,bash_completion.d} \
540         $RPM_BUILD_ROOT{%{apacheconfdir},%{apachelibdir},%{_infodir}} \
541         $RPM_BUILD_ROOT%{_examplesdir}/{%{name}-%{version},python-%{name}-%{version}} \
542         $RPM_BUILD_ROOT%{_sysconfdir}/%{name} \
543         $RPM_BUILD_ROOT/home/services/subversion{,/repos}
544
545 %{__make} install -j1 \
546         toolsdir=%{_bindir} \
547         DESTDIR=$RPM_BUILD_ROOT \
548         APACHE_LIBEXECDIR="$(%{_sbindir}/apxs -q LIBEXECDIR)" \
549 %if %{with javahl}
550         install-javahl \
551         javahl_javadir="%{_javadir}" \
552 %endif
553 %if %{with python}
554         install-swig-py \
555         swig_pydir=%{py_sitedir}/libsvn \
556         swig_pydir_extra=%{py_sitedir}/svn \
557 %endif
558 %if %{with csvn}
559         install-ctypes-python \
560 %endif
561         install-tools
562
563 %if %{with ruby}
564 %{__make} install -j1 \
565         DESTDIR=$RPM_BUILD_ROOT \
566         install-swig-rb install-swig-rb-doc \
567
568 # not our package
569 %{__rm} -r $RPM_BUILD_ROOT%{ruby_ridir}/OptionParser
570 %{__rm} -r $RPM_BUILD_ROOT%{ruby_ridir}/Time
571 %{__rm} $RPM_BUILD_ROOT%{ruby_ridir}/cache.ri
572 %{__rm} $RPM_BUILD_ROOT%{ruby_ridir}/created.rid
573 %endif
574
575 %if %{with perl}
576 %{__make} install-swig-pl-lib \
577         DESTDIR=$RPM_BUILD_ROOT
578 %{__make} -C subversion/bindings/swig/perl/native install \
579         DESTDIR=$RPM_BUILD_ROOT \
580         PREFIX=$RPM_BUILD_ROOT%{_prefix} \
581         LIBDIR=$RPM_BUILD_ROOT%{_libdir}
582 %endif
583
584 %if %{with apache}
585 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{apacheconfdir}/65_mod_dav_svn.conf
586 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{apacheconfdir}/66_mod_authz_svn.conf
587 cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/svnserve
588 install -p %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/svnserve
589 %endif
590
591 %if %{without net_client_only}
592 install -p tools/backup/hot-backup.py $RPM_BUILD_ROOT%{_bindir}/svn-hot-backup
593 %endif
594
595 # rename not to conflict with standard packages. (are these needed at all?)
596 mv $RPM_BUILD_ROOT%{_bindir}/{,svn}diff
597 mv $RPM_BUILD_ROOT%{_bindir}/{,svn}diff3
598 mv $RPM_BUILD_ROOT%{_bindir}/{,svn}diff4
599
600 %if %{with python} || %{with csvn}
601 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
602 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
603 %py_postclean
604 %endif
605 %if %{with python}
606 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/libsvn/*.la
607 # .a created on ac only
608 %{__rm} -f $RPM_BUILD_ROOT%{py_sitedir}/libsvn/*.a
609 cp -p tools/examples/*.py $RPM_BUILD_ROOT%{_examplesdir}/python-%{name}-%{version}
610 %endif
611
612 cp -p tools/client-side/bash_completion $RPM_BUILD_ROOT/etc/bash_completion.d/%{name}
613 cp -p tools/examples/*.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
614
615 %if %{with javahl}
616 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libsvnjavahl*.{la,a}
617 %endif
618 %if %{with swig}
619 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libsvn_swig*.{la,a}
620 %if %{with ruby}
621 %{__rm} $RPM_BUILD_ROOT%{ruby_vendorarchdir}/svn/ext/*.la
622 %endif
623 %endif
624 %if %{with gnome} || %{with kwallet}
625 # dlopened by soname (libsvn_auth_*-1.so.0)
626 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libsvn_auth_*-1.{so,la,a}
627 %endif
628
629 %find_lang %{name}
630
631 %clean
632 rm -rf $RPM_BUILD_ROOT
633
634 %pre svnserve
635 %groupadd -g 86 svn
636 %useradd -u 180 -d /home/services/subversion -c "Subversion svnserve" -g svn svn
637
638 %post   libs -p /sbin/ldconfig
639 %postun libs -p /sbin/ldconfig
640
641 %post   devel -p /sbin/postshell
642 -/usr/sbin/fix-info-dir -c %{_infodir}
643
644 %postun devel -p /sbin/postshell
645 -/usr/sbin/fix-info-dir -c %{_infodir}
646
647 %post   -n java-subversion -p /sbin/ldconfig
648 %postun -n java-subversion -p /sbin/ldconfig
649
650 %post   -n perl-subversion -p /sbin/ldconfig
651 %postun -n perl-subversion -p /sbin/ldconfig
652
653 %post   -n python-subversion -p /sbin/ldconfig
654 %postun -n python-subversion -p /sbin/ldconfig
655
656 %post   -n ruby-subversion -p /sbin/ldconfig
657 %postun -n ruby-subversion -p /sbin/ldconfig
658
659 %post   -n gnome-keyring-subversion -p /sbin/ldconfig
660 %postun -n gnome-keyring-subversion -p /sbin/ldconfig
661
662 %post   -n kde4-kwallet-subversion -p /sbin/ldconfig
663 %postun -n kde4-kwallet-subversion -p /sbin/ldconfig
664
665 %post svnserve
666 /sbin/chkconfig --add svnserve
667 %service svnserve restart "svnserve daemon"
668
669 %preun svnserve
670 if [ "$1" = "0" ]; then
671         %service svnserve stop
672         /sbin/chkconfig --del svnserve
673 fi
674
675 %postun svnserve
676 if [ "$1" = "0" ]; then
677         %userremove svn
678         %groupremove svn
679 fi
680
681 %post -n apache-mod_dav_svn
682 %service -q httpd restart
683
684 %postun -n apache-mod_dav_svn
685 if [ "$1" = "0" ]; then
686         %service -q httpd restart
687 fi
688
689 %post -n apache-mod_authz_svn
690 %service -q httpd restart
691
692 %postun -n apache-mod_authz_svn
693 if [ "$1" = "0" ]; then
694         %service -q httpd restart
695 fi
696
697 %post -n apache-mod_dontdothat_svn
698 %service -q httpd restart
699
700 %postun -n apache-mod_dontdothat_svn
701 if [ "$1" = "0" ]; then
702         %service -q httpd restart
703 fi
704
705 %files
706 %defattr(644,root,root,755)
707 %doc BUGS CHANGES INSTALL README
708 %doc doc/*/*.html
709 %doc tools/hook-scripts/*.{pl,py,example}
710 %doc tools/hook-scripts/mailer/*.{py,example}
711 %doc tools/xslt/*
712 %attr(755,root,root) %{_bindir}/svn
713 %attr(755,root,root) %{_bindir}/svnadmin
714 %attr(755,root,root) %{_bindir}/svndumpfilter
715 %attr(755,root,root) %{_bindir}/svnlook
716 %attr(755,root,root) %{_bindir}/svnmucc
717 %attr(755,root,root) %{_bindir}/svnrdump
718 %attr(755,root,root) %{_bindir}/svnsync
719 %attr(755,root,root) %{_bindir}/svnversion
720 %{_mandir}/man1/svn.1*
721 %{_mandir}/man1/svnadmin.1*
722 %{_mandir}/man1/svndumpfilter.1*
723 %{_mandir}/man1/svnrdump.1*
724 %{_mandir}/man1/svnlook.1*
725 %{_mandir}/man1/svnmucc.1*
726 %{_mandir}/man1/svnsync.1*
727 %{_mandir}/man1/svnversion.1*
728
729 %files libs -f %{name}.lang
730 %defattr(644,root,root,755)
731 %dir %{_sysconfdir}/%{name}
732 %attr(755,root,root) %{_libdir}/libsvn_client-1.so.*.*.*
733 %attr(755,root,root) %ghost %{_libdir}/libsvn_client-1.so.0
734 %attr(755,root,root) %{_libdir}/libsvn_delta-1.so.*.*.*
735 %attr(755,root,root) %ghost %{_libdir}/libsvn_delta-1.so.0
736 %attr(755,root,root) %{_libdir}/libsvn_diff-1.so.*.*.*
737 %attr(755,root,root) %ghost %{_libdir}/libsvn_diff-1.so.0
738 %attr(755,root,root) %{_libdir}/libsvn_fs-1.so.*.*.*
739 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs-1.so.0
740 %if %{without net_client_only}
741 %attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so.*.*.*
742 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_base-1.so.0
743 %endif
744 %attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so.*.*.*
745 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_fs-1.so.0
746 %attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so.*.*.*
747 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_util-1.so.0
748 %attr(755,root,root) %{_libdir}/libsvn_ra-1.so.*.*.*
749 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra-1.so.0
750 %attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so.*.*.*
751 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_local-1.so.0
752 %attr(755,root,root) %{_libdir}/libsvn_ra_serf-1.so.*.*.*
753 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_serf-1.so.0
754 %attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so.*.*.*
755 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_svn-1.so.0
756 %attr(755,root,root) %{_libdir}/libsvn_repos-1.so.*.*.*
757 %attr(755,root,root) %ghost %{_libdir}/libsvn_repos-1.so.0
758 %attr(755,root,root) %{_libdir}/libsvn_subr-1.so.*.*.*
759 %attr(755,root,root) %ghost %{_libdir}/libsvn_subr-1.so.0
760 %attr(755,root,root) %{_libdir}/libsvn_wc-1.so.*.*.*
761 %attr(755,root,root) %ghost %{_libdir}/libsvn_wc-1.so.0
762
763 %files devel
764 %defattr(644,root,root,755)
765 %attr(755,root,root) %{_libdir}/libsvn_client-1.so
766 %attr(755,root,root) %{_libdir}/libsvn_delta-1.so
767 %attr(755,root,root) %{_libdir}/libsvn_diff-1.so
768 %attr(755,root,root) %{_libdir}/libsvn_fs-1.so
769 %if %{without net_client_only}
770 %attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so
771 %endif
772 %attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so
773 %attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so
774 %attr(755,root,root) %{_libdir}/libsvn_ra-1.so
775 %attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so
776 %attr(755,root,root) %{_libdir}/libsvn_ra_serf-1.so
777 %attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so
778 %attr(755,root,root) %{_libdir}/libsvn_repos-1.so
779 %attr(755,root,root) %{_libdir}/libsvn_subr-1.so
780 %attr(755,root,root) %{_libdir}/libsvn_wc-1.so
781 %{_libdir}/libsvn_client-1.la
782 %{_libdir}/libsvn_delta-1.la
783 %{_libdir}/libsvn_diff-1.la
784 %{_libdir}/libsvn_fs-1.la
785 %if %{without net_client_only}
786 %{_libdir}/libsvn_fs_base-1.la
787 %endif
788 %{_libdir}/libsvn_fs_fs-1.la
789 %{_libdir}/libsvn_fs_util-1.la
790 %{_libdir}/libsvn_ra-1.la
791 %{_libdir}/libsvn_ra_local-1.la
792 %{_libdir}/libsvn_ra_serf-1.la
793 %{_libdir}/libsvn_ra_svn-1.la
794 %{_libdir}/libsvn_repos-1.la
795 %{_libdir}/libsvn_subr-1.la
796 %{_libdir}/libsvn_wc-1.la
797 %{_includedir}/%{name}-1
798 %{_examplesdir}/%{name}-%{version}
799
800 %files static
801 %defattr(644,root,root,755)
802 %{_libdir}/libsvn_client-1.a
803 %{_libdir}/libsvn_delta-1.a
804 %{_libdir}/libsvn_diff-1.a
805 %{_libdir}/libsvn_fs-1.a
806 %if %{without net_client_only}
807 %{_libdir}/libsvn_fs_base-1.a
808 %endif
809 %{_libdir}/libsvn_fs_fs-1.a
810 %{_libdir}/libsvn_fs_util-1.a
811 %{_libdir}/libsvn_ra-1.a
812 %{_libdir}/libsvn_ra_local-1.a
813 %{_libdir}/libsvn_ra_serf-1.a
814 %{_libdir}/libsvn_ra_svn-1.a
815 %{_libdir}/libsvn_repos-1.a
816 %{_libdir}/libsvn_subr-1.a
817 %{_libdir}/libsvn_wc-1.a
818
819 %if %{with gnome}
820 %files -n gnome-keyring-subversion
821 %defattr(644,root,root,755)
822 %attr(755,root,root) %{_libdir}/libsvn_auth_gnome_keyring-1.so.*.*.*
823 %attr(755,root,root) %ghost %{_libdir}/libsvn_auth_gnome_keyring-1.so.0
824 %endif
825
826 %if %{with kwallet}
827 %files -n kde4-kwallet-subversion
828 %defattr(644,root,root,755)
829 %attr(755,root,root) %{_libdir}/libsvn_auth_kwallet-1.so.*.*.*
830 %attr(755,root,root) %ghost %{_libdir}/libsvn_auth_kwallet-1.so.0
831 %endif
832
833 %if %{without net_client_only}
834 %files svnserve
835 %defattr(644,root,root,755)
836 %attr(755,root,root) %{_bindir}/svnserve
837 %{_mandir}/man5/svnserve.conf.5*
838 %{_mandir}/man8/svnserve.8*
839 %dir %attr(750,svn,svn) /home/services/subversion
840 %dir %attr(750,svn,svn) /home/services/subversion/repos
841 %if %{with apache}
842 %attr(754,root,root) /etc/rc.d/init.d/svnserve
843 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/svnserve
844 %endif
845
846 %files tools
847 %defattr(644,root,root,755)
848 # tools/backup/hot-backup.py
849 %attr(755,root,root) %{_bindir}/svn-hot-backup
850
851 # tools/diff
852 %attr(755,root,root) %{_bindir}/svndiff
853 %attr(755,root,root) %{_bindir}/svndiff3
854 %attr(755,root,root) %{_bindir}/svndiff4
855
856 # tools/server-side
857 %attr(755,root,root) %{_bindir}/fsfs-stats
858 %attr(755,root,root) %{_bindir}/svn-populate-node-origins-index
859 %attr(755,root,root) %{_bindir}/svn-rep-sharing-stats
860 %attr(755,root,root) %{_bindir}/svnauthz
861 %attr(755,root,root) %{_bindir}/svnauthz-validate
862
863 # tools/client-side
864 %attr(755,root,root) %{_bindir}/svn-bench
865
866 # tools/dev/svnraisetreeconflict
867 %attr(755,root,root) %{_bindir}/svnraisetreeconflict
868
869 # tools/dev/
870 %attr(755,root,root) %{_bindir}/fsfs-access-map
871 %attr(755,root,root) %{_bindir}/fsfs-reorg
872
873 %files -n bash-completion-subversion
874 %defattr(644,root,root,755)
875 /etc/bash_completion.d/%{name}
876
877 %endif # net_client_only
878
879 %if %{with javahl}
880 %files -n java-subversion
881 %defattr(644,root,root,755)
882 %attr(755,root,root) %{_libdir}/libsvnjavahl-1.so.*.*.*
883 %attr(755,root,root) %ghost %{_libdir}/libsvnjavahl-1.so.0
884 %attr(755,root,root) %{_libdir}/libsvnjavahl-1.so
885 %{_javadir}/svn-javahl.jar
886 %endif
887
888 %if %{with python}
889 %files -n python-subversion
890 %defattr(644,root,root,755)
891 %doc tools/backup/*.py
892 %attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so.*.*.*
893 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_py-1.so.0
894 %attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so
895 %dir %{py_sitedir}/libsvn
896 %attr(755,root,root) %{py_sitedir}/libsvn/_*.so
897 %{py_sitedir}/libsvn/*.py[co]
898 %dir %{py_sitedir}/svn
899 %{py_sitedir}/svn/*.py[co]
900 %{_examplesdir}/python-%{name}-%{version}
901 %endif
902
903 %if %{with csvn}
904 %files -n python-csvn
905 %defattr(644,root,root,755)
906 %doc subversion/bindings/ctypes-python/{README,TODO}
907 %doc subversion/bindings/ctypes-python/examples/*.py
908 %dir %{py_sitescriptdir}/csvn
909 %{py_sitescriptdir}/csvn/*.py[co]
910 %dir %{py_sitescriptdir}/csvn/core
911 %{py_sitescriptdir}/csvn/core/*.py[co]
912 %dir %{py_sitescriptdir}/csvn/ext
913 %{py_sitescriptdir}/csvn/ext/*.py[co]
914 %{py_sitescriptdir}/svn_ctypes_python_bindings-0.1-py*.egg-info
915 %endif
916
917 %if %{with perl}
918 %files -n perl-subversion
919 %defattr(644,root,root,755)
920 %attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so.*.*.*
921 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_perl-1.so.0
922 %attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so
923 %{perl_vendorarch}/SVN
924 %dir %{perl_vendorarch}/auto/SVN
925 %dir %{perl_vendorarch}/auto/SVN/*
926 %attr(755,root,root) %{perl_vendorarch}/auto/SVN/*/*.so
927 %{perl_vendorarch}/auto/SVN/*/*.bs
928 %{_mandir}/man3/*.3pm*
929 %endif
930
931 %if %{with ruby}
932 %files -n ruby-subversion
933 %defattr(644,root,root,755)
934 %attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so.*.*.*
935 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_ruby-1.so.0
936 %attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so
937 %dir %{ruby_vendorarchdir}/svn
938 %{ruby_vendorarchdir}/svn/*.rb
939 %dir %{ruby_vendorarchdir}/svn/ext
940 %attr(755,root,root) %{ruby_vendorarchdir}/svn/ext/*.so
941 %{ruby_ridir}/Svn
942 %endif
943
944 %if %{with apache}
945 %files -n apache-mod_dav_svn
946 %defattr(644,root,root,755)
947 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_dav_svn.conf
948 %attr(755,root,root) %{apachelibdir}/mod_dav_svn.so
949
950 %files -n apache-mod_authz_svn
951 %defattr(644,root,root,755)
952 %doc subversion/mod_authz_svn/INSTALL
953 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_authz_svn.conf
954 %attr(755,root,root) %{apachelibdir}/mod_authz_svn.so
955
956 %files -n apache-mod_dontdothat_svn
957 %defattr(644,root,root,755)
958 %doc tools/server-side/mod_dontdothat/README
959 %attr(755,root,root) %{apachelibdir}/mod_dontdothat.so
960 %endif
This page took 1.233023 seconds and 2 git commands to generate.