]> git.pld-linux.org Git - packages/subversion.git/blob - subversion.spec
c39cc172268775dd2d666fa00f55ee4ceecf5250
[packages/subversion.git] / subversion.spec
1 #
2 # Conditional build:
3 %bcond_with     internal_neon           # build with internal neon
4 %bcond_without  net_client_only         # build only net client
5 #       
6 %include        /usr/lib/rpm/macros.python
7 %{!?with_net_client_only:%include       /usr/lib/rpm/macros.perl}
8 Summary:        A Concurrent Versioning system similar to but better than CVS
9 Summary(pl):    System kontroli wersji podobny, ale lepszy, ni¿ CVS
10 Summary(pt_BR): Sistema de versionamento concorrente
11 Name:           subversion
12 Version:        1.0.1
13 Release:        2
14 License:        Apache/BSD Style
15 Group:          Development/Version Control
16 Source0:        http://svn.collab.net/tarballs/%{name}-%{version}.tar.bz2
17 # Source0-md5:  50ca608d260b76d99ed85909acb7ae92
18 Source1:        %{name}-dav_svn.conf
19 Source2:        %{name}-authz_svn.conf
20 Source3:        %{name}-svnserve.init
21 Source4:        %{name}-svnserve.sysconfig
22 #Patch0:                %{name}-svnlook.patch
23 #Patch1:                %{name}-hot_backup_num.patch
24 URL:            http://subversion.tigris.org/
25 Requires:       %{name}-libs = %{version}-%{release}
26 %if %{with net_client_only}
27 %global apache_modules_api 0
28 %else
29 BuildRequires:  automake
30 BuildRequires:  apache-devel >= 2.0.47-0.6
31 BuildRequires:  db-devel >= 4.1.25
32 BuildRequires:  rpmbuild(macros) >= 1.120
33 BuildRequires:  swig >= 1.3.19
34 BuildRequires:  swig-python >= 1.3.19
35 BuildRequires:  swig-perl >= 1.3.19
36 BuildRequires:  perl-devel >= 5.8.0
37 BuildRequires:  rpm-perlprov
38 %endif
39 BuildRequires:  apr-devel >= 1:0.9.5
40 BuildRequires:  apr-util-devel >= 1:0.9.5
41 BuildRequires:  autoconf >= 2.57
42 BuildRequires:  bison
43 BuildRequires:  docbook-style-xsl >= 1.56
44 BuildRequires:  expat-devel
45 BuildRequires:  libtool >= 1.4-9
46 BuildRequires:  libxslt-progs
47 %{!?with_internal_neon:BuildRequires:   neon-devel >= 0.24.1}
48 BuildRequires:  python-devel >= 2.2
49 BuildRequires:  rpm-pythonprov >= 4.0.2-50
50 BuildRequires:  texinfo
51 BuildRequires:  which
52 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
53
54 %define         _apachelibdir   /usr/%{_lib}/apache
55 %define         _libexecdir     %{_libdir}/svn
56
57 %description
58 The goal of the Subversion project is to build a version control
59 system that is a compelling replacement for CVS in the open source
60 community.
61
62 Our goals are:
63 - All current CVS features.
64 - Directories, renames, and file meta-data are versioned.
65 - Symbolic links, etc, are supported
66 - Commits are truly atomic.
67 - Branching and tagging are cheap (constant time) operations
68 - Repeated merges are handled gracefully
69 - Support for plug-in client side diff programs
70 - Natively client/server
71 - Client/server protocol sends diffs in both directions
72 - Costs are proportional to change size, not project size
73 - Internationalization
74 - Progressive multi-lingual support
75
76 %description -l pl
77 Celem projektu Subversion jest stworzenie systemu kontroli wersji jako
78 zamiennika dla CVS.
79
80 Cele projektu to:
81 - Wszystkie aktualne mo¿liwo¶ci CVS.
82 - Katalogi, zmiany nazw oraz meta-dane plików s± wersjonowane.
83 - Wsparcie dla linków symbolicznych itp.
84 - Commity s± w pe³ni atomowe.
85 - Branchowanie oraz tagowanie s± tanimi (sta³ymi w czasie) operacjami.
86 - Powtarzaj±ce merge.
87 - Wsparcie dla pluginów diff'a po stronie klienta.
88 - Natywny klient/serwer.
89 - Klient/Serwer przesy³aj± diffy w obu kierunkach.
90 - Koszty proporcjonalne do rozmiaru zmiany, a nie rozmiaru projektu.
91 - Internacjonalizacja.
92 - Postêpuj±ce wsparcie dla wielu jêzyków.
93
94 %description -l pt_BR
95 O objetivo do projeto Subversion é construir um sistema de controle de
96 versões que seja um substituto para o CVS (Concurrent Versioning
97 System) na comunidade opensource, fornecendo grandes melhorias.
98
99 %package libs
100 Summary:        Subversion libraries and modules
101 Summary(pl):    Biblioteka subversion oraz ³adowalne modu³y
102 Group:          Libraries
103 Obsoletes:      libsubversion0
104
105 %description libs
106 Subversion libraries and modules.
107
108 %description libs -l pl
109 Biblioteka subversion oraz ³adowalne modu³y.
110
111 %package devel
112 Summary:        Header files and develpment documentation for subversion
113 Summary(pl):    Pliki nag³ówkowe i dokumetacja do subversion
114 Summary(pt_BR): Arquivos de desenvolvimento para o Subversion
115 Group:          Development/Libraries
116 Requires:       %{name}-libs = %{version}-%{release}
117 Obsoletes:      libsubversion0-devel
118
119 %description devel
120 Header files and develpment documentation for subversion.
121
122 %description devel -l pl
123 Pliki nag³ówkowe i dokumetacja do subversion.
124
125 %description devel -l pt_BR
126 Este pacote provê os arquivos necessários para desenvolvedores
127 interagirem com o Subversion.
128
129 %package static
130 Summary:        Static subversion library
131 Summary(pl):    Biblioteka statyczna subversion
132 Summary(pt_BR): Sistema de versionamento concorrente
133 Group:          Development/Libraries
134 Requires:       %{name}-devel = %{version}
135 Obsoletes:      libsubversion0-static-devel
136
137 %description static
138 Static subversion library.
139
140 %description static -l pl
141 Biblioteka statyczna subversion.
142
143 %description static -l pt_BR
144 Este pacote provê um cliente estático do subversion.
145
146 %package svnserve
147 Summary:        Subversion svnserve
148 Summary(pl):    Subversion svnserve
149 Group:          Networking/Daemons
150 PreReq:         rc-scripts
151 Requires(post,preun):   /sbin/chkconfig
152 Requires:       %{name} = %{version}-%{release}
153
154 %description svnserve
155 Subversion svnserve server.
156
157 %description svnserve -l pl
158 Serwer subversion svnserve.
159
160 %package tools
161 Summary:        Subversion tools and scripts
162 Summary(pl):    Narzêdzia oraz skrypty dla subversion
163 Summary(pt_BR): Módulos python para acessar os recursos do Subversion
164 Group:          Applications
165 %pyrequires_eq  python
166 Requires:       python-rcsparse >= 0.1-0.20031026.0
167 Requires:       python-subversion = %{version}
168 Requires:       %{name} = %{version}-%{release}
169
170 %description tools
171 Subversion tools and scripts.
172
173 %description tools -l pl
174 Narzêdzia oraz skrypty dla subversion.
175
176 %package -n python-subversion
177 Summary:        Subversion python bindings
178 Summary(pl):    Dowi±zania do subversion dla pythona
179 Summary(pt_BR): Módulos python para acessar os recursos do Subversion
180 Group:          Development/Languages/Python
181 %pyrequires_eq  python
182 Obsoletes:      subversion-python
183 Requires:       %{name}-libs = %{version}-%{release}
184
185 %description -n python-subversion
186 Subversion python bindings.
187
188 %description -n python-subversion -l pl
189 Dowi±zania do subversion dla pythona.
190
191 %description -n python-subversion -l pt_BR
192 Módulos python para acessar os recursos do Subversion.
193
194 %package -n perl-subversion
195 Summary:        Subversion perl bindings
196 Summary(pl):    Dowi±zania do subversion dla perla
197 Summary(pt_BR): Módulos perl para acessar os recursos do Subversion
198 Group:          Development/Languages/Perl
199 Obsoletes:      subversion-perl
200 Requires:       %{name}-libs = %{version}-%{release}
201
202 %description -n perl-subversion
203 Subversion perl bindings.
204
205 %description -n perl-subversion -l pl
206 Dowi±zania do subversion dla perl.
207
208 %description -n perl-subversion -l pt_BR
209 Módulos perl para acessar os recursos do Subversion.
210
211 %package -n apache-mod_dav_svn
212 Summary:        Apache module: Subversion Server
213 Summary(pl):    Modu³ apache: Serwer Subversion
214 Group:          Networking/Daemons
215 Requires:       apache >= 2.0.47
216 Requires:       apache(modules-api) = %{apache_modules_api}
217 Requires:       apache-mod_dav
218 Requires:       %{name} = %{version}-%{release}
219
220 %description -n apache-mod_dav_svn
221 Apache module: Subversion Server.
222
223 %description -n apache-mod_dav_svn -l pl
224 Modu³ apache: Serwer Subversion.
225
226 %package -n apache-mod_authz_svn
227 Summary:        Apache module: Subversion Server - path-based authorization
228 Summary(pl):    Modu³ apache: autoryzacja na podstawie ¶cie¿ki dla serwera Subversion
229 Group:          Networking/Daemons
230 Requires:       apache-mod_dav_svn = %{version}-%{release}
231 Requires:       apache >= 2.0.47
232 Requires:       apache(modules-api) = %{apache_modules_api}
233
234 %description -n apache-mod_authz_svn
235 Apache module: Subversion Server - path-based authorization.
236
237 %description -n apache-mod_authz_svn -l pl
238 Modu³ apache: autoryzacja na podstawie ¶cie¿ki dla serwera Subversion.
239
240 %prep
241 %setup -q
242 #%patch0 -p0
243 #%patch1 -p1
244
245 %build
246 cp -f /usr/share/automake/config.sub ac-helpers
247 chmod +x ./autogen.sh && ./autogen.sh
248
249 # don't enable dso - currently it's broken
250 %configure \
251 %if %{with net_client_only}
252         --without-apache \
253         --without-swig \
254         --without-apxs \
255         --without-berkeley-db \
256 %else
257         --disable-dso \
258         --disable-mod-activation \
259         --with-apxs=%{_sbindir}/apxs \
260         --with-berkeley-db=%{_includedir}/db4:%{_libdir} \
261 %endif
262         %{!?with_internal_neon:--with-neon=%{_prefix}} \
263         --with-apr=%{_bindir}/apr-config \
264         --with-apr-util=%{_bindir}/apu-config
265
266 %{__make}
267
268 %if ! %{with net_client_only}
269 # python
270 %{__make} swig-py \
271         swig_pydir=%{py_sitedir}/libsvn \
272         swig_pydir_extra=%{py_sitedir}/svn
273 # perl
274 bdir=$(pwd)
275 %{__make} install-swig-pl-lib \
276         LC_ALL=C \
277         DESTDIR=${bdir}/swig-pl-lib-buildroot
278 %{__make}
279 cd subversion/bindings/swig/perl
280 env APR_CONFIG=%{_bindir}/apr-config \
281     APU_CONFIG=%{_bindir}/apu-config \
282         %{__perl} Makefile.PL \
283         INSTALLDIRS=vendor
284 env LIBRARY_PATH=${bdir}/swig-pl-lib-buildroot%{_libdir} %{__make}
285 cd ../../../../
286 %endif
287
288 # build documentation; build process for documentation is severely
289 # braindamaged -- authors suggests to untar docbook distribution in
290 # build directory, hence the hack here
291 ln -s /usr/share/sgml/docbook/xsl-stylesheets doc/book/tools/xsl
292 %{__make} -C doc/book all-html
293
294 # prepare for %%doc below
295 mv -f doc/book/book/html-chunk svn-handbook
296 mkdir svn-handbook/images/
297 cp -f doc/book/book/images/*.png svn-handbook/images/
298
299 %install
300 rm -rf $RPM_BUILD_ROOT
301 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,bash_completion.d} \
302         $RPM_BUILD_ROOT{%{_sysconfdir}/httpd/httpd.conf,%{_apachelibdir},%{_infodir}} \
303         $RPM_BUILD_ROOT%{_examplesdir}/{%{name}-%{version},python-%{name}-%{version}}
304
305 %{__make} install \
306         LC_ALL=C \
307         %{!?with_net_client_only:install-swig-py} \
308         DESTDIR=$RPM_BUILD_ROOT \
309         swig_pydir=%{py_sitedir}/libsvn \
310         swig_pydir_extra=%{py_sitedir}/svn
311
312 %if ! %{with net_client_only}
313 %{__make} install-swig-pl-lib \
314         LC_ALL=C \
315         DESTDIR=$RPM_BUILD_ROOT
316 %{__make} -C subversion/bindings/swig/perl install \
317         DESTDIR=$RPM_BUILD_ROOT
318 %endif
319
320 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd/httpd.conf/65_mod_dav_svn.conf
321 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/httpd/httpd.conf/66_mod_authz_svn.conf
322 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/svnserve
323 install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/svnserve
324 install doc/programmer/design/*.info* $RPM_BUILD_ROOT%{_infodir}/
325
326 %if ! %{with net_client_only}
327 install tools/backup/hot-backup.py $RPM_BUILD_ROOT%{_bindir}/svn-hot-backup
328
329 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
330 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
331 find $RPM_BUILD_ROOT%{py_sitedir} -name "*.py" -o -name "*.a" -o -name "*.la" | xargs rm -f
332 install tools/examples/*.py $RPM_BUILD_ROOT%{_examplesdir}/python-%{name}-%{version}
333 %endif
334
335 install tools/client-side/bash_completion $RPM_BUILD_ROOT/etc/bash_completion.d/%{name}
336 install tools/examples/*.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
337
338 %clean
339 rm -rf $RPM_BUILD_ROOT
340
341 %post devel
342 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
343
344 %postun devel
345 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
346
347 %post   libs -p /sbin/ldconfig
348 %postun libs -p /sbin/ldconfig
349
350 %post svnserve
351 if [ -f /var/lock/subsys/svnserve ]; then
352         /etc/rc.d/init.d/svnserve restart 1>&2
353 else
354         echo "Run \"/etc/rc.d/init.d/svnserve start\" to start subversion svnserve daemon."
355 fi
356
357 %preun svnserve
358 if [ "$1" = "0" ]; then
359         if [ -f /var/lock/subsys/svnserve ]; then
360                 /etc/rc.d/init.d/svnserve restart 1>&2
361         fi
362 fi
363
364 %post -n apache-mod_dav_svn
365 if [ -f /var/lock/subsys/httpd ]; then
366         /etc/rc.d/init.d/httpd restart 1>&2
367 else
368         echo "Run \"/etc/rc.d/init.d/httpd start\" to start apache http daemon."
369 fi
370
371 %preun -n apache-mod_dav_svn
372 if [ "$1" = "0" ]; then
373         if [ -f /var/lock/subsys/httpd ]; then
374                 /etc/rc.d/init.d/httpd restart 1>&2
375         fi
376 fi
377
378 %files
379 %defattr(644,root,root,755)
380 %doc BUGS CHANGES COPYING INSTALL README
381 %doc svn-handbook doc/book/misc-docs/misc-docs.html
382 %doc tools/hook-scripts/*.{pl,py,example}
383 %doc tools/hook-scripts/mailer/*.{py,example}
384 %doc tools/xslt/*
385 %attr(755,root,root) %{_bindir}/svn
386 %attr(755,root,root) %{_bindir}/svn[!s-]*
387 %{_mandir}/man1/svn*
388 %if ! %{with net_client_only}
389 %{_mandir}/man5/*
390 %{_mandir}/man8/*
391 %endif
392
393 %files libs
394 %defattr(644,root,root,755)
395 %attr(755,root,root) %{_libdir}/lib*.so.*
396
397 %files devel
398 %defattr(644,root,root,755)
399 %{_includedir}/%{name}*
400 %attr(755,root,root) %{_libdir}/lib*.so
401 %{_libdir}/lib*.la
402 %{_infodir}/svn*
403 %{_examplesdir}/%{name}-%{version}
404
405 %files static
406 %defattr(644,root,root,755)
407 %{_libdir}/lib*.a
408
409 %if ! %{with net_client_only}
410 %files svnserve
411 %defattr(644,root,root,755)
412 %attr(755,root,root) %{_bindir}/svnserve
413 %{_mandir}/man?/svnserve*
414 %attr(754,root,root) /etc/rc.d/init.d/svnserve
415 %attr(640,root,root) %config(noreplace) %verify(not mtime md5 size) /etc/sysconfig/svnserve
416
417 %files tools
418 %defattr(644,root,root,755)
419 %attr(755,root,root) %{_bindir}/svn-hot-backup
420 /etc/bash_completion.d/%{name}
421
422 %files -n python-subversion
423 %defattr(644,root,root,755)
424 %doc tools/backup/*.py tools/examples/*.py
425 %dir %{py_sitedir}/svn
426 %dir %{py_sitedir}/libsvn
427 %{py_sitedir}/svn/*.py[co]
428 %{py_sitedir}/libsvn/*.py[co]
429 %attr(755,root,root) %{py_sitedir}/libsvn/*.so
430 %{_examplesdir}/python-%{name}-%{version}
431
432 %files -n perl-subversion
433 %defattr(644,root,root,755)
434 %{perl_vendorarch}/SVN
435 %dir %{perl_vendorarch}/auto/SVN
436 %dir %{perl_vendorarch}/auto/SVN/*
437 %attr(755,root,root) %{perl_vendorarch}/auto/SVN/*/*.so
438 %{perl_vendorarch}/auto/SVN/*/*.bs
439 %{_mandir}/man3/*.3pm*
440
441 %files -n apache-mod_dav_svn
442 %defattr(644,root,root,755)
443 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/httpd/httpd.conf/*_mod_dav_svn.conf
444 %attr(755,root,root) %{_apachelibdir}/mod_dav_svn.so
445
446 %files -n apache-mod_authz_svn
447 %defattr(644,root,root,755)
448 %doc subversion/mod_authz_svn/INSTALL
449 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/httpd/httpd.conf/*_mod_authz_svn.conf
450 %attr(755,root,root) %{_apachelibdir}/mod_authz_svn.so
451 %endif
This page took 0.104313 seconds and 2 git commands to generate.