]> git.pld-linux.org Git - packages/subversion.git/blob - subversion.spec
b24df575dda76fc5812ba9062e3bb9d6fa9b4e31
[packages/subversion.git] / subversion.spec
1 #
2 # Conditional build:
3 %bcond_with     internal_neon           # build with internal neon
4 %bcond_with     net_client_only         # build only net client
5 #       
6 %include        /usr/lib/rpm/macros.python
7 Summary:        A Concurrent Versioning system similar to but better than CVS
8 Summary(pl):    System kontroli wersji podobny, ale lepszy, ni¿ CVS
9 Summary(pt_BR): Sistema de versionamento concorrente
10 Name:           subversion
11 Version:        0.32.1
12 Release:        0.1
13 License:        Apache/BSD Style
14 Group:          Development/Version Control
15 Source0:        http://svn.collab.net/tarballs/%{name}-%{version}.tar.gz
16 # Source0-md5:  b06717a8ef50db4b5c4d380af00bd901
17 Source1:        %{name}-dav_svn.conf
18 Source2:        %{name}-authz_svn.conf
19 URL:            http://subversion.tigris.org/
20 %if %{with net_client_only}
21 %global apache_modules_api 0
22 %else
23 BuildRequires:  apache-devel >= 2.0.47-0.6
24 BuildRequires:  db-devel >= 4.1.25
25 BuildRequires:  rpmbuild(macros) >= 1.120
26 BuildRequires:  swig >= 1.3.17
27 BuildRequires:  swig-python >= 1.3.17
28 %endif
29 BuildRequires:  apr-devel >= 1:0.9.4
30 BuildRequires:  apr-util-devel >= 1:0.9.4
31 BuildRequires:  autoconf >= 2.53
32 BuildRequires:  bison
33 BuildRequires:  docbook-style-xsl >= 1.56
34 BuildRequires:  expat-devel
35 BuildRequires:  libtool >= 1.4-9
36 BuildRequires:  libxslt-progs
37 %{!?with_internal_neon:BuildRequires:   neon-devel >= 0.24.1}
38 BuildRequires:  python >= 2.2
39 BuildRequires:  rpm-pythonprov >= 4.0.2-50
40 BuildRequires:  texinfo
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %define         _apachelibdir   /usr/lib/apache
44 %define         _libexecdir     %{_libdir}/svn
45
46 %description
47 The goal of the Subversion project is to build a version control
48 system that is a compelling replacement for CVS in the open source
49 community.
50
51 Our goals are:
52 - All current CVS features.
53 - Directories, renames, and file meta-data are versioned.
54 - Symbolic links, etc, are supported
55 - Commits are truly atomic.
56 - Branching and tagging are cheap (constant time) operations
57 - Repeated merges are handled gracefully
58 - Support for plug-in client side diff programs
59 - Natively client/server
60 - Client/server protocol sends diffs in both directions
61 - Costs are proportional to change size, not project size
62 - Internationalization
63 - Progressive multi-lingual support
64
65 %description -l pl
66 Celem projektu Subversion jest stworzenie systemu kontroli wersji jako
67 zamiennika dla CVS.
68
69 Cele projektu to:
70 - Wszystkie aktualne mo¿liwo¶ci CVS.
71 - Katalogi, zmiany nazw oraz meta-dane plików s± wersjonowane.
72 - Wsparcie dla linków symbolicznych itp.
73 - Commity s± w pe³ni atomowe.
74 - Branchowanie oraz tagowanie s± tanimi (sta³ymi w czasie) operacjami.
75 - Powtarzaj±ce merge.
76 - Wsparcie dla pluginów diff'a po stronie klienta.
77 - Natywny klient/serwer.
78 - Klient/Serwer przesy³aj± diffy w obu kierunkach.
79 - Koszty proporcjonalne do rozmiaru zmiany, a nie rozmiaru projektu.
80 - Internacjonalizacja.
81 - Postêpuj±ce wsparcie dla wielu jêzyków.
82
83 %description -l pt_BR
84 O objetivo do projeto Subversion é construir um sistema de controle de
85 versões que seja um substituto para o CVS (Concurrent Versioning
86 System) na comunidade opensource, fornecendo grandes melhorias.
87
88 %package libs
89 Summary:        Subversion libraries and modules
90 Summary(pl):    Biblioteka subversion oraz ³adowalne modu³y
91 Group:          Libraries
92 Obsoletes:      libsubversion0
93
94 %description libs
95 Subversion libraries and modules.
96
97 %description libs -l pl
98 Biblioteka subversion oraz ³adowalne modu³y.
99
100 %package devel
101 Summary:        Header files and develpment documentation for subversion
102 Summary(pl):    Pliki nag³ówkowe i dokumetacja do subversion
103 Summary(pt_BR): Arquivos de desenvolvimento para o Subversion
104 Group:          Development/Libraries
105 Requires:       %{name}-libs = %{version}
106 Obsoletes:      libsubversion0-devel
107
108 %description devel
109 Header files and develpment documentation for subversion.
110
111 %description devel -l pl
112 Pliki nag³ówkowe i dokumetacja do subversion.
113
114 %description devel -l pt_BR
115 Este pacote provê os arquivos necessários para desenvolvedores
116 interagirem com o Subversion.
117
118 %package static
119 Summary:        Static subversion library
120 Summary(pl):    Biblioteka statyczna subversion
121 Summary(pt_BR): Sistema de versionamento concorrente
122 Group:          Development/Libraries
123 Requires:       %{name}-devel = %{version}
124 Obsoletes:      libsubversion0-static-devel
125
126 %description static
127 Static subversion library.
128
129 %description static -l pl
130 Biblioteka statyczna subversion.
131
132 %description static -l pt_BR
133 Este pacote provê um cliente estático do subversion.
134
135 %package tools
136 Summary:        Subversion tools and scripts
137 Summary(pl):    Narzêdzia oraz skrypty dla subversion
138 Summary(pt_BR): Módulos python para acessar os recursos do Subversion
139 Group:          Applications
140 %pyrequires_eq  python
141 Requires:       python-rcsparse
142 Requires:       python-subversion = %{version}
143
144 %description tools
145 Subversion tools and scripts.
146
147 %description tools -l pl
148 Narzêdzia oraz skrypty dla subversion.
149
150
151 %package -n python-subversion
152 Summary:        Subversion python bindings
153 Summary(pl):    Dowi±zania do subversion dla pythona
154 Summary(pt_BR): Módulos python para acessar os recursos do Subversion
155 Group:          Development/Languages/Python
156 %pyrequires_eq  python
157 Obsoletes:      subversion-python
158
159 %description -n python-subversion
160 Subversion python bindings.
161
162 %description -n python-subversion -l pl
163 Dowi±zania do subversion dla pythona.
164
165 %description -n python-subversion -l pt_BR
166 Módulos python para acessar os recursos do Subversion.
167
168 %package -n apache-mod_dav_svn
169 Summary:        Apache module: Subversion Server
170 Summary(pl):    Modu³ apache: Serwer Subversion
171 Group:          Networking/Daemons
172 Requires:       apache >= 2.0.47
173 Requires:       apache(modules-api) = %{apache_modules_api}
174 Requires:       apache-mod_dav
175
176 %description -n apache-mod_dav_svn
177 Apache module: Subversion Server.
178
179 %description -n apache-mod_dav_svn -l pl
180 Modu³ apache: Serwer Subversion.
181
182 %package -n apache-mod_authz_svn
183 Summary:        Apache module: Subversion Server - path-based authorization
184 Summary(pl):    Modu³ apache: autoryzacja na podstawie ¶cie¿ki dla serwera Subversion
185 Group:          Networking/Daemons
186 Requires:       apache-mod_dav_svn = %{version}
187 Requires:       apache >= 2.0.47
188 Requires:       apache(modules-api) = %{apache_modules_api}
189
190 %description -n apache-mod_authz_svn
191 Apache module: Subversion Server - path-based authorization.
192
193 %description -n apache-mod_authz_svn -l pl
194 Modu³ apache: autoryzacja na podstawie ¶cie¿ki dla serwera Subversion.
195
196 %prep
197 %setup -q
198
199 %build
200 chmod +x ./autogen.sh && ./autogen.sh
201
202 # don't enable dso - currently it's broken
203 %configure \
204 %if %{with net_client_only}
205         --without-apache \
206         --without-swig \
207         --without-apxs \
208         --without-berkeley-db \
209 %else
210         --disable-dso \
211         --disable-mod-activation \
212         --with-apxs=%{_sbindir}/apxs \
213         --with-berkeley-db=%{_includedir}/db4:%{_libdir} \
214 %endif
215         %{!?with_internal_neon:--with-neon=%{_prefix}} \
216         --with-apr=%{_bindir}/apr-config \
217         --with-apr-util=%{_bindir}/apu-config
218
219 %{__make}
220
221 %if ! %{with net_client_only}
222 %{__make} swig-py \
223         swig_pydir=%{py_sitedir}/libsvn \
224         swig_pydir_extra=%{py_sitedir}/svn
225 %endif
226
227 # build documentation; build process for documentation is severely
228 # braindamaged -- authors suggests to untar docbook distribution in
229 # build directory, hence the hack here
230 %{__make} -C doc/book all-html \
231         XSL_DIR=/usr/share/sgml/docbook/xsl-stylesheets/
232
233 # prepare for %%doc below
234 mv -f doc/book/book/html-chunk svn-handbook
235 mkdir svn-handbook/images/
236 cp -f doc/book/book/images/*.png svn-handbook/images/
237
238 %install
239 rm -rf $RPM_BUILD_ROOT
240 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/httpd/httpd.conf,%{_apachelibdir},%{_infodir}}
241
242 %{__make} install \
243         LC_ALL=C \
244         %{!?with_net_client_only:install-swig-py} \
245         DESTDIR=$RPM_BUILD_ROOT \
246         swig_pydir=%{py_sitedir}/libsvn \
247         swig_pydir_extra=%{py_sitedir}/svn
248
249 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd/httpd.conf/65_mod_dav_svn.conf
250 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/httpd/httpd.conf/66_mod_authz_svn.conf
251 install doc/programmer/design/*.info* $RPM_BUILD_ROOT%{_infodir}/
252
253 %if ! %{with net_client_only}
254 install tools/cvs2svn/cvs2svn.py        $RPM_BUILD_ROOT%{_bindir}/cvs2svn
255 install tools/cvs2svn/cvs2svn.1         $RPM_BUILD_ROOT%{_mandir}/man1
256 cp tools/cvs2svn/README tools/cvs2svn/README.cvs2svn
257
258 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
259 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
260 %endif
261
262 %clean
263 rm -rf $RPM_BUILD_ROOT
264
265 %post devel
266 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
267
268 %postun devel
269 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
270
271 %post   libs -p /sbin/ldconfig
272 %postun libs -p /sbin/ldconfig
273
274 %post -n apache-mod_dav_svn
275 if [ -f /var/lock/subsys/httpd ]; then
276         /etc/rc.d/init.d/httpd restart 1>&2
277 else
278         echo "Run \"/etc/rc.d/init.d/httpd start\" to start apache http daemon."
279 fi
280
281 %preun -n apache-mod_dav_svn
282 if [ "$1" = "0" ]; then
283         if [ -f /var/lock/subsys/httpd ]; then
284                 /etc/rc.d/init.d/httpd restart 1>&2
285         fi
286 fi
287
288 %files
289 %defattr(644,root,root,755)
290 %doc BUGS CHANGES COPYING INSTALL README
291 %doc svn-handbook doc/book/misc-docs/misc-docs.html
292 %doc tools/hook-scripts/*.{pl,py,example}
293 %doc tools/hook-scripts/mailer/*.{py,example}
294 %attr(755,root,root) %{_bindir}/svn*
295 #%exclude %{_bindir}/svn-config
296 %{_mandir}/man1/*
297 %{?with_internal_neon:%exclude %{_mandir}/man1/neon*}
298
299 %files libs
300 %defattr(644,root,root,755)
301 %attr(755,root,root) %{_libdir}/lib*.so.*
302
303 %files devel
304 %defattr(644,root,root,755)
305 %{_includedir}/%{name}*
306 #%attr(755,root,root) %{_bindir}/svn-config
307 %attr(755,root,root) %{_libdir}/lib*.so
308 %{_libdir}/lib*.la
309 %{_infodir}/svn*
310
311 %files static
312 %defattr(644,root,root,755)
313 %{_libdir}/lib*.a
314
315 %if ! %{with net_client_only}
316 %files tools
317 %defattr(644,root,root,755)
318 %doc tools/cvs2svn/README*
319 %attr(755,root,root) %{_bindir}/cvs*
320 %{_mandir}/man1/cvs*
321
322 %files -n python-subversion
323 %defattr(644,root,root,755)
324 %doc tools/backup/*.py tools/examples/*.py
325 %dir %{py_sitedir}/svn
326 %dir %{py_sitedir}/libsvn
327 %{py_sitedir}/svn/*.py[co]
328 %{py_sitedir}/libsvn/*.py[co]
329 %attr(755,root,root) %{py_sitedir}/libsvn/*.so
330
331 %files -n apache-mod_dav_svn
332 %defattr(644,root,root,755)
333 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/httpd/httpd.conf/*_mod_dav_svn.conf
334 %attr(755,root,root) %{_apachelibdir}/mod_dav_svn.so
335
336 %files -n apache-mod_authz_svn
337 %defattr(644,root,root,755)
338 %doc subversion/mod_authz_svn/INSTALL
339 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/httpd/httpd.conf/*_mod_authz_svn.conf
340 %attr(755,root,root) %{_apachelibdir}/mod_authz_svn.so
341
342 %endif
This page took 0.067983 seconds and 2 git commands to generate.