]> git.pld-linux.org Git - packages/subversion.git/blob - subversion.spec
- tools subpackage introduced (right now only cvs2svn there)
[packages/subversion.git] / subversion.spec
1 %bcond_with     internal_neon
2 %bcond_with     net_client_only
3 %include        /usr/lib/rpm/macros.python
4 %define distdir 15/6494
5 Summary:        A Concurrent Versioning system similar to but better than CVS
6 Summary(pl):    System kontroli wersji podobny, ale lepszy, ni¿ CVS
7 Summary(pt_BR): Sistema de versionamento concorrente
8 Name:           subversion
9 Version:        0.30.0
10 Release:        0.1
11 License:        Apache/BSD Style
12 Group:          Development/Version Control
13 #Source0Download:       http://subversion.tigris.org/servlets/ProjectDocumentList?folderID=260
14 Source0:        http://subversion.tigris.org/files/documents/%{distdir}/subversion-%{version}.tar.gz
15 # Source0-md5:  9dac76a67a217dc6b7f63259761ff93f
16 Source1:        %{name}-dav_svn.conf
17 Source2:        %{name}-authz_svn.conf
18 URL:            http://subversion.tigris.org/
19 %if %{with net_client_only}
20 %global apache_modules_api 0
21 %else
22 BuildRequires:  apache-devel >= 2.0.47-0.6
23 BuildRequires:  db-devel >= 4.1.25
24 BuildRequires:  rpmbuild(macros) >= 1.120
25 BuildRequires:  swig >= 1.3.17
26 BuildRequires:  swig-python >= 1.3.17
27 %endif
28 BuildRequires:  apr-devel >= 1:0.9.4
29 BuildRequires:  apr-util-devel >= 1:0.9.4
30 BuildRequires:  autoconf >= 2.53
31 BuildRequires:  bison
32 BuildRequires:  docbook-style-xsl >= 1.56
33 BuildRequires:  expat-devel
34 BuildRequires:  libtool >= 1.4-9
35 BuildRequires:  libxslt-progs
36 %{!?with_internal_neon:BuildRequires:   neon-devel >= 0.24.1}
37 BuildRequires:  python >= 2.2
38 BuildRequires:  rpm-pythonprov >= 4.0.2-50
39 BuildRequires:  texinfo
40 Requires(post): /usr/sbin/fix-info-dir
41 Requires(postun):       /usr/sbin/fix-info-dir
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %define         _apachelibdir   /usr/lib/apache
45 %define         _libexecdir     %{_libdir}/svn
46
47 %description
48 The goal of the Subversion project is to build a version control
49 system that is a compelling replacement for CVS in the open source
50 community.
51
52 Our goals are:
53 - All current CVS features.
54 - Directories, renames, and file meta-data are versioned.
55 - Symbolic links, etc, are supported
56 - Commits are truly atomic.
57 - Branching and tagging are cheap (constant time) operations
58 - Repeated merges are handled gracefully
59 - Support for plug-in client side diff programs
60 - Natively client/server
61 - Client/server protocol sends diffs in both directions
62 - Costs are proportional to change size, not project size
63 - Internationalization
64 - Progressive multi-lingual support
65
66 %description -l pl
67 Celem projektu Subversion jest stworzenie systemu kontroli wersji jako
68 zamiennika dla CVS.
69
70 Cele projektu to:
71 - Wszystkie aktualne mo¿liwo¶ci CVS.
72 - Katalogi, zmiany nazw oraz meta-dane plików s± wersjonowane.
73 - Wsparcie dla linków symbolicznych itp.
74 - Commity s± w pe³ni atomowe.
75 - Branchowanie oraz tagowanie s± tanimi (sta³ymi w czasie) operacjami.
76 - Powtarzaj±ce merge.
77 - Wsparcie dla pluginów diff'a po stronie klienta.
78 - Natywny klient/serwer.
79 - Klient/Serwer przesy³aj± diffy w obu kierunkach.
80 - Koszty proporcjonalne do rozmiaru zmiany, a nie rozmiaru projektu.
81 - Internacjonalizacja.
82 - Postêpuj±ce wsparcie dla wielu jêzyków.
83
84 %description -l pt_BR
85 O objetivo do projeto Subversion é construir um sistema de controle de
86 versões que seja um substituto para o CVS (Concurrent Versioning
87 System) na comunidade opensource, fornecendo grandes melhorias.
88
89 %package libs
90 Summary:        Subversion libraries and modules
91 Summary(pl):    Biblioteka subversion oraz ³adowalne modu³y
92 Group:          Libraries
93 Obsoletes:      libsubversion0
94
95 %description libs
96 Subversion libraries and modules.
97
98 %description libs -l pl
99 Biblioteka subversion oraz ³adowalne modu³y.
100
101 %package devel
102 Summary:        Header files and develpment documentation for subversion
103 Summary(pl):    Pliki nag³ówkowe i dokumetacja do subversion
104 Summary(pt_BR): Arquivos de desenvolvimento para o Subversion
105 Group:          Development/Libraries
106 Requires:       %{name}-libs = %{version}
107 Obsoletes:      libsubversion0-devel
108
109 %description devel
110 Header files and develpment documentation for subversion.
111
112 %description devel -l pl
113 Pliki nag³ówkowe i dokumetacja do subversion.
114
115 %description devel -l pt_BR
116 Este pacote provê os arquivos necessários para desenvolvedores
117 interagirem com o Subversion.
118
119 %package static
120 Summary:        Static subversion library
121 Summary(pl):    Biblioteka statyczna subversion
122 Summary(pt_BR): Sistema de versionamento concorrente
123 Group:          Development/Libraries
124 Requires:       %{name}-devel = %{version}
125 Obsoletes:      libsubversion0-static-devel
126
127 %description static
128 Static subversion library.
129
130 %description static -l pl
131 Biblioteka statyczna subversion.
132
133 %description static -l pt_BR
134 Este pacote provê um cliente estático do subversion.
135
136 %package tools
137 Summary:        Subversion tools and scripts
138 Summary(pl):    Narzêdzia oraz skrypty dla subversion
139 Summary(pt_BR): Módulos python para acessar os recursos do Subversion
140 Group:          Applications
141 Requires:       python >= 2.2
142 %pyrequires_eq  python
143 Requires:       python-rcsparse
144 Requires:       python-subversion = %{version}
145
146 %description tools
147 Subversion tools and scripts.
148
149 %description tools -l pl
150 Narzêdzia oraz skrypty dla subversion.
151
152
153 %package -n python-subversion
154 Summary:        Subversion python bindings
155 Summary(pl):    Dowi±zania do subversion dla pythona
156 Summary(pt_BR): Módulos python para acessar os recursos do Subversion
157 Group:          Development/Languages/Python
158 Requires:       python >= 2.2
159 Obsoletes:      subversion-python
160 %pyrequires_eq  python
161
162 %description -n python-subversion
163 Subversion python bindings.
164
165 %description -n python-subversion -l pl
166 Dowi±zania do subversion dla pythona.
167
168 %description -n python-subversion -l pt_BR
169 Módulos python para acessar os recursos do Subversion.
170
171 %package -n apache-mod_dav_svn
172 Summary:        Apache module: Subversion Server
173 Summary(pl):    Modu³ apache: Serwer Subversion
174 Group:          Networking/Daemons
175 Requires:       apache >= 2.0.47
176 Requires:       apache(modules-api) = %{apache_modules_api}
177 Requires:       apache-mod_dav
178
179 %description -n apache-mod_dav_svn
180 Apache module: Subversion Server.
181
182 %description -n apache-mod_dav_svn -l pl
183 Modu³ apache: Serwer Subversion.
184
185 %package -n apache-mod_authz_svn
186 Summary:        Apache module: Subversion Server - path-based authorization
187 Summary(pl):    Modu³ apache: autoryzacja na podstawie ¶cie¿ki dla serwera Subversion
188 Group:          Networking/Daemons
189 Requires:       apache-mod_dav_svn = %{version}
190 Requires:       apache >= 2.0.47
191 Requires:       apache(modules-api) = %{apache_modules_api}
192
193 %description -n apache-mod_authz_svn
194 Apache module: Subversion Server - path-based authorization.
195
196 %description -n apache-mod_authz_svn -l pl
197 Modu³ apache: autoryzacja na podstawie ¶cie¿ki dla serwera Subversion.
198
199 %prep
200 %setup -q
201
202 %build
203 chmod +x ./autogen.sh && ./autogen.sh
204
205 # don't enable dso - currently it's broken
206 %configure \
207 %if %{with net_client_only}
208         --without-apache \
209         --without-swig \
210         --without-apxs \
211         --without-berkeley-db \
212 %else
213         --disable-dso \
214         --disable-mod-activation \
215         --with-apxs=%{_sbindir}/apxs \
216         --with-berkeley-db=%{_includedir}/db4:%{_libdir} \
217 %endif
218         %{!?with_internal_neon:--with-neon=%{_prefix}} \
219         --with-apr=%{_bindir}/apr-config \
220         --with-apr-util=%{_bindir}/apu-config
221
222 %{__make}
223
224 %if ! %{with net_client_only}
225 %{__make} swig-py \
226         swig_pydir=%{py_sitedir}/libsvn \
227         swig_pydir_extra=%{py_sitedir}/svn
228 %endif
229
230 # build documentation; build process for documentation is severely
231 # braindamaged -- authors suggests to untar docbook distribution in
232 # build directory, hence the hack here
233 %{__make} -C doc/book all-html \
234         XSL_DIR=/usr/share/sgml/docbook/xsl-stylesheets/
235
236 # prepare for %%doc below
237 mv -f doc/book/book/html-chunk svn-handbook
238 mkdir svn-handbook/images/
239 cp -f doc/book/book/images/*.png svn-handbook/images/
240
241 %install
242 rm -rf $RPM_BUILD_ROOT
243 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/httpd/httpd.conf,%{_apachelibdir},%{_infodir}}
244
245 %{__make} install \
246         LC_ALL=C \
247         %{!?with_net_client_only:install-swig-py} \
248         DESTDIR=$RPM_BUILD_ROOT \
249         swig_pydir=%{py_sitedir}/libsvn \
250         swig_pydir_extra=%{py_sitedir}/svn
251
252 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd/httpd.conf/65_mod_dav_svn.conf
253 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/httpd/httpd.conf/66_mod_authz_svn.conf
254 install doc/programmer/design/*.info* $RPM_BUILD_ROOT%{_infodir}/
255
256 %if ! %{with net_client_only}
257 install tools/cvs2svn/cvs2svn.py        $RPM_BUILD_ROOT%{_bindir}
258 install tools/cvs2svn/cvs2svn.1         $RPM_BUILD_ROOT%{_mandir}/man1
259 cp tools/cvs2svn/README tools/cvs2svn/README.cvs2svn
260
261 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
262 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
263 %endif
264
265 %clean
266 rm -rf $RPM_BUILD_ROOT
267
268 %post devel
269 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
270
271 %postun devel
272 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
273
274 %post   libs -p /sbin/ldconfig
275 %postun libs -p /sbin/ldconfig
276
277 %post -n apache-mod_dav_svn
278 if [ -f /var/lock/subsys/httpd ]; then
279         /etc/rc.d/init.d/httpd restart 1>&2
280 else
281         echo "Run \"/etc/rc.d/init.d/httpd start\" to start apache http daemon."
282 fi
283
284 %preun -n apache-mod_dav_svn
285 if [ "$1" = "0" ]; then
286         if [ -f /var/lock/subsys/httpd ]; then
287                 /etc/rc.d/init.d/httpd restart 1>&2
288         fi
289 fi
290
291 %files
292 %defattr(644,root,root,755)
293 %doc BUGS CHANGES COPYING INSTALL README
294 %doc svn-handbook doc/book/misc-docs/misc-docs.html
295 %doc tools/hook-scripts/*.{pl,py,example}
296 %doc tools/hook-scripts/mailer/*.{py,example}
297 %attr(755,root,root) %{_bindir}/svn*
298 #%exclude %{_bindir}/svn-config
299 %{_mandir}/man1/*
300 %{?with_internal_neon:%exclude %{_mandir}/man1/neon*}
301
302 %files libs
303 %defattr(644,root,root,755)
304 %attr(755,root,root) %{_libdir}/lib*.so.*
305
306 %files devel
307 %defattr(644,root,root,755)
308 %{_includedir}/%{name}*
309 #%attr(755,root,root) %{_bindir}/svn-config
310 %attr(755,root,root) %{_libdir}/lib*.so
311 %{_libdir}/lib*.la
312 %{_infodir}/svn*
313
314 %files static
315 %defattr(644,root,root,755)
316 %{_libdir}/lib*.a
317
318 %if ! %{with net_client_only}
319 %files tools
320 %defattr(644,root,root,755)
321 %doc tools/cvs2svn/README*
322 %attr(755,root,root) %{_bindir}/cvs*
323 %{_mandir}/man1/cvs*
324
325 %files -n python-subversion
326 %defattr(644,root,root,755)
327 %doc tools/backup/*.py tools/examples/*.py
328 %dir %{py_sitedir}/svn
329 %dir %{py_sitedir}/libsvn
330 %{py_sitedir}/svn/*.py[co]
331 %{py_sitedir}/libsvn/*.py[co]
332 %attr(755,root,root) %{py_sitedir}/libsvn/*.so
333
334 %files -n apache-mod_dav_svn
335 %defattr(644,root,root,755)
336 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/httpd/httpd.conf/*_mod_dav_svn.conf
337 %attr(755,root,root) %{_apachelibdir}/mod_dav_svn.so
338
339 %files -n apache-mod_authz_svn
340 %defattr(644,root,root,755)
341 %doc subversion/mod_authz_svn/INSTALL
342 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/httpd/httpd.conf/*_mod_authz_svn.conf
343 %attr(755,root,root) %{_apachelibdir}/mod_authz_svn.so
344
345 %endif
This page took 0.062865 seconds and 3 git commands to generate.