]> git.pld-linux.org Git - packages/subversion.git/blob - subversion.spec
5141556a29b0964fba23fd7a549d6fc7f9251da4
[packages/subversion.git] / subversion.spec
1 #
2 # Conditional build:
3 %bcond_with     internal_neon           # build with internal neon
4 %bcond_with     net_client_only         # build only net client
5 #       
6 %include        /usr/lib/rpm/macros.python
7 %{!?with_net_client_only:%include       /usr/lib/rpm/macros.perl}
8 Summary:        A Concurrent Versioning system similar to but better than CVS
9 Summary(pl):    System kontroli wersji podobny, ale lepszy, ni¿ CVS
10 Summary(pt_BR): Sistema de versionamento concorrente
11 Name:           subversion
12 Version:        1.0.0
13 Release:        1
14 License:        Apache/BSD Style
15 Group:          Development/Version Control
16 Source0:        http://svn.collab.net/tarballs/%{name}-%{version}.tar.bz2
17 # Source0-md5:  ee14f19960c7fa9f2640ff04acdce804
18 Source1:        %{name}-dav_svn.conf
19 Source2:        %{name}-authz_svn.conf
20 Source3:        %{name}-svnserve.init
21 Source4:        %{name}-svnserve.sysconfig
22 #Patch0:                %{name}-svnlook.patch
23 #Patch1:                %{name}-hot_backup_num.patch
24 URL:            http://subversion.tigris.org/
25 Requires:       %{name}-libs = %{version}-%{release}
26 %if %{with net_client_only}
27 %global apache_modules_api 0
28 %else
29 BuildRequires:  automake
30 BuildRequires:  apache-devel >= 2.0.47-0.6
31 BuildRequires:  db-devel >= 4.1.25
32 BuildRequires:  rpmbuild(macros) >= 1.120
33 BuildRequires:  swig >= 1.3.19
34 BuildRequires:  swig-python >= 1.3.19
35 BuildRequires:  swig-perl >= 1.3.19
36 BuildRequires:  perl-devel >= 5.8.0
37 BuildRequires:  rpm-perlprov
38 %endif
39 BuildRequires:  apr-devel >= 1:0.9.5
40 BuildRequires:  apr-util-devel >= 1:0.9.5
41 BuildRequires:  autoconf >= 2.59
42 BuildRequires:  bison
43 BuildRequires:  docbook-style-xsl >= 1.56
44 BuildRequires:  expat-devel
45 BuildRequires:  libtool >= 1.4-9
46 BuildRequires:  libxslt-progs
47 %{!?with_internal_neon:BuildRequires:   neon-devel >= 0.24.1}
48 BuildRequires:  python-devel >= 2.2
49 BuildRequires:  rpm-pythonprov >= 4.0.2-50
50 BuildRequires:  texinfo
51 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
52
53 %define         _apachelibdir   /usr/%{_lib}/apache
54 %define         _libexecdir     %{_libdir}/svn
55
56 %description
57 The goal of the Subversion project is to build a version control
58 system that is a compelling replacement for CVS in the open source
59 community.
60
61 Our goals are:
62 - All current CVS features.
63 - Directories, renames, and file meta-data are versioned.
64 - Symbolic links, etc, are supported
65 - Commits are truly atomic.
66 - Branching and tagging are cheap (constant time) operations
67 - Repeated merges are handled gracefully
68 - Support for plug-in client side diff programs
69 - Natively client/server
70 - Client/server protocol sends diffs in both directions
71 - Costs are proportional to change size, not project size
72 - Internationalization
73 - Progressive multi-lingual support
74
75 %description -l pl
76 Celem projektu Subversion jest stworzenie systemu kontroli wersji jako
77 zamiennika dla CVS.
78
79 Cele projektu to:
80 - Wszystkie aktualne mo¿liwo¶ci CVS.
81 - Katalogi, zmiany nazw oraz meta-dane plików s± wersjonowane.
82 - Wsparcie dla linków symbolicznych itp.
83 - Commity s± w pe³ni atomowe.
84 - Branchowanie oraz tagowanie s± tanimi (sta³ymi w czasie) operacjami.
85 - Powtarzaj±ce merge.
86 - Wsparcie dla pluginów diff'a po stronie klienta.
87 - Natywny klient/serwer.
88 - Klient/Serwer przesy³aj± diffy w obu kierunkach.
89 - Koszty proporcjonalne do rozmiaru zmiany, a nie rozmiaru projektu.
90 - Internacjonalizacja.
91 - Postêpuj±ce wsparcie dla wielu jêzyków.
92
93 %description -l pt_BR
94 O objetivo do projeto Subversion é construir um sistema de controle de
95 versões que seja um substituto para o CVS (Concurrent Versioning
96 System) na comunidade opensource, fornecendo grandes melhorias.
97
98 %package libs
99 Summary:        Subversion libraries and modules
100 Summary(pl):    Biblioteka subversion oraz ³adowalne modu³y
101 Group:          Libraries
102 Obsoletes:      libsubversion0
103
104 %description libs
105 Subversion libraries and modules.
106
107 %description libs -l pl
108 Biblioteka subversion oraz ³adowalne modu³y.
109
110 %package devel
111 Summary:        Header files and develpment documentation for subversion
112 Summary(pl):    Pliki nag³ówkowe i dokumetacja do subversion
113 Summary(pt_BR): Arquivos de desenvolvimento para o Subversion
114 Group:          Development/Libraries
115 Requires:       %{name}-libs = %{version}-%{release}
116 Obsoletes:      libsubversion0-devel
117
118 %description devel
119 Header files and develpment documentation for subversion.
120
121 %description devel -l pl
122 Pliki nag³ówkowe i dokumetacja do subversion.
123
124 %description devel -l pt_BR
125 Este pacote provê os arquivos necessários para desenvolvedores
126 interagirem com o Subversion.
127
128 %package static
129 Summary:        Static subversion library
130 Summary(pl):    Biblioteka statyczna subversion
131 Summary(pt_BR): Sistema de versionamento concorrente
132 Group:          Development/Libraries
133 Requires:       %{name}-devel = %{version}
134 Obsoletes:      libsubversion0-static-devel
135
136 %description static
137 Static subversion library.
138
139 %description static -l pl
140 Biblioteka statyczna subversion.
141
142 %description static -l pt_BR
143 Este pacote provê um cliente estático do subversion.
144
145 %package svnserve
146 Summary:        Subversion svnserve
147 Summary(pl):    Subversion svnserve
148 Group:          Networking/Daemons
149 PreReq:         rc-scripts
150 Requires(post,preun):   /sbin/chkconfig
151 Requires:       %{name} = %{version}-%{release}
152
153 %description svnserve
154 Subversion svnserve server.
155
156 %description svnserve -l pl
157 Serwer subversion svnserve.
158
159 %package tools
160 Summary:        Subversion tools and scripts
161 Summary(pl):    Narzêdzia oraz skrypty dla subversion
162 Summary(pt_BR): Módulos python para acessar os recursos do Subversion
163 Group:          Applications
164 %pyrequires_eq  python
165 Requires:       python-rcsparse >= 0.1-0.20031026.0
166 Requires:       python-subversion = %{version}
167 Requires:       %{name} = %{version}-%{release}
168
169 %description tools
170 Subversion tools and scripts.
171
172 %description tools -l pl
173 Narzêdzia oraz skrypty dla subversion.
174
175 %package -n python-subversion
176 Summary:        Subversion python bindings
177 Summary(pl):    Dowi±zania do subversion dla pythona
178 Summary(pt_BR): Módulos python para acessar os recursos do Subversion
179 Group:          Development/Languages/Python
180 %pyrequires_eq  python
181 Obsoletes:      subversion-python
182 Requires:       %{name}-libs = %{version}-%{release}
183
184 %description -n python-subversion
185 Subversion python bindings.
186
187 %description -n python-subversion -l pl
188 Dowi±zania do subversion dla pythona.
189
190 %description -n python-subversion -l pt_BR
191 Módulos python para acessar os recursos do Subversion.
192
193 %package -n perl-subversion
194 Summary:        Subversion perl bindings
195 Summary(pl):    Dowi±zania do subversion dla perla
196 Summary(pt_BR): Módulos perl para acessar os recursos do Subversion
197 Group:          Development/Languages/Perl
198 Obsoletes:      subversion-perl
199 Requires:       %{name}-libs = %{version}-%{release}
200
201 %description -n perl-subversion
202 Subversion perl bindings.
203
204 %description -n perl-subversion -l pl
205 Dowi±zania do subversion dla perl.
206
207 %description -n perl-subversion -l pt_BR
208 Módulos perl para acessar os recursos do Subversion.
209
210 %package -n apache-mod_dav_svn
211 Summary:        Apache module: Subversion Server
212 Summary(pl):    Modu³ apache: Serwer Subversion
213 Group:          Networking/Daemons
214 Requires:       apache >= 2.0.47
215 Requires:       apache(modules-api) = %{apache_modules_api}
216 Requires:       apache-mod_dav
217 Requires:       %{name} = %{version}-%{release}
218
219 %description -n apache-mod_dav_svn
220 Apache module: Subversion Server.
221
222 %description -n apache-mod_dav_svn -l pl
223 Modu³ apache: Serwer Subversion.
224
225 %package -n apache-mod_authz_svn
226 Summary:        Apache module: Subversion Server - path-based authorization
227 Summary(pl):    Modu³ apache: autoryzacja na podstawie ¶cie¿ki dla serwera Subversion
228 Group:          Networking/Daemons
229 Requires:       apache-mod_dav_svn = %{version}-%{release}
230 Requires:       apache >= 2.0.47
231 Requires:       apache(modules-api) = %{apache_modules_api}
232
233 %description -n apache-mod_authz_svn
234 Apache module: Subversion Server - path-based authorization.
235
236 %description -n apache-mod_authz_svn -l pl
237 Modu³ apache: autoryzacja na podstawie ¶cie¿ki dla serwera Subversion.
238
239 %prep
240 %setup -q
241 #%patch0 -p0
242 #%patch1 -p1
243
244 %build
245 cp -f /usr/share/automake/config.sub ac-helpers
246 chmod +x ./autogen.sh && ./autogen.sh
247
248 # don't enable dso - currently it's broken
249 %configure \
250 %if %{with net_client_only}
251         --without-apache \
252         --without-swig \
253         --without-apxs \
254         --without-berkeley-db \
255 %else
256         --disable-dso \
257         --disable-mod-activation \
258         --with-apxs=%{_sbindir}/apxs \
259         --with-berkeley-db=%{_includedir}/db4:%{_libdir} \
260 %endif
261         %{!?with_internal_neon:--with-neon=%{_prefix}} \
262         --with-apr=%{_bindir}/apr-config \
263         --with-apr-util=%{_bindir}/apu-config
264
265 %{__make}
266
267 %if ! %{with net_client_only}
268 # python
269 %{__make} swig-py \
270         swig_pydir=%{py_sitedir}/libsvn \
271         swig_pydir_extra=%{py_sitedir}/svn
272 # perl
273 bdir=$(pwd)
274 %{__make} install-swig-pl-lib \
275         LC_ALL=C \
276         DESTDIR=${bdir}/swig-pl-lib-buildroot
277 %{__make}
278 cd subversion/bindings/swig/perl
279 env APR_CONFIG=%{_bindir}/apr-config \
280     APU_CONFIG=%{_bindir}/apu-config \
281         %{__perl} Makefile.PL \
282         INSTALLDIRS=vendor
283 env LIBRARY_PATH=${bdir}/swig-pl-lib-buildroot%{_libdir} %{__make}
284 cd ../../../../
285 %endif
286
287 # build documentation; build process for documentation is severely
288 # braindamaged -- authors suggests to untar docbook distribution in
289 # build directory, hence the hack here
290 ln -s /usr/share/sgml/docbook/xsl-stylesheets doc/book/tools/xsl
291 %{__make} -C doc/book all-html
292
293 # prepare for %%doc below
294 mv -f doc/book/book/html-chunk svn-handbook
295 mkdir svn-handbook/images/
296 cp -f doc/book/book/images/*.png svn-handbook/images/
297
298 %install
299 rm -rf $RPM_BUILD_ROOT
300 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,bash_completion.d} \
301         $RPM_BUILD_ROOT{%{_sysconfdir}/httpd/httpd.conf,%{_apachelibdir},%{_infodir}} \
302         $RPM_BUILD_ROOT%{_examplesdir}/{%{name}-%{version}/auth_provider,python-%{name}-%{version}}
303
304 %{__make} install \
305         LC_ALL=C \
306         %{!?with_net_client_only:install-swig-py} \
307         DESTDIR=$RPM_BUILD_ROOT \
308         swig_pydir=%{py_sitedir}/libsvn \
309         swig_pydir_extra=%{py_sitedir}/svn
310
311 %if ! %{with net_client_only}
312 %{__make} install-swig-pl-lib \
313         LC_ALL=C \
314         DESTDIR=$RPM_BUILD_ROOT
315 %{__make} -C subversion/bindings/swig/perl install \
316         DESTDIR=$RPM_BUILD_ROOT
317 %endif
318
319 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd/httpd.conf/65_mod_dav_svn.conf
320 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/httpd/httpd.conf/66_mod_authz_svn.conf
321 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/svnserve
322 install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/svnserve
323 install doc/programmer/design/*.info* $RPM_BUILD_ROOT%{_infodir}/
324
325 %if ! %{with net_client_only}
326 install tools/cvs2svn/cvs2svn.py        $RPM_BUILD_ROOT%{_bindir}/cvs2svn
327 install tools/cvs2svn/cvs2svn.1         $RPM_BUILD_ROOT%{_mandir}/man1
328 cp tools/cvs2svn/README tools/cvs2svn/README.cvs2svn
329 install tools/backup/hot-backup.py $RPM_BUILD_ROOT%{_bindir}/svn-hot-backup
330
331 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
332 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
333 find $RPM_BUILD_ROOT%{py_sitedir} -name "*.py" -o -name "*.a" -o -name "*.la" | xargs rm -f
334 install tools/examples/*.py $RPM_BUILD_ROOT%{_examplesdir}/python-%{name}-%{version}
335 %endif
336
337 install tools/client-side/bash_completion $RPM_BUILD_ROOT/etc/bash_completion.d/%{name}
338 install tools/examples/*.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
339 install tools/examples/auth_provider/*.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/auth_provider
340
341 %clean
342 rm -rf $RPM_BUILD_ROOT
343
344 %post devel
345 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
346
347 %postun devel
348 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
349
350 %post   libs -p /sbin/ldconfig
351 %postun libs -p /sbin/ldconfig
352
353 %post svnserve
354 if [ -f /var/lock/subsys/svnserve ]; then
355         /etc/rc.d/init.d/svnserve restart 1>&2
356 else
357         echo "Run \"/etc/rc.d/init.d/svnserve start\" to start subversion svnserve daemon."
358 fi
359
360 %preun svnserve
361 if [ "$1" = "0" ]; then
362         if [ -f /var/lock/subsys/svnserve ]; then
363                 /etc/rc.d/init.d/svnserve restart 1>&2
364         fi
365 fi
366
367 %post -n apache-mod_dav_svn
368 if [ -f /var/lock/subsys/httpd ]; then
369         /etc/rc.d/init.d/httpd restart 1>&2
370 else
371         echo "Run \"/etc/rc.d/init.d/httpd start\" to start apache http daemon."
372 fi
373
374 %preun -n apache-mod_dav_svn
375 if [ "$1" = "0" ]; then
376         if [ -f /var/lock/subsys/httpd ]; then
377                 /etc/rc.d/init.d/httpd restart 1>&2
378         fi
379 fi
380
381 %files
382 %defattr(644,root,root,755)
383 %doc BUGS CHANGES COPYING INSTALL README
384 %doc svn-handbook doc/book/misc-docs/misc-docs.html
385 %doc tools/hook-scripts/*.{pl,py,example}
386 %doc tools/hook-scripts/mailer/*.{py,example}
387 %doc tools/xslt/*
388 %attr(755,root,root) %{_bindir}/svn*
389 %exclude %{_bindir}/svnserve
390 %exclude %{_bindir}/svn-hot-backup
391 %{_mandir}/man1/*
392 %{_mandir}/man5/*
393 %{_mandir}/man8/*
394 %exclude %{_mandir}/man?/svnserve*
395 %{?with_internal_neon:%exclude %{_mandir}/man1/neon*}
396
397 %files libs
398 %defattr(644,root,root,755)
399 %attr(755,root,root) %{_libdir}/lib*.so.*
400
401 %files devel
402 %defattr(644,root,root,755)
403 %{_includedir}/%{name}*
404 %attr(755,root,root) %{_libdir}/lib*.so
405 %{_libdir}/lib*.la
406 %{_infodir}/svn*
407 %{_examplesdir}/%{name}-%{version}
408
409 %files static
410 %defattr(644,root,root,755)
411 %{_libdir}/lib*.a
412
413 %if ! %{with net_client_only}
414 %files svnserve
415 %defattr(644,root,root,755)
416 %attr(755,root,root) %{_bindir}/svnserve
417 %{_mandir}/man?/svnserve*
418 %attr(754,root,root) /etc/rc.d/init.d/svnserve
419 %attr(640,root,root) %config(noreplace) %verify(not mtime md5 size) /etc/sysconfig/svnserve
420
421 %files tools
422 %defattr(644,root,root,755)
423 %doc tools/cvs2svn/README*
424 %attr(755,root,root) %{_bindir}/cvs*
425 %attr(755,root,root) %{_bindir}/svn-hot-backup
426 /etc/bash_completion.d/%{name}
427 %{_mandir}/man1/cvs*
428
429 %files -n python-subversion
430 %defattr(644,root,root,755)
431 %doc tools/backup/*.py tools/examples/*.py
432 %dir %{py_sitedir}/svn
433 %dir %{py_sitedir}/libsvn
434 %{py_sitedir}/svn/*.py[co]
435 %{py_sitedir}/libsvn/*.py[co]
436 %attr(755,root,root) %{py_sitedir}/libsvn/*.so
437 %{_examplesdir}/python-%{name}-%{version}
438
439 %files -n perl-subversion
440 %defattr(644,root,root,755)
441 %{perl_vendorarch}/SVN
442 %dir %{perl_vendorarch}/auto/SVN
443 %dir %{perl_vendorarch}/auto/SVN/*
444 %attr(755,root,root) %{perl_vendorarch}/auto/SVN/*/*.so
445 %{perl_vendorarch}/auto/SVN/*/*.bs
446 %{_mandir}/man3/*.3pm*
447
448 %files -n apache-mod_dav_svn
449 %defattr(644,root,root,755)
450 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/httpd/httpd.conf/*_mod_dav_svn.conf
451 %attr(755,root,root) %{_apachelibdir}/mod_dav_svn.so
452
453 %files -n apache-mod_authz_svn
454 %defattr(644,root,root,755)
455 %doc subversion/mod_authz_svn/INSTALL
456 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/httpd/httpd.conf/*_mod_authz_svn.conf
457 %attr(755,root,root) %{_apachelibdir}/mod_authz_svn.so
458 %endif
This page took 0.0724939999999999 seconds and 2 git commands to generate.