]> git.pld-linux.org Git - packages/subversion.git/blob - subversion.spec
- updated to 0.36.0
[packages/subversion.git] / subversion.spec
1 #
2 # TODO:
3 # - separate subpackage with svnserve + init.d script + sysconfig file
4 #
5 # Conditional build:
6 %bcond_with     internal_neon           # build with internal neon
7 %bcond_with     net_client_only         # build only net client
8 #       
9 %include        /usr/lib/rpm/macros.python
10 %{!?with_net_client_only:%include       /usr/lib/rpm/macros.perl}
11 Summary:        A Concurrent Versioning system similar to but better than CVS
12 Summary(pl):    System kontroli wersji podobny, ale lepszy, ni¿ CVS
13 Summary(pt_BR): Sistema de versionamento concorrente
14 Name:           subversion
15 Version:        0.36.0
16 Release:        1
17 License:        Apache/BSD Style
18 Group:          Development/Version Control
19 Source0:        http://svn.collab.net/tarballs/%{name}-%{version}.tar.gz
20 # Source0-md5:  84749fc90377e8ac23dbcd7aa4d99f75
21 Source1:        %{name}-dav_svn.conf
22 Source2:        %{name}-authz_svn.conf
23 Source3:        %{name}-svnserve.init
24 Source4:        %{name}-svnserve.sysconfig
25 Patch0:         %{name}-svnlook.patch
26 Patch1:         %{name}-bindings.patch
27 URL:            http://subversion.tigris.org/
28 %if %{with net_client_only}
29 %global apache_modules_api 0
30 %else
31 BuildRequires:  automake
32 BuildRequires:  apache-devel >= 2.0.47-0.6
33 BuildRequires:  db-devel >= 4.1.25
34 BuildRequires:  rpmbuild(macros) >= 1.120
35 BuildRequires:  swig = 1.3.19
36 BuildRequires:  swig-python = 1.3.19
37 BuildRequires:  swig-perl = 1.3.19
38 BuildRequires:  perl-devel >= 5.8.0
39 BuildRequires:  rpm-perlprov
40 %endif
41 BuildRequires:  apr-devel >= 1:0.9.5
42 BuildRequires:  apr-util-devel >= 1:0.9.5
43 BuildRequires:  autoconf >= 2.59
44 BuildRequires:  bison
45 BuildRequires:  docbook-style-xsl >= 1.56
46 BuildRequires:  expat-devel
47 BuildRequires:  libtool >= 1.4-9
48 BuildRequires:  libxslt-progs
49 %{!?with_internal_neon:BuildRequires:   neon-devel >= 0.24.1}
50 BuildRequires:  python >= 2.2
51 BuildRequires:  rpm-pythonprov >= 4.0.2-50
52 BuildRequires:  texinfo
53 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
54
55 %define         _apachelibdir   /usr/%{_lib}/apache
56 %define         _libexecdir     %{_libdir}/svn
57
58 %description
59 The goal of the Subversion project is to build a version control
60 system that is a compelling replacement for CVS in the open source
61 community.
62
63 Our goals are:
64 - All current CVS features.
65 - Directories, renames, and file meta-data are versioned.
66 - Symbolic links, etc, are supported
67 - Commits are truly atomic.
68 - Branching and tagging are cheap (constant time) operations
69 - Repeated merges are handled gracefully
70 - Support for plug-in client side diff programs
71 - Natively client/server
72 - Client/server protocol sends diffs in both directions
73 - Costs are proportional to change size, not project size
74 - Internationalization
75 - Progressive multi-lingual support
76
77 %description -l pl
78 Celem projektu Subversion jest stworzenie systemu kontroli wersji jako
79 zamiennika dla CVS.
80
81 Cele projektu to:
82 - Wszystkie aktualne mo¿liwo¶ci CVS.
83 - Katalogi, zmiany nazw oraz meta-dane plików s± wersjonowane.
84 - Wsparcie dla linków symbolicznych itp.
85 - Commity s± w pe³ni atomowe.
86 - Branchowanie oraz tagowanie s± tanimi (sta³ymi w czasie) operacjami.
87 - Powtarzaj±ce merge.
88 - Wsparcie dla pluginów diff'a po stronie klienta.
89 - Natywny klient/serwer.
90 - Klient/Serwer przesy³aj± diffy w obu kierunkach.
91 - Koszty proporcjonalne do rozmiaru zmiany, a nie rozmiaru projektu.
92 - Internacjonalizacja.
93 - Postêpuj±ce wsparcie dla wielu jêzyków.
94
95 %description -l pt_BR
96 O objetivo do projeto Subversion é construir um sistema de controle de
97 versões que seja um substituto para o CVS (Concurrent Versioning
98 System) na comunidade opensource, fornecendo grandes melhorias.
99
100 %package libs
101 Summary:        Subversion libraries and modules
102 Summary(pl):    Biblioteka subversion oraz ³adowalne modu³y
103 Group:          Libraries
104 Obsoletes:      libsubversion0
105
106 %description libs
107 Subversion libraries and modules.
108
109 %description libs -l pl
110 Biblioteka subversion oraz ³adowalne modu³y.
111
112 %package devel
113 Summary:        Header files and develpment documentation for subversion
114 Summary(pl):    Pliki nag³ówkowe i dokumetacja do subversion
115 Summary(pt_BR): Arquivos de desenvolvimento para o Subversion
116 Group:          Development/Libraries
117 Requires:       %{name}-libs = %{version}
118 Obsoletes:      libsubversion0-devel
119
120 %description devel
121 Header files and develpment documentation for subversion.
122
123 %description devel -l pl
124 Pliki nag³ówkowe i dokumetacja do subversion.
125
126 %description devel -l pt_BR
127 Este pacote provê os arquivos necessários para desenvolvedores
128 interagirem com o Subversion.
129
130 %package static
131 Summary:        Static subversion library
132 Summary(pl):    Biblioteka statyczna subversion
133 Summary(pt_BR): Sistema de versionamento concorrente
134 Group:          Development/Libraries
135 Requires:       %{name}-devel = %{version}
136 Obsoletes:      libsubversion0-static-devel
137
138 %description static
139 Static subversion library.
140
141 %description static -l pl
142 Biblioteka statyczna subversion.
143
144 %description static -l pt_BR
145 Este pacote provê um cliente estático do subversion.
146
147 %package svnserve
148 Summary:        Subversion svnserve
149 Summary(pl):    Subversion svnserve
150 Group:          Networking/Daemons
151 PreReq:         rc-scripts
152 Requires(post,preun):   /sbin/chkconfig
153
154 %description svnserve
155 Subversion svnserve server.
156
157 %description svnserve -l pl
158 Serwer subversion svnserve.
159
160 %package tools
161 Summary:        Subversion tools and scripts
162 Summary(pl):    Narzêdzia oraz skrypty dla subversion
163 Summary(pt_BR): Módulos python para acessar os recursos do Subversion
164 Group:          Applications
165 %pyrequires_eq  python
166 Requires:       python-rcsparse >= 0.1-0.20031026.0
167 Requires:       python-subversion = %{version}
168
169 %description tools
170 Subversion tools and scripts.
171
172 %description tools -l pl
173 Narzêdzia oraz skrypty dla subversion.
174
175 %package -n python-subversion
176 Summary:        Subversion python bindings
177 Summary(pl):    Dowi±zania do subversion dla pythona
178 Summary(pt_BR): Módulos python para acessar os recursos do Subversion
179 Group:          Development/Languages/Python
180 %pyrequires_eq  python
181 Obsoletes:      subversion-python
182
183 %description -n python-subversion
184 Subversion python bindings.
185
186 %description -n python-subversion -l pl
187 Dowi±zania do subversion dla pythona.
188
189 %description -n python-subversion -l pt_BR
190 Módulos python para acessar os recursos do Subversion.
191
192 %package -n perl-subversion
193 Summary:        Subversion perl bindings
194 Summary(pl):    Dowi±zania do subversion dla perla
195 Summary(pt_BR): Módulos perl para acessar os recursos do Subversion
196 Group:          Development/Languages/Perl
197 Obsoletes:      subversion-perl
198
199 %description -n perl-subversion
200 Subversion perl bindings.
201
202 %description -n perl-subversion -l pl
203 Dowi±zania do subversion dla perl.
204
205 %description -n perl-subversion -l pt_BR
206 Módulos perl para acessar os recursos do Subversion.
207
208 %package -n apache-mod_dav_svn
209 Summary:        Apache module: Subversion Server
210 Summary(pl):    Modu³ apache: Serwer Subversion
211 Group:          Networking/Daemons
212 Requires:       apache >= 2.0.47
213 Requires:       apache(modules-api) = %{apache_modules_api}
214 Requires:       apache-mod_dav
215
216 %description -n apache-mod_dav_svn
217 Apache module: Subversion Server.
218
219 %description -n apache-mod_dav_svn -l pl
220 Modu³ apache: Serwer Subversion.
221
222 %package -n apache-mod_authz_svn
223 Summary:        Apache module: Subversion Server - path-based authorization
224 Summary(pl):    Modu³ apache: autoryzacja na podstawie ¶cie¿ki dla serwera Subversion
225 Group:          Networking/Daemons
226 Requires:       apache-mod_dav_svn = %{version}
227 Requires:       apache >= 2.0.47
228 Requires:       apache(modules-api) = %{apache_modules_api}
229
230 %description -n apache-mod_authz_svn
231 Apache module: Subversion Server - path-based authorization.
232
233 %description -n apache-mod_authz_svn -l pl
234 Modu³ apache: autoryzacja na podstawie ¶cie¿ki dla serwera Subversion.
235
236 %prep
237 %setup -q
238 %patch0 -p0
239 %patch1 -p1
240
241 %build
242 cp -f /usr/share/automake/config.sub ac-helpers
243 chmod +x ./autogen.sh && ./autogen.sh
244
245 # don't enable dso - currently it's broken
246 %configure \
247 %if %{with net_client_only}
248         --without-apache \
249         --without-swig \
250         --without-apxs \
251         --without-berkeley-db \
252 %else
253         --disable-dso \
254         --disable-mod-activation \
255         --with-apxs=%{_sbindir}/apxs \
256         --with-berkeley-db=%{_includedir}/db4:%{_libdir} \
257 %endif
258         %{!?with_internal_neon:--with-neon=%{_prefix}} \
259         --with-apr=%{_bindir}/apr-config \
260         --with-apr-util=%{_bindir}/apu-config
261
262 %{__make}
263
264 %if ! %{with net_client_only}
265 # python
266 %{__make} swig-py \
267         swig_pydir=%{py_sitedir}/libsvn \
268         swig_pydir_extra=%{py_sitedir}/svn
269 # perl
270 bdir=$(pwd)
271 %{__make} install-swig-pl-lib \
272         LC_ALL=C \
273         DESTDIR=${bdir}/swig-pl-lib-buildroot
274 %{__make}
275 cd subversion/bindings/swig/perl
276 env APR_CONFIG=%{_bindir}/apr-config \
277     APU_CONFIG=%{_bindir}/apu-config \
278         %{__perl} Makefile.PL \
279         INSTALLDIRS=vendor
280 env LIBRARY_PATH=${bdir}/swig-pl-lib-buildroot%{_libdir} %{__make}
281 cd ../../../../
282 %endif
283
284 # build documentation; build process for documentation is severely
285 # braindamaged -- authors suggests to untar docbook distribution in
286 # build directory, hence the hack here
287 ln -s /usr/share/sgml/docbook/xsl-stylesheets doc/book/tools/xsl
288 %{__make} -C doc/book all-html
289
290 # prepare for %%doc below
291 mv -f doc/book/book/html-chunk svn-handbook
292 mkdir svn-handbook/images/
293 cp -f doc/book/book/images/*.png svn-handbook/images/
294
295 %install
296 rm -rf $RPM_BUILD_ROOT
297 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig}
298 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/httpd/httpd.conf,%{_apachelibdir},%{_infodir}}
299
300 %{__make} install \
301         LC_ALL=C \
302         %{!?with_net_client_only:install-swig-py} \
303         DESTDIR=$RPM_BUILD_ROOT \
304         swig_pydir=%{py_sitedir}/libsvn \
305         swig_pydir_extra=%{py_sitedir}/svn
306
307 %if ! %{with net_client_only}
308 %{__make} install-swig-pl-lib \
309         LC_ALL=C \
310         DESTDIR=$RPM_BUILD_ROOT
311 %{__make} -C subversion/bindings/swig/perl install \
312         DESTDIR=$RPM_BUILD_ROOT
313 %endif
314
315 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd/httpd.conf/65_mod_dav_svn.conf
316 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/httpd/httpd.conf/66_mod_authz_svn.conf
317 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/svnserve
318 install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/svnserve
319 install doc/programmer/design/*.info* $RPM_BUILD_ROOT%{_infodir}/
320
321 %if ! %{with net_client_only}
322 install tools/cvs2svn/cvs2svn.py        $RPM_BUILD_ROOT%{_bindir}/cvs2svn
323 install tools/cvs2svn/cvs2svn.1         $RPM_BUILD_ROOT%{_mandir}/man1
324 cp tools/cvs2svn/README tools/cvs2svn/README.cvs2svn
325
326 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
327 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
328 %endif
329
330 %clean
331 rm -rf $RPM_BUILD_ROOT
332
333 %post devel
334 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
335
336 %postun devel
337 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
338
339 %post   libs -p /sbin/ldconfig
340 %postun libs -p /sbin/ldconfig
341
342 %post svnserve
343 if [ -f /var/lock/subsys/svnserve ]; then
344         /etc/rc.d/init.d/svnserve restart 1>&2
345 else
346         echo "Run \"/etc/rc.d/init.d/svnserve start\" to start subversion svnserve daemon."
347 fi
348
349 %preun svnserve
350 if [ "$1" = "0" ]; then
351         if [ -f /var/lock/subsys/svnserve ]; then
352                 /etc/rc.d/init.d/svnserve restart 1>&2
353         fi
354 fi
355
356 %post -n apache-mod_dav_svn
357 if [ -f /var/lock/subsys/httpd ]; then
358         /etc/rc.d/init.d/httpd restart 1>&2
359 else
360         echo "Run \"/etc/rc.d/init.d/httpd start\" to start apache http daemon."
361 fi
362
363 %preun -n apache-mod_dav_svn
364 if [ "$1" = "0" ]; then
365         if [ -f /var/lock/subsys/httpd ]; then
366                 /etc/rc.d/init.d/httpd restart 1>&2
367         fi
368 fi
369
370 %files
371 %defattr(644,root,root,755)
372 %doc BUGS CHANGES COPYING INSTALL README
373 %doc svn-handbook doc/book/misc-docs/misc-docs.html
374 %doc tools/hook-scripts/*.{pl,py,example}
375 %doc tools/hook-scripts/mailer/*.{py,example}
376 %attr(755,root,root) %{_bindir}/svn*
377 %exclude %{_bindir}/svnserve
378 %{_mandir}/man1/*
379 %{_mandir}/man5/*
380 %{_mandir}/man8/*
381 %exclude %{_mandir}/man?/svnserve*
382 %{?with_internal_neon:%exclude %{_mandir}/man1/neon*}
383
384 %files libs
385 %defattr(644,root,root,755)
386 %attr(755,root,root) %{_libdir}/lib*.so.*
387
388 %files devel
389 %defattr(644,root,root,755)
390 %{_includedir}/%{name}*
391 %attr(755,root,root) %{_libdir}/lib*.so
392 %{_libdir}/lib*.la
393 %{_infodir}/svn*
394
395 %files static
396 %defattr(644,root,root,755)
397 %{_libdir}/lib*.a
398
399 %if ! %{with net_client_only}
400 %files svnserve
401 %defattr(644,root,root,755)
402 %attr(755,root,root) %{_bindir}/svnserve
403 %{_mandir}/man?/svnserve*
404 %attr(754,root,root) /etc/rc.d/init.d/svnserve
405 %attr(640,root,root) %config(noreplace) %verify(not mtime md5 size) /etc/sysconfig/svnserve
406
407 %files tools
408 %defattr(644,root,root,755)
409 %doc tools/cvs2svn/README*
410 %attr(755,root,root) %{_bindir}/cvs*
411 %{_mandir}/man1/cvs*
412
413 %files -n python-subversion
414 %defattr(644,root,root,755)
415 %doc tools/backup/*.py tools/examples/*.py
416 %dir %{py_sitedir}/svn
417 %dir %{py_sitedir}/libsvn
418 %{py_sitedir}/svn/*.py[co]
419 %{py_sitedir}/libsvn/*.py[co]
420 %attr(755,root,root) %{py_sitedir}/libsvn/*.so
421
422 %files -n perl-subversion
423 %defattr(644,root,root,755)
424 %{perl_vendorarch}/SVN
425 %dir %{perl_vendorarch}/auto/SVN
426 %dir %{perl_vendorarch}/auto/SVN/*
427 %attr(755,root,root) %{perl_vendorarch}/auto/SVN/*/*.so
428 %{perl_vendorarch}/auto/SVN/*/*.bs
429 %{_mandir}/man3/*.3pm*
430
431 %files -n apache-mod_dav_svn
432 %defattr(644,root,root,755)
433 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/httpd/httpd.conf/*_mod_dav_svn.conf
434 %attr(755,root,root) %{_apachelibdir}/mod_dav_svn.so
435
436 %files -n apache-mod_authz_svn
437 %defattr(644,root,root,755)
438 %doc subversion/mod_authz_svn/INSTALL
439 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/httpd/httpd.conf/*_mod_authz_svn.conf
440 %attr(755,root,root) %{_apachelibdir}/mod_authz_svn.so
441 %endif
This page took 0.126673 seconds and 3 git commands to generate.