]> git.pld-linux.org Git - packages/subversion.git/blob - subversion.spec
-up to 1.7.16
[packages/subversion.git] / subversion.spec
1 # TODO:
2 # - serf as default: https://subversion.apache.org/docs/release-notes/1.7.html#serf
3 #
4 # Conditional build:
5 %bcond_with     net_client_only         # build only net client
6 %bcond_without  neon                    # use serf instead of neon
7 %bcond_without  swig                    # disable bindings generation with Swig
8 %bcond_without  python                  # build without Python bindings (broken)
9 %bcond_without  csvn                    # build Python csvn bindings
10 %bcond_without  perl                    # build without Perl bindings
11 %bcond_without  ruby                    # build without Ruby bindings
12 %bcond_without  apache                  # build without Apache support (webdav, etc)
13 %bcond_without  javahl                  # build without javahl support (Java high-level bindings)
14 %bcond_without  tests                   # don't perform "make check"
15 %bcond_without  kwallet                 # build without kde4 wallet support
16 %bcond_without  kde                     # build without kde4 support (alias for kwallet)
17 %bcond_without  gnome                   # build without gnome keyring support
18 %bcond_without  db                      # disable Subversion Berkeley DB based filesystem library
19
20 # for AC: --without csvn,gnome,javahl,kde,ruby
21
22 %if %{with net_client_only}
23 %undefine       with_apache
24 %undefine       with_db
25 %undefine       with_swig
26 %undefine       with_javahl
27 %endif
28
29 %if %{without swig}
30 %undefine       with_perl
31 %undefine       with_python
32 %undefine       with_ruby
33 %endif
34
35 %if %{without kde}
36 %undefine       with_kwallet
37 %endif
38
39 %if %{without python} && %{without perl} && %{without ruby}
40 %undefine       with_swig
41 %endif
42
43 %define apxs    /usr/sbin/apxs
44 %define pdir    SVN
45 %define pnam    _Core
46
47 %if %{with neon}
48 %define webdavlib       neon
49 %else
50 %define webdavlib       serf
51 %endif
52 %{?with_perl:%include   /usr/lib/rpm/macros.perl}
53 Summary:        A Concurrent Versioning system similar to but better than CVS
54 Summary(pl.UTF-8):      System kontroli wersji podobny, ale lepszy, niż CVS
55 Summary(pt_BR.UTF-8):   Sistema de versionamento concorrente
56 Name:           subversion
57 Version:        1.7.16
58 Release:        1
59 License:        Apache v2.0
60 Group:          Development/Version Control
61 Source0:        http://ftp.ps.pl/pub/apache/subversion/%{name}-%{version}.tar.bz2
62 # Source0-md5:  70d633fc6bd173b419c92d5e494919a5
63 Source1:        %{name}-dav_svn.conf
64 Source2:        %{name}-authz_svn.conf
65 Source3:        %{name}-svnserve.init
66 Source4:        %{name}-svnserve.sysconfig
67 # current subversion tarball has correct *.swg files
68 # but after regeneration these are broken again, so
69 # we still need this script
70 Source5:        %{name}-convert-typemaps-to-ifdef.py
71 Patch0:         %{name}-home_etc.patch
72 Patch1:         %{name}-DESTDIR.patch
73 Patch2:         %{name}-ruby-datadir-path.patch
74 Patch3:         %{name}-tests.patch
75 Patch4:         subversion-1.7.2-ruby19.patch
76 URL:            http://subversion.apache.org/
77 %{?with_apache:BuildRequires:   apache-devel >= 2.2.0-8}
78 BuildRequires:  apr-devel >= 1:1.0.0
79 BuildRequires:  apr-util-devel >= 1:1.2.8-3
80 BuildRequires:  autoconf >= 2.59
81 BuildRequires:  automake
82 BuildRequires:  bison
83 BuildRequires:  cyrus-sasl-devel
84 %if %{with kwallet} || %{with gnome}
85 BuildRequires:  dbus-devel
86 %endif
87 BuildRequires:  db-devel >= 4.1.25
88 BuildRequires:  expat-devel
89 BuildRequires:  gettext-devel
90 %{?with_kwallet:BuildRequires:  kde4-kdelibs-devel}
91 %{?with_gnome:BuildRequires:    libgnome-keyring-devel}
92 BuildRequires:  libmagic-devel
93 BuildRequires:  libtool >= 1.4-9
94 BuildRequires:  pkgconfig
95 %{?with_csvn:BuildRequires:     python-ctypesgen}
96 BuildRequires:  rpm-pythonprov
97 BuildRequires:  rpmbuild(macros) >= 1.656
98 BuildRequires:  sed >= 4.0
99 BuildRequires:  sqlite3-devel >= 3.6.18
100 BuildRequires:  texinfo
101 BuildRequires:  which
102 %if %{with neon}
103 BuildRequires:  neon-devel >= 0.26.0
104 %else
105 BuildRequires:  serf-devel >= 0.7.1
106 %endif
107 %if %{with javahl}
108 BuildRequires:  jdk >= 1.5
109 BuildRequires:  libstdc++-devel
110 %endif
111 %if %{with perl}
112 BuildRequires:  perl-devel >= 1:5.8.0
113 BuildRequires:  rpm-perlprov >= 4.1-13
114 BuildRequires:  swig-perl >= 1.3.24
115 %endif
116 %if %{with python}
117 BuildRequires:  python-devel >= 1:2.4
118 BuildRequires:  swig-python >= 1.3.24
119 %endif
120 %if %{with ruby}
121 BuildRequires:  rpm-rubyprov
122 BuildRequires:  ruby-devel >= 1:1.8.2
123 BuildRequires:  ruby-rubygems
124 BuildRequires:  swig-ruby >= 1.3.24
125 %endif
126 Requires:       %{name}-libs = %{version}-%{release}
127 %requires_ge    sqlite3
128 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
129
130 %define         _libexecdir             %{_libdir}/svn
131 %define         apacheconfdir   %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
132 %define         apachelibdir    %(%{apxs} -q LIBEXECDIR 2>/dev/null)
133
134 %define         skip_post_check_so      libsvn_swig_py-1.so.* libsvn_swig_perl-1.so.*
135
136 %description
137 The goal of the Subversion project is to build a version control
138 system that is a compelling replacement for CVS in the open source
139 community.
140
141 Our goals are:
142 - All current CVS features.
143 - Directories, renames, and file meta-data are versioned.
144 - Symbolic links, etc, are supported
145 - Commits are truly atomic.
146 - Branching and tagging are cheap (constant time) operations
147 - Repeated merges are handled gracefully
148 - Support for plug-in client side diff programs
149 - Natively client/server
150 - Client/server protocol sends diffs in both directions
151 - Costs are proportional to change size, not project size
152 - Internationalization
153 - Progressive multi-lingual support
154
155 %description -l pl.UTF-8
156 Celem projektu Subversion jest stworzenie systemu kontroli wersji jako
157 zamiennika dla CVS.
158
159 Cele projektu to:
160 - Wszystkie aktualne możliwości CVS.
161 - Katalogi, zmiany nazw oraz metadane plików są wersjonowane.
162 - Obsługa dowiązań symbolicznych itp.
163 - Commity są w pełni atomowe.
164 - Branchowanie oraz tagowanie są tanimi (stałymi w czasie) operacjami.
165 - Dobra obsługa powtarzanego łączenia (merge).
166 - Obsługa wtyczek diff po stronie klienta.
167 - Natywny klient/serwer.
168 - Klient/Serwer przesyłają diffy w obu kierunkach.
169 - Koszty proporcjonalne do rozmiaru zmiany, a nie rozmiaru projektu.
170 - Internacjonalizacja.
171 - Postępujące wsparcie dla wielu języków.
172
173 %description -l pt_BR.UTF-8
174 O objetivo do projeto Subversion é construir um sistema de controle de
175 versões que seja um substituto para o CVS (Concurrent Versioning
176 System) na comunidade opensource, fornecendo grandes melhorias.
177
178 %package libs
179 Summary:        Subversion libraries and modules
180 Summary(pl.UTF-8):      Biblioteka subversion oraz ładowalne moduły
181 Group:          Libraries
182 %if %{with neon}
183 Requires:       neon >= 0.26.0
184 %else
185 Requires:       serf >= 0.7.1
186 %endif
187 Obsoletes:      libsubversion0
188
189 %description libs
190 Subversion libraries and modules.
191
192 %description libs -l pl.UTF-8
193 Biblioteka subversion oraz ładowalne moduły.
194
195 %package devel
196 Summary:        Header files and develpment documentation for subversion
197 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumetacja do subversion
198 Summary(pt_BR.UTF-8):   Arquivos de desenvolvimento para o Subversion
199 Group:          Development/Libraries
200 Requires:       %{name}-libs = %{version}-%{release}
201 Requires:       apr-util-devel >= 1:1.0.0
202 %{?with_neon:Requires:  neon-devel >= 0.26.0}
203 Obsoletes:      libsubversion0-devel
204
205 %description devel
206 Header files and develpment documentation for subversion.
207
208 %description devel -l pl.UTF-8
209 Pliki nagłówkowe i dokumetacja do subversion.
210
211 %description devel -l pt_BR.UTF-8
212 Este pacote provê os arquivos necessários para desenvolvedores
213 interagirem com o Subversion.
214
215 %package static
216 Summary:        Static subversion library
217 Summary(pl.UTF-8):      Biblioteka statyczna subversion
218 Summary(pt_BR.UTF-8):   Sistema de versionamento concorrente
219 Group:          Development/Libraries
220 Requires:       %{name}-devel = %{version}
221 Obsoletes:      libsubversion0-static-devel
222
223 %description static
224 Static subversion library.
225
226 %description static -l pl.UTF-8
227 Biblioteka statyczna subversion.
228
229 %description static -l pt_BR.UTF-8
230 Este pacote provê um cliente estático do subversion.
231
232 %package svnserve
233 Summary:        Subversion svnserve
234 Summary(pl.UTF-8):      Subversion svnserve
235 Group:          Networking/Daemons
236 Requires(post,preun):   /sbin/chkconfig
237 Requires(postun):       /usr/sbin/groupdel
238 Requires(postun):       /usr/sbin/userdel
239 Requires(pre):  /bin/id
240 Requires(pre):  /usr/bin/getgid
241 Requires(pre):  /usr/lib/rpm/user_group.sh
242 Requires(pre):  /usr/sbin/groupadd
243 Requires(pre):  /usr/sbin/useradd
244 Requires(pre):  /usr/sbin/usermod
245 Requires:       %{name} = %{version}-%{release}
246 Requires:       rc-scripts
247 Provides:       group(svn)
248 Provides:       user(svn)
249
250 %description svnserve
251 Subversion svnserve server.
252
253 %description svnserve -l pl.UTF-8
254 Serwer subversion svnserve.
255
256 %package tools
257 Summary:        Subversion tools and scripts
258 Summary(pl.UTF-8):      Narzędzia oraz skrypty dla subversion
259 Summary(pt_BR.UTF-8):   Módulos python para acessar os recursos do Subversion
260 Group:          Applications
261 Requires:       %{name} = %{version}-%{release}
262 Requires:       python
263 Requires:       python-subversion = %{version}
264
265 %description tools
266 Subversion tools and scripts.
267
268 %description tools -l pl.UTF-8
269 Narzędzia oraz skrypty dla subversion.
270
271 %package -n bash-completion-subversion
272 Summary:        bash completion for subversion
273 Summary(pl.UTF-8):      Dopełnienia basha dla subversion
274 Group:          Applications/Shells
275 Requires:       %{name} = %{version}-%{release}
276 Requires:       bash-completion
277 Conflicts:      %{name}-tools <= 1.1.0-0.rc6.1
278
279 %description -n bash-completion-subversion
280 Bash completion for subversion.
281
282 %description -n bash-completion-subversion -l pl.UTF-8
283 Dopełnienia basha dla subversion.
284
285 %package -n java-subversion
286 Summary:        Subversion Java bindings
287 Summary(pl.UTF-8):      Dowiązania do Subversion dla Javy
288 Group:          Development/Languages/Java
289 Requires:       %{name}-libs = %{version}-%{release}
290
291 %description -n java-subversion
292 This is a set of Java classes which provide the functionality of
293 subversion-libs, the Subversion libraries. It is useful if you want
294 to, for example, write a Java class that manipulates a Subversion
295 repository or working copy. See the 'subversion' package for more
296 information.
297
298 %description -n java-subversion -l pl.UTF-8
299 Ten pakiet zawiera zestaw klas Javy udostępniających funkcjonalność
300 subversion-libs, czyli bibliotek Subversion. Jest przydatny przy
301 pisaniu klas Javy np. modyfikujących repozytorium Subversion lub kopię
302 roboczą. Więcej informacji w pakiecie subversion.
303
304 %package -n python-subversion
305 Summary:        Subversion Python bindings
306 Summary(pl.UTF-8):      Dowiązania do Subversion dla Pythona
307 Summary(pt_BR.UTF-8):   Módulos Python para acessar os recursos do Subversion
308 Group:          Development/Languages/Python
309 Requires:       %{name}-libs = %{version}-%{release}
310 Requires:       python
311 Obsoletes:      subversion-python
312
313 %description -n python-subversion
314 Subversion Python bindings.
315
316 %description -n python-subversion -l pl.UTF-8
317 Dowiązania do Subversion dla Pythona.
318
319 %description -n python-subversion -l pt_BR.UTF-8
320 Módulos Python para acessar os recursos do Subversion.
321
322 %package -n python-csvn
323 Summary:        CTypes Subversion Python bindings
324 Summary(pl.UTF-8):      Dowiązania do Subversion dla Pythona
325 Summary(pt_BR.UTF-8):   Módulos Python para acessar os recursos do Subversion
326 Group:          Development/Languages/Python
327 Requires:       %{name}-libs = %{version}-%{release}
328 Requires:       python
329
330 %description -n python-csvn
331 Subversion CTypes Python bindings.
332
333 %description -n python-csvn -l pl.UTF-8
334 Dowiązania do Subversion dla Pythona używające CTypes.
335
336 %description -n python-csvn -l pt_BR.UTF-8
337 Módulos Python para acessar os recursos do Subversion.
338
339 %package -n perl-subversion
340 Summary:        Subversion Perl bindings
341 Summary(pl.UTF-8):      Dowiązania do Subversion dla Perla
342 Summary(pt_BR.UTF-8):   Módulos Perl para acessar os recursos do Subversion
343 Group:          Development/Languages/Perl
344 Requires:       %{name}-libs = %{version}-%{release}
345 Obsoletes:      subversion-perl
346
347 %description -n perl-subversion
348 Subversion Perl bindings.
349
350 %description -n perl-subversion -l pl.UTF-8
351 Dowiązania do Subversion dla Perla.
352
353 %description -n perl-subversion -l pt_BR.UTF-8
354 Módulos Perl para acessar os recursos do Subversion.
355
356 %package -n ruby-subversion
357 Summary:        Subversion Ruby bindings
358 Summary(pl.UTF-8):      Dowiązania do Subversion dla języka Ruby
359 Summary(pt_BR.UTF-8):   Módulos Ruby para acessar os recursos do Subversion
360 Group:          Development/Languages
361 Requires:       %{name}-libs = %{version}-%{release}
362 Obsoletes:      subversion-ruby
363
364 %description -n ruby-subversion
365 Subversion Ruby bindings.
366
367 %description -n ruby-subversion -l pl.UTF-8
368 Dowiązania do Subversion dla języka Ruby.
369
370 %description -n ruby-subversion -l pt_BR.UTF-8
371 Módulos Ruby para acessar os recursos do Subversion.
372
373 %package -n apache-mod_dav_svn
374 Summary:        Apache module: Subversion Server
375 Summary(pl.UTF-8):      Moduł Apache'a: serwer Subversion
376 Group:          Networking/Daemons
377 Requires:       %{name} = %{version}-%{release}
378 Requires:       apache(modules-api) = %apache_modules_api
379 Requires:       apache-mod_dav
380
381 %description -n apache-mod_dav_svn
382 Apache module: Subversion Server.
383
384 %description -n apache-mod_dav_svn -l pl.UTF-8
385 Moduł Apache'a: serwer Subversion.
386
387 %package -n apache-mod_authz_svn
388 Summary:        Apache module: Subversion Server - path-based authorization
389 Summary(pl.UTF-8):      Moduł Apache'a: autoryzacja na podstawie ścieżki dla serwera Subversion
390 Group:          Networking/Daemons
391 Requires:       %{name}-libs = %{version}-%{release}
392 Requires:       apache(modules-api) = %apache_modules_api
393 Requires:       apache-mod_dav_svn = %{version}-%{release}
394
395 %description -n apache-mod_authz_svn
396 Apache module: Subversion Server - path-based authorization.
397
398 %description -n apache-mod_authz_svn -l pl.UTF-8
399 Moduł Apache'a: autoryzacja na podstawie ścieżki dla serwera
400 Subversion.
401
402 %package -n apache-mod_dontdothat_svn
403 Summary:        Apache module: Allows you to block specific svn requests
404 Summary(pl.UTF-8):      Moduł Apache'a pozwalający na blokowanie pewnych zapytań svn
405 Group:          Networking/Daemons
406 Requires:       %{name}-libs = %{version}-%{release}
407 Requires:       apache(modules-api) = %apache_modules_api
408 Requires:       apache-mod_dav_svn = %{version}-%{release}
409
410 %description -n apache-mod_dontdothat_svn
411 Apache module: Allows you to block specific svn requests.
412
413 %description -n apache-mod_dontdothat_svn -l pl.UTF-8
414 Moduł Apache'a pozwalający na blokowanie pewnych zapytań svn.
415
416 %package -n gnome-keyring-subversion
417 Summary:        GNOME Keyring authentication provider for Subversion
418 Summary(pl.UTF-8):      Moduł uwierzytelniający GNOME Keyring dla Subversion
419 Group:          X11/Applications
420 Requires:       %{name}-libs = %{version}-%{release}
421
422 %description -n gnome-keyring-subversion
423 Authentication provider module for Subversion which allows SVN client
424 to authenticate using GNOME Keyring.
425
426 %description -n gnome-keyring-subversion -l pl.UTF-8
427 Moduł uwierzytelniający dla Subversion pozwalający klientom SVN
428 uwierzytelniać się przy użyciu mechanizmu GNOME Keyring.
429
430 %package -n kde4-kwallet-subversion
431 Summary:        KDE Wallet authentication provider for Subversion
432 Summary(pl.UTF-8):      Moduł uwierzytelniający dla Subversion wykorzystujący Portfel KDE
433 Group:          X11/Applications
434 Requires:       %{name}-libs = %{version}-%{release}
435
436 %description -n kde4-kwallet-subversion
437 Authentication provider module for Subversion which allows SVN client
438 to authenticate using KDE Wallet.
439
440 %description -n kde4-kwallet-subversion -l pl.UTF-8
441 Moduł uwierzytelniający dla Subversion pozwalający klientom SVN
442 uwierzytelniać się przy użyciu Portfela KDE.
443
444 %prep
445 %setup -q
446 %patch0 -p0
447 %patch1 -p1
448 %patch2 -p0
449 %patch3 -p1
450 %patch4 -p1
451
452 sed -i -e 's#serf_prefix/lib#serf_prefix/%{_lib}#g' build/ac-macros/serf.m4
453
454 # serf.m4 macro is broken and ignores --without serf
455 %{?with_neon:sed -i -e 's#serf_found="yes"#serf_found="no"#g' build/ac-macros/serf.m4}
456
457 %build
458 # disabled regeneration - subversion 1.6.13 is not ready for swig 2.0.x
459 #%{__rm} subversion/bindings/swig/proxy/*.swg
460 #cd subversion/bindings/swig && python "%{SOURCE5}" && cd ../../..
461 chmod +x ./autogen.sh && ./autogen.sh
462 %{__libtoolize}
463 %configure \
464         --with-editor=vi \
465         --with-zlib=%{_libdir} \
466         --disable-runtime-module-search \
467         --disable-mod-activation \
468 %if %{with db}
469         --with-berkeley-db="db.h:%{_includedir}:%{_libdir}:db" \
470 %else
471         --without-berkeley-db \
472 %endif
473 %if %{with apache}
474         --with-apxs=%{_sbindir}/apxs \
475 %else
476         --without-apxs \
477 %endif
478 %if %{without swig}
479         --without-swig \
480 %endif
481 %if %{with ruby}
482         svn_cv_ruby_sitedir_libsuffix="" \
483         svn_cv_ruby_sitedir_archsuffix="" \
484         --with-ruby-sitedir=%{ruby_vendorarchdir} \
485 %else
486         ac_cv_path_RUBY=none \
487 %endif
488 %if %{with csvn}
489         --with-ctypesgen=%{_bindir}/ctypesgen.py \
490 %endif
491 %if %{with javahl}
492         --enable-javahl \
493         --with-jdk="%{java_home}" \
494         --without-jikes \
495 %else
496         --disable-javahl \
497 %endif
498 %if %{with neon}
499         --without-serf \
500         --with-neon=%{_prefix} \
501         --disable-neon-version-check \
502 %else
503         --with-serf=%{_prefix} \
504         --without-neon \
505 %endif
506         --with-apr=%{_bindir}/apr-1-config \
507         --with-apr-util=%{_bindir}/apu-1-config \
508 %if %{with kwallet}
509         --with-kwallet \
510 %endif
511 %if %{with gnome}
512         --with-gnome-keyring
513 %endif
514
515 %{__make} -j1
516
517 %{__make} tools
518
519 %if %{with csvn}
520 # Python ctypes bindings
521 %{__make} ctypes-python
522 %endif
523 %if %{with python}
524 # Python swig bindings
525 %{__make} swig-py \
526         swig_pydir=%{py_sitedir}/libsvn \
527         swig_pydir_extra=%{py_sitedir}/svn
528 %endif
529 %if %{with perl}
530 # Perl swig bindings
531 %{__make} -j1 swig-pl-lib
532 cd subversion/bindings/swig/perl/native
533 %{__perl} Makefile.PL INSTALLDIRS=vendor
534 %{__make} -j1
535 cd -
536 %endif
537 %if %{with javahl}
538 %{__make} -j1 javahl \
539         javahl_javadir="%{_javadir}"
540 %endif
541 # ruby
542 %if %{with ruby}
543 %{__make} swig-rb
544 %endif
545
546 %if %{with tests}
547 %{__make} -j1 check
548 %if %{with csvn}
549 %{__make} -j1 check-ctypes-python
550 %endif
551 %if %{with python}
552 %{__make} -j1 check-swig-py
553 %endif
554 %if %{with perl}
555 %{__make} -j1 check-swig-pl
556 %endif
557 %if %{with ruby}
558 # disabled, see https://bugs.launchpad.net/pld-linux/+bug/734340
559 #%{__make} check-swig-rb
560 %endif
561 %endif
562
563 %install
564 rm -rf $RPM_BUILD_ROOT
565 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,bash_completion.d} \
566         $RPM_BUILD_ROOT{%{apacheconfdir},%{apachelibdir},%{_infodir}} \
567         $RPM_BUILD_ROOT%{_examplesdir}/{%{name}-%{version},python-%{name}-%{version}} \
568         $RPM_BUILD_ROOT%{_sysconfdir}/%{name} \
569         $RPM_BUILD_ROOT/home/services/subversion{,/repos}
570
571 %{__make} install -j1 \
572         toolsdir=%{_bindir} \
573         DESTDIR=$RPM_BUILD_ROOT \
574         APACHE_LIBEXECDIR="$(%{_sbindir}/apxs -q LIBEXECDIR)" \
575 %if %{with javahl}
576         install-javahl \
577         javahl_javadir="%{_javadir}" \
578 %endif
579 %if %{with python}
580         install-swig-py \
581         swig_pydir=%{py_sitedir}/libsvn \
582         swig_pydir_extra=%{py_sitedir}/svn \
583 %endif
584 %if %{with csvn}
585         install-ctypes-python \
586 %endif
587         install-tools
588
589 %if %{with ruby}
590 %{__make} install -j1 \
591         DESTDIR=$RPM_BUILD_ROOT \
592         install-swig-rb install-swig-rb-doc \
593
594 # not our package
595 %{__rm} -r $RPM_BUILD_ROOT%{ruby_ridir}/OptionParser
596 %{__rm} -r $RPM_BUILD_ROOT%{ruby_ridir}/Time
597 %{__rm} $RPM_BUILD_ROOT%{ruby_ridir}/cache.ri
598 %{__rm} $RPM_BUILD_ROOT%{ruby_ridir}/created.rid
599 %endif
600
601 %if %{with perl}
602 %{__make} install-swig-pl-lib \
603         DESTDIR=$RPM_BUILD_ROOT
604 %{__make} -C subversion/bindings/swig/perl/native install \
605         DESTDIR=$RPM_BUILD_ROOT \
606         PREFIX=$RPM_BUILD_ROOT%{_prefix} \
607         LIBDIR=$RPM_BUILD_ROOT%{_libdir}
608 %endif
609
610 %if %{with apache}
611 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{apacheconfdir}/65_mod_dav_svn.conf
612 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{apacheconfdir}/66_mod_authz_svn.conf
613 cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/svnserve
614 install -p %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/svnserve
615 %endif
616
617 %if %{without net_client_only}
618 install -p tools/backup/hot-backup.py $RPM_BUILD_ROOT%{_bindir}/svn-hot-backup
619 %endif
620
621 # rename not to conflict with standard packages. (are these needed at all?)
622 mv $RPM_BUILD_ROOT%{_bindir}/{,svn}diff
623 mv $RPM_BUILD_ROOT%{_bindir}/{,svn}diff3
624 mv $RPM_BUILD_ROOT%{_bindir}/{,svn}diff4
625
626 %if %{with python} || %{with csvn}
627 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
628 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
629 %py_postclean
630 %endif
631 %if %{with python}
632 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/libsvn/*.la
633 # .a created on ac only
634 %{__rm} -f $RPM_BUILD_ROOT%{py_sitedir}/libsvn/*.a
635 cp -p tools/examples/*.py $RPM_BUILD_ROOT%{_examplesdir}/python-%{name}-%{version}
636 %endif
637
638 cp -p tools/client-side/bash_completion $RPM_BUILD_ROOT/etc/bash_completion.d/%{name}
639 cp -p tools/examples/*.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
640
641 %if %{with javahl}
642 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libsvnjavahl*.{la,a}
643 %endif
644 %if %{with swig}
645 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libsvn_swig*.{la,a}
646 %if %{with ruby}
647 %{__rm} $RPM_BUILD_ROOT%{ruby_vendorarchdir}/svn/ext/*.la
648 %endif
649 %endif
650 %if %{with gnome} || %{with kwallet}
651 # dlopened by soname (libsvn_auth_*-1.so.0)
652 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libsvn_auth_*-1.{so,la,a}
653 %endif
654
655 %find_lang %{name}
656
657 %clean
658 rm -rf $RPM_BUILD_ROOT
659
660 %pre svnserve
661 %groupadd -g 86 svn
662 %useradd -u 180 -d /home/services/subversion -c "Subversion svnserve" -g svn svn
663
664 %post   libs -p /sbin/ldconfig
665 %postun libs -p /sbin/ldconfig
666
667 %post   devel -p /sbin/postshell
668 -/usr/sbin/fix-info-dir -c %{_infodir}
669
670 %postun devel -p /sbin/postshell
671 -/usr/sbin/fix-info-dir -c %{_infodir}
672
673 %post   -n java-subversion -p /sbin/ldconfig
674 %postun -n java-subversion -p /sbin/ldconfig
675
676 %post   -n perl-subversion -p /sbin/ldconfig
677 %postun -n perl-subversion -p /sbin/ldconfig
678
679 %post   -n python-subversion -p /sbin/ldconfig
680 %postun -n python-subversion -p /sbin/ldconfig
681
682 %post   -n ruby-subversion -p /sbin/ldconfig
683 %postun -n ruby-subversion -p /sbin/ldconfig
684
685 %post   -n gnome-keyring-subversion -p /sbin/ldconfig
686 %postun -n gnome-keyring-subversion -p /sbin/ldconfig
687
688 %post   -n kde4-kwallet-subversion -p /sbin/ldconfig
689 %postun -n kde4-kwallet-subversion -p /sbin/ldconfig
690
691 %post svnserve
692 /sbin/chkconfig --add svnserve
693 %service svnserve restart "svnserve daemon"
694
695 %preun svnserve
696 if [ "$1" = "0" ]; then
697         %service svnserve stop
698         /sbin/chkconfig --del svnserve
699 fi
700
701 %postun svnserve
702 if [ "$1" = "0" ]; then
703         %userremove svn
704         %groupremove svn
705 fi
706
707 %post -n apache-mod_dav_svn
708 %service -q httpd restart
709
710 %postun -n apache-mod_dav_svn
711 if [ "$1" = "0" ]; then
712         %service -q httpd restart
713 fi
714
715 %post -n apache-mod_authz_svn
716 %service -q httpd restart
717
718 %postun -n apache-mod_authz_svn
719 if [ "$1" = "0" ]; then
720         %service -q httpd restart
721 fi
722
723 %post -n apache-mod_dontdothat_svn
724 %service -q httpd restart
725
726 %postun -n apache-mod_dontdothat_svn
727 if [ "$1" = "0" ]; then
728         %service -q httpd restart
729 fi
730
731 %files
732 %defattr(644,root,root,755)
733 %doc BUGS CHANGES INSTALL README
734 %doc doc/*/*.html
735 %doc tools/hook-scripts/*.{pl,py,example}
736 %doc tools/hook-scripts/mailer/*.{py,example}
737 %doc tools/xslt/*
738 %attr(755,root,root) %{_bindir}/svn
739 %attr(755,root,root) %{_bindir}/svnadmin
740 %attr(755,root,root) %{_bindir}/svndumpfilter
741 %attr(755,root,root) %{_bindir}/svnrdump
742 %attr(755,root,root) %{_bindir}/svnlook
743 %attr(755,root,root) %{_bindir}/svnsync
744 %attr(755,root,root) %{_bindir}/svnversion
745 %{_mandir}/man1/svn.1*
746 %{_mandir}/man1/svnadmin.1*
747 %{_mandir}/man1/svndumpfilter.1*
748 %{_mandir}/man1/svnrdump.1*
749 %{_mandir}/man1/svnlook.1*
750 %{_mandir}/man1/svnsync.1*
751 %{_mandir}/man1/svnversion.1*
752
753 %files libs -f %{name}.lang
754 %defattr(644,root,root,755)
755 %dir %{_sysconfdir}/%{name}
756 %attr(755,root,root) %{_libdir}/libsvn_client-1.so.*.*.*
757 %attr(755,root,root) %ghost %{_libdir}/libsvn_client-1.so.0
758 %attr(755,root,root) %{_libdir}/libsvn_delta-1.so.*.*.*
759 %attr(755,root,root) %ghost %{_libdir}/libsvn_delta-1.so.0
760 %attr(755,root,root) %{_libdir}/libsvn_diff-1.so.*.*.*
761 %attr(755,root,root) %ghost %{_libdir}/libsvn_diff-1.so.0
762 %attr(755,root,root) %{_libdir}/libsvn_fs-1.so.*.*.*
763 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs-1.so.0
764 %if %{without net_client_only}
765 %attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so.*.*.*
766 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_base-1.so.0
767 %endif
768 %attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so.*.*.*
769 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_fs-1.so.0
770 %attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so.*.*.*
771 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_util-1.so.0
772 %attr(755,root,root) %{_libdir}/libsvn_ra-1.so.*.*.*
773 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra-1.so.0
774 %attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so.*.*.*
775 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_local-1.so.0
776 %attr(755,root,root) %{_libdir}/libsvn_ra_%{webdavlib}-1.so.*.*.*
777 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_%{webdavlib}-1.so.0
778 %attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so.*.*.*
779 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_svn-1.so.0
780 %attr(755,root,root) %{_libdir}/libsvn_repos-1.so.*.*.*
781 %attr(755,root,root) %ghost %{_libdir}/libsvn_repos-1.so.0
782 %attr(755,root,root) %{_libdir}/libsvn_subr-1.so.*.*.*
783 %attr(755,root,root) %ghost %{_libdir}/libsvn_subr-1.so.0
784 %attr(755,root,root) %{_libdir}/libsvn_wc-1.so.*.*.*
785 %attr(755,root,root) %ghost %{_libdir}/libsvn_wc-1.so.0
786
787 %files devel
788 %defattr(644,root,root,755)
789 %attr(755,root,root) %{_libdir}/libsvn_client-1.so
790 %attr(755,root,root) %{_libdir}/libsvn_delta-1.so
791 %attr(755,root,root) %{_libdir}/libsvn_diff-1.so
792 %attr(755,root,root) %{_libdir}/libsvn_fs-1.so
793 %if %{without net_client_only}
794 %attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so
795 %endif
796 %attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so
797 %attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so
798 %attr(755,root,root) %{_libdir}/libsvn_ra-1.so
799 %attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so
800 %attr(755,root,root) %{_libdir}/libsvn_ra_%{webdavlib}-1.so
801 %attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so
802 %attr(755,root,root) %{_libdir}/libsvn_repos-1.so
803 %attr(755,root,root) %{_libdir}/libsvn_subr-1.so
804 %attr(755,root,root) %{_libdir}/libsvn_wc-1.so
805 %{_libdir}/libsvn_client-1.la
806 %{_libdir}/libsvn_delta-1.la
807 %{_libdir}/libsvn_diff-1.la
808 %{_libdir}/libsvn_fs-1.la
809 %if %{without net_client_only}
810 %{_libdir}/libsvn_fs_base-1.la
811 %endif
812 %{_libdir}/libsvn_fs_fs-1.la
813 %{_libdir}/libsvn_fs_util-1.la
814 %{_libdir}/libsvn_ra-1.la
815 %{_libdir}/libsvn_ra_local-1.la
816 %{_libdir}/libsvn_ra_%{webdavlib}-1.la
817 %{_libdir}/libsvn_ra_svn-1.la
818 %{_libdir}/libsvn_repos-1.la
819 %{_libdir}/libsvn_subr-1.la
820 %{_libdir}/libsvn_wc-1.la
821 %{_includedir}/%{name}-1
822 %{_examplesdir}/%{name}-%{version}
823
824 %files static
825 %defattr(644,root,root,755)
826 %{_libdir}/libsvn_client-1.a
827 %{_libdir}/libsvn_delta-1.a
828 %{_libdir}/libsvn_diff-1.a
829 %{_libdir}/libsvn_fs-1.a
830 %if %{without net_client_only}
831 %{_libdir}/libsvn_fs_base-1.a
832 %endif
833 %{_libdir}/libsvn_fs_fs-1.a
834 %{_libdir}/libsvn_fs_util-1.a
835 %{_libdir}/libsvn_ra-1.a
836 %{_libdir}/libsvn_ra_local-1.a
837 %{_libdir}/libsvn_ra_%{webdavlib}-1.a
838 %{_libdir}/libsvn_ra_svn-1.a
839 %{_libdir}/libsvn_repos-1.a
840 %{_libdir}/libsvn_subr-1.a
841 %{_libdir}/libsvn_wc-1.a
842
843 %if %{with gnome}
844 %files -n gnome-keyring-subversion
845 %defattr(644,root,root,755)
846 %attr(755,root,root) %{_libdir}/libsvn_auth_gnome_keyring-1.so.*.*.*
847 %attr(755,root,root) %ghost %{_libdir}/libsvn_auth_gnome_keyring-1.so.0
848 %endif
849
850 %if %{with kwallet}
851 %files -n kde4-kwallet-subversion
852 %defattr(644,root,root,755)
853 %attr(755,root,root) %{_libdir}/libsvn_auth_kwallet-1.so.*.*.*
854 %attr(755,root,root) %ghost %{_libdir}/libsvn_auth_kwallet-1.so.0
855 %endif
856
857 %if %{without net_client_only}
858 %files svnserve
859 %defattr(644,root,root,755)
860 %attr(755,root,root) %{_bindir}/svnserve
861 %{_mandir}/man5/svnserve.conf.5*
862 %{_mandir}/man8/svnserve.8*
863 %dir %attr(750,svn,svn) /home/services/subversion
864 %dir %attr(750,svn,svn) /home/services/subversion/repos
865 %if %{with apache}
866 %attr(754,root,root) /etc/rc.d/init.d/svnserve
867 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/svnserve
868 %endif
869
870 %files tools
871 %defattr(644,root,root,755)
872 # tools/backup/hot-backup.py
873 %attr(755,root,root) %{_bindir}/svn-hot-backup
874
875 # tools/diff
876 %attr(755,root,root) %{_bindir}/svndiff
877 %attr(755,root,root) %{_bindir}/svndiff3
878 %attr(755,root,root) %{_bindir}/svndiff4
879
880 # tools/server-side
881 %attr(755,root,root) %{_bindir}/svn-populate-node-origins-index
882 %attr(755,root,root) %{_bindir}/svn-rep-sharing-stats
883 %attr(755,root,root) %{_bindir}/svnauthz-validate
884
885 # tools/client-side/svnmucc
886 %attr(755,root,root) %{_bindir}/svnmucc
887 # tools/dev/svnraisetreeconflict
888 %attr(755,root,root) %{_bindir}/svnraisetreeconflict
889
890 %files -n bash-completion-subversion
891 %defattr(644,root,root,755)
892 /etc/bash_completion.d/%{name}
893
894 %endif # net_client_only
895
896 %if %{with javahl}
897 %files -n java-subversion
898 %defattr(644,root,root,755)
899 %attr(755,root,root) %{_libdir}/libsvnjavahl-1.so.*.*.*
900 %attr(755,root,root) %ghost %{_libdir}/libsvnjavahl-1.so.0
901 %attr(755,root,root) %{_libdir}/libsvnjavahl-1.so
902 %{_javadir}/svn-javahl.jar
903 %endif
904
905 %if %{with python}
906 %files -n python-subversion
907 %defattr(644,root,root,755)
908 %doc tools/backup/*.py
909 %attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so.*.*.*
910 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_py-1.so.0
911 %attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so
912 %dir %{py_sitedir}/libsvn
913 %attr(755,root,root) %{py_sitedir}/libsvn/_*.so
914 %{py_sitedir}/libsvn/*.py[co]
915 %dir %{py_sitedir}/svn
916 %{py_sitedir}/svn/*.py[co]
917 %{_examplesdir}/python-%{name}-%{version}
918 %endif
919
920 %if %{with csvn}
921 %files -n python-csvn
922 %defattr(644,root,root,755)
923 %doc subversion/bindings/ctypes-python/{README,TODO}
924 %doc subversion/bindings/ctypes-python/examples/*.py
925 %dir %{py_sitescriptdir}/csvn
926 %{py_sitescriptdir}/csvn/*.py[co]
927 %dir %{py_sitescriptdir}/csvn/core
928 %{py_sitescriptdir}/csvn/core/*.py[co]
929 %dir %{py_sitescriptdir}/csvn/ext
930 %{py_sitescriptdir}/csvn/ext/*.py[co]
931 %{py_sitescriptdir}/svn_ctypes_python_bindings-0.1-py*.egg-info
932 %endif
933
934 %if %{with perl}
935 %files -n perl-subversion
936 %defattr(644,root,root,755)
937 %attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so.*.*.*
938 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_perl-1.so.0
939 %attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so
940 %{perl_vendorarch}/SVN
941 %dir %{perl_vendorarch}/auto/SVN
942 %dir %{perl_vendorarch}/auto/SVN/*
943 %attr(755,root,root) %{perl_vendorarch}/auto/SVN/*/*.so
944 %{perl_vendorarch}/auto/SVN/*/*.bs
945 %{_mandir}/man3/*.3pm*
946 %endif
947
948 %if %{with ruby}
949 %files -n ruby-subversion
950 %defattr(644,root,root,755)
951 %attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so.*.*.*
952 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_ruby-1.so.0
953 %attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so
954 %dir %{ruby_vendorarchdir}/svn
955 %{ruby_vendorarchdir}/svn/*.rb
956 %dir %{ruby_vendorarchdir}/svn/ext
957 %attr(755,root,root) %{ruby_vendorarchdir}/svn/ext/*.so
958 %{ruby_ridir}/Svn
959 %endif
960
961 %if %{with apache}
962 %files -n apache-mod_dav_svn
963 %defattr(644,root,root,755)
964 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_dav_svn.conf
965 %attr(755,root,root) %{apachelibdir}/mod_dav_svn.so
966
967 %files -n apache-mod_authz_svn
968 %defattr(644,root,root,755)
969 %doc subversion/mod_authz_svn/INSTALL
970 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_authz_svn.conf
971 %attr(755,root,root) %{apachelibdir}/mod_authz_svn.so
972
973 %files -n apache-mod_dontdothat_svn
974 %defattr(644,root,root,755)
975 %doc tools/server-side/mod_dontdothat/README
976 %attr(755,root,root) %{apachelibdir}/mod_dontdothat.so
977 %endif
This page took 1.057191 seconds and 3 git commands to generate.