]> git.pld-linux.org Git - packages/strace.git/commitdiff
- patch for compiling strace with kernel 2.6 and userspace headers
authorJacek Konieczny <jajcus@pld-linux.org>
Sun, 21 Dec 2003 08:56:48 +0000 (08:56 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    strace-kernel26_userspace.patch -> 1.1

strace-kernel26_userspace.patch [new file with mode: 0644]

diff --git a/strace-kernel26_userspace.patch b/strace-kernel26_userspace.patch
new file mode 100644 (file)
index 0000000..3cbf2fe
--- /dev/null
@@ -0,0 +1,32 @@
+diff -durN -x '*~' strace-4.5.1.orig/configure.ac strace-4.5.1/configure.ac
+--- strace-4.5.1.orig/configure.ac     2003-11-07 00:44:09.000000000 +0100
++++ strace-4.5.1/configure.ac  2004-12-21 09:51:41.882695896 +0100
+@@ -190,7 +190,7 @@
+ AC_CHECK_FUNCS(sigaction strerror strsignal pread sys_siglist _sys_siglist getdents mctl prctl sendmsg inet_ntop if_indextoname)
+ AC_CHECK_HEADERS([sys/reg.h sys/filio.h sys/acl.h sys/asynch.h sys/door.h stropts.h sys/conf.h sys/stream.h sys/tihdr.h sys/tiuser.h sys/sysconfig.h ioctls.h sys/ioctl.h sys/ptrace.h termio.h linux/ptrace.h asm/reg.h sys/uio.h sys/aio.h  poll.h sys/poll.h sys/vfs.h asm/sysmips.h linux/utsname.h sys/nscsys.h], [], [])
+ AC_CHECK_HEADERS([linux/icmp.h linux/in6.h linux/netlink.h linux/if_packet.h],
+-                 [], [], [#include <linux/socket.h>])
++                 [], [], [#include <sys/socket.h>])
+ AC_CHECK_HEADERS([asm/sigcontext.h], [], [], [#include <signal.h>])
+ AC_CHECK_HEADERS([netinet/tcp.h netinet/udp.h],,, [#include <netinet/in.h>])
+diff -durN -x '*~' strace-4.5.1.orig/system.c strace-4.5.1/system.c
+--- strace-4.5.1.orig/system.c 2002-11-06 15:00:13.000000000 +0100
++++ strace-4.5.1/system.c      2004-12-21 09:52:32.005076136 +0100
+@@ -1626,16 +1626,7 @@
+ };
+ static struct xlat sysctl_vm[] = {
+-      { VM_SWAPCTL, "VM_SWAPCTL" },
+-      { VM_SWAPOUT, "VM_SWAPOUT" },
+-      { VM_FREEPG, "VM_FREEPG" },
+-      { VM_BDFLUSH, "VM_BDFLUSH" },
+       { VM_OVERCOMMIT_MEMORY, "VM_OVERCOMMIT_MEMORY" },
+-      { VM_BUFFERMEM, "VM_BUFFERMEM" },
+-      { VM_PAGECACHE, "VM_PAGECACHE" },
+-      { VM_PAGERDAEMON, "VM_PAGERDAEMON" },
+-      { VM_PGT_CACHE, "VM_PGT_CACHE" },
+-      { VM_PAGE_CLUSTER, "VM_PAGE_CLUSTER" },
+       { 0, NULL },
+ };
This page took 0.126992 seconds and 4 git commands to generate.