]> git.pld-linux.org Git - packages/strace.git/blob - strace.spec
4d1a774747480468c30a518c8aed488ac7bad020
[packages/strace.git] / strace.spec
1 #
2 # Conditional build:
3 %bcond_without  libunwind       # strack tracing using libunwind
4 %bcond_without  libiberty       # symbol demangling in stack backtraces
5 #
6 %ifnarch %{ix86} %{x8664} x32 %{arm} hppa ia64 mips ppc ppc64 sh
7 %undefine       with_libunwind
8 %endif
9 Summary:        prints system call strace of a running process
10 Summary(de.UTF-8):      druckt ein Protokoll der Systemaufrufe eines laufenden Prozesses
11 Summary(es.UTF-8):      Enseña las llamadas de sistema de un proceso en ejecución
12 Summary(fr.UTF-8):      affiche l'appel système strace d'un processus en exécution
13 Summary(pl.UTF-8):      strace wyświetla funkcje systemowe wywoływane przez uruchomiony proces
14 Summary(pt_BR.UTF-8):   Mostra as chamadas de sistema de um processo rodando
15 Summary(ru.UTF-8):      Отслеживает и показывает системные вызовы, связанные с запущенным процессом
16 Summary(tr.UTF-8):      Çalışan bir sürecin yaptığı sistem çağrılarını listeler
17 Summary(uk.UTF-8):      Відслідковує та показує системні виклики, пов'язані із запущеним процесом
18 Name:           strace
19 Version:        5.0
20 Release:        1
21 License:        LGPL v2.1+
22 Group:          Development/Debuggers
23 Source0:        https://github.com/strace/strace/releases/download/v%{version}/%{name}-%{version}.tar.xz
24 # Source0-md5:  8499d66e5c467fd391c272dd82f0b691
25 Source1:        %{name}.1.pl
26 URL:            https://strace.io/
27 # acl and libaio for headers only
28 BuildRequires:  acl-devel
29 %{?with_libiberty:BuildRequires:        binutils-devel >= 4:2.30-1}
30 BuildRequires:  libaio-devel
31 %{?with_libunwind:BuildRequires:        libunwind-devel}
32 BuildRequires:  tar >= 1:1.22
33 BuildRequires:  xz
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 Strace prints a record of each system call another program makes,
38 including all of the arguments passed to it and the system call's
39 return value.
40
41 %description -l de.UTF-8
42 Strace druckt ein Protokoll aller von einem anderen Programm
43 ausgegebenen Systemaufrufe, einschließlich aller weitergeleiteten
44 Argumente und dem Ausgabewert des Systemaufrufs.
45
46 %description -l es.UTF-8
47 Strace imprime una "grabación" de cada llamada de sistema que el
48 programa hace, incluyendo todos los argumentos pasados para él, si la
49 vuelta de cada llamada de sistema es verdadera, o si hay creado error.
50
51 %description -l fr.UTF-8
52 strace affiche l'enregistrement de chaque appel système que fait un
53 programme ainsi que tous les arguments qui lui ont été passés et la
54 valeur de retour de l'appel.
55
56 %description -l pl.UTF-8
57 Strace wyświetla informacje o każdym wywołaniu funkcji systemowych
58 przez uruchamiany program, w tym również wszystkie argumenty wywołania
59 i zwróconą wartość.
60
61 %description -l pt_BR.UTF-8
62 Strace imprime uma "gravação" de cada chamada de sistema que o
63 programa faz, incluindo todos os argumentos passados para ele e se o
64 retorno de cada chamada de sistema é verdadeiro ou gerou erro.
65
66 %description -l ru.UTF-8
67 Программа strace перехватывает и регистрирует системные вызовы,
68 произведенные и полученные исполняющимся процессом. Strace может
69 вывести список всех системных вызовов, их аргументов и возвращаемые
70 ими значения. Strace полезна для диагностики проблем и отладки.
71
72 %description -l tr.UTF-8
73 strace bir programın çalıştığı sürece yaptığı bütün sistem
74 çağrılarını, gönderdiği parametreler ve geri dönüş değerleriyle
75 birlikte döker.
76
77 %description -l uk.UTF-8
78 Програма strace перехоплює та регіструє системні визови, зроблені та
79 отримані процесом, який виконується. Strace може вивести список усіх
80 системних визовів, їх аргументів та значень, які вони повернули.
81 Strace корисний для діагностики проблем та відладки.
82
83 %package graph
84 Summary:        strace graph
85 Summary(pl.UTF-8):      Graf strace
86 Group:          Development/Debuggers
87 # NOTE: doesn't require directly strace binary.
88
89 %description graph
90 strace-graph script processes strace -f output. It displays a graph of
91 invoked subprocesses, and is useful for finding out what complex
92 commands do.
93
94 The script can also handle the output with strace -t, -tt, or -ttt. It
95 will add elapsed time for each process in that case.
96
97 %description graph -l pl.UTF-8
98 Skrypt strace-graph przetwarza wynik strace -f i wyświetla graf
99 wywoływanych podprocesów. Jest przydatny do sprawdzania co robią
100 złożone polecenia.
101
102 Skrypt jest w stanie obsłużyć także wyjście ze strace -t, -tt i -ttt.
103 Doda wtedy upływający czas dla każdego procesu.
104
105 %prep
106 %setup -q
107
108 %build
109 %if %{with libunwind}
110 # workaround for:
111 # /usr/bin/ld: copy reloc against protected `_UPT_accessors' is invalid
112 # /usr/bin/ld: failed to set dynamic section sizes: Bad value
113 # (should be fixed in gcc >(=?) 5.1)
114 CFLAGS="%{rpmcflags} -fPIE"
115 %endif
116 %configure \
117         %{!?with_libiberty:--without-libiberty} \
118         %{!?with_libunwind:--without-libunwind}
119 %{__make}
120
121 %install
122 rm -rf $RPM_BUILD_ROOT
123
124 %{__make} install \
125         DESTDIR=$RPM_BUILD_ROOT
126
127 install -D %{SOURCE1} $RPM_BUILD_ROOT%{_mandir}/pl/man1/strace.1
128
129 %clean
130 rm -rf $RPM_BUILD_ROOT
131
132 %files
133 %defattr(644,root,root,755)
134 %doc COPYING CREDITS ChangeLog NEWS README-linux-ptrace
135 %attr(755,root,root) %{_bindir}/strace
136 %attr(755,root,root) %{_bindir}/strace-log-merge
137 %{_mandir}/man1/strace.1*
138 %{_mandir}/man1/strace-log-merge.1*
139 %lang(pl) %{_mandir}/pl/man1/strace.1*
140
141 %files graph
142 %defattr(644,root,root,755)
143 %attr(755,root,root) %{_bindir}/strace-graph
This page took 0.050563 seconds and 2 git commands to generate.