]> git.pld-linux.org Git - packages/steam-launcher.git/blame_incremental - steam-launcher.spec
disable debug packages; rel 2
[packages/steam-launcher.git] / steam-launcher.spec
... / ...
CommitLineData
1%define _enable_debug_packages 0
2
3Summary: Launcher for the Steam software distribution service
4Name: steam-launcher
5Version: 1.0.0.69
6Release: 2
7License: distributable
8Group: Applications
9Source0: https://repo.steampowered.com/steam/pool/steam/s/steam/steam_%{version}.tar.gz
10# Source0-md5: 9099e348686ac5d50f6a8823e40c421d
11Source1: %{name}.sysconfig
12Patch0: steamdeps.patch
13Patch1: desktop_path.patch
14URL: http://store.steampowered.com/
15BuildRequires: sed >= 4.0
16Requires: ca-certificates >= 20180409-3
17Requires: curl
18Requires: fonts-TTF-RedHat-liberation
19Requires: glibc >= 6:2.15
20Requires: libtxc_dxtn
21Requires: pld-release
22Requires: poldek
23Requires: python-modules
24Requires: rpm
25Requires: which
26Requires: xdg-user-dirs
27Requires: xterm
28Requires: xz
29Requires: zenity
30ExclusiveArch: %{ix86} %{x8664}
31BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33%ifarch %{x8664}
34%define poldek_sources -n th -n th-i686
35%else
36%define poldek_sources -n th
37%endif
38
39%description
40Steam is a software distribution service with an online store,
41automated installation, automatic updates, achievements, SteamCloud
42synchronized savegame and screenshot functionality, and many social
43features.
44
45%prep
46%setup -qn steam-launcher
47%patch0 -p1
48%patch1 -p1
49
50%{__sed} -i -e '1s,/usr/bin/env python3,%{__python3},' bin_steamdeps.py
51%{__sed} -i -e '1s,/usr/bin/env bash,%{__bash},' bin_steam.sh
52
53sed -i -e's/^ARCH\s*=.*$/ARCH = "%{_arch}"/' steamdeps
54
55%install
56rm -rf $RPM_BUILD_ROOT
57
58install -d $RPM_BUILD_ROOT/etc/sysconfig
59
60%{__make} install \
61 DESTDIR=$RPM_BUILD_ROOT
62
63rm $RPM_BUILD_ROOT%{_docdir}/steam/{README,steam_subscriber_agreement.txt}
64
65# installed only when apt is installed on the build host
66[ -d $RPM_BUILD_ROOT/etc/apt ] && rm -r $RPM_BUILD_ROOT/etc/apt
67
68sed -e's/@SOURCES@/%{poldek_sources}/' %{SOURCE1} > $RPM_BUILD_ROOT/etc/sysconfig/%{name}
69
70%{__rm} $RPM_BUILD_ROOT%{_desktopdir}/steam.desktop
71%{__mv} $RPM_BUILD_ROOT/usr/lib/steam/steam.desktop $RPM_BUILD_ROOT%{_desktopdir}/steam.desktop
72
73
74%clean
75rm -rf $RPM_BUILD_ROOT
76
77%post
78%update_icon_cache hicolor
79%update_desktop_database
80%glib_compile_schemas
81
82%postun
83%update_icon_cache hicolor
84%update_desktop_database_postun
85%glib_compile_schemas
86
87%files
88%defattr(644,root,root,755)
89%doc steam_subscriber_agreement.txt
90%attr(755,root,root) %{_bindir}/steam
91%attr(755,root,root) %{_bindir}/steamdeps
92%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
93%dir /usr/lib/steam
94%attr(755,root,root) /usr/lib/steam/bin_steam.sh
95%attr(755,root,root) /usr/lib/steam/bin_steamdeps.py
96/usr/lib/steam/bootstraplinux*.tar.xz
97%{_desktopdir}/steam.desktop
98%{_iconsdir}/hicolor/*/*/*.png
99%{_mandir}/man6/steam.6*
100%{_pixmapsdir}/*.png
This page took 0.063905 seconds and 4 git commands to generate.