]> git.pld-linux.org Git - packages/sqlite3.git/commitdiff
up to 3.37.0 auto/th/sqlite3-3.37.0-1
authorJan Palus <atler@pld-linux.org>
Fri, 3 Dec 2021 20:36:38 +0000 (21:36 +0100)
committerJan Palus <atler@pld-linux.org>
Fri, 3 Dec 2021 20:38:13 +0000 (21:38 +0100)
it appears that sqlite added option to generated version of configure
script instead of configure.ac so patch the latter with the same logic

sqlite3-amalgamation_configure.patch [new file with mode: 0644]
sqlite3.spec

diff --git a/sqlite3-amalgamation_configure.patch b/sqlite3-amalgamation_configure.patch
new file mode 100644 (file)
index 0000000..6b035b6
--- /dev/null
@@ -0,0 +1,37 @@
+--- sqlite-src-3370000/configure.ac.orig       2021-11-27 16:05:17.000000000 +0100
++++ sqlite-src-3370000/configure.ac    2021-12-03 21:21:47.506868981 +0100
+@@ -116,6 +116,13 @@
+ USE_AMALGAMATION=1
+ #########
++# By default, amalgamation sqlite3.c will have #line directives.
++# This is a build option not shown by ./configure --help
++# To control it, use configure option: amalgamation_line_macros=?
++# where ? is no to suppress #line directives or yes to create them.
++AMALGAMATION_LINE_MACROS=--linemacros=0
++
++#########
+ # See whether we can run specific tclsh versions known to work well;
+ # if not, then we fall back to plain tclsh.
+ # TODO: try other versions before falling back?
+@@ -574,6 +581,20 @@
+ fi
+ AC_SUBST(USE_AMALGAMATION)
++########
++# See whether --disable
++if test "${amalgamation_line_macros+set}" = set; then :
++  enableval=$amalgamation_line_macros;
++fi
++
++if test "${amalgamation_line_macros}" = "yes" ; then
++  AMALGAMATION_LINE_MACROS=--linemacros=1
++fi
++if test "${amalgamation_line_macros}" = "no" ; then
++  AMALGAMATION_LINE_MACROS=--linemacros=0
++fi
++AC_SUBST(AMALGAMATION_LINE_MACROS)
++
+ #########
+ # Look for zlib.  Only needed by extensions and by the sqlite3.exe shell
+ AC_CHECK_HEADERS(zlib.h)
index f0d4735171b135331a8db9c16ff8fa4b079029b8..4c403941205e9299c16f2b87c1fc679b482f19ba 100644 (file)
@@ -25,7 +25,7 @@
 
 # sqlite3 version with zero padded without any dots (3 08 10 01 is 3.8.10.1)
 # but trailing 00 means no 4rd part (3 11 01 00 is 3.11.1)
-%define                vnum    3360000
+%define                vnum    3370000
 %define                ver             %{lua:vn=rpm.expand("%vnum");v="";for i in string.gmatch(string.format("%08d", vn), "..") do v=v.."."..i:gsub("^0", "");end;v=v:gsub("^.",""):gsub("\.0$","");print(v)}
 
 %define                tclver          8.6
@@ -38,7 +38,8 @@ License:      Public Domain
 Group:         Libraries
 # Source0Download: http://www.sqlite.org/download.html
 Source0:       https://www.sqlite.org/2021/sqlite-src-%{vnum}.zip
-# Source0-md5: b0d614ffe9b19638dcf7f80046e5020e
+# Source0-md5: d75d06336e541712d5297a2ec405e2cd
+Patch0:                %{name}-amalgamation_configure.patch
 URL:           https://www.sqlite.org/
 BuildRequires: autoconf >= 2.50
 BuildRequires: automake
@@ -198,6 +199,7 @@ Rozszerzenie sqlite3 dla Tcl.
 
 %prep
 %setup -q -n sqlite-src-%{vnum}
+%patch0 -p1
 
 %{__sed} -i 's/mkdir doc/#mkdir doc/' Makefile.in
 
This page took 0.798335 seconds and 4 git commands to generate.