]> git.pld-linux.org Git - packages/sqlite3.git/blob - sqlite3.spec
- up to 3.5.1
[packages/sqlite3.git] / sqlite3.spec
1 # TODO:
2 # - some tests fail with tcl8.5, it's tcl fault,
3 #       if someone REALLY cares (s)he can look into it
4 #
5 # Conditional build:
6 %bcond_with     tests   # run tests
7 %bcond_without  tcl     # disable tcl extension
8 %bcond_without  doc     # disable documentation building
9 #
10 %ifarch alpha sparc %{x8664}
11 %undefine       with_tests
12 %endif
13
14 # disabling tcl currently breaks making test target,
15 # some hack in Makefile needs to be done
16 %if !%{with tcl}
17 %undefine       with_tests
18 %endif
19
20 %define         _ulibdir        /usr/lib
21 %define         tclver          %(rpm -q --qf '%{V}' tcl)
22
23 Summary:        SQLite library
24 Summary(pl.UTF-8):      Biblioteka SQLite
25 Name:           sqlite3
26 Version:        3.5.1
27 Release:        1
28 License:        LGPL
29 Group:          Libraries
30 # Source0Download: http://sqlite.org/download.html
31 Source0:        http://sqlite.org/sqlite-%{version}.tar.gz
32 # Source0-md5:  b015a6db82b95a4668280982fbabfa67
33 Patch0:         %{name}-sign-function.patch
34 Patch1:         %{name}-pkgconfig.patch
35 Patch2:         %{name}-doc.patch
36 URL:            http://sqlite.org/
37 BuildRequires:  autoconf
38 BuildRequires:  automake
39 BuildRequires:  libtool
40 BuildRequires:  readline-devel
41 %{?with_tcl:BuildRequires:      tcl-devel}
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %description
45 SQLite is a C library that implements an SQL database engine. A large
46 subset of SQL92 is supported. A complete database is stored in a
47 single disk file. The API is designed for convenience and ease of use.
48 Applications that link against SQLite can enjoy the power and
49 flexiblity of an SQL database without the administrative hassles of
50 supporting a separate database server. Because it omits the
51 client-server interaction overhead and writes directly to disk, SQLite
52 is also faster than the big database servers for most operations. In
53 addition to the C library, the SQLite distribution includes a
54 command-line tool for interacting with SQLite databases and SQLite
55 bindings for Tcl/Tk.
56
57 %description -l pl.UTF-8
58 SQLite jest biblioteką języka C, która implementuje silnik baz danych
59 SQL (obsługiwana jest większość standardu SQL92). Cała baza danych
60 przechowywana jest w jednym pliku. Aplikacje wykorzystujące tę
61 bibliotekę charakteryzują się siłą i elastycznością SQLowych baz
62 danych bez konieczności utrzymywania osobnego serwera baz danych.
63 Ponieważ pomijana jest komunikacja klient-serwer i dane są zapisywane
64 bezpośrednio na dysku, SQLite jest szybsza od dużych serwerów
65 bazodanowych przy większości operacji na bazie danych. Dodatkowo
66 oprócz biblioteki języka C, dostarczany jest program do zarządzania
67 bazami danych.
68
69 %package devel
70 Summary:        Header files for SQLite development
71 Summary(pl.UTF-8):      Pliki nagłówkowe SQLite
72 Group:          Development/Libraries
73 Requires:       %{name} = %{version}-%{release}
74
75 %description devel
76 SQLite is a C library that implements an SQL database engine. A large
77 subset of SQL92 is supported. A complete database is stored in a
78 single disk file. The API is designed for convenience and ease of use.
79 Applications that link against SQLite can enjoy the power and
80 flexiblity of an SQL database without the administrative hassles of
81 supporting a separate database server. Because it omits the
82 client-server interaction overhead and writes directly to disk, SQLite
83 is also faster than the big database servers for most operations. In
84 addition to the C library, the SQLite distribution includes a
85 command-line tool for interacting with SQLite databases and SQLite
86 bindings for Tcl/Tk.
87
88 This package contains the header files needed to develop programs that
89 use these SQLite.
90
91 %description devel -l pl.UTF-8
92 SQLite jest biblioteką języka C, która implementuje silnik baz danych
93 SQL (obsługiwana jest większość standardu SQL92). Cała baza danych
94 przechowywana jest w jednym pliku. Aplikacje wykorzystujące tę
95 bibliotekę charakteryzują się siłą i elastycznością SQLowych baz
96 danych bez konieczności utrzymywania osobnego serwera baz danych.
97 Ponieważ pomijana jest komunikacja klient-serwer i dane są zapisywane
98 bezpośrednio na dysku, SQLite jest szybsza od dużych serwerów
99 bazodanowych przy większości operacji na bazie danych. Dodatkowo
100 oprócz biblioteki języka C, dostarczany jest program do zarządzania
101 bazami danych.
102
103 Pakiet zawiera pliki nagówkowe niezbedne do kompilowania programów
104 używających biblioteki SQLite.
105
106 %package static
107 Summary:        Static libraries for SQLite development
108 Summary(pl.UTF-8):      Statyczne biblioteki SQLite
109 Group:          Development/Libraries
110 Requires:       %{name}-devel = %{version}-%{release}
111
112 %description static
113 SQLite is a C library that implements an SQL database engine. A large
114 subset of SQL92 is supported. A complete database is stored in a
115 single disk file. The API is designed for convenience and ease of use.
116 Applications that link against SQLite can enjoy the power and
117 flexiblity of an SQL database without the administrative hassles of
118 supporting a separate database server. Because it omits the
119 client-server interaction overhead and writes directly to disk, SQLite
120 is also faster than the big database servers for most operations. In
121 addition to the C library, the SQLite distribution includes a
122 command-line tool for interacting with SQLite databases and SQLite
123 bindings for Tcl/Tk.
124
125 This package contains the static SQLite libraries.
126
127 %description static -l pl.UTF-8
128 SQLite jest biblioteką języka C, która implementuje silnik baz danych
129 SQL (obsługiwana jest większość standardu SQL92). Cała baza danych
130 przechowywana jest w jednym pliku. Aplikacje wykorzystujące tę
131 bibliotekę charakteryzują się siłą i elastycznością SQLowych baz
132 danych bez konieczności utrzymywania osobnego serwera baz danych.
133 Ponieważ pomijana jest komunikacja klient-serwer i dane są zapisywane
134 bezpośrednio na dysku, SQLite jest szybsza od dużych serwerów
135 bazodanowych przy większości operacji na bazie danych. Dodatkowo
136 oprócz biblioteki języka C, dostarczany jest program do zarządzania
137 bazami danych.
138
139 Pakiet zawiera statyczne biblioteki SQLite.
140
141 %package -n tcl-%{name}
142 Summary:        sqlite3 tcl extension
143 Summary(pl.UTF-8):      Rozszerzenie sqlite3 dla Tcl
144 Group:          Development/Languages/Tcl
145
146 %description -n tcl-%{name}
147 sqlite3 tcl extension.
148
149 %description -n tcl-%{name} -l pl.UTF-8
150 Rozszerzenie sqlite3 dla Tcl.
151
152 %prep
153 %setup -q -n sqlite-%{version}
154 %patch0 -p1
155 %patch1 -p1
156 %patch2 -p1
157
158 sed -i 's/mkdir doc/#mkdir doc/' Makefile*
159
160 %build
161 %{__libtoolize}
162 cp -f /usr/share/automake/config.sub .
163 %{__aclocal}
164 %{__autoconf}
165 CFLAGS="%{rpmcflags} -DSQLITE_ENABLE_COLUMN_METADATA=1"
166 export CFLAGS
167 %configure \
168         %{?with_tcl:--with-tcl=%{_ulibdir}} \
169         %{!?with_tcl:--disable-tcl} \
170         --enable-threadsafe
171 %{__make}
172
173 %if %{with doc}
174 %{__make} doc
175 %endif
176
177 %{?with_tests:LC_ALL=C %{__make} test}
178
179 %install
180 rm -rf $RPM_BUILD_ROOT
181 install -d $RPM_BUILD_ROOT{%{_bindir},%{_includedir},%{_libdir},%{_mandir}/man1}
182
183 %{__make} install \
184         DESTDIR=$RPM_BUILD_ROOT \
185         TCLLIBDIR=%{_libdir}/tcl%{tclver}
186
187 %if %{with tcl}
188 sed -i -e "s#$RPM_BUILD_ROOT##g" $RPM_BUILD_ROOT%{_libdir}/tcl*/sqlite3/*.tcl
189 %endif
190
191 install sqlite3.1 $RPM_BUILD_ROOT%{_mandir}/man1
192
193 %clean
194 rm -rf $RPM_BUILD_ROOT
195
196 %post   -p /sbin/ldconfig
197 %postun -p /sbin/ldconfig
198
199 %files
200 %defattr(644,root,root,755)
201 %doc README
202 %attr(755,root,root) %{_bindir}/sqlite3
203 %attr(755,root,root) %{_libdir}/lib*.so.*.*
204 %{_mandir}/man1/sqlite3.1*
205
206 %files devel
207 %defattr(644,root,root,755)
208 %doc doc/*
209 %attr(755,root,root) %{_libdir}/lib*.so
210 %{_libdir}/lib*.la
211 %{_includedir}/sqlite3.h
212 %{_includedir}/sqlite3ext.h
213 %{_pkgconfigdir}/*.pc
214
215 %files static
216 %defattr(644,root,root,755)
217 %{_libdir}/lib*.a
218
219 %if %{with tcl}
220 %files -n tcl-%{name}
221 %defattr(644,root,root,755)
222 %dir %{_libdir}/tcl*/sqlite3
223 %attr(755,root,root) %{_libdir}/tcl*/sqlite3/*.so
224 %{_libdir}/tcl*/sqlite3/*.tcl
225 %endif
This page took 0.042079 seconds and 4 git commands to generate.