]> git.pld-linux.org Git - packages/sqlite3.git/blob - sqlite3.spec
- 3.3.6
[packages/sqlite3.git] / sqlite3.spec
1 # TODO:
2 # - fix lib64 in tcl module
3 # - date test fail on tcl8.5 because of missing tcl library initialization
4 #   (and thus unavailable clock command)
5 #
6 # Conditional build:
7 %bcond_without  tests # don't run tests
8 %bcond_without  tcl   # disable tcl extension
9 %bcond_without  docs  # disable documentation building
10 #
11 Summary:        SQLite library
12 Summary(pl):    Biblioteka SQLite
13 Name:           sqlite3
14 Version:        3.3.6
15 Release:        1
16 License:        LGPL
17 Group:          Libraries
18 # Source0Download: http://sqlite.org/download.html
19 Source0:        http://sqlite.org/sqlite-%{version}.tar.gz
20 # Source0-md5:  a2cb1fafad5c2587e513dcbd18ace097
21 Patch0:         %{name}-sign-function.patch
22 Patch1:         %{name}-pkgconfig.patch
23 URL:            http://sqlite.org/
24 BuildRequires:  autoconf
25 BuildRequires:  automake
26 BuildRequires:  libtool
27 BuildRequires:  readline-devel
28 %{?with_tcl:BuildRequires:      tcl-devel}
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %ifarch alpha %{x8664}
32 %undefine       with_tests
33 %endif
34
35 # disabling tcl currently breaks making test target,
36 # some hack in Makefile needs to be done
37 %if %{without tcl}
38 %undefine       with_tests
39 %endif
40
41 %define         _ulibdir        /usr/lib
42
43 %description
44 SQLite is a C library that implements an SQL database engine. A large
45 subset of SQL92 is supported. A complete database is stored in a
46 single disk file. The API is designed for convenience and ease of use.
47 Applications that link against SQLite can enjoy the power and
48 flexiblity of an SQL database without the administrative hassles of
49 supporting a separate database server. Because it omits the
50 client-server interaction overhead and writes directly to disk, SQLite
51 is also faster than the big database servers for most operations. In
52 addition to the C library, the SQLite distribution includes a
53 command-line tool for interacting with SQLite databases and SQLite
54 bindings for Tcl/Tk.
55
56 %description -l pl
57 SQLite jest bibliotek± jêzyka C, która implementuje silnik baz danych
58 SQL (obs³ugiwana jest wiêkszo¶æ standardu SQL92). Ca³a baza danych
59 przechowywana jest w jednym pliku. Aplikacje wykorzystuj±ce tê
60 bibliotekê charakteryzuj± siê si³± i elastyczno¶ci± SQLowych baz
61 danych bez konieczno¶ci utrzymywania osobnego serwera baz danych.
62 Poniewa¿ pomijana jest komunikacja klient-serwer i dane s± zapisywane
63 bezpo¶rednio na dysku, SQLite jest szybsza od du¿ych serwerów
64 bazodanowych przy wiêkszo¶ci operacji na bazie danych. Dodatkowo
65 oprócz biblioteki jêzyka C, dostarczany jest program do zarz±dzania
66 bazami danych.
67
68 %package devel
69 Summary:        Header files for SQLite development
70 Summary(pl):    Pliki nag³ówkowe SQLite
71 Group:          Development/Libraries
72 Requires:       %{name} = %{version}-%{release}
73
74 %description devel
75 SQLite is a C library that implements an SQL database engine. A large
76 subset of SQL92 is supported. A complete database is stored in a
77 single disk file. The API is designed for convenience and ease of use.
78 Applications that link against SQLite can enjoy the power and
79 flexiblity of an SQL database without the administrative hassles of
80 supporting a separate database server. Because it omits the
81 client-server interaction overhead and writes directly to disk, SQLite
82 is also faster than the big database servers for most operations. In
83 addition to the C library, the SQLite distribution includes a
84 command-line tool for interacting with SQLite databases and SQLite
85 bindings for Tcl/Tk.
86
87 This package contains the header files needed to develop programs that
88 use these SQLite.
89
90 %description devel -l pl
91 SQLite jest bibliotek± jêzyka C, która implementuje silnik baz danych
92 SQL (obs³ugiwana jest wiêkszo¶æ standardu SQL92). Ca³a baza danych
93 przechowywana jest w jednym pliku. Aplikacje wykorzystuj±ce tê
94 bibliotekê charakteryzuj± siê si³± i elastyczno¶ci± SQLowych baz
95 danych bez konieczno¶ci utrzymywania osobnego serwera baz danych.
96 Poniewa¿ pomijana jest komunikacja klient-serwer i dane s± zapisywane
97 bezpo¶rednio na dysku, SQLite jest szybsza od du¿ych serwerów
98 bazodanowych przy wiêkszo¶ci operacji na bazie danych. Dodatkowo
99 oprócz biblioteki jêzyka C, dostarczany jest program do zarz±dzania
100 bazami danych.
101
102 Pakiet zawiera pliki nagówkowe niezbedne do kompilowania programów
103 u¿ywaj±cych biblioteki SQLite.
104
105 %package static
106 Summary:        Static libraries for SQLite development
107 Summary(pl):    Statyczne biblioteki SQLite
108 Group:          Development/Libraries
109 Requires:       %{name}-devel = %{version}-%{release}
110
111 %description static
112 SQLite is a C library that implements an SQL database engine. A large
113 subset of SQL92 is supported. A complete database is stored in a
114 single disk file. The API is designed for convenience and ease of use.
115 Applications that link against SQLite can enjoy the power and
116 flexiblity of an SQL database without the administrative hassles of
117 supporting a separate database server. Because it omits the
118 client-server interaction overhead and writes directly to disk, SQLite
119 is also faster than the big database servers for most operations. In
120 addition to the C library, the SQLite distribution includes a
121 command-line tool for interacting with SQLite databases and SQLite
122 bindings for Tcl/Tk.
123
124 This package contains the static SQLite libraries.
125
126 %description static -l pl
127 SQLite jest bibliotek± jêzyka C, która implementuje silnik baz danych
128 SQL (obs³ugiwana jest wiêkszo¶æ standardu SQL92). Ca³a baza danych
129 przechowywana jest w jednym pliku. Aplikacje wykorzystuj±ce tê
130 bibliotekê charakteryzuj± siê si³± i elastyczno¶ci± SQLowych baz
131 danych bez konieczno¶ci utrzymywania osobnego serwera baz danych.
132 Poniewa¿ pomijana jest komunikacja klient-serwer i dane s± zapisywane
133 bezpo¶rednio na dysku, SQLite jest szybsza od du¿ych serwerów
134 bazodanowych przy wiêkszo¶ci operacji na bazie danych. Dodatkowo
135 oprócz biblioteki jêzyka C, dostarczany jest program do zarz±dzania
136 bazami danych.
137
138 Pakiet zawiera statyczne biblioteki SQLite.
139
140 %package -n tcl-%{name}
141 Summary:        sqlite3 tcl extension
142 Summary(pl):    Rozszerzenie sqlite3 dla Tcl
143 Group:          Development/Languages/Tcl
144
145 %description -n tcl-%{name}
146 sqlite3 tcl extension.
147
148 %description -n tcl-%{name} -l pl
149 Rozszerzenie sqlite3 dla Tcl.
150
151 %prep
152 %setup -q -n sqlite-%{version}
153 %patch0 -p1
154 %patch1 -p1
155
156 sed -i 's/mkdir doc/#mkdir doc/' Makefile*
157
158 %build
159 %{__libtoolize}
160 cp -f /usr/share/automake/config.sub .
161 %{__aclocal}
162 %{__autoconf}
163 %configure \
164         %{?with_tcl:--with-tcl=%{_ulibdir}} \
165         %{!?with_tcl:--disable-tcl} \
166         --enable-threadsafe
167 %{__make}
168
169 %if %{with docs}
170 %{__make} doc
171 %endif
172
173 %{?with_tests:LC_ALL=C %{__make} test}
174
175 %install
176 rm -rf $RPM_BUILD_ROOT
177 install -d $RPM_BUILD_ROOT{%{_bindir},%{_includedir},%{_libdir},%{_mandir}/man1}
178
179 %{__make} install \
180         DESTDIR=$RPM_BUILD_ROOT
181
182 install sqlite3.1 $RPM_BUILD_ROOT%{_mandir}/man1
183
184 %clean
185 rm -rf $RPM_BUILD_ROOT
186
187 %post   -p /sbin/ldconfig
188 %postun -p /sbin/ldconfig
189
190 %files
191 %defattr(644,root,root,755)
192 %doc README
193 %attr(755,root,root) %{_bindir}/sqlite3
194 %attr(755,root,root) %{_libdir}/lib*.so.*.*
195 %{_mandir}/man1/sqlite3.1*
196
197 %files devel
198 %defattr(644,root,root,755)
199 %doc doc/*
200 %attr(755,root,root) %{_libdir}/lib*.so
201 %{_libdir}/lib*.la
202 %{_includedir}/sqlite3.h
203 %{_pkgconfigdir}/*.pc
204
205 %files static
206 %defattr(644,root,root,755)
207 %{_libdir}/lib*.a
208
209 %if %{with tcl}
210 %files -n tcl-%{name}
211 %defattr(644,root,root,755)
212 %dir %{_ulibdir}/tcl*/sqlite3
213 %attr(755,root,root) %{_ulibdir}/tcl*/sqlite3/*.so
214 %{_ulibdir}/tcl*/sqlite3/*.tcl
215 %endif
This page took 0.055918 seconds and 4 git commands to generate.