]> git.pld-linux.org Git - packages/sqlite3.git/blob - sqlite3.spec
- tcl now uses %{_libdir}/tcl%{major}, fix for broken directory dep
[packages/sqlite3.git] / sqlite3.spec
1 # TODO:
2 # - some tests fail with tcl8.5, it's tcl fault,
3 #       if someone REALLY cares (s)he can look into it
4 #
5 # Conditional build:
6 %bcond_with     tests   # run tests
7 %bcond_without  tcl     # disable tcl extension
8 %bcond_without  doc     # disable documentation building
9 #
10 %ifarch alpha sparc %{x8664}
11 %undefine       with_tests
12 %endif
13
14 # disabling tcl currently breaks making test target,
15 # some hack in Makefile needs to be done
16 %if !%{with tcl}
17 %undefine       with_tests
18 %endif
19
20 %define         _ulibdir        /usr/lib
21 %define         tclver          8.5
22
23 Summary:        SQLite library
24 Summary(pl.UTF-8):      Biblioteka SQLite
25 Name:           sqlite3
26 Version:        3.5.6
27 Release:        2
28 License:        LGPL
29 Group:          Libraries
30 # Source0Download: http://sqlite.org/download.html
31 Source0:        http://sqlite.org/sqlite-%{version}.tar.gz
32 # Source0-md5:  903c9e935c538af392364a9172a3d98d
33 Patch0:         %{name}-sign-function.patch
34 Patch1:         %{name}-pkgconfig.patch
35 URL:            http://sqlite.org/
36 BuildRequires:  autoconf
37 BuildRequires:  automake
38 BuildRequires:  libtool
39 BuildRequires:  readline-devel
40 %{?with_tcl:BuildRequires:      tcl-devel}
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %description
44 SQLite is a C library that implements an SQL database engine. A large
45 subset of SQL92 is supported. A complete database is stored in a
46 single disk file. The API is designed for convenience and ease of use.
47 Applications that link against SQLite can enjoy the power and
48 flexiblity of an SQL database without the administrative hassles of
49 supporting a separate database server. Because it omits the
50 client-server interaction overhead and writes directly to disk, SQLite
51 is also faster than the big database servers for most operations. In
52 addition to the C library, the SQLite distribution includes a
53 command-line tool for interacting with SQLite databases and SQLite
54 bindings for Tcl/Tk.
55
56 %description -l pl.UTF-8
57 SQLite jest biblioteką języka C, która implementuje silnik baz danych
58 SQL (obsługiwana jest większość standardu SQL92). Cała baza danych
59 przechowywana jest w jednym pliku. Aplikacje wykorzystujące tę
60 bibliotekę charakteryzują się siłą i elastycznością SQLowych baz
61 danych bez konieczności utrzymywania osobnego serwera baz danych.
62 Ponieważ pomijana jest komunikacja klient-serwer i dane są zapisywane
63 bezpośrednio na dysku, SQLite jest szybsza od dużych serwerów
64 bazodanowych przy większości operacji na bazie danych. Dodatkowo
65 oprócz biblioteki języka C, dostarczany jest program do zarządzania
66 bazami danych.
67
68 %package devel
69 Summary:        Header files for SQLite development
70 Summary(pl.UTF-8):      Pliki nagłówkowe SQLite
71 Group:          Development/Libraries
72 Requires:       %{name} = %{version}-%{release}
73
74 %description devel
75 SQLite is a C library that implements an SQL database engine. A large
76 subset of SQL92 is supported. A complete database is stored in a
77 single disk file. The API is designed for convenience and ease of use.
78 Applications that link against SQLite can enjoy the power and
79 flexiblity of an SQL database without the administrative hassles of
80 supporting a separate database server. Because it omits the
81 client-server interaction overhead and writes directly to disk, SQLite
82 is also faster than the big database servers for most operations. In
83 addition to the C library, the SQLite distribution includes a
84 command-line tool for interacting with SQLite databases and SQLite
85 bindings for Tcl/Tk.
86
87 This package contains the header files needed to develop programs that
88 use these SQLite.
89
90 %description devel -l pl.UTF-8
91 SQLite jest biblioteką języka C, która implementuje silnik baz danych
92 SQL (obsługiwana jest większość standardu SQL92). Cała baza danych
93 przechowywana jest w jednym pliku. Aplikacje wykorzystujące tę
94 bibliotekę charakteryzują się siłą i elastycznością SQLowych baz
95 danych bez konieczności utrzymywania osobnego serwera baz danych.
96 Ponieważ pomijana jest komunikacja klient-serwer i dane są zapisywane
97 bezpośrednio na dysku, SQLite jest szybsza od dużych serwerów
98 bazodanowych przy większości operacji na bazie danych. Dodatkowo
99 oprócz biblioteki języka C, dostarczany jest program do zarządzania
100 bazami danych.
101
102 Pakiet zawiera pliki nagówkowe niezbedne do kompilowania programów
103 używających biblioteki SQLite.
104
105 %package static
106 Summary:        Static libraries for SQLite development
107 Summary(pl.UTF-8):      Statyczne biblioteki SQLite
108 Group:          Development/Libraries
109 Requires:       %{name}-devel = %{version}-%{release}
110
111 %description static
112 SQLite is a C library that implements an SQL database engine. A large
113 subset of SQL92 is supported. A complete database is stored in a
114 single disk file. The API is designed for convenience and ease of use.
115 Applications that link against SQLite can enjoy the power and
116 flexiblity of an SQL database without the administrative hassles of
117 supporting a separate database server. Because it omits the
118 client-server interaction overhead and writes directly to disk, SQLite
119 is also faster than the big database servers for most operations. In
120 addition to the C library, the SQLite distribution includes a
121 command-line tool for interacting with SQLite databases and SQLite
122 bindings for Tcl/Tk.
123
124 This package contains the static SQLite libraries.
125
126 %description static -l pl.UTF-8
127 SQLite jest biblioteką języka C, która implementuje silnik baz danych
128 SQL (obsługiwana jest większość standardu SQL92). Cała baza danych
129 przechowywana jest w jednym pliku. Aplikacje wykorzystujące tę
130 bibliotekę charakteryzują się siłą i elastycznością SQLowych baz
131 danych bez konieczności utrzymywania osobnego serwera baz danych.
132 Ponieważ pomijana jest komunikacja klient-serwer i dane są zapisywane
133 bezpośrednio na dysku, SQLite jest szybsza od dużych serwerów
134 bazodanowych przy większości operacji na bazie danych. Dodatkowo
135 oprócz biblioteki języka C, dostarczany jest program do zarządzania
136 bazami danych.
137
138 Pakiet zawiera statyczne biblioteki SQLite.
139
140 %package -n tcl-%{name}
141 Summary:        sqlite3 tcl extension
142 Summary(pl.UTF-8):      Rozszerzenie sqlite3 dla Tcl
143 Group:          Development/Languages/Tcl
144
145 %description -n tcl-%{name}
146 sqlite3 tcl extension.
147
148 %description -n tcl-%{name} -l pl.UTF-8
149 Rozszerzenie sqlite3 dla Tcl.
150
151 %prep
152 %setup -q -n sqlite-%{version}
153 %patch0 -p1
154 %patch1 -p1
155
156 sed -i 's/mkdir doc/#mkdir doc/' Makefile*
157
158 %build
159 %{__libtoolize}
160 cp -f /usr/share/automake/config.sub .
161 %{__aclocal}
162 %{__autoconf}
163 CFLAGS="%{rpmcflags} -DSQLITE_ENABLE_COLUMN_METADATA=1"
164 export CFLAGS
165 %configure \
166         %{?with_tcl:--with-tcl=%{_ulibdir}} \
167         %{!?with_tcl:--disable-tcl} \
168         --enable-threadsafe
169 %{__make}
170
171 %if %{with doc}
172 %{__make} doc
173 %endif
174
175 %{?with_tests:LC_ALL=C %{__make} test}
176
177 %install
178 rm -rf $RPM_BUILD_ROOT
179 install -d $RPM_BUILD_ROOT{%{_bindir},%{_includedir},%{_libdir},%{_mandir}/man1}
180
181 %{__make} install \
182         DESTDIR=$RPM_BUILD_ROOT \
183         TCLLIBDIR=%{_libdir}/tcl%{tclver}
184
185 %if %{with tcl}
186 sed -i -e "s#$RPM_BUILD_ROOT##g" $RPM_BUILD_ROOT%{_libdir}/tcl%{tclver}/sqlite3/pkgIndex.tcl
187 %endif
188
189 install sqlite3.1 $RPM_BUILD_ROOT%{_mandir}/man1
190
191 %clean
192 rm -rf $RPM_BUILD_ROOT
193
194 %post   -p /sbin/ldconfig
195 %postun -p /sbin/ldconfig
196
197 %files
198 %defattr(644,root,root,755)
199 %doc README
200 %attr(755,root,root) %{_bindir}/sqlite3
201 %attr(755,root,root) %{_libdir}/libsqlite3.so.*.*.*
202 %attr(755,root,root) %ghost %{_libdir}/libsqlite3.so.0
203 %{_mandir}/man1/sqlite3.1*
204
205 %files devel
206 %defattr(644,root,root,755)
207 %doc doc/lemon.html doc/report1.txt
208 %attr(755,root,root) %{_libdir}/libsqlite3.so
209 %{_libdir}/libsqlite3.la
210 %{_includedir}/sqlite3.h
211 %{_includedir}/sqlite3ext.h
212 %{_pkgconfigdir}/sqlite3.pc
213
214 %files static
215 %defattr(644,root,root,755)
216 %{_libdir}/libsqlite3.a
217
218 %if %{with tcl}
219 %files -n tcl-%{name}
220 %defattr(644,root,root,755)
221 %dir %{_libdir}/tcl*/sqlite3
222 %attr(755,root,root) %{_libdir}/tcl%{tclver}/sqlite3/libtclsqlite3.so
223 %{_libdir}/tcl%{tclver}/sqlite3/pkgIndex.tcl
224 %endif
This page took 0.038998 seconds and 4 git commands to generate.