]> git.pld-linux.org Git - packages/sqlite3.git/blob - sqlite3.spec
- updated to 3.4.2
[packages/sqlite3.git] / sqlite3.spec
1 # TODO:
2 # - fix lib64 in tcl module
3 # - date test fail on tcl8.5 because of missing tcl library initialization
4 #   (and thus unavailable clock command)
5 #
6 # Conditional build:
7 %bcond_without  tests # don't run tests
8 %bcond_without  tcl   # disable tcl extension
9 %bcond_without  doc  # disable documentation building
10 #
11 Summary:        SQLite library
12 Summary(pl.UTF-8):      Biblioteka SQLite
13 Name:           sqlite3
14 Version:        3.4.2
15 Release:        1
16 License:        LGPL
17 Group:          Libraries
18 # Source0Download: http://sqlite.org/download.html
19 Source0:        http://sqlite.org/sqlite-%{version}.tar.gz
20 # Source0-md5:  2feec9b429f9298c9f288420c8b449f8
21 Patch0:         %{name}-sign-function.patch
22 Patch1:         %{name}-pkgconfig.patch
23 URL:            http://sqlite.org/
24 BuildRequires:  autoconf
25 BuildRequires:  automake
26 BuildRequires:  libtool
27 BuildRequires:  readline-devel
28 %{?with_tcl:BuildRequires:      tcl-devel}
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %ifarch alpha sparc %{x8664}
32 %undefine       with_tests
33 %endif
34
35 # disabling tcl currently breaks making test target,
36 # some hack in Makefile needs to be done
37 %if !%{with tcl}
38 %undefine       with_tests
39 %endif
40
41 %define         _ulibdir        /usr/lib
42
43 %description
44 SQLite is a C library that implements an SQL database engine. A large
45 subset of SQL92 is supported. A complete database is stored in a
46 single disk file. The API is designed for convenience and ease of use.
47 Applications that link against SQLite can enjoy the power and
48 flexiblity of an SQL database without the administrative hassles of
49 supporting a separate database server. Because it omits the
50 client-server interaction overhead and writes directly to disk, SQLite
51 is also faster than the big database servers for most operations. In
52 addition to the C library, the SQLite distribution includes a
53 command-line tool for interacting with SQLite databases and SQLite
54 bindings for Tcl/Tk.
55
56 %description -l pl.UTF-8
57 SQLite jest biblioteką języka C, która implementuje silnik baz danych
58 SQL (obsługiwana jest większość standardu SQL92). Cała baza danych
59 przechowywana jest w jednym pliku. Aplikacje wykorzystujące tę
60 bibliotekę charakteryzują się siłą i elastycznością SQLowych baz
61 danych bez konieczności utrzymywania osobnego serwera baz danych.
62 Ponieważ pomijana jest komunikacja klient-serwer i dane są zapisywane
63 bezpośrednio na dysku, SQLite jest szybsza od dużych serwerów
64 bazodanowych przy większości operacji na bazie danych. Dodatkowo
65 oprócz biblioteki języka C, dostarczany jest program do zarządzania
66 bazami danych.
67
68 %package devel
69 Summary:        Header files for SQLite development
70 Summary(pl.UTF-8):      Pliki nagłówkowe SQLite
71 Group:          Development/Libraries
72 Requires:       %{name} = %{version}-%{release}
73
74 %description devel
75 SQLite is a C library that implements an SQL database engine. A large
76 subset of SQL92 is supported. A complete database is stored in a
77 single disk file. The API is designed for convenience and ease of use.
78 Applications that link against SQLite can enjoy the power and
79 flexiblity of an SQL database without the administrative hassles of
80 supporting a separate database server. Because it omits the
81 client-server interaction overhead and writes directly to disk, SQLite
82 is also faster than the big database servers for most operations. In
83 addition to the C library, the SQLite distribution includes a
84 command-line tool for interacting with SQLite databases and SQLite
85 bindings for Tcl/Tk.
86
87 This package contains the header files needed to develop programs that
88 use these SQLite.
89
90 %description devel -l pl.UTF-8
91 SQLite jest biblioteką języka C, która implementuje silnik baz danych
92 SQL (obsługiwana jest większość standardu SQL92). Cała baza danych
93 przechowywana jest w jednym pliku. Aplikacje wykorzystujące tę
94 bibliotekę charakteryzują się siłą i elastycznością SQLowych baz
95 danych bez konieczności utrzymywania osobnego serwera baz danych.
96 Ponieważ pomijana jest komunikacja klient-serwer i dane są zapisywane
97 bezpośrednio na dysku, SQLite jest szybsza od dużych serwerów
98 bazodanowych przy większości operacji na bazie danych. Dodatkowo
99 oprócz biblioteki języka C, dostarczany jest program do zarządzania
100 bazami danych.
101
102 Pakiet zawiera pliki nagówkowe niezbedne do kompilowania programów
103 używających biblioteki SQLite.
104
105 %package static
106 Summary:        Static libraries for SQLite development
107 Summary(pl.UTF-8):      Statyczne biblioteki SQLite
108 Group:          Development/Libraries
109 Requires:       %{name}-devel = %{version}-%{release}
110
111 %description static
112 SQLite is a C library that implements an SQL database engine. A large
113 subset of SQL92 is supported. A complete database is stored in a
114 single disk file. The API is designed for convenience and ease of use.
115 Applications that link against SQLite can enjoy the power and
116 flexiblity of an SQL database without the administrative hassles of
117 supporting a separate database server. Because it omits the
118 client-server interaction overhead and writes directly to disk, SQLite
119 is also faster than the big database servers for most operations. In
120 addition to the C library, the SQLite distribution includes a
121 command-line tool for interacting with SQLite databases and SQLite
122 bindings for Tcl/Tk.
123
124 This package contains the static SQLite libraries.
125
126 %description static -l pl.UTF-8
127 SQLite jest biblioteką języka C, która implementuje silnik baz danych
128 SQL (obsługiwana jest większość standardu SQL92). Cała baza danych
129 przechowywana jest w jednym pliku. Aplikacje wykorzystujące tę
130 bibliotekę charakteryzują się siłą i elastycznością SQLowych baz
131 danych bez konieczności utrzymywania osobnego serwera baz danych.
132 Ponieważ pomijana jest komunikacja klient-serwer i dane są zapisywane
133 bezpośrednio na dysku, SQLite jest szybsza od dużych serwerów
134 bazodanowych przy większości operacji na bazie danych. Dodatkowo
135 oprócz biblioteki języka C, dostarczany jest program do zarządzania
136 bazami danych.
137
138 Pakiet zawiera statyczne biblioteki SQLite.
139
140 %package -n tcl-%{name}
141 Summary:        sqlite3 tcl extension
142 Summary(pl.UTF-8):      Rozszerzenie sqlite3 dla Tcl
143 Group:          Development/Languages/Tcl
144
145 %description -n tcl-%{name}
146 sqlite3 tcl extension.
147
148 %description -n tcl-%{name} -l pl.UTF-8
149 Rozszerzenie sqlite3 dla Tcl.
150
151 %prep
152 %setup -q -n sqlite-%{version}
153 %patch0 -p1
154 %patch1 -p1
155
156 sed -i 's/mkdir doc/#mkdir doc/' Makefile*
157
158 %build
159 %{__libtoolize}
160 cp -f /usr/share/automake/config.sub .
161 %{__aclocal}
162 %{__autoconf}
163 %configure \
164         %{?with_tcl:--with-tcl=%{_ulibdir}} \
165         %{!?with_tcl:--disable-tcl} \
166         --enable-threadsafe
167 %{__make}
168
169 %if %{with doc}
170 %{__make} doc
171 %endif
172
173 %{?with_tests:LC_ALL=C %{__make} test}
174
175 %install
176 rm -rf $RPM_BUILD_ROOT
177 install -d $RPM_BUILD_ROOT{%{_bindir},%{_includedir},%{_libdir},%{_mandir}/man1}
178
179 %{__make} install \
180         DESTDIR=$RPM_BUILD_ROOT
181
182 %if %{with tcl}
183 sed -i -e "s#$RPM_BUILD_ROOT##g" $RPM_BUILD_ROOT%{_ulibdir}/tcl*/sqlite3/*.tcl
184 %endif
185
186 install sqlite3.1 $RPM_BUILD_ROOT%{_mandir}/man1
187
188 %clean
189 rm -rf $RPM_BUILD_ROOT
190
191 %post   -p /sbin/ldconfig
192 %postun -p /sbin/ldconfig
193
194 %files
195 %defattr(644,root,root,755)
196 %doc README
197 %attr(755,root,root) %{_bindir}/sqlite3
198 %attr(755,root,root) %{_libdir}/lib*.so.*.*
199 %{_mandir}/man1/sqlite3.1*
200
201 %files devel
202 %defattr(644,root,root,755)
203 %doc doc/*
204 %attr(755,root,root) %{_libdir}/lib*.so
205 %{_libdir}/lib*.la
206 %{_includedir}/sqlite3.h
207 %{_includedir}/sqlite3ext.h
208 %{_pkgconfigdir}/*.pc
209
210 %files static
211 %defattr(644,root,root,755)
212 %{_libdir}/lib*.a
213
214 %if %{with tcl}
215 %files -n tcl-%{name}
216 %defattr(644,root,root,755)
217 %dir %{_ulibdir}/tcl*/sqlite3
218 %attr(755,root,root) %{_ulibdir}/tcl*/sqlite3/*.so
219 %{_ulibdir}/tcl*/sqlite3/*.tcl
220 %endif
This page took 0.041656 seconds and 4 git commands to generate.