]> git.pld-linux.org Git - packages/sqlite3.git/blob - sqlite3.spec
60295003682c46acd87ebfb89925f8d85e50e9b2
[packages/sqlite3.git] / sqlite3.spec
1 # TODO:
2 # - some tests fail with tcl8.5, it's tcl fault,
3 #       if someone REALLY cares (s)he can look into it
4 # - alpha build fail:
5 #   tclsh ./tool/mksqlite3c.tcl
6 #   tclsh: allocatestack.c:404: allocate_stack: Assertion `size != 0' failed.
7 #   make: *** [sqlite3.c] Aborted
8 #
9 # Conditional build:
10 %bcond_with     tests   # run tests
11 %bcond_without  tcl     # disable tcl extension
12 %bcond_without  doc     # disable documentation building
13 #
14 %ifarch alpha sparc %{x8664}
15 %undefine       with_tests
16 %endif
17
18 # disabling tcl currently breaks making test target,
19 # some hack in Makefile needs to be done
20 %if !%{with tcl}
21 %undefine       with_tests
22 %endif
23
24 %define         _ulibdir        /usr/lib
25 %define         tclver          8.5
26
27 Summary:        SQLite library
28 Summary(pl.UTF-8):      Biblioteka SQLite
29 Name:           sqlite3
30 Version:        3.6.2
31 Release:        1
32 License:        LGPL
33 Group:          Libraries
34 # Source0Download: http://www.sqlite.org/download.html
35 Source0:        http://www.sqlite.org/sqlite-%{version}.tar.gz
36 # Source0-md5:  46f92e42243bc51aaa3871645ce78bd5
37 Patch0:         %{name}-sign-function.patch
38 Patch1:         %{name}-pkgconfig.patch
39 URL:            http://www.sqlite.org/
40 BuildRequires:  autoconf
41 BuildRequires:  automake
42 BuildRequires:  libtool
43 BuildRequires:  readline-devel
44 %{?with_tcl:BuildRequires:      tcl-devel}
45 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47 %description
48 SQLite is a C library that implements an SQL database engine. A large
49 subset of SQL92 is supported. A complete database is stored in a
50 single disk file. The API is designed for convenience and ease of use.
51 Applications that link against SQLite can enjoy the power and
52 flexiblity of an SQL database without the administrative hassles of
53 supporting a separate database server. Because it omits the
54 client-server interaction overhead and writes directly to disk, SQLite
55 is also faster than the big database servers for most operations. In
56 addition to the C library, the SQLite distribution includes a
57 command-line tool for interacting with SQLite databases and SQLite
58 bindings for Tcl/Tk.
59
60 %description -l pl.UTF-8
61 SQLite jest biblioteką języka C, która implementuje silnik baz danych
62 SQL (obsługiwana jest większość standardu SQL92). Cała baza danych
63 przechowywana jest w jednym pliku. Aplikacje wykorzystujące tę
64 bibliotekę charakteryzują się siłą i elastycznością SQLowych baz
65 danych bez konieczności utrzymywania osobnego serwera baz danych.
66 Ponieważ pomijana jest komunikacja klient-serwer i dane są zapisywane
67 bezpośrednio na dysku, SQLite jest szybsza od dużych serwerów
68 bazodanowych przy większości operacji na bazie danych. Dodatkowo
69 oprócz biblioteki języka C, dostarczany jest program do zarządzania
70 bazami danych.
71
72 %package devel
73 Summary:        Header files for SQLite development
74 Summary(pl.UTF-8):      Pliki nagłówkowe SQLite
75 Group:          Development/Libraries
76 Requires:       %{name} = %{version}-%{release}
77
78 %description devel
79 SQLite is a C library that implements an SQL database engine. A large
80 subset of SQL92 is supported. A complete database is stored in a
81 single disk file. The API is designed for convenience and ease of use.
82 Applications that link against SQLite can enjoy the power and
83 flexiblity of an SQL database without the administrative hassles of
84 supporting a separate database server. Because it omits the
85 client-server interaction overhead and writes directly to disk, SQLite
86 is also faster than the big database servers for most operations. In
87 addition to the C library, the SQLite distribution includes a
88 command-line tool for interacting with SQLite databases and SQLite
89 bindings for Tcl/Tk.
90
91 This package contains the header files needed to develop programs that
92 use these SQLite.
93
94 %description devel -l pl.UTF-8
95 SQLite jest biblioteką języka C, która implementuje silnik baz danych
96 SQL (obsługiwana jest większość standardu SQL92). Cała baza danych
97 przechowywana jest w jednym pliku. Aplikacje wykorzystujące tę
98 bibliotekę charakteryzują się siłą i elastycznością SQLowych baz
99 danych bez konieczności utrzymywania osobnego serwera baz danych.
100 Ponieważ pomijana jest komunikacja klient-serwer i dane są zapisywane
101 bezpośrednio na dysku, SQLite jest szybsza od dużych serwerów
102 bazodanowych przy większości operacji na bazie danych. Dodatkowo
103 oprócz biblioteki języka C, dostarczany jest program do zarządzania
104 bazami danych.
105
106 Pakiet zawiera pliki nagówkowe niezbedne do kompilowania programów
107 używających biblioteki SQLite.
108
109 %package static
110 Summary:        Static libraries for SQLite development
111 Summary(pl.UTF-8):      Statyczne biblioteki SQLite
112 Group:          Development/Libraries
113 Requires:       %{name}-devel = %{version}-%{release}
114
115 %description static
116 SQLite is a C library that implements an SQL database engine. A large
117 subset of SQL92 is supported. A complete database is stored in a
118 single disk file. The API is designed for convenience and ease of use.
119 Applications that link against SQLite can enjoy the power and
120 flexiblity of an SQL database without the administrative hassles of
121 supporting a separate database server. Because it omits the
122 client-server interaction overhead and writes directly to disk, SQLite
123 is also faster than the big database servers for most operations. In
124 addition to the C library, the SQLite distribution includes a
125 command-line tool for interacting with SQLite databases and SQLite
126 bindings for Tcl/Tk.
127
128 This package contains the static SQLite libraries.
129
130 %description static -l pl.UTF-8
131 SQLite jest biblioteką języka C, która implementuje silnik baz danych
132 SQL (obsługiwana jest większość standardu SQL92). Cała baza danych
133 przechowywana jest w jednym pliku. Aplikacje wykorzystujące tę
134 bibliotekę charakteryzują się siłą i elastycznością SQLowych baz
135 danych bez konieczności utrzymywania osobnego serwera baz danych.
136 Ponieważ pomijana jest komunikacja klient-serwer i dane są zapisywane
137 bezpośrednio na dysku, SQLite jest szybsza od dużych serwerów
138 bazodanowych przy większości operacji na bazie danych. Dodatkowo
139 oprócz biblioteki języka C, dostarczany jest program do zarządzania
140 bazami danych.
141
142 Pakiet zawiera statyczne biblioteki SQLite.
143
144 %package -n tcl-%{name}
145 Summary:        sqlite3 tcl extension
146 Summary(pl.UTF-8):      Rozszerzenie sqlite3 dla Tcl
147 Group:          Development/Languages/Tcl
148
149 %description -n tcl-%{name}
150 sqlite3 tcl extension.
151
152 %description -n tcl-%{name} -l pl.UTF-8
153 Rozszerzenie sqlite3 dla Tcl.
154
155 %prep
156 %setup -q -n sqlite-%{version}
157 %patch0 -p1
158 %patch1 -p1
159
160 sed -i 's/mkdir doc/#mkdir doc/' Makefile*
161
162 %build
163 %{__libtoolize}
164 cp -f /usr/share/automake/config.sub .
165 %{__aclocal}
166 %{__autoconf}
167 CFLAGS="%{rpmcflags} -DSQLITE_ENABLE_COLUMN_METADATA=1"
168 export CFLAGS
169 %configure \
170         %{?with_tcl:--with-tcl=%{_ulibdir}} \
171         %{!?with_tcl:--disable-tcl} \
172         --enable-threadsafe
173 %{__make}
174
175 %if %{with doc}
176 %{__make} doc
177 %endif
178
179 %{?with_tests:LC_ALL=C %{__make} test}
180
181 %install
182 rm -rf $RPM_BUILD_ROOT
183 install -d $RPM_BUILD_ROOT{%{_bindir},%{_includedir},%{_libdir},%{_mandir}/man1}
184
185 %{__make} install \
186         DESTDIR=$RPM_BUILD_ROOT \
187         TCLLIBDIR=%{_libdir}/tcl%{tclver}
188
189 %if %{with tcl}
190 sed -i -e "s#$RPM_BUILD_ROOT##g" $RPM_BUILD_ROOT%{_libdir}/tcl%{tclver}/sqlite3/pkgIndex.tcl
191 %endif
192
193 install sqlite3.1 $RPM_BUILD_ROOT%{_mandir}/man1
194
195 %clean
196 rm -rf $RPM_BUILD_ROOT
197
198 %post   -p /sbin/ldconfig
199 %postun -p /sbin/ldconfig
200
201 %files
202 %defattr(644,root,root,755)
203 %doc README
204 %attr(755,root,root) %{_bindir}/sqlite3
205 %attr(755,root,root) %{_libdir}/libsqlite3.so.*.*.*
206 %attr(755,root,root) %ghost %{_libdir}/libsqlite3.so.0
207 %{_mandir}/man1/sqlite3.1*
208
209 %files devel
210 %defattr(644,root,root,755)
211 %attr(755,root,root) %{_libdir}/libsqlite3.so
212 %{_libdir}/libsqlite3.la
213 %{_includedir}/sqlite3.h
214 %{_includedir}/sqlite3ext.h
215 %{_pkgconfigdir}/sqlite3.pc
216
217 %files static
218 %defattr(644,root,root,755)
219 %{_libdir}/libsqlite3.a
220
221 %if %{with tcl}
222 %files -n tcl-%{name}
223 %defattr(644,root,root,755)
224 %dir %{_libdir}/tcl*/sqlite3
225 %attr(755,root,root) %{_libdir}/tcl%{tclver}/sqlite3/libtclsqlite3.so
226 %{_libdir}/tcl%{tclver}/sqlite3/pkgIndex.tcl
227 %endif
This page took 0.087876 seconds and 2 git commands to generate.