]> git.pld-linux.org Git - packages/spl.git/commitdiff
- fix build on linux 3.18
authorJan Rękorajski <baggins@pld-linux.org>
Sun, 25 Jan 2015 23:24:56 +0000 (00:24 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Sun, 25 Jan 2015 23:24:56 +0000 (00:24 +0100)
linux-3.18.patch [new file with mode: 0644]
spl.spec

diff --git a/linux-3.18.patch b/linux-3.18.patch
new file mode 100644 (file)
index 0000000..c33d8d9
--- /dev/null
@@ -0,0 +1,14 @@
+--- spl-0.6.3/module/spl/spl-kmem.c~   2015-01-26 00:23:23.000000000 +0100
++++ spl-0.6.3/module/spl/spl-kmem.c    2015-01-26 00:24:13.312560884 +0100
+@@ -2369,7 +2369,11 @@
+       spl_slab_reclaim(skc, count, 1);
+       clear_bit(KMC_BIT_REAPING, &skc->skc_flags);
++#if ( LINUX_VERSION_CODE < KERNEL_VERSION(3,18,0) )
+       smp_mb__after_clear_bit();
++#else
++      smp_mb__after_atomic();
++#endif
+       wake_up_bit(&skc->skc_flags, KMC_BIT_REAPING);
+ out:
+       atomic_dec(&skc->skc_ref);
index d9b078fb9f2b8cf942a4c77cc236cac899d12aa0..d5022cde7822fc63819eb75c521c0b5c937b68aa 100644 (file)
--- a/spl.spec
+++ b/spl.spec
@@ -41,7 +41,7 @@ exit 1
 %define                bkpkg   %(echo %{_build_kernels} | tr , '\\n' | while read n ; do echo %%undefine alt_kernel ; [ -z "$n" ] || echo %%define alt_kernel $n ; echo %%build_kernel_pkg ; done)
 
 %define                pname   spl
-%define                rel     3
+%define                rel     4
 Summary:       Solaris Porting Layer
 Summary(pl.UTF-8):     Solaris Porting Layer - warstwa do portowania kodu z Solarisa
 Name:          %{pname}%{?_pld_builder:%{?with_kernel:-kernel}}%{_alt_kernel}
@@ -52,6 +52,7 @@ Group:                Applications/System
 Source0:       http://archive.zfsonlinux.org/downloads/zfsonlinux/spl/%{pname}-%{version}.tar.gz
 # Source0-md5: 8df6ce3c8f1d9af6526b36f5079cba59
 Patch0:                linux-3.17.patch
+Patch0:                linux-3.18.patch
 URL:           http://zfsonlinux.org/
 BuildRequires: rpmbuild(macros) >= 1.678
 %{?with_dist_kernel:%{expand:%kbrs}}
@@ -147,6 +148,7 @@ p=`pwd`\
 %prep
 %setup -q -n %{pname}-%{version}
 %patch0 -p1
+%patch1 -p1
 
 %build
 %{__aclocal} -I config
This page took 0.039675 seconds and 4 git commands to generate.