]> git.pld-linux.org Git - packages/spice-space.git/commitdiff
- updated to 0.12.5 auto/th/spice-space-0.12.5-1
authorJakub Bogusz <qboosh@pld-linux.org>
Fri, 23 May 2014 18:10:49 +0000 (20:10 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Fri, 23 May 2014 18:10:49 +0000 (20:10 +0200)
- updated sh patch
- slirp/tunneling support is gone; opus support added

spice-sh.patch
spice-space.spec

index 76f524a9bcf9af53b99633518a662d9ee9f53013..2b7c2042eb16b7fce03a0c73c3a7e1bd3dc61935 100644 (file)
@@ -1,6 +1,6 @@
---- spice-0.10.0/configure.ac.orig     2011-11-10 16:02:06.000000000 +0100
-+++ spice-0.10.0/configure.ac  2011-11-13 08:00:42.323766723 +0100
-@@ -145,9 +145,9 @@
+--- spice-0.12.5/configure.ac.orig     2014-05-19 14:20:53.000000000 +0200
++++ spice-0.12.5/configure.ac  2014-05-23 19:18:10.227726292 +0200
+@@ -163,9 +163,9 @@
  AC_SUBST(LIBRT)
  
  if test "$red_target" = "windows"; then
  fi
  
  dnl The client needs a yield function
-@@ -191,7 +191,7 @@
-       PKG_CHECK_MODULES(SLIRP, slirp)
-       AC_SUBST(SLIRP_CFLAGS)
-       AC_SUBST(SLIRP_LIBS)
--      SPICE_REQUIRES+=" slirp"
-+      SPICE_REQUIRES="$SPICE_REQUIRES slirp"
-       AC_DEFINE([HAVE_SLIRP], [], [Define if we have slirp])
+@@ -211,24 +211,24 @@
+     SMARTCARD_CFLAGS="$CAC_CARD_CFLAGS"
+     AC_SUBST(SMARTCARD_LIBS)
+     AC_SUBST(SMARTCARD_CFLAGS)
+-    SPICE_REQUIRES+=" libcacard >= 0.1.2"
++    SPICE_REQUIRES="$SPICE_REQUIRES libcacard >= 0.1.2"
  fi
  
-@@ -207,13 +207,13 @@
+ PKG_CHECK_MODULES([GLIB2], [glib-2.0 >= 2.22])
+-SPICE_REQUIRES+=" glib-2.0 >= 2.22"
++SPICE_REQUIRES="$SPICE_REQUIRES glib-2.0 >= 2.22"
  PKG_CHECK_MODULES(PIXMAN, pixman-1 >= 0.17.7)
  AC_SUBST(PIXMAN_CFLAGS)
  AC_SUBST(PIXMAN_LIBS)
 -SPICE_REQUIRES+=" pixman-1 >= 0.17.7"
 +SPICE_REQUIRES="$SPICE_REQUIRES pixman-1 >= 0.17.7"
  
- PKG_CHECK_MODULES(CELT051, celt051 >= 0.5.1.1)
- AC_SUBST(CELT051_CFLAGS)
- AC_SUBST(CELT051_LIBS)
- AC_SUBST(CELT051_LIBDIR)
--SPICE_REQUIRES+=" celt051 >= 0.5.1.1"
-+SPICE_REQUIRES="$SPICE_REQUIRES celt051 >= 0.5.1.1"
+ AC_ARG_ENABLE(celt051,
+     [  --disable-celt051       Disable celt051 audio codec (enabled by default)],,
+         [enable_celt051="yes"])
+ if test "x$enable_celt051" = "xyes"; then
+-    PKG_CHECK_MODULES(CELT051, celt051 >= 0.5.1.1, SPICE_REQUIRES+=" celt051 >= 0.5.1.1")
++    PKG_CHECK_MODULES(CELT051, celt051 >= 0.5.1.1, SPICE_REQUIRES="$SPICE_REQUIRES celt051 >= 0.5.1.1")
+ fi
  
  if test ! -e client/generated_marshallers.cpp; then
- AC_MSG_CHECKING([for pyparsing python module])
-@@ -234,14 +234,14 @@
+@@ -244,14 +244,14 @@
  PKG_CHECK_MODULES(SSL, openssl)
  AC_SUBST(SSL_CFLAGS)
  AC_SUBST(SSL_LIBS)
  
  if test "x$enable_opengl" = "xyes"; then
     AC_CHECK_LIB(GL, glBlendFunc, GL_LIBS="$GL_LIBS -lGL", enable_opengl=no)
-@@ -256,7 +256,7 @@
+@@ -266,7 +266,7 @@
  
  AC_SUBST(GL_CFLAGS)
  AC_SUBST(GL_LIBS)
 -SPICE_NONPKGCONFIG_LIBS+=" $GL_LIBS"
 +SPICE_NONPKGCONFIG_LIBS="$SPICE_NONPKGCONFIG_LIBS $GL_LIBS"
  
- if test "$red_target" = "x11"; then
-       PKG_CHECK_MODULES(XRANDR, xrandr)
+ if test "x$red_target" = "xx11" && test "x$enable_client" = "xyes" ; then
+       if test "$os_linux" = yes; then
+@@ -319,7 +319,7 @@
+   AC_DEFINE([HAVE_XINERAMA], [], [Define if we have Xinerama])
+   AC_SUBST(XINERAMA_CFLAGS)
+   AC_SUBST(XINERAMA_LIBS)
+-  SPICE_REQUIRES+=" xinerama"
++  SPICE_REQUIRES="$SPICE_REQUIRES xinerama"
+ fi
+ # Add parameter for (partial) static linkage of spice client.
index ac14b24365a3523fa05f080bf7c0650c1f1ce95f..9d26b152a66f340e3b1db3102970bb70973a38a4 100644 (file)
@@ -1,35 +1,35 @@
-# TODO: verify slirp comment validity with current qemu/spice versions [how to?]
 #
 # Conditional build:
-%bcond_with    slirp           # build with tunneling support (breaks qemu)
+%bcond_without opengl  # OpenGL support
 #
 Summary:       SPICE virtualization solution
 Summary(pl.UTF-8):     System wirtualizacji SPICE
 # real package name (spice) is already occupied
 Name:          spice-space
-Version:       0.12.4
+Version:       0.12.5
 Release:       1
 License:       LGPL v2.1+
 Group:         Applications/Emulators
-Source0:       http://spice-space.org/download/releases/spice-%{version}.tar.bz2
-# Source0-md5: 325b1c42ce24e75de45a75876b73a8bd
+Source0:       http://www.spice-space.org/download/releases/spice-%{version}.tar.bz2
+# Source0-md5: 1256286214fe402703c0a01bd3a85319
 Patch0:                spice-sh.patch
 Patch1:                spice-link.patch
 Patch2:                spice-am.patch
-URL:           http://spice-space.org/
-BuildRequires: OpenGL-GLU-devel
+URL:           http://www.spice-space.org/
+%{?with_opengl:BuildRequires:  OpenGL-devel}
+%{?with_opengl:BuildRequires:  OpenGL-GLU-devel}
 BuildRequires: alsa-lib-devel
-BuildRequires: autoconf >= 2.57
-BuildRequires: automake
+BuildRequires: autoconf >= 2.63
+BuildRequires: automake >= 1:1.11
 BuildRequires: celt051-devel >= 0.5.1.1
 BuildRequires: cyrus-sasl-devel >= 2
 BuildRequires: glib2-devel >= 1:2.22
 BuildRequires: libcacard-devel >= 0.1.2
 BuildRequires: libjpeg-devel
-%{?with_slirp:BuildRequires:   libslirp-devel}
 BuildRequires: libstdc++-devel
-BuildRequires: libtool
+BuildRequires: libtool >= 2:2
 BuildRequires: openssl-devel
+BuildRequires: opus-devel >= 0.9.14
 BuildRequires: pixman-devel >= 0.17.7
 BuildRequires: pkgconfig
 BuildRequires: python >= 2
@@ -67,6 +67,7 @@ Summary:      SPICE server library
 Summary(pl.UTF-8):     Biblioteka serwera SPICE
 Group:         Libraries
 Requires:      celt051 >= 0.5.1.1
+Requires:      opus >= 0.9.14
 Requires:      glib2 >= 1:2.22
 Requires:      pixman >= 0.17.7
 
@@ -82,7 +83,6 @@ Summary(pl.UTF-8):    Pliki nagłówkowe biblioteki serwera SPICE
 Group:         Development/Libraries
 Requires:      celt051-devel >= 0.5.1.1
 Requires:      glib2-devel >= 1:2.22
-%{?with_slirp:Requires:        libslirp-devel}
 Requires:      openssl-devel
 Requires:      pixman-devel >= 0.17.7
 Requires:      spice-server-libs = %{version}-%{release}
@@ -111,6 +111,7 @@ Summary(pl.UTF-8):  Klient SPICE dla X11
 Group:         X11/Applications
 Requires:      celt051 >= 0.5.1.1
 Requires:      libcacard >= 0.1.2
+Requires:      opus >= 0.9.14
 Requires:      pixman >= 0.17.7
 Requires:      xorg-lib-libXrandr >= 1.2
 Requires:      xorg-lib-libXinerama >= 1.0
@@ -136,9 +137,9 @@ Klient SPICE dla X11.
 %configure \
        --disable-silent-rules \
        --enable-client \
-       --enable-opengl \
-       --enable-smartcard \
-       --enable-tunnel%{!?with_slirp:=no}
+       %{?with_opengl:--enable-opengl} \
+       --enable-smartcard
+
 # --enable-gui         BR: CEGUI-devel >= 0.6.0 < 0.7.0
 
 %{__make}
This page took 0.150291 seconds and 4 git commands to generate.